Jump to content

[1.11.x] TAC - Life Support v0.17.0 - Release 29th Dec 2020


Recommended Posts

59 minutes ago, BlackMoons said:

Brand new station... falls apart during launch, and a kerbal instantly dies of no oxygen in the science lab when oxygen tank snaps off.

I thought they could at least go a few minutes without oxygen?

Who knows, how long can you hold your breath in space?

Link to post
Share on other sites
9 minutes ago, goldenpsp said:

Who knows, how long can you hold your breath in space?

Couple minutes if I am in a nice pressurized science lab at least, that was suddenly exposed to.. atmosphere at 5000m, and im in my spacesuit.

Edited by BlackMoons
Link to post
Share on other sites

Perhaps Kerbals are very intolerant? :)

No more water in the bottle? Instant death.
No more oxygen in the tank? Instant death.
No more kraken in the wormhole...

and btw - when oxygen is off (by accident or not), the Kerbal got a suit with a couple of hours in resources...

Edited by Gordon Dry
Link to post
Share on other sites
Just now, Gordon Dry said:

Perhaps Kerbals are very intolerant? :)

No more water in the bottle? Instant death.
No more oxygen in the tank? Instant death.
No more kraken in the wormhole...

Im going to say its related to the bug that is keeping me from rescuing any kerbals since I updated TAC life support, hence why Im reporting different conditions I have seen it occur.

Link to post
Share on other sites
50 minutes ago, BlackMoons said:

Couple minutes if I am in a nice pressurized science lab at least, that was suddenly exposed to.. atmosphere at 5000m, and im in my spacesuit.

Well maybe it just comes down to how much programming effort it would take to put in a few minutes buffer vs. the times it would actually come into play.

Link to post
Share on other sites
1 minute ago, goldenpsp said:

Well maybe it just comes down to how much programming effort it would take to put in a few minutes buffer vs. the times it would actually come into play.

.. It used to have delays, And they are kinda needed to rescue kerbals on rescue contracts. Also needed for when your ship does some disassembly on landing.

Link to post
Share on other sites
1 minute ago, BlackMoons said:

.. It used to have delays, And they are kinda needed to rescue kerbals on rescue contracts. Also needed for when your ship does some disassembly on landing.

In that case have you checked github issues?  It looks like there is an issue already open concerning this.  It might be a better place to contribute details to help solve the bug as most dev's use that location to better manage their bug list.

https://github.com/KSP-RO/TacLifeSupport/issues

Link to post
Share on other sites

Sorry peeps.. This is getting more than annoying I am sure..
I have attempted a couple of times to fix these problems. and they haven't been fixed...  The reason being, I am time poor and unfortunately, what it really needs is hours of my time uninterrupted in a block where I can sit down and do testing/debugging and root through and find and fix the issues.
That's the problem, finding the time to do it, given I have two paid jobs, a family life, and fixing and maintaining my mods are below those things on my list.
I can keep saying I will look at it as soon as I can, but when that is I can't say. Could be tomorrow, could be next week. I'm sure I can fix these issues as soon as I can find the time.

The root cause of most of the issues related to EC, resources, etc. Is that I thought it would be a great idea to implement resource processing for unloaded vessels. Which is indeed a great idea. But what wasn't a great idea was trying to do it with all my other priorities. I know there are probably a few bugs still left in that system, and I know the root cause of the time warp issues. The EVA and Rescue kerbals problems are also indirectly related somewhat.

Indeed, raising and putting info into github really helps me a lot. Also, checking what bug reports are there already and adding any info to existing reports also helps me a great deal.
Raising new issues that are duplicates of the ones already there does not. As it means I have to read each one, correlate them together, are they the same issue? gather the info together, etc.

Hopefully I will get to it this weekend. Please be patient and thanks all for the input and info to help me find the problems.

Link to post
Share on other sites
40 minutes ago, JPLRepo said:

 

Hopefully I will get to it this weekend. Please be patient and thanks all for the input and info to help me find the problems.

Absolutely love this mod mate, for now it gives me a chance to sort my comms out around the system. Take your time bud, I understand time management myself so all good.

Again thanks for taking the time with this mod.

Link to post
Share on other sites

Yes, take your time to solve the issues. Real life always comes first.  I will also be fixing my comm network and doing some remote missions and if needed I will just make a 2nd install without life support to play till it gets fixed or the next DLC comes out.    This is still one of the best life support mods for the game.   

Link to post
Share on other sites

A new issue to me coming from nowhere.

I launched the same vessel as before, but this time the log got spammed with:

-WARNING- Tac.LifeSupportController[FF492744][14587.96]: Removing hibernation status from crew member: Bill Kerman
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-WARNING- Tac.LifeSupportController[FF492744][14587.96]: Removing hibernation status from crew member: Jencan Kerman
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-WARNING- Tac.LifeSupportController[FF492744][14587.96]: Removing hibernation status from crew member: Dunfel Kerman
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-WARNING- Tac.LifeSupportController[FF492744][14587.96]: Removing hibernation status from crew member: Jebediah Kerman
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

These 4 were in the vessel that was under my control.

This dropped the fps down to 4-5 and the physics delta from 80% to 35% during the whole launch.

 

Edit:

ah yeah, I got it, I switched from "death" to "hibernate", but that loaded Kerbals with life support get the hibernation status removed every second is interesting...

Edited by Gordon Dry
Link to post
Share on other sites
On 7/26/2017 at 11:36 PM, Gordon Dry said:

At first it does not go over the "magic" border of being to much of time warp ...

@JPLRepo:

 

Errr... Nope. Not true at all. The TAC LS EC generation calculation for solar panels is calculated from the vessel position to the Sun, that's it. Solar panel location, orientation or orientation of the vessel are not part of the equation. Trying to do it for an unloaded vessel based on orientation of the vessel, orientation of the Solar panel, if it tracks the sun or is static, etc... is simply not what it does. It would be too much overhead to be doing that for every solar panel on every vessel in a game.

8 hours ago, Gordon Dry said:

A new issue to me coming from nowhere.

I launched the same vessel as before, but this time the log got spammed with:

-WARNING- Tac.LifeSupportController[FF492744][14587.96]: Removing hibernation status from crew member: Bill Kerman
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-WARNING- Tac.LifeSupportController[FF492744][14587.96]: Removing hibernation status from crew member: Jencan Kerman
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-WARNING- Tac.LifeSupportController[FF492744][14587.96]: Removing hibernation status from crew member: Dunfel Kerman
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

-WARNING- Tac.LifeSupportController[FF492744][14587.96]: Removing hibernation status from crew member: Jebediah Kerman
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

These 4 were in the vessel that was under my control.

This dropped the fps down to 4-5 and the physics delta from 80% to 35% during the whole launch.

 

Edit:

ah yeah, I got it, I switched from "death" to "hibernate", but that loaded Kerbals with life support get the hibernation status removed every second is interesting...

this has already been reported.

On 7/28/2017 at 1:56 AM, BlackMoons said:

Brand new station... falls apart during launch, and a kerbal instantly dies of no oxygen in the science lab when oxygen tank snaps off.

I thought they could at least go a few minutes without oxygen?

More information required. They don't do for me.
Did you change the settings at all? in particular the max time without O2 setting?

On 7/25/2017 at 8:20 AM, aluc24 said:

Hey, @JPLRepo, would it be possible to add TAC support for Near Future Command Modules? As of now, they have no TAC Life Support Module, nor any resources inside.

TAC LS automatically adds Life Support to all parts that can contain crew and are Command Modules.
So I'm guessing the one you are asking about doesn't meet that criteria. Link to the mod and which parts please.

Link to post
Share on other sites
1 hour ago, aluc24 said:

It's Near Future Spacecraft [0.7.2] (scroll down a bit until you see it). The part is Mk3-9 Orbital Command Pod.

That one is a combination command pod and probe core and if you look at the list for the right click you will see it does show TAC-LS listed on the menu.  Seems to me, because its also able to fly on its own it would be added weight you might not want.  I would just attach an external round 1.75m tank if you decide to add a crew.

Edited by Vaga
Link to post
Share on other sites
19 minutes ago, Vaga said:

That one is a combination command pod and probe core and if you look at the list for the right click you will see it does show TAC-LS listed on the menu.  Seems to me, because its also able to fly on its own it would be added weight you might not want.  I would just attach an external round 1.75m tank if you decide to add a crew.

Yeah, the TAC is listed, I just found it weird that it is the only manned module that doesn't have any life support supplies. But maybe it was intentional, as you suggest.

Link to post
Share on other sites
6 hours ago, JPLRepo said:

More information required. They don't do for me.
Did you change the settings at all? in particular the max time without O2 setting?

 

Did not change the settings at all. Also happens if they lose water or any other resource. Might be because my save is old? (Used TAC 13.2 before) Up to like year 7 in game time. Even brand new ships are affected.. I would suggest loading my save from the github bug report and seeing if a newly launched ship does it for you too.

Also take a look in a text editor to see if TAC is saving the right values in the save for the ships with life support?

Edited by BlackMoons
Link to post
Share on other sites
7 hours ago, BlackMoons said:

Did not change the settings at all. Also happens if they lose water or any other resource. Might be because my save is old? (Used TAC 13.2 before) Up to like year 7 in game time. Even brand new ships are affected.. I would suggest loading my save from the github bug report and seeing if a newly launched ship does it for you too.

Also take a look in a text editor to see if TAC is saving the right values in the save for the ships with life support?

Thanks. But a) your save is full of mods that would take me too long to install. b) I already know what the problems are.

Link to post
Share on other sites
23 minutes ago, JPLRepo said:

Thanks. But a) your save is full of mods that would take me too long to install. b) I already know what the problems are.

Yea but since it affects new launches too, it might still glitch if you just load it without mods and let KSP delete all my craft. But yea if you already know whats causing this type of bug i'll wait and gladly try your next dev release to see if that fixes it.

Link to post
Share on other sites
23 minutes ago, BlackMoons said:

Yea but since it affects new launches too, it might still glitch if you just load it without mods and let KSP delete all my craft. But yea if you already know whats causing this type of bug i'll wait and gladly try your next dev release to see if that fixes it.

I can't reproduce the problem with my current build. So that's a positive. Working on a new dev build today. and I am having a hard time now reproducing any of the reported issues.
So it's looking positive.
[edit] - the hibernate spam, killing kerbals instantly, not giving rescue kerbals the right resources are all fixed. As is the EC problem, from what I can tell. But I have had a hard time reproducing the EC problems in past builds that everyone somehow manages to find. I want to test it as much as I can the next few hours and will publish a dev build after that if I don't find any issues.

Link to post
Share on other sites
3 hours ago, JPLRepo said:

Please try a new dev build that I just posted on this link.
Please try dev build from this link:
https://github.com/KSP-RO/TacLifeSupport/releases/tag/v0.13.4dev

Yes same dev version as previous. But brand shiny new build that hopefully has fixed all the issues.

 

Can confirm the pausing issue seems to be fixed. Will check the rest later when I have more time (but this is the only thing I had issues with before) - Thanks!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...