Jump to content

[1.11.x] TAC - Life Support v0.17.0 - Release 29th Dec 2020


Recommended Posts

@jebalicious @Skarlinger
So the current issue is Detailed Explanation: Solar Panels wont work on other vessels when they are not the selected vessel

so kopernicus solar panels are not working with TAC LS for any vessel except the active vessel yeah?
Could be something kopernicus has done. Will put on the list to investigate.

Link to post
Share on other sites

Hi there! it appears the person before me posting had the same/similar issue i did. All my crewed vessels have sufficient power - but whenever i unload that vessel, the solar panels just stop working until it is reloaded. I have Kopernicus installed also, using OPM and Minor Planets expansion. I'm using stock solar panels on the vessels that are having fits, if you need any further information i'll be happy to provide anything i can to assist you.

Link to post
Share on other sites

Can also confirm Kopernicus to be the culprit... have a heavily modded game that worked great, and decided to swap out Astronomer's Visual Pack for the newer (and sweet looking) Parallax. Kopernicus is a requirement, and as soon as I installed it I noticed the vessel electric charge issue. Tagging@R-T-B on this, since he's leading the charge on bleeding edge Kopernicus and may be willing to look into fixing it so TAC-LS electric charge behaves properly for unloaded vessels.

Edit: also opened a bug on the Github repository

Edited by attosecond
Link to post
Share on other sites

Hoping to connect the dots with a few threads related to solar panels using Kopernicus Bleeding Edge and TAC-LS in KSP 1.10.x. 

Around the same time as these posts in the TAC-LS thread (Nov. 12th - 16th 2020), over in the Kop-BE thread, R-T-B fielded questions related to solar panels & TAC-LS:

Specifically, he suggests:

"You can revert to the 'stock' solar code by deleting solarpanels.cfg from the config folder of Kopernicus.  Do be advised this only works for single star systems, as the stock code is not aware of more than one star."

Has anyone using TAC-LS tested this and does this resolve the issue of EC on non-selected vessels?

 

Edited by scottadges
Link to post
Share on other sites
7 hours ago, Raptor_1596 said:

Is there a way with stock TAC LS or another mod which will show accurate times for your resources including recycling/growing and not just what you have stored?

I use this mod: 

It has a time readout that shows how long until a resource is depleted/filled at current consumption.

 

 

Link to post
Share on other sites
  • 2 weeks later...

Whatever happened to the mini algae farm that was in the Kerbal Planetary Base Systems form factor? I can't seem to find it anywhere on my parts list or my tech tree. There's a greenhouse module in that form factor under the "Hydroponics" Tech, but no algae farm. 

Trying to figure out if it was removed from the mod or if I just screwed up something somewhere and am missing it. 

Link to post
Share on other sites
12 hours ago, Auriga_Nexus said:

Whatever happened to the mini algae farm that was in the Kerbal Planetary Base Systems form factor? I can't seem to find it anywhere on my parts list or my tech tree. There's a greenhouse module in that form factor under the "Hydroponics" Tech, but no algae farm. 

Trying to figure out if it was removed from the mod or if I just screwed up something somewhere and am missing it. 

Look under "Automation" in the tech tree, its a tech 8 robot icon just above the lowest tech line for power.

Edited by histalonia
Link to post
Share on other sites
  • 2 weeks later...
On 12/28/2020 at 6:47 AM, Isildurd said:

Good afternoon, no solutions for kopernicus and TAC solar panels to work for unloaded ships? I play with Kerbal Galaxy and sadly :(version 1.9.1

 

TAC doesn't have solar panels?

If you mean Kopernicus mod - which changes all parts that use ModuleSolarPanels (The stock solar panels) - to it's own version of solar panels. Then yes.

Seems Kopernicus no longer does this by basing it's solar panel code from the stock code. It renames the module and applies two modules to the part.

So I have a fix in progress for this for next version that hopefully I will get out this week some time.

 

Link to post
Share on other sites
On 11/1/2020 at 5:27 AM, gulegule said:

I see this exception repeatedly if I activate a recycler module while in the VAB:

[EXC 21:59:19.833] NullReferenceException: Object reference not set to an instance of an object
	BaseConverter.HasSpecialist (System.String effect) (at <c1858a3f77504bd1aaa946fdccf84670>:0)
	BaseConverter.GetCrewEfficiencyBonus () (at <c1858a3f77504bd1aaa946fdccf84670>:0)
	BaseConverter.GetEfficiencyMultiplier () (at <c1858a3f77504bd1aaa946fdccf84670>:0)
	BaseConverter.FixedUpdate () (at <c1858a3f77504bd1aaa946fdccf84670>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

 

Sorry I missed this post. I have tried this with the water recycler, sabatier, etc. with and without resources. Tried activating them all in the VAB and I get no errors.

 

Link to post
Share on other sites
On 10/20/2020 at 12:14 PM, dresoccer4 said:

hey there. i just got this mod and am having a fun time learning it.

quick question though: i just went on my first mission which was to stay in orbit for 12 days. i threw in a single life support hex can and blasted off. i began to fast forward in time after i was in orbit, when all the sudden i got a message saying my Kerbal died of air toxicity :( why did this happen?

i read the instructions thoroughly before use and it says:

  • Filling up with waste resources (Carbon Dioxide, Waste, Waste Water) has no effect. Any excess is dumped overboard, and you lose the opportunity to convert them back into good resources.

This conflicts with my dead Kerbal's understanding of how it all works. Thanks for any help!

You ran out of Electric Charge. Which is required to circulate the air in the capsule.

Link to post
Share on other sites

V0.17.0 Published. See OP for links.

    Re-compile for KSP 1.11.x.
    Fix Kopernicus Solar Panel background processing.
    Added EVA construction capabilities to all 0.625m, 1.5m and 2.5m TAC-LS parts.

Link to post
Share on other sites
  • 3 weeks later...
8 hours ago, Messeno said:

hi I would like to use both the tac and the USI life support, are the mods compatible?

You can possibly turn off USI's need for resources and keep just the habitation function if you like that part of USI. If you cannot do this then you cannot have two life support mods installed. They are redundant (with complete overlap of what they're meant to do) and mutually exclusive. Mixing them makes needless excessive work for you and can cause problems for the mod makers, that the mod makers won't touch with a 10 foot pole.

Link to post
Share on other sites

Hey, I'm new to TAC and was wondering about a few things.

My last playthrough was using USI Life Support, which I found fun.  But the annoying part was how complicated it was to become self-sufficient.  USI fits into the broader MKS pack, and the issue with that one is that it has like... 17 different kinds of ores.  So while the Life Support is quite straightforward (mostly just supplies and mulch).  Feeding the machines that renew your food takes forever to set up.  

I've got Nertea's parts (which come with the Fish Tank and Greenhouses) and I'm hoping to keep the resupply as simple as possible.  Like,  using the stock ore to feed the greenhouses directly (or at least feed them in a more straightforward manner than in MKS).  Is there a combination of mods that lets you do this?

 

Oh and thank you to the mod-maker for making these and for keeping them updated.  It's very much appreciated.

Link to post
Share on other sites

Hello,

Sorry if already posted, that 45 pages thread is massive...

Also I'm not 100% sure this is TAC LS related, maybe more a 1.11 thing, but still might be of interest...

When using the EVA MMUs (aka jetpacks), the thrusters drain all resources the Kerbal is carrying. With TAC LS it means it drains food, water, oxygen (and of course EC)... Really quite an inconvenience. Any idea on how to fix this ? Thanks.

Link to post
Share on other sites
On 1/24/2021 at 1:36 PM, N_Molson said:

Hello,

Sorry if already posted, that 45 pages thread is massive...

Also I'm not 100% sure this is TAC LS related, maybe more a 1.11 thing, but still might be of interest...

When using the EVA MMUs (aka jetpacks), the thrusters drain all resources the Kerbal is carrying. With TAC LS it means it drains food, water, oxygen (and of course EC)... Really quite an inconvenience. Any idea on how to fix this ? Thanks.

I think this is a stock bug that also affects other mods. It should just be a display bug in the resource panel, not actual resource consumption. I've entered a report on the Squad tracker here, and it's discussed on the Snacks thread here

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...