Jump to content

[1.11.x] TAC - Life Support v0.17.0 - Release 29th Dec 2020


Recommended Posts

3 hours ago, Booots said:

I'm not sure if you're aware already, but the newest release of CC exposed a bug in Blizzy's toolbar. The fix requires all mods using it to update the toolbar wrapper.

More info here:

 

I've already applied that fix. Are you having an issue?

Link to post
Share on other sites

I'm getting tons of nullrefs from this mod and all my kerbals just disappearing (not marked as missing.dead either). I've linked the log here

 

It first gives a lot of these:
 

[LOG 00:10:52.329] Starting the Dispatcher
[LOG 00:10:52.329] 
[LOG 00:10:52.330] PartLoader: Part 'Squad/Parts/Command/probeRoverBody/probeRoverBody/roverBody' has no database record. Creating.
[LOG 00:10:52.332] Starting the Dispatcher
[LOG 00:10:52.332] 
[LOG 00:10:52.332] DragCubeSystem: Creating drag cubes for part 'roverBody'
[LOG 00:10:52.348] PartLoader: Compiling Part 'Squad/Parts/Command/probeStackLarge/probeStackLarge/probeStackLarge'
[LOG 00:10:52.356] Starting the Dispatcher
[LOG 00:10:52.356] 
[ERR 00:10:52.383] Cannot find a PartModule of typename 'BuildEngineer'

[ERR 00:10:52.383] Cannot find a PartModule of typename 'FlightEngineer'

then followed by thousands of these:
 

[WRN 00:15:57.973] -WARNING- Tac.LifeSupportController[FFECFC24][329.50]: Unknown crew member: Fredfrey Kerman
[EXC 00:15:57.973] NullReferenceException: Object reference not set to an instance of an object
	Tac.CrewMemberInfo..ctor (System.String crewMemberName, System.String vesselName, Guid vesselId, Double currentTime)
	Tac.LifeSupportController.ConsumeResources (Double currentTime, .Vessel vessel, Tac.VesselInfo vesselInfo)
	Tac.LifeSupportController.FixedUpdate ()

 

Edited by Jimbodiah
Link to post
Share on other sites

Hey, got a bug report.

Using blizzy's toolbar 1.7.13 & TAC LS 0.12.6.

The toolbar is looking in the wrong place for some of the icons.. looks like a missing " / "

[ERR 18:44:25.738] [Toolbar] [ERROR] button texture not found: ThunderAerospace/TacLifeSupport/IconsTACyellowIconTB

Spams the error forever.

Does it for the yellow & red icons, dunno if any of the others are incorrect.. ran out of time to test. Works correctly if you copy the icons over & rename them to what its looking for.

Link to post
Share on other sites
20 hours ago, Jimbodiah said:

I'm getting tons of nullrefs from this mod and all my kerbals just disappearing (not marked as missing.dead either). I've linked the log here

 

It first gives a lot of these:
 

[LOG 00:10:52.329] Starting the Dispatcher
[LOG 00:10:52.329] 
[LOG 00:10:52.330] PartLoader: Part 'Squad/Parts/Command/probeRoverBody/probeRoverBody/roverBody' has no database record. Creating.
[LOG 00:10:52.332] Starting the Dispatcher
[LOG 00:10:52.332] 
[LOG 00:10:52.332] DragCubeSystem: Creating drag cubes for part 'roverBody'
[LOG 00:10:52.348] PartLoader: Compiling Part 'Squad/Parts/Command/probeStackLarge/probeStackLarge/probeStackLarge'
[LOG 00:10:52.356] Starting the Dispatcher
[LOG 00:10:52.356] 
[ERR 00:10:52.383] Cannot find a PartModule of typename 'BuildEngineer'

[ERR 00:10:52.383] Cannot find a PartModule of typename 'FlightEngineer'

then followed by thousands of these:
 

[WRN 00:15:57.973] -WARNING- Tac.LifeSupportController[FFECFC24][329.50]: Unknown crew member: Fredfrey Kerman
[EXC 00:15:57.973] NullReferenceException: Object reference not set to an instance of an object
	Tac.CrewMemberInfo..ctor (System.String crewMemberName, System.String vesselName, Guid vesselId, Double currentTime)
	Tac.LifeSupportController.ConsumeResources (Double currentTime, .Vessel vessel, Tac.VesselInfo vesselInfo)
	Tac.LifeSupportController.FixedUpdate ()

 

Is this with the DEV build? the first lot of lines are nothing to do with TAC.
The NullReference is. I'll have to investigate. Can you provide further context? what were you doing at the time? IE: Where did Fredfrey come from? was this on a vessel already launched that you switched away from and came back to? Or better yet, a full log is better.

17 hours ago, Usgiyi said:

Hey, got a bug report.

Using blizzy's toolbar 1.7.13 & TAC LS 0.12.6.

The toolbar is looking in the wrong place for some of the icons.. looks like a missing " / "

[ERR 18:44:25.738] [Toolbar] [ERROR] button texture not found: ThunderAerospace/TacLifeSupport/IconsTACyellowIconTB

Spams the error forever.

Does it for the yellow & red icons, dunno if any of the others are incorrect.. ran out of time to test. Works correctly if you copy the icons over & rename them to what its looking for.

Thanks! I'll take a look and fix it up. EDIT: Yep missing a "/" for ToolBar. Should be fine if you use the AppLauncher (stock icons) for now. Will look at the other problems above and try to get a new dev build out soon(tm)ish.

Edited by JPLRepo
Link to post
Share on other sites

Hi. I'm back to ksp after a year of inactivity.

Question about rescue contracts: I remember that TAC LS didn't kick in for "vessels we don't own" until we rendezvous with them or in other words, until the physics kicks in at 2-3 km distance.

Well yesterday I rendezvoused with a stranded kerbonaut's pod and it disappeared when I got into physics range and I got the message that the guy died because of lack of, well, everything.

Does this mean I now have to fly rescue missions the moment I accept the contract, and cannot do so many orbits until I get an intercept?

Link to post
Share on other sites
2 hours ago, ROXunreal said:

Hi. I'm back to ksp after a year of inactivity.

Question about rescue contracts: I remember that TAC LS didn't kick in for "vessels we don't own" until we rendezvous with them or in other words, until the physics kicks in at 2-3 km distance.

Well yesterday I rendezvoused with a stranded kerbonaut's pod and it disappeared when I got into physics range and I got the message that the guy died because of lack of, well, everything.

Does this mean I now have to fly rescue missions the moment I accept the contract, and cannot do so many orbits until I get an intercept?

Is this using the Dev build I posted above?
If it is then yep, I might have forgotten this use case. I'll need to fix it up.

EDIT: Yep, The new dev version has a bug in that I didn't cater for rescue kerbals use case. Use at your own peril. I'll fix it up and do a new dev version next day or two.

Edited by JPLRepo
Link to post
Share on other sites
5 hours ago, JPLRepo said:

Is this using the Dev build I posted above?
If it is then yep, I might have forgotten this use case. I'll need to fix it up.

EDIT: Yep, The new dev version has a bug in that I didn't cater for rescue kerbals use case. Use at your own peril. I'll fix it up and do a new dev version next day or two.

Actually I loaded a save from before I made the rendezvous but after taking the contracts. Maybe a dumb question that you can't know the answer to without testing but: do you think they'll be alive after your fix or would I need to restart the contracts?

Link to post
Share on other sites
On 10/25/2016 at 3:02 PM, JPLRepo said:

The NullReference is. I'll have to investigate. Can you provide further context? what were you doing at the time? IE: Where did Fredfrey come from? was this on a vessel already launched that you switched away from and came back to? Or better yet, a full log is better.

I'm getting the same null ref errors also. Seems to only be happening for tourists though.  I'm also using Tourism Plus if that matters at all and the tourists were from one of those contracts.  It happens regardless of whether the torusits are loaded onto the vessel from the VAB or from the launchpad

Link to post
Share on other sites

strange what probe/rovers and other unmanned things in KSP not freezing to death without electricity. Internal temperature almost not used thing.

Maybe add something for this in future in TAC-LS?

----

soory for my poor english

Link to post
Share on other sites
2 minutes ago, *MajorTom* said:

strange what probe/rovers and other unmanned things in KSP not freezing to death without electricity. Internal temperature almost not used thing.

Maybe add something for this in future in TAC-LS?

----

soory for my poor english

Great Idea. It's already here for Kerbals (see link). But I'm not sure Probes/rovers. I definitely think it's a good idea. But not sure it fits in the scope of this mod which is a Life Support mod.
https://github.com/KSP-RO/TacLifeSupport/issues/42

Link to post
Share on other sites

Ok, I've updated the development build. Available on Github only.
https://github.com/KSP-RO/TacLifeSupport/releases/tag/v0.12.6dev
Addresses a number of the bugs reported above.

  • Fixed part search tags.
  • Fixed turning TAC LS on/Off in a save file.
  • Added support for Community Category Kit
  • Rebalanced smaller Recyclers to support 3 kerbals.
  • Fixed Rescue and tourist kerbals. NREs.
  • Fixed Blizzy ToolBar Icon issue.

 

Edited by JPLRepo
Link to post
Share on other sites
14 minutes ago, JPLRepo said:

 But not sure it fits in the scope of this mod which is a Life Support mod.
 

what is "life".. the meaning of this word..? the life of kerbals or life of spacecraft... i just look wider at the name for mod :)

 

ps: even NASA is used words like "dead" for unmanned things (not unoperable or so on). http://www.space.com/22884-nasa-deep-impact-comet-probe-dead.html  So IMHO the "life" also is not wrong word for human created things

Edited by *MajorTom*
Link to post
Share on other sites
20 minutes ago, *MajorTom* said:

what is "life".. the meaning of this word..? the life of kerbals or life of spacecraft... i just look wider at the name for mod :)

 

ps: even NASA is used words like "dead" for unmanned things (not unoperable or so on). http://www.space.com/22884-nasa-deep-impact-comet-probe-dead.html  So IMHO the "life" also is not wrong word for human created things

I have added the last few comments into the GitHub item. Let's open it up for debate there.
Anyone with an opinion welcome to discuss on the Github item, or here.

EDIT: And while we are at it. All input welcome on this item as well:
Modelling Cabin Atmosphere

Edited by JPLRepo
Link to post
Share on other sites

So " Fixed Rescue and tourist kerbals. NREs. " in the dev version would apply to things like the below (crew member is a tourist)? Man, here I thought I had a juicy one.:sticktongue:

Off to grab the dev version to find out.

Congrats on assuming direct control - TACLS is in good hands. Reading the last few posts...things seem to be turning interesting.

-WARNING- Tac.LifeSupportController[FF8EF84A][10261.72]: Unknown crew member: Desby Kerman
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

NullReferenceException: Object reference not set to an instance of an object
  at Tac.CrewMemberInfo..ctor (System.String crewMemberName, System.String vesselName, Guid vesselId, Double currentTime) [0x00000] in <filename unknown>:0 
  at Tac.LifeSupportController.ConsumeResources (Double currentTime, .Vessel vessel, Tac.VesselInfo vesselInfo) [0x00000] in <filename unknown>:0 
  at Tac.LifeSupportController.FixedUpdate () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

EDIT:

Yup.

https://github.com/KSP-RO/TacLifeSupport/issues/52

Edited by Deimos Rast
Link to post
Share on other sites

Hi, i'm proud to say i'm using TAC-life, but i'm having some issues since last update. I'm also using USI-kolonization, and i'm wondering if there is already a way to make kolonization parts production tac-life supplies (a .cfg file ?). In previous versions, it was possible, but since last realease, i'm not able to play because of that. Thanks by advance.

Link to post
Share on other sites

issue with dev. 12.6 version ---> rescued pilots (stock contracts) die when i come closer to 2.4 km

7ae17aa16db7.png
 

i test same save in ..12.5 latest relese- it is ok (peter kerman alive in approach)

891546b153b7.png
 

 

and...so this is ultimate issue for new dev version in kampain (i return to older 12.5)

Edited by *MajorTom*
Link to post
Share on other sites
19 hours ago, feuby said:

Hi, i'm proud to say i'm using TAC-life, but i'm having some issues since last update. I'm also using USI-kolonization, and i'm wondering if there is already a way to make kolonization parts production tac-life supplies (a .cfg file ?). In previous versions, it was possible, but since last realease, i'm not able to play because of that. Thanks by advance.

USI Kolonization has a cfg file for TAC-LS and is supposed to support it. That file is part of USI mod not TAC-LS.
So if it's not working, or you have an issue with the USI mod, you will have to take that up in the USI thread.

1 hour ago, *MajorTom* said:

issue with dev. 12.6 version ---> rescued pilots (stock contracts) die when i come closer to 2.4 km

<snip pic>

i test same save in ..12.5 latest relese- it is ok (peter kerman alive in approach)

<snip pic>

and...so this is ultimate issue for new dev version in kampain (i return to older 12.5)

I assume this is the latest dev build I did that was supposed to fix this.
So I will have to investigate what is still going wrong. Thanks.

Link to post
Share on other sites

I have an issue that I've already seemingly solved, but I mention is because I'm running the dev version, so it might be important.

One of my landers, "Minmus DIRECT v2", is en route home from Minus (due in a few days or so). TACLS registers the lander and the occupant as being Prelaunch status, and thus doesn't show/update their life support requirements/needs. Switching to the vessel in question seems to have fixed things, and now when I go back to the tracking station, TACLS accurately reports things, and all seems well.

You can see in the picture the TACLS screen and the lander/crew in question. Below are attached a log and my persistence file if  you're curious.

Cheers.

EDIT: Oh, I'll also mention, since I'm here, maybe change the Life Support containers to all read "Life Support Food Container, 1.25m" since currently half refer to their diameters. Also, looking at the food containers now, they at least seem to be missing the bulkhead profiles. Github issue?

 

http://imgur.com/a/24ZWN

Log

Save

 

Link to post
Share on other sites
17 minutes ago, Deimos Rast said:

I have an issue that I've already seemingly solved, but I mention is because I'm running the dev version, so it might be important.

One of my landers, "Minmus DIRECT v2", is en route home from Minus (due in a few days or so). TACLS registers the lander and the occupant as being Prelaunch status, and thus doesn't show/update their life support requirements/needs. Switching to the vessel in question seems to have fixed things, and now when I go back to the tracking station, TACLS accurately reports things, and all seems well.

You can see in the picture the TACLS screen and the lander/crew in question. Below are attached a log and my persistence file if  you're curious.

Cheers.

EDIT: Oh, I'll also mention, since I'm here, maybe change the Life Support containers to all read "Life Support Food Container, 1.25m" since currently half refer to their diameters. Also, looking at the food containers now, they at least seem to be missing the bulkhead profiles. Github issue?

 

http://imgur.com/a/24ZWN

Log

Save

 

Yeah - That's due to the changes I made for the dev version. Any existing saves/vessels will default to PRELAUNCH status.
Once you switch to them it's all good and going forward from there.

I'll look at the container names.

Link to post
Share on other sites

Ok everyone, I have finally got the Rescue Kerbals sorted.
I've updated the v0.12.6Dev release on Github. https://github.com/KSP-RO/TacLifeSupport/releases/tag/v0.12.6dev
Assuming no one else finds anything else and someone can confirm rescue kerbals are good I'll be doing a full release with this version.
Fixes since last Dev build:
Fix Rescue Kerbals processing/monitoring.
Fixed NullReferenceException on the Air Filter TACGenericConverter in the Editor scene.
Added bulkheadprofiles to part configs (for size sorting in editor).
Aligned part names to include size in their names.

Link to post
Share on other sites

V0.12.6 published for KSP 1.2.1.
Big changelist. See the changelist in the OP.
Please note: due to underlying internal changes you may notice existing vessels in your save appear in the TAC LS monitoring window as "PRELAUNCH" after upgrading.
This is ok, just switch to each of these vessels in flight and TAC LS should start monitoring them correctly again. This should only occur once.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...