JPLRepo

[1.7.x] TAC - Life Support v0.13.13 - Release 29th Jun 2019

Recommended Posts

1 hour ago, Modding Maniac said:

are there any greenhouse mods for this?

yes there is one

Share this post


Link to post
Share on other sites

I am Having trouble with consumption of electricity

I have a Mun station and it seems that no matter how many batteries i attach,  the electric charge only last 3 days for the kerbals on the station during the lunar night. here is the math.

1 kerbal consume 459 EC/day

I have

7 kerbals, so 3213 EC/Day

 

I have

14,000 EC worth in base.

so it should last me atleast 4.3 kerbal days of EC. you guys know what's going on?

 

Edit. the math worked out. sry :[

didn't account for systems and command

Edited by justicarab
I didn't account for running systems

Share this post


Link to post
Share on other sites

As my understanding the MM_AddLifeSupportModule.cfg and the MM_AddResources adds Lifesupport and Ressources to every manned pod. Right?
Why does TAC not add them to Tantares??? All other Mods without extra configs works for me.

Share this post


Link to post
Share on other sites

Hi 

I', experimenting to reduce the part list of TAC using FireSpitter and MM:

+PART[HexCanOxygenSmall]:NEEDS[ThunderAerospace]
{
    @name = HexCanSmall
    @title = Small Switchable Hex Can for Tac

	MODULE
	{
		name = FStextureSwitch2
		nextButtonText = Next resource
		prevButtonText = Previous resource
		statusText = Current resource
		switchableInFlight = true
		repaintableEVA = false
		textureRootFolder = MacLuky/SmallTAC/
		textureNames = hexempty;hexfood;hexwater;hexlifesupport;hexoxygen;hexwaste
		objectNames = Untagged
		textureDisplayNames = Empty;Food;Water;LifeSupport;Oxygen;Waste
		useFuelSwitchModule = true
		fuelTankSetups = 0;1;2;3;4;5
	}

	MODULE
	{
		name = FSfuelSwitch
		resourceNames = Structural;Food;Water;Water,Food,Oxygen;Oxygen;Waste,WasteWater,CarbonDioxide
		resourceAmounts = 0;16.2;16.2;7.6,5,776.4;3593.4;1.3,12.2,1272.9
		initialResourceAmounts = 0;16.2;16.2;7.6,5,776.4;3593.4;0,0,0
		hasGUI = false
		switchableInFlight = true
	}
}

The hard part is trying to find out what mesh I should switch (objectNames) I tried Untagged and HexCan, but that ain't it. Any pointers?

 

Update: it is Canister

Edited by MacLuky

Share this post


Link to post
Share on other sites
On ‎3‎/‎24‎/‎2018 at 3:16 PM, Modding Maniac said:

and what is it

Check out my DSSHU pack

Share this post


Link to post
Share on other sites

Hi, JPLRepo , i'm having the same problem as below:

On 18.03.2018 at 5:52 PM, tmynott2511 said:

 have downloaded the most up to date version for 1.4 and it no longer works. I have the resources although they never get depleted which is a shame. Any advise?

I'd like to post log and follow your instructions, but link in your post and in the topic starting post is not valid ("The page you requested does not exist"). Would you be so kind to update this link?

On 21.03.2018 at 12:51 AM, JPLRepo said:

For support please ensure you are following these instructions.

Share this post


Link to post
Share on other sites

This mod has to have the option to take off eva suit in oxygen atmosphere. What's the point of running out of oxygen while eva in an oxygen atmosphere?

Share this post


Link to post
Share on other sites

The base game does not allow you to take your suit off in an oxygen atmosphere.  I'm not sure why a mod designed to add life support resources should be required to go out of it's intended function to provide this functionality. 

As for running out of oxygen, just because another body has oxygen does not mean the rest of the atmosphere is not toxic, nor does it mean that there is sufficient oxygen to sustain life.  A space suit designed with the ability to filter the toxic elements and/or collect oxygen in sufficient concentration to sustain a Kerbal from a non-Kerbin/homeworld atmosphere would be bulkier and heavier than a suit not designed to perform such tasks.  With only one celestial body containing oxygen in the stock game, these kinds of functions would be dead weight for most space exploration.

Share this post


Link to post
Share on other sites

TAC-LS was working.. unfortunately i did not notice when resources were not being used (there were no problems with parts or loading) I recently.. updated KIS, KK Planetary Parts (the first update of this mod had some funky graphics issues, the second fixed these issues).

Im sorry but i dont recall if i tried to reinstall TAC-LS with 13.6(?vs) first.. before install 13.9  The issue is as follows.. after installation of TAC-LS 13.9.. and its a game breaker.. 

On loading my save (quick saves, regular saves, and "persistent" saves) almost all Kerbals.. deployed die of "Air Toxicity".  This happens further and further into saves.. basically, its killing the kerbals during saves where they perfectly safe when saved.  i DO get some anomalies, between saves.. but i cannot differentiate what kerbals are saved and which are not. On investigating the craft.. the Electric Charge is ample, in some cases full.

The Green pop-up text, center screen.. that informs of the death by Air Toxicity.. Scrolls endlessly.. For instance.. i get the prompt "Jebediah has died from Air Toxicity" then i get the same prompt over again. This loop is indicated in the Alt-f12? f11? console as a -Warning- from TAC controller.. FFF7C8E8  Unkown crew member : valentina etc etc.  followed by a -info- fff7c8e8  Certain craft - certain kerbal - died of toxicity..  

These Warning and Info listed in the command console Repeat.. killing the same kerbal multiple times, over and over. The time stamp? Execution order? AS ONE OF THE SAVE EXAMPLES starts at this FFF7C8E8 [ 416.82 ] and continues to scroll the same warnings to FFF7C8E8 [ 418.02 ]   It takes a quite a whille to scroll through.. sometimes a minute..

The Save i just tried gives me the warning and info console code of FFF6D504 scrolled from 998.80 to 1000.08, 

656292807411F82854E5FB8AF0EC784F5CBB895CHere is the Green Flavor Prompt, this flickers as the same indication scrolls over and over. 

6CD10DAF2455973D729C42FDCB568DF2516CC3F3This is the command console prompt of a random save. This is showing the same Kerbal being killed over and over.

These next two pics, show the TAC-LS info and the corresponding craft.. RIGHT AFTER loading the save.

46F3B8892EAA2DE7BBF8A4B27FD8C0427855278BThe craft "KA5 DUNAFALL" registering a -200 day Electricity on save load. 

Immediately after this pic (while electricity remaining  number quickly rises) to actual levels

347572AA96B1A81157D8EDD25B6D43A9A87417C3You can see the craft orientation.. undisturbed, with operational solar panels

Here is the Prompt "MOON STATION ABILENE" reporting no electric charge (after killing the occupants)95E298A3DF663CCC06E9D51362C40ABE406F5254and then a shot of "MOON STATION ABILENE" A70C774AA896A5CA0389B135D0AD15CA9EE6D1AFNote the zero EC in both crewed modules, and the over all EC being positive numbers (unlike the previous craft, this one is in shadow during the save.. showing the positive EC sum for the craft.

I cant find a work around.. i cant uninstall TAC-ls because all my craft carry TAC parts.. i cant turn off TAC, until i load a save and by then the damage is done.. and quite frankly, i wouldnt want to play KSP anymore without TAC, or a similar program

I tried monkeying with the config file, adding a few zeros to the MaxTimeWithoutElectricity 'lifesupport.cfg'  but it either didnt work.. or i didnt add enough zeros.

:rep::rep::rep:

If anyone could help it woul dbe much appreciated.. I spend alot of time building these games.. and unfortunately.. everytime Squad wants to add Swahili to the language list, or make a change to somethingorother, i have to start all over.  Im only a month into 1.4.1, even though, i only have my relay sats enroute to each planet, my first wave of kerbals en route to Duna.. and my orbital stations in place for both the Mun, Minmus and Kerbin..  that alone is alot of work, and a good accomplishment.. for me at least. I really dont want to lose it.

 

Thanks for you time, in reading this.. I appreciate any input, from anyone..

And love the software.. i put a couple thousand hours into KSP, before i even bought it. TAC life support made the 2000 ive logged on Steam..  just as fun.  

Keep up the good work, 

Bart

Share this post


Link to post
Share on other sites
On 3/31/2018 at 2:23 AM, Bartacomus said:

TAC-LS was working.. unfortunately i did not notice when resources were not being used (there were no problems with parts or loading) I recently.. updated KIS, KK Planetary Parts (the first update of this mod had some funky graphics issues, the second fixed these issues).

Im sorry but i dont recall if i tried to reinstall TAC-LS with 13.6(?vs) first.. before install 13.9  The issue is as follows.. after installation of TAC-LS 13.9.. and its a game breaker.. 

On loading my save (quick saves, regular saves, and "persistent" saves) almost all Kerbals.. deployed die of "Air Toxicity".  This happens further and further into saves.. basically, its killing the kerbals during saves where they perfectly safe when saved.  i DO get some anomalies, between saves.. but i cannot differentiate what kerbals are saved and which are not. On investigating the craft.. the Electric Charge is ample, in some cases full.

The Green pop-up text, center screen.. that informs of the death by Air Toxicity.. Scrolls endlessly.. For instance.. i get the prompt "Jebediah has died from Air Toxicity" then i get the same prompt over again. This loop is indicated in the Alt-f12? f11? console as a -Warning- from TAC controller.. FFF7C8E8  Unkown crew member : valentina etc etc.  followed by a -info- fff7c8e8  Certain craft - certain kerbal - died of toxicity..  

These Warning and Info listed in the command console Repeat.. killing the same kerbal multiple times, over and over. The time stamp? Execution order? AS ONE OF THE SAVE EXAMPLES starts at this FFF7C8E8 [ 416.82 ] and continues to scroll the same warnings to FFF7C8E8 [ 418.02 ]   It takes a quite a whille to scroll through.. sometimes a minute..

The Save i just tried gives me the warning and info console code of FFF6D504 scrolled from 998.80 to 1000.08, 

Here is the Green Flavor Prompt, this flickers as the same indication scrolls over and over. 

This is the command console prompt of a random save. This is showing the same Kerbal being killed over and over.

These next two pics, show the TAC-LS info and the corresponding craft.. RIGHT AFTER loading the save.

The craft "KA5 DUNAFALL" registering a -200 day Electricity on save load. 

Immediately after this pic (while electricity remaining  number quickly rises) to actual levels

You can see the craft orientation.. undisturbed, with operational solar panels

Here is the Prompt "MOON STATION ABILENE" reporting no electric charge (after killing the occupants)and then a shot of "MOON STATION ABILENE" Note the zero EC in both crewed modules, and the over all EC being positive numbers (unlike the previous craft, this one is in shadow during the save.. showing the positive EC sum for the craft.

I cant find a work around.. i cant uninstall TAC-ls because all my craft carry TAC parts.. i cant turn off TAC, until i load a save and by then the damage is done.. and quite frankly, i wouldnt want to play KSP anymore without TAC, or a similar program

I tried monkeying with the config file, adding a few zeros to the MaxTimeWithoutElectricity 'lifesupport.cfg'  but it either didnt work.. or i didnt add enough zeros.

:rep::rep::rep:

If anyone could help it woul dbe much appreciated.. I spend alot of time building these games.. and unfortunately.. everytime Squad wants to add Swahili to the language list, or make a change to somethingorother, i have to start all over.  Im only a month into 1.4.1, even though, i only have my relay sats enroute to each planet, my first wave of kerbals en route to Duna.. and my orbital stations in place for both the Mun, Minmus and Kerbin..  that alone is alot of work, and a good accomplishment.. for me at least. I really dont want to lose it.

 

Thanks for you time, in reading this.. I appreciate any input, from anyone..

And love the software.. i put a couple thousand hours into KSP, before i even bought it. TAC life support made the 2000 ive logged on Steam..  just as fun.  

Keep up the good work, 

Bart

I snipped all your pictures...
If you want help. Refer to the opening post. Logs and save files would go a long way to getting some help.

30 minutes ago, HaydenTheKing said:

What is this .gitignore file?

It's a file that shouldn't be there.. it's just a git thing... you can safely delete it.

On 3/25/2018 at 8:16 AM, Modding Maniac said:

and what is it

Haven't checked for a while. But...
there were a few - but checking a lot of them have fallen by the side of the road.......
I know this one works:

 

Share this post


Link to post
Share on other sites

I'm not looking for support and that's why I do not include logs. The only reason why I have registered is to be able to say something...

Yesterday I started a new game. No possibility of recovering lost Kerbals, without being able to revert a flight. All good. Landing in Iota without problems (I use Galileo's, GPP). The same lander at Ceti, properly equipped with solar panels and electricity to spare (I am a foresight, I do not want to lose something because of some stupid mistake on my part) besides supplies also to spare... Normal landing without problems. I'm going home and half way to approach Gael and during a time warp at 10000x I see a message saying that my ship runs out of electricity (all solar panels extended all the time). I return to normal speed and to my great displeasure my ship has lost control (dead kerbal). At this moment I'm about to delete this mod from my hard drive and forget about it forever. It seems to me a total lack of respect to publish a mod with such a serious bug... 

I like difficult things but this is ridiculous. At the very least you should warn people that they are about to use a mod with some huge flaws that can turn a nice session into something far less rewarding... Bye.

Edited by Actkqk
I forgot the name of 1 moon

Share this post


Link to post
Share on other sites
17 minutes ago, Actkqk said:

... It seems to me a total lack of respect to publish a mod with such a serious bug... At the very least you should warn people that they are about to use a mod with some huge flaws that can turn a nice session into something far less rewarding... Bye.

Every piece of complex software is going to have some bugs. No reasonable person expects otherwise, and no reasonable person attacks the software maker in such a personal way. That's especially true in the case of mod makers, who do not get paid for their work, and offer it solely in hopes that fellow players will get some enjoyment out of it. 

Share this post


Link to post
Share on other sites
31 minutes ago, Actkqk said:

I'm not looking for support and that's why I do not include logs. The only reason why I have registered is to be able to say something...

Yesterday I started a new game. No possibility of recovering lost Kerbals, without being able to revert a flight. All good. Landing in Iota without problems (I use Galileo's, GPP). The same lander at Ceti, properly equipped with solar panels and electricity to spare (I am a foresight, I do not want to lose something because of some stupid mistake on my part) besides supplies also to spare... Normal landing without problems. I'm going home and half way to approach Gael and during a time warp at 10000x I see a message saying that my ship runs out of electricity (all solar panels extended all the time). I return to normal speed and to my great displeasure my ship has lost control (dead kerbal). At this moment I'm about to delete this mod from my hard drive and forget about it forever. It seems to me a total lack of respect to publish a mod with such a serious bug... 

I like difficult things but this is ridiculous. At the very least you should warn people that they are about to use a mod with some huge flaws that can turn a nice session into something far less rewarding... Bye.

As a mod maintainer who freely gives their spare time: you are welcome to submit pull request to the code with a fix. Coming on here to personally attack a mod maintainer rather than being a civil person grants you the immediate response of being ignored. Fair well.

Share this post


Link to post
Share on other sites

I'm running ksp version 1.41 (x64), with TACLS 0.13.9, and it appears that recyclers are not functioning on unloaded vessels, though they'll recalculate upon reload (unloaded vessel processing is checked). I've also tried using the mod on otherwise vanilla 1.41 and 1.42, with the same issues. 

logs : https://www.dropbox.com/s/plk0uhu9u4vv9yx/output_log.txt?dl=0

Edited by KnightofNiOG
clarify issue

Share this post


Link to post
Share on other sites
5 hours ago, KnightofNiOG said:

I'm running ksp version 1.41 (x64), with TACLS 0.13.9, and it appears that recyclers are not functioning on unloaded vessels, though they'll recalculate upon reload (unloaded vessel processing is checked). I've also tried using the mod on otherwise vanilla 1.41 and 1.42, with the same issues. 

logs : https://www.dropbox.com/s/plk0uhu9u4vv9yx/output_log.txt?dl=0

Because they don't yet work when unloaded. Hopefully I will get some time to add in the next week or so.
The only things that do are: Generators, Fuel cells, Solarpanels and the life support consumption.

Share this post


Link to post
Share on other sites
2 hours ago, JPLRepo said:

Because they don't yet work when unloaded. Hopefully I will get some time to add in the next week or so.
The only things that do are: Generators, Fuel cells, Solarpanels and the life support consumption.

Thanks for the info, I look forward to the update! I'll just make sure my green people have enough buffer on their crafts in the meantime. 

Share this post


Link to post
Share on other sites
5 hours ago, KnightofNiOG said:

Thanks for the info, I look forward to the update! I'll just make sure my green people have enough buffer on their crafts in the meantime. 

either that or you can turn off the background resource processing completely... as goes for anyone else. I will also look at this high time warp EC issue in the next week or two time permitting as well.

Go into the difficulty settings menu for your save (from the pause menu - settings - then difficulty settings button at the top of the menu) and select TAC LS then there is an option to turn off the background resource processing completely.

Share this post


Link to post
Share on other sites
On 28.03.2018 at 10:41 AM, ubergosu said:

Hi, JPLRepo , i'm having the same problem as below:

 

Hello, now i'm back with logs and savegame. My issue is that TACLS just don't consume resources . I start new game, launch test vehichle, wait it to land and warp time for several days. LS resources quantity is equal to starting level.

https://yadi.sk/d/Q1doLyrg3ULxko

 

 

Share this post


Link to post
Share on other sites

I am in KSP version 1.3.1 playing RSS/RO and the levels won't move at all. No food depletion, no rise in CO2 levels, nothing, no matter how far I timewarp. I was like "screw it" and downloaded the 1.4.1 version of this mod and got limited parts (as usual from version incompatibility) but the levels started to run down. Somethings up with that... help? I'd love to play with this mod and think it would be a real joy to pack lunch for ma kerbals so can someone help me out?

Edited by PossiblyPrecarious

Share this post


Link to post
Share on other sites

@PossiblyPrecarious

As for the mostly mod issues

1)try it on a frsh ksp (1.3.1or1.4.2) install with the right version of the mod

2)(download again even the version u got and filesize the same,somtimes the DLfile is corrupt)

 3) (alt+F12)open dbug window look for RED lines

Tip-on debbuging first 2 checkboxes ON- let u see red lines on start or when the happen .ever

when still exist     LOG file,Sys specs  

and READ - HOW to get support on the first page

much luck bug-hunting(its a part of ksp=)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.