JPLRepo

[1.7.x] TAC - Life Support v0.13.13 - Release 29th Jun 2019

Recommended Posts

ive installed v0.13.13 and it seems to be working correctly except the displays list a Kerbin day as 7hrs long when I have my day length set to 8hrs through kronometer.  I dont seem to have any errors in the console or KSP.log file

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, macc92 said:

ive installed v0.13.13 and it seems to be working correctly except the displays list a Kerbin day as 7hrs long when I have my day length set to 8hrs through kronometer.  I dont seem to have any errors in the console or KSP.log file

Would you mind to post the MM patch you've used to configure kronometer? I just tried it on my own and it works perfectly fine.

I've tested it with a stack of 8 mk1 command pods, which results in a food reserve for 24 days without kronometer (6hours day length) and the same stack will carry enough food for 18 days after setting the day length to 8hours, which is exactly the expected result.

Edited by 4x4cheesecake

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, 4x4cheesecake said:

Would you mind to post the MM patch you've used to configure kronometer? I just tried it on my own and it works perfectly fine.

I've tested it with a stack of 8 mk1 command pods, which results in a food reserve for 24 days without kronometer (6hours day length) and the same stack will carry enough food for 18 days after setting the day length to 8hours, which is exactly the expected result.

I havent used a MM patch, the day length was set to 8hrs through 2.5x RESCALE! mod and I used kronometer to set the clock to show the 8hr days. The only change I have done personally is change the day length from the 7.5hr it comes with to 8 and that was in the rescale .cfg file

stacking 8 mk1 command pods for me gives 20days 4hrs of food, I also have no ability to switch to either 6hr/24hr readouts

Edited by macc92

Share this post


Link to post
Share on other sites
19 minutes ago, macc92 said:

I havent used a MM patch, the day length was set to 8hrs through 2.5x RESCALE! mod and I used kronometer to set the clock to show the 8hr days. The only change I have done personally is change the day length from the 7.5hr it comes with to 8 and that was in the rescale .cfg file

Ok, but still we need to know how exactly did you do that, otherwise we have to guess for the next three days. Did you edit the "Settings.cfg" of Kronometer or the config which comes with the rescale mod?

You probably just edited the value for the days but forgot to set "useHomeDay" to false. I actually don't know why the config of rescale contains values for the day and year length, it's not functional while "useHomeDay" and "useHomeYear" are set to true.

1 hour ago, macc92 said:

I also have no ability to switch to either 6hr/24hr readouts

Well, that's kinda expected while kronometer is installed since it overwrites the KSP clock, so even when you change the KSP settings to display "earth time", kronometer will change it to the custom clock settings.

Share this post


Link to post
Share on other sites
1 minute ago, 4x4cheesecake said:

Ok, but still we need to know how exactly did you do that, otherwise we have to guess for the next three days. Did you edit the "Settings.cfg" of Kronometer or the config which comes with the rescale mod?

You probably just edited the value for the days but forgot to set "useHomeDay" to false. I actually don't know why the config of rescale contains values for the day and year length, it's not functional while "useHomeDay" and "useHomeYear" are set to true.

I changed the @dayLengthMultiplier in 2.5xKSP.cfg from 1.25 to 1.333.. and the Kronometer useHomeDay was set to false since I downloaded it

Share this post


Link to post
Share on other sites
2 hours ago, macc92 said:

I changed the @dayLengthMultiplier in 2.5xKSP.cfg from 1.25 to 1.333.. and the Kronometer useHomeDay was set to false since I downloaded it

Ok, even this works for me (the 2.5xKSP.cfg contains a MM patch for kronometer to set "useHomeDay" to true, so kronometer adjust automatically to the new daylength). Not exactly 8hours but 7h58m though. Well, my KSC was buried in the ground but that's a different issue :D
Would you mind to upload a log file and your ModuleManager.ConfigCache please?

If you don't know where to find the log, take a look at this post, it contains the log file location for each operating system (for KSP 1.4.+ on windows system, it's the third path).
The ModuleManager.ConfigCache is located in your GameData directory.

Please upload the files to a filehoster or cloud service like dropbox, google drive, one drive, etc... and share a download link for it :)

Share this post


Link to post
Share on other sites
2 hours ago, macc92 said:

Hm...I'm a bit puzzled here. The configs are fine, nothing exceptional in the log.

But I've noticed two things anyway:

1) I made a mistake :/ My "test craft" actually got 7 mk1 pods, not 8. 8 pods actually sum up to 20d and 4h like you said.

2) there seem to be some inaccuracy when using "useHomeDay" in this case. For example: The calulations are on point when using 7 pods (I choose this number to get an easy way to double check it manually).

7 pods in stock = food for 144h, divided by 6h per day = 24 days
7 pods in rescale = food for 144h, divided by 8h per day = 18 days

But for some reason, it doesn't work for a single pod. The TAC LS ingame helper calculates 2 days and 4 hours in this case, but it need to be 2 days and 2 hours. After setting the day length in kronometer to 28800 seconds (that's 8 hours), it works perfectly fine though.

Try to run this patch:

@Kronometer:FINAL
{
	@useHomeDay = false
	@useHomeYear = true
	@useLeapYears = true
	
    @CustomTime
    {
        @Day
        {
			%singular = Day
			%plural = Days
			%symbol = d
			%value = 28800
        }
    }
}

That should fix it for now :)

Share this post


Link to post
Share on other sites
13 hours ago, 4x4cheesecake said:

Try to run this patch:


@Kronometer:FINAL
{
	@useHomeDay = false
	@useHomeYear = true
	@useLeapYears = true
	
    @CustomTime
    {
        @Day
        {
			%singular = Day
			%plural = Days
			%symbol = d
			%value = 28800
        }
    }
}

That should fix it for now :)

Yep, it's running perfectly fine now, thanks for sorting this out :D

Share this post


Link to post
Share on other sites

Will I be able to use the parts ok if I remove the TacLifeSupport.dll file?  I like using Kerblism, but also like the TAC parts.

Share this post


Link to post
Share on other sites

I've done it before while using USI LS and Snacks because I liked the hex cans.  I did have to write MM patches to give them the proper resources though.

Share this post


Link to post
Share on other sites
Posted (edited)

I am having a strange issue where only Val has monoprop when she goes on EVA. No other Kerbals bring along monoprop.

Is this possibly due to TAC?

Never mind. It was due to only partially unistalling kerbalism.

Edited by mikegarrison

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.