JPLRepo

[1.8.x] TAC - Life Support v0.14.0 - Release 19th Oct 2019

Recommended Posts

On 1/12/2019 at 1:14 AM, TGApples said:

I think there may be an issue with electrocharge and potentially Oxygen in 1.6. They don't show up in the "life support crew roster" tab, unlike food and water, and I'm pretty sure one of my kerbals should be dead due to an electrocharge issue.

They never have showed in the crew roster section. Because EC and O2 is vessel based... not per kerbal.

Share this post


Link to post
Share on other sites

v0.13.12.0 released for KSP 1.6.x - Note changes to unloaded resource processing.

    Re-compile for KSP 1.6.x
    Added support for Near Future fission Generator in Unloaded Resource processing.
    Added support for TacGenericConvertor in Unloaded Resource processing. - NB: does not factor in crew bonuses in resource calcs for unloaded vessels.
    Added support for ModuleResourceConverter's that produce ElectricCharge ONLY (eg: FuelCell) in Unloaded Resource processing. - NB: does not factor in crew bonuses in resource calcs for unloaded vessels.
    Fix ModuleTestSubject configuration for the revamped pod parts.

Share this post


Link to post
Share on other sites
15 minutes ago, JPLRepo said:

Added support for Near Future fission Generator in Unloaded Resource processing.

Excellent.
I don't see NearFutureFissionGenerator.cs anywhere in https://github.com/JPLRepo/REPOSoftTechKSPUtils/tree/master/ though, despite it being referenced in BackgroundResources.csproj. Slightly confused.
I am looking at the correct repo, right?

Share this post


Link to post
Share on other sites

Oh my god I wish I had this a month earlier but better late than never I guess. Now that Recyclers work unloaded, I don't have to repeated switch over to crafts which run solely on recyclng food! 

Share this post


Link to post
Share on other sites

Thank you for your work!

I have some troubles with the new TacGenericConvertor background processing.

My space station built with SSPXr is leaking large amounts of water in the background (no time-warp) if any of its life-support converters are active, even those that don't consume water (carbon extractor, water purifier). The active vessel, however, does not lose any water, the purifier even regenerates some of it.

It doesn't seem to appear with the Tac-Recyclers, although I didn't get to do much testing, yet. I don't see anything in SSPXr's MM patches that looks out of order.

I'd guess it might have something to do with how "DumpExcess" is handled in background, e.g. the water splitter continues to consume water if all oxygen tanks are full? I tried to get my head around how UnloadedResourceProcessing RequestResource() handles those but didn't quite get how the overflow works.

Share this post


Link to post
Share on other sites
12 hours ago, HansAcker said:

Thank you for your work!

I have some troubles with the new TacGenericConvertor background processing.

My space station built with SSPXr is leaking large amounts of water in the background (no time-warp) if any of its life-support converters are active, even those that don't consume water (carbon extractor, water purifier). The active vessel, however, does not lose any water, the purifier even regenerates some of it.

It doesn't seem to appear with the Tac-Recyclers, although I didn't get to do much testing, yet. I don't see anything in SSPXr's MM patches that looks out of order.

I'd guess it might have something to do with how "DumpExcess" is handled in background, e.g. the water splitter continues to consume water if all oxygen tanks are full? I tried to get my head around how UnloadedResourceProcessing RequestResource() handles those but didn't quite get how the overflow works.

Oh... hmm. could be onto something there... it looks like if the output of any Tac recycler is set to dump excess it doesn't shutdown.... which is correct. and so it will keep consuming the input resources forever and dumping the output into space.. which is how it would work when the active vessel. and how it would work with the unloaded vessel processing I added..  Yet you say this is not happening when it is the active vessel? which doesn't make sense.

 

Share this post


Link to post
Share on other sites

With all mods removed except for SSPXr, TacLS and their dependencies, background processing seem to happen normally.

I only have a handful of other mods installed, maybe one of them does its own things in the background. I'll investigate and restart KSP over and over and over again until I find the culprit :-)

Edit: well, that was quick. One of my own experimental patches springs a leak, even though the "Water Shunt" isn't enabled. I had added this converter because my greenhouse simulations were running out of WasteWater. I made a test craft with just a habitat and a water tank. If I start any of the converters and go back to the tracking station, the tanks are losing days worth of water within seconds.

I don't really understand why it's happening. At least I know how to stop it :-)

Spoiler

// experimental: turn Water into WasteWater for use in the greenhouse

@PART[*]:HAS[@MODULE[TacGenericConverter]:HAS[#ConverterName[Water?Purifier]]]:NEEDS[TacLifeSupport]
{
	MODULE
	{
		name = TacGenericConverter
		ConverterName = Water Shunt
		StartActionName = Start Water Shunt
		StopActionName = Stop Water Shunt
		GeneratesHeat = false
		conversionRate = 0.1
		INPUT_RESOURCE
		{
			ResourceName = ElectricCharge
			Ratio = 0.001
		}
		INPUT_RESOURCE
		{
			ResourceName = Water
			Ratio = 1
		}
		OUTPUT_RESOURCE
		{
			ResourceName = WasteWater
			Ratio = 1
			DumpExcess = false
		}
		UseSpecialistBonus = false
		EfficiencyBonus = 1
	}
}

 

N3atujX.png

 

Edited by HansAcker

Share this post


Link to post
Share on other sites

Hey y'all, I'm having an issue where the monitoring screen shows any missions in prelaunch along with any past missions. It doesn't, however actually show any current missions. I've tried re-installing it multiple times, nothing changed. It does work on a separate install, so I have no idea what the issue is. Any advice on what to do?

https://imgur.com/a/LgEtqO1 for reference. Thanks!

Edit: it also appears that no life support resources are being consumed.

Edited by crowsnose

Share this post


Link to post
Share on other sites
On 2/21/2019 at 9:10 PM, crowsnose said:

Hey y'all, I'm having an issue where the monitoring screen shows any missions in prelaunch along with any past missions. It doesn't, however actually show any current missions. I've tried re-installing it multiple times, nothing changed. It does work on a separate install, so I have no idea what the issue is. Any advice on what to do?

https://imgur.com/a/LgEtqO1 for reference. Thanks!

Edit: it also appears that no life support resources are being consumed.

UPDATE: I've completely re-installed the game, but after transporting the save over, the problem still persists only in that save. All is good in my eyes, so if anyone else is having this issue here's what I'd do: Copy your Gamedata folder, then delete literally everything else. Install a fresh copy, then load your Gamedata folder back in, and all should be fine. 

Share this post


Link to post
Share on other sites
11 hours ago, Rebel Assassin said:

is there a way to make this work with 1.4.5?

Why are you running 1.4.5?

Share this post


Link to post
Share on other sites

Hello. I'm currently having a problem. Whenever my station isn't focused, I am getting electricity alerts. Could this be because I am using solar panels from SSTU? And if so, how can I solve this problem?

Share this post


Link to post
Share on other sites

Hello!

Same problem like Bob Jub. Whenever I´m on my station, electricity is normal. I had enough batteries, solar panels, etc. But when I leave my station after the next day/night period, TAC send the message that electricity is running out. 

Share this post


Link to post
Share on other sites
On 2/25/2019 at 11:09 AM, Bob Jub said:

Hello. I'm currently having a problem. Whenever my station isn't focused, I am getting electricity alerts. Could this be because I am using solar panels from SSTU? And if so, how can I solve this problem?

 

On 3/7/2019 at 11:49 PM, Jockel380 said:

Hello!

Same problem like Bob Jub. Whenever I´m on my station, electricity is normal. I had enough batteries, solar panels, etc. But when I leave my station after the next day/night period, TAC send the message that electricity is running out. 

No logs = NO support. See the OP. you need to supply me with more information.

Share this post


Link to post
Share on other sites

Is there a list of mods that integrate with TAC LS and add parts to support it? Looking for greenhouses basically and I can only find MKS and KPS that do. Trying to get self sufficient bases (with a lot of work and planning) and not sure if it's possible. Maybe with other mods supporting it? I know USI LS can be self sufficient with enough work but I prefer TAC.

Share this post


Link to post
Share on other sites
On 3/10/2019 at 2:03 AM, JPLRepo said:

 

No logs = NO support. See the OP. you need to supply me with more information.

How can I send you a log? It´s an error without any message or log-file...

Share this post


Link to post
Share on other sites
1 hour ago, Jockel380 said:

How can I send you a log? It´s an error without any message or log-file...

The various logs and how to correctly post link them to the forum can be found here:

 

Share this post


Link to post
Share on other sites
On 3/13/2019 at 7:20 PM, Raccoon said:

Is there a list of mods that integrate with TAC LS and add parts to support it? Looking for greenhouses basically and I can only find MKS and KPS that do. Trying to get self sufficient bases (with a lot of work and planning) and not sure if it's possible. Maybe with other mods supporting it? I know USI LS can be self sufficient with enough work but I prefer TAC.

Check out Pathfinder by Angel-125. Complex, but very powerful. I made a self sufficient base on Vall using it.

Share this post


Link to post
Share on other sites

Is this mod known to cause performance issues? It seems to, since my game slowed down tremendously when I installed it. I see there are some performance optimization settings included, which ones can I tweak without causing many problems? Is there a drawback to the setting that doesn't run life support calcs in the background?

 

Thanks for working on this mod, very cool!

Share this post


Link to post
Share on other sites
Posted (edited)

I have a question.

Can I somehow filter or made an exception for ships with fuel cells ?  Like on one ship I have electricity for 1 day and 3 hours but I have there fuel cell so that ship has EC always for 1 day and 3 hours due to its battery capacity. And if I warp time in space center I am getting issues that TAC LS thinks that EC is out on that ship that I am not controlling. I have to jump to ship each day so TAC LS will update its calucaltions for another 1 day and 3 hours. 

Is there some option or filter where I can set that do not alert me for this ship about EC is out ( due to having fuel cell on it ) 

Thank you

Edited by Jovzin

Share this post


Link to post
Share on other sites

JUst a query as ive not kept up with the changes.

 

Are the Command pods still meant to come with some a small amount of food, water and O2 stocked in them?

Share this post


Link to post
Share on other sites
Posted (edited)

I've been doing some searching and not found an answer, so here's the question. Does TAC-LS automatically convert the Real Fuels resource LqdOxygen into O2? I noticed that my first manned orbiter in this save (the first for me in at least a year) never lost O2 until after I decoupled the service module which contained Kerosene and LqdOxygen. In the past I remember that LO2 and O2 were considered completely different resources and the only way to get your Kerbals to breath the LO2 was to create a converter, but for the life of me I can't find any sort of patched in converter.. I've been searching for anything in a module manager config throughout my entire install that would create a converter for this and have come up empty so far, though that doesn't mean I'm not just looking in the wrong place / using the wrong search terms. Mainly the reason I'm trying to figure this out is because I don't want my Kerbals to be consuming my dV when they have perfectly good O2 already stored in the form of life support resources. Anyway, any help / direction on how to sort this out would be greatly appreciated.

EDIT: Further testing has shown that there is definitely some sort of conversion going on, as the capsule O2 will be continually filled as long as there is LO2 on the craft at all. Disabling crossfeed and shutting off the tanks containing LO2 had no effect. Essentially, the only way to stop the LO2 from being converted into O2 is to remove the LO2 from the vehicle.

EDIT 2: I believe I've figured this out on my own after much searching and testing. It appears that there actually wasn't a real converter patched in anywhere at all, but instead this is a function of Real Fuels when using the Service Module tank type. Real Fuels models fuel boil off so when liquids like hydrogen or oxygen are kept for a long time in non-cryogenic tanks, they eventually evaporate. In the normal tanks, this happens passively and it is simply lost, but with the service module tank type specifically, O2 is specified as the byproduct and is recaptured if there is space available in the life support tanks. This is why my O2 levels weren't going down as I'd used the service module tank type for my craft. Additionally, in case anyone runs into the same question, the kerbals aren't sucking up the craft's dV for their own use, but rather simply making use of what would otherwise be lost in this circumstance.

Edited by SpacedInvader

Share this post


Link to post
Share on other sites
6 hours ago, SpacedInvader said:

I've been doing some searching and not found an answer, so here's the question. Does TAC-LS automatically convert the Real Fuels resource LqdOxygen into O2? I noticed that my first manned orbiter in this save (the first for me in at least a year) never lost O2 until after I decoupled the service module which contained Kerosene and LqdOxygen. In the past I remember that LO2 and O2 were considered completely different resources and the only way to get your Kerbals to breath the LO2 was to create a converter, but for the life of me I can't find any sort of patched in converter.. I've been searching for anything in a module manager config throughout my entire install that would create a converter for this and have come up empty so far, though that doesn't mean I'm not just looking in the wrong place / using the wrong search terms. Mainly the reason I'm trying to figure this out is because I don't want my Kerbals to be consuming my dV when they have perfectly good O2 already stored in the form of life support resources. Anyway, any help / direction on how to sort this out would be greatly appreciated.

EDIT: Further testing has shown that there is definitely some sort of conversion going on, as the capsule O2 will be continually filled as long as there is LO2 on the craft at all. Disabling crossfeed and shutting off the tanks containing LO2 had no effect. Essentially, the only way to stop the LO2 from being converted into O2 is to remove the LO2 from the vehicle.

EDIT 2: I believe I've figured this out on my own after much searching and testing. It appears that there actually wasn't a real converter patched in anywhere at all, but instead this is a function of Real Fuels when using the Service Module tank type. Real Fuels models fuel boil off so when liquids like hydrogen or oxygen are kept for a long time in non-cryogenic tanks, they eventually evaporate. In the normal tanks, this happens passively and it is simply lost, but with the service module tank type specifically, O2 is specified as the byproduct and is recaptured if there is space available in the life support tanks. This is why my O2 levels weren't going down as I'd used the service module tank type for my craft. Additionally, in case anyone runs into the same question, the kerbals aren't sucking up the craft's dV for their own use, but rather simply making use of what would otherwise be lost in this circumstance.

You have to take that to the RO/RF threads. This mod itself contains contain or support those mods directly. Rather real fuels and RO contain patch files to modify TAC/LS to support them.

Share this post


Link to post
Share on other sites
3 hours ago, JPLRepo said:

You have to take that to the RO/RF threads. This mod itself contains contain or support those mods directly. Rather real fuels and RO contain patch files to modify TAC/LS to support them.

The last edit was more for information for anyone who lands on the post with the same questions. Essentially, the system is working as intended and I didn't know that the system existed prior to my investigations. I'm not 100% sure about the realism of propulsion system LO2 being use in the life support system (which is indeed a question for that thread), but ultimately, this isn't a bug, but a feature.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.