Tokamak

[1.1.3] Tokamak Industries Refurbished Parts v0.1.2 (Featuring Porkjet's hab pack)

Recommended Posts

4 hours ago, Tokamak said:

How would you feel about me tossing that into the next release, so I don't have one more thing to research and fiddle with? :)

Absolutely good with that. I missed making a .cfg for the dry workshop. Here's one now.

@PART[TIdryworkshop]:NEEDS[Snacks]:AFTER[Snacks]
{   
    !RESOURCE[Snacks]{}
    RESOURCE
    {  
        name = Snacks  
        amount = 100  
        maxAmount = 100
    }
}

Snacks.cfg can be downloaded on my Github. Just drop it into the Tokamak directory.

Edited by BigFatStupidHead
Added link for the .cfg

Share this post


Link to post
Share on other sites

Hey @Tokamak, could you update this mod 

I find it a very simple and useful part in reducing part count in the Mk 1-2 command pod craft. I don't know if you can still get the files for it but I still have the folder in my KSP gamedata.

Share this post


Link to post
Share on other sites

This one too!

The mother of all awesome part packs!

Share this post


Link to post
Share on other sites

Unless I'm missing something about the "Dry Workshop" in relation to MKS/USI-LS it it's a bit off balance compaired to the PPD-10 HitchHiker.

 

Dry Workshop:           Crew - 8, Kerbal months - 9, Crew effected - 10, Hab multiplyer 0

PPD-10 HitchHiker:    Crew - 4, Kerbal months - 25, Crew effected - 4, Hab multiplyer 0

While the workshop is more then twice the size and nearly twice the mass, when you bring up the effects these 2 have, the little HitchHiker gives ~about a year more while the big workshop only gives ~100 days. This is just using a probe core as the root node. But using a command pod with 1 kerbal has about the same effect. Now maybe the workshop pulls ahead with more kerbals. I haven't checks.

Share this post


Link to post
Share on other sites
On 11/2/2016 at 1:08 PM, Titan 3000 said:

Hey @Tokamak, could you update this mod 

I find it a very simple and useful part in reducing part count in the Mk 1-2 command pod craft. I don't know if you can still get the files for it but I still have the folder in my KSP gamedata.

That looks simple enough that it would be just as easy for me to re-create it without needing the original files

Share this post


Link to post
Share on other sites
On 11/3/2016 at 0:26 AM, Vorg said:

Unless I'm missing something about the "Dry Workshop" in relation to MKS/USI-LS it it's a bit off balance compaired to the PPD-10 HitchHiker.

 

Dry Workshop:           Crew - 8, Kerbal months - 9, Crew effected - 10, Hab multiplyer 0

PPD-10 HitchHiker:    Crew - 4, Kerbal months - 25, Crew effected - 4, Hab multiplyer 0

While the workshop is more then twice the size and nearly twice the mass, when you bring up the effects these 2 have, the little HitchHiker gives ~about a year more while the big workshop only gives ~100 days. This is just using a probe core as the root node. But using a command pod with 1 kerbal has about the same effect. Now maybe the workshop pulls ahead with more kerbals. I haven't checks.

At least according to the config files (and the USI-LS wiki), the PPD-10 gives 12.5 kerbal months with a hab space of 5, whereas the dry workshop gives 20 kerbal months with a hab space of 9. I'm a bit confused as to where those numbers are coming from on your install... O.o

Share this post


Link to post
Share on other sites

Some of it from mousing over parts in the parts list in the VAB. And putting the 2 parts on a probe core while looking at RD's info popup (the greenish box icon button).

 

Also, In my career save I unlocked your expanding heat shield and it is showing up in aerodynamics tab instead of Thermo tab. But I see a number of parts from mods in the wrong tabs. Even the Derp Electric generating parts from RD's mod are not in the electric tab.

Edited by Vorg

Share this post


Link to post
Share on other sites
20 hours ago, Vorg said:

Some of it from mousing over parts in the parts list in the VAB. And putting the 2 parts on a probe core while looking at RD's info popup (the greenish box icon button).

 

Also, In my career save I unlocked your expanding heat shield and it is showing up in aerodynamics tab instead of Thermo tab. But I see a number of parts from mods in the wrong tabs. Even the Derp Electric generating parts from RD's mod are not in the electric tab.

Oh, I meant that I'm curious about what is generating those numbers, since those don't match what I see.

Share this post


Link to post
Share on other sites

Maybe it is something that RD's mod adds based on some info about the part?

0vUaecv.png

Share this post


Link to post
Share on other sites

@Tokamak

So I completely forgot you were updating Porkjet's HabitatPack and I went ahead and did the same thing (along with AtomicAge). It's just a set of MM patches, and comparing my work to your's, we took it in very different directions. I just have to say that I think it's really cool that you're dusting off his work, and giving it new life. You are of course more than welcome to use whatever you want from my patches, which I will link down below.

Looking over your work, I have some suggestions, if I may:

  • You've ditched the deployableHabRestrictor, in favor of USIAnimation, which I can understand, as it's more likely to be up to date going forward. However, not everyone wants to download the USI suite just to use the HabitatPack, when the current Habitat.dll already works just fine.
  • I would break out all the USI, CLS, EPL stuff into separate patches with proper :NEEDS[xyz]
  • You have a ModuleHabitation with a HabMultiplier of 0 (InflatoFlat)...I think that might cause issues, not entirely up on my USI modules though.
  • Why all the stagingIcons?
  • Your maxTemp (2900) is very high; I based my values off the HitchHiker's.
  • Did you add lights to the Inflato Flat? Would be neato.:)

I also updated the BaseMount and the Orbital Orb, added tags and bulkheads, along with the 1.2 stuff.

Anyway, patches are here if you're curious.

Cheers.

Share this post


Link to post
Share on other sites

@Tokamak: May I ask, how to we increase the habitation time in the inflatables. Holding at 75 days and I want up to 4-7 years

 

Share this post


Link to post
Share on other sites

I installed this mod and the porkjet parts on KSP. But now I have two copies of the engines(in addition to the stock engines that I hid, per instructions). I was looking to delete the excess engines, but I don't see the parts anywhere in the mod. I prefer the look of the original porkjet parts that he left behind. How do I correct this? The easiest thing is to just delete porkjet and leave this mod alone, which isn't ideal but OK. 

Share this post


Link to post
Share on other sites
4 hours ago, sardia said:

I installed this mod and the porkjet parts on KSP. But now I have two copies of the engines(in addition to the stock engines that I hid, per instructions). I was looking to delete the excess engines, but I don't see the parts anywhere in the mod. I prefer the look of the original porkjet parts that he left behind. How do I correct this? The easiest thing is to just delete porkjet and leave this mod alone, which isn't ideal but OK. 

I'm not quite clear on what you are talking about. This mod doesn't involve any engines.

Share this post


Link to post
Share on other sites

I think he may have downloaded the released parts by squad that porkjet updated, they didnt include them in the 1.2 update it was a separate download link and gives you two versions of the same engine but they look different. They are in a folder called part overhauls in Gamedata

Edited by Virtualgenius

Share this post


Link to post
Share on other sites
22 minutes ago, Virtualgenius said:

I think he may have downloaded the released parts by squad that porkjet updated, they didnt include them in the 1.2 update it was a separate download link and gives you two versions of the same engine but they look different. They are in a folder called part overhauls in Gamedata

Ah, that makes sense. 

Share this post


Link to post
Share on other sites

Love the parts! I'm having challenges with the FLAT command pod and the multiple docking ports. I can't target an individual port when I'm trying to dock. Clicking on any portion of the part highlights the whole FLAT module and I can't set targeting. Same thing happens when I want to "control from here" on one of the FLAT docking parts.

is this a known issue? is there a workaround?

Thanks!

Share this post


Link to post
Share on other sites
On 1/3/2017 at 4:58 PM, Tyko said:

Love the parts! I'm having challenges with the FLAT command pod and the multiple docking ports. I can't target an individual port when I'm trying to dock. Clicking on any portion of the part highlights the whole FLAT module and I can't set targeting. Same thing happens when I want to "control from here" on one of the FLAT docking parts.

is this a known issue? is there a workaround?

Thanks!

Right click the FLAT for the context menu. There should be three buttons for targeting (or controlling from) the port. That's how the part worked originally.

Share this post


Link to post
Share on other sites
7 hours ago, Starwaster said:

Right click the FLAT for the context menu. There should be three buttons for targeting (or controlling from) the port. That's how the part worked originally.

Thanks, that's the same behavior for any other docking port. I tried it and it doesn't work. When I choose "control from here" from any port on the FLAT it interprets my command as "control from the entire FLAT". If I subsequently tell SAS to point to Target the craft orients so the top of the FLAT is pointed at the Target, not any of the docking ports.

Furthermore, I can't actually dock with the ports. My craft just bounces off of the FLAT's port. 

Share this post


Link to post
Share on other sites
On 1/5/2017 at 10:46 AM, Tyko said:

Thanks, that's the same behavior for any other docking port. I tried it and it doesn't work. When I choose "control from here" from any port on the FLAT it interprets my command as "control from the entire FLAT". If I subsequently tell SAS to point to Target the craft orients so the top of the FLAT is pointed at the Target, not any of the docking ports.

Furthermore, I can't actually dock with the ports. My craft just bounces off of the FLAT's port. 

Ok just took a look at @Tokamak's configs for the FLAT

The three ports are configured with deployAnimationController = 1 which is not going to work. That number has to point at the index location of the animator module. 0 = first so 1 = second, which just so happens to be the second docking port and not an animator at all.

Furthermore, he's using a modded animator and not the stock ModuleAnimateGeneric. That is also not going to work unless USIAnimation uses ModuleAnimateGeneric as a parent. The reason for that is because when ModuleDockingPort tries to retrieve the animator it's going to try to cast to ModuleAnimateGeneric which will fail big time. (checked USI while writing this. USIAnimation is written from scratch and uses totally different field names. CANNOT cast it to MAG)

One of the following things has to happen here or this isn't going to work:

  1. Switch back to using ModuleAnimateGeneric or an animator derived from it AND fix the indexing to point to the animator
  2. Don't use deployAnimationController. This is probably a bad solution because then it will be possible to attempt docking of deflated FLATs. Which may or may not fail because of the closed shields getting in the way. And even IF successfully docked, inflation of the FLAT will not move any docked vessel. The FLAT will then be in danger of engulfing docked vessels or docked FLATs. Physics hilarity will ensue. (of course, one could just pin the blame for that on the player. When they stop doing that it will stop hurting)
Edited by Starwaster

Share this post


Link to post
Share on other sites

Heyo. Life has dragged me away from Kerbal for the time being. Just popping in to comment though.

 

The reason why I used the alternate animation module was so I could get the "deployable habitat" feature, whereby the module was not inhabitable until inflated. That may or may not have been the best call, but it's what I did. Feel free to change that, as long as you know the effect.

For that matter, since I am currently dropping the ball in terms of maintaining this stuff, it's worth noting that the project CClicensed and is on github so people can contribute to it, or can just take everything and make their own new version. It'd be cool if anyone who does that could ping me so I can follow it, but yeah, no possessiveness here. :)

Share this post


Link to post
Share on other sites
On ‎1‎/‎10‎/‎2017 at 1:26 PM, Tokamak said:

Heyo. Life has dragged me away from Kerbal for the time being. Just popping in to comment though.

 

The reason why I used the alternate animation module was so I could get the "deployable habitat" feature, whereby the module was not inhabitable until inflated. That may or may not have been the best call, but it's what I did. Feel free to change that, as long as you know the effect.

For that matter, since I am currently dropping the ball in terms of maintaining this stuff, it's worth noting that the project CClicensed and is on github so people can contribute to it, or can just take everything and make their own new version. It'd be cool if anyone who does that could ping me so I can follow it, but yeah, no possessiveness here. :)

Just wanted to say I love this pack and I am glad you picked it up.  However I want to also add my voice for TAC-LS MM support.  Its the only LS mod I use.  No rush when ever you get time.  :)

 

Here is a patch I tried to get working.  Didn't work for me.  Perhaps someone else can help with it.

@PART[TIinflato1]:FOR[TokamakIndustries]:NEEDS[TacLifeSupport]
{
	@RESOURCE[ElectricCharge]
	{
		@amount = 350
		@maxAmount = 350
	}

//21 crew-days of life support
	RESOURCE
	{
		name = Food
		amount = 7.679
		maxAmount = 7.679
	}
	RESOURCE
	{
		name = Water
		amount = 5.075
		maxAmount = 5.075
	}
	RESOURCE
	{
		name = Oxygen
		amount = 777.266
		maxAmount = 777.266
	}
	RESOURCE
	{
		name = CarbonDioxide
		amount = 0
		maxAmount = 95.913
	}
	RESOURCE
	{
		name = Waste
		amount = 0
		maxAmount = 0.1
	}
	RESOURCE
	{
		name = WasteWater
		amount = 0
		maxAmount = 0.924
	}
}

@PART[TIinflato2]:FOR[TokamakIndustries]:NEEDS[TacLifeSupport]
{
	@RESOURCE[ElectricCharge]
	{
		@amount = 350
		@maxAmount = 350
	}

//21 crew-days of life support
	RESOURCE
	{
		name = Food
		amount = 7.679
		maxAmount = 7.679
	}
	RESOURCE
	{
		name = Water
		amount = 5.075
		maxAmount = 5.075
	}
	RESOURCE
	{
		name = Oxygen
		amount = 777.266
		maxAmount = 777.266
	}
	RESOURCE
	{
		name = CarbonDioxide
		amount = 0
		maxAmount = 95.913
	}
	RESOURCE
	{
		name = Waste
		amount = 0
		maxAmount = 0.1
	}
	RESOURCE
	{
		name = WasteWater
		amount = 0
		maxAmount = 0.924
	}
}

@PART[TIinflatoFlat]:FOR[TokamakIndustries]:NEEDS[TacLifeSupport]
{
	@RESOURCE[ElectricCharge]
	{
		@amount = 350
		@maxAmount = 350
	}

//21 crew-days of life support
	RESOURCE
	{
		name = Food
		amount = 7.679
		maxAmount = 7.679
	}
	RESOURCE
	{
		name = Water
		amount = 5.075
		maxAmount = 5.075
	}
	RESOURCE
	{
		name = Oxygen
		amount = 777.266
		maxAmount = 777.266
	}
	RESOURCE
	{
		name = CarbonDioxide
		amount = 0
		maxAmount = 95.913
	}
	RESOURCE
	{
		name = Waste
		amount = 0
		maxAmount = 0.1
	}
	RESOURCE
	{
		name = WasteWater
		amount = 0
		maxAmount = 0.924
	}
}

 

Edited by Vaga
New Info

Share this post


Link to post
Share on other sites

would you consider porkjets nuclear rockets?

Share this post


Link to post
Share on other sites
On 1/20/2017 at 8:59 PM, rel1c said:

has anyone had this work with 1.2.2? i miss these great parts :(

most work just fine. The only one I've had some problams with is the FLAT - which seems to have problems with the docking ports

Share this post


Link to post
Share on other sites

Awesome work!

On 27/08/2016 at 7:18 AM, Tokamak said:

One genuine Porkworks low-profile base mount!

Have you managed to update the base mount to use the proper landing leg module, or is it still just a generic animated part?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.