Jump to content

[1.9.x] Vessel Viewer Continued


Recommended Posts

When I try clicking the button to bring up vessel viewer, there's no click sound, and the MFD I tried to bring up Vessel Viewer on goes unresponsive, and won't load anything.

Link to post
Share on other sites
On 7/3/2017 at 11:38 AM, StevieC said:

When I try clicking the button to bring up vessel viewer, there's no click sound, and the MFD I tried to bring up Vessel Viewer on goes unresponsive, and won't load anything.

It's been recompiiled, please reinstall

Link to post
Share on other sites
14 hours ago, KerBlitz Kerman said:

I used the previous version on KSP 1.3, twas fine*, just got notification, reinstalled.

 

*was calibrating HOTAS, may have missed it:wink:

May also have been related to other mods;  and did you have the latest RPM installed?

Link to post
Share on other sites
  • 4 weeks later...
4 hours ago, Gordon Dry said:

@Diddly Feelerino

Hmm. I also had some yellow screen issues, but not always.

I was not able to find out which parts could be the culprit yet...

Did you by chance use the B9 Aerospace InfoDrive part on your vessel? (I'm not sure about it, just an idea)

Thanks for the reply. Umm no I don't think I have anything like that on my vessel. In my Gamedata folder I have a B9PartSwitch folder but nothing else really resembling that.

Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...

Hi all.

@Diddly Feelerino @Hydrothermalventclam @themaster401

For me it's a green screen issue. However, are you guys using Astronomers Visual Enhancements?

I've just found out, that for me "AstronomersVisualPack\EVE\atmosphere.cfg" breaks VesselViewer. For whatever reason. You could try to remove it and report back, if so. 

@themaster401 @linuxgurugamer

Do you maybe have any idea, why this file confuses VesselViewer(RPM)?

All what is in this file (atmosphere.cfg) is:

 

EVE_ATMOSPHERE
{
	OBJECT
	{
		body = Kerbin
		atmosphereMaterial
		{
			_Color = 0,0,35,0
			_SunsetColor = 0,0,35,0
		}
	}
}

Hmm?!

BR
Jebs

Edited by Jebs_SY
Link to post
Share on other sites

@Jebs_SY

I am using Astronomer's pack.  Next time I launch the game I will see if getting rid of that file fixes it for me.

 

Edit:

Alright I removed the file and vessel viewer worked.  The green screen was gone.

No idea what the  file does, as I did not notice any changes in game.

Edited by Hydrothermalventclam
Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...

https://github.com/linuxgurugamer/VesselViewer/pull/8

I have submitted a pull request for this mod which should create a single plugin which will work with and without Blizzy's toolbar and with and without RPM.  I have tested it myself but I am interested in having others test it as well.

The pull request has a bunch of other changes which update the build process to use `msbuild` as well.

Please let me know either on the PR or here what you think of this version!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...