Jump to content
  • 0

Persistent staging.and sub assemblys?


LN400
 Share

Question

When attaching a multi stage sub assembly, what I get is an unholy mess in the staging with the events spreading out with total disregard to where the parts in question are attached. Is this inevitable with the current game code or are there hints and tips on how to make this a more pleasant experience?

PS: Same problem occurs when docking to a multi stage ship while in orbit. After docking it can be a bit of a nightmare to sort the staging in the correct order so this really is a bit of an issue.

Edited by LN400
Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 3

The trick I've found for this is leaving a lot of empty stages on subassemblies, especially lifters. A lifter subassembly with 5 empty stages above the uppermost stage will merge neatly with almost any payload.

Similar can be done when docking craft. Count the number of stages in each craft docking, add enough empty ones to one of them so their stage numbers don't overlap and then dock them.

Link to comment
Share on other sites

  • 0
7 minutes ago, Red Iron Crown said:

The trick I've found for this is leaving a lot of empty stages on subassemblies, especially lifters. A lifter subassembly with 5 empty stages above the uppermost stage will merge neatly with almost any payload.

Similar can be done when docking craft. Count the number of stages in each craft docking, add enough empty ones to one of them so their stage numbers don't overlap and then dock them.

I have to try this. Man if that works here then you just saved my day!

Link to comment
Share on other sites

  • 0

Both of your posts deserve an uptick, but sadly I've already depleted my measly 25 allowance for the day.

@Red Iron Crown: So if I understand correctly, the working principle is:

Include a number of empty stages at the top of any stage you will be attaching to a target ship (either in editor or docking) that is equal to the number of existing stages on the target ship?

Example: I have a "Munar Orbital Rendezvous System" (MORS) Comprising an Munar Excursion Daughter (MED), a Munar Rover Baby (MRB) and a Munar Orbital Momma (MOM) with about 7 stages ([0] radial chutes on both MED and MOM, for when MOM (and maybe MED haven't tested that on reentry) return home; [1] drogue chutes too; [2] decoupler between the docking port on the MED and its belly-mounted rover (MRB); [3] 8 RCS engines on the MED; [4] decoupler between the MRB's belly and the docking port on nose of the MOM; [5] decoupler between the command module portion of MOM and its final main engine (one tank and a terrier or something like that); [6] The Munar manuever and return engine.

Lets say I have a 4 stage launcher sub-assembly (actually lots going on in each stage though, lots of chutes because I use Stage Recovery), if I want to plug that sub-assembly into MORS to make a "Munar Expeditionary Synthetic Ship" (MESS) I just need to add seven empty stages to the sub-assembly before I bring it in?

Edited by Diche Bach
messy
Link to comment
Share on other sites

  • 0

Give RIC a huge cigar, kingdom or a horse, it seems to work perfectly, at least in the VAB.

 

EDIT: It would perhaps be nice if Squad implemented some better visual clues to which part each staging icon belongs to. The highlight can be a bit difficult to see at times. Perhaps something like a line drawn from the icon to the corresponding part, or a label on the icon.

Edited by LN400
Link to comment
Share on other sites

  • 0

And a new issue on "advanced staging", just to sound pretentious :D

Ok, I have put together an Apollo/Saturn V rocket courtesy of the FASA mod, and RIC's method works in the VAB. It appeared to have worked when I docket the CSM to the LEM in that the staging was in the same order as in the VAB. It was after the Mun transit burn and docking that it dawned on me that the CSM engine came in a later stage and that the first stage after jettison the 3rd stage/bay was the LEM's landing engine. I thought, no biggie, I just move the CSM engine stage down and that should solve it. Wrong.

The stage did appear as the upcoming stage but when I tapped space, the LEM's landing engine fired up and the icon moved in with the CSM icon below. I tapped space again but then the LEM's ascent engine fired up. Another tap on the space bar separated the landing module from the ascent module. The CSM engine remained cold all throughout the madness even though it was the first-to-happen on the list.

Not sure how to upload the craft file without registering at some site but if necessary, I could give it a try.

Another issue with this rocket is: After releasing the CSM from the bay, to do the docking, the uncontrolled 3rd stage with the LEM was now the active craft and I had to [ my way over to the CSM. The CSM is the root part in the VAB.

Edited by LN400
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...