linuxgurugamer

[1.4.5, 1.5.1, 1.6.1, 1.7.2] End your parts list nightmare - Introducing The Janitor's Closet

Recommended Posts

4 hours ago, Hojoz said:

I have this issue too in the same KSP version and would love to help via sharing my log file, but where can I find it?

In my signature:  

Read this BEFORE asking for supporthttp://forum.kerbalspaceprogram.com/index.php?/topic/83212-how-to-get-support-read-first/

Share this post


Link to post
Share on other sites
4 hours ago, Hojoz said:

I have this issue too in the same KSP version and would love to help via sharing my log file, but where can I find it?

As LinuxGuruGamer has pointed you to the link for the support thread, for KSP 1.4.3 mine was in c:\Users\[username]\AppData\LocalLow\Squad\Kerbal Space Program\.  I've created a shortcut to it on my desktop because it is need so often if you're having problems.

Edited by Brigadier

Share this post


Link to post
Share on other sites

I'm using JC on 1.4.3 and have also had the bug where very occasionally the tooltip disappears, same as @Beetlecat. It's so infrequent, and I realise so rarely, that I just live with it, but I'll try to grab a log next time i notice.

Edited by JH4C

Share this post


Link to post
Share on other sites

New release, 0.3.4.1

  • Updated .version for all of 1.4
  • Added dependency checking for ClickThroughBlocker

Share this post


Link to post
Share on other sites
3 hours ago, linuxgurugamer said:

New release, 0.3.4.1

  • Updated .version for all of 1.4
  • Added dependency checking for ClickThroughBlocker

Spacedock download has JanitorsCloset.dll.mdb and JanitosClosetTestBuild.zip within the plugins folder, I assume these are extraneous?

Share this post


Link to post
Share on other sites
22 minutes ago, JH4C said:

Spacedock download has JanitorsCloset.dll.mdb and JanitosClosetTestBuild.zip within the plugins folder, I assume these are extraneous?

delete the zip, leave the mdb

Share this post


Link to post
Share on other sites

Hello @linuxgurugamer apologies, you may have seen my posts in a few of your threads. Sorry for the spam!

I noticed the following in my KSP.log with a fresh install of 1.4.5 and installing Janitor's Closet (0.3.4.1) via CKAN:

[ERR 01:48:28.707] Janitor's Closet: Error adding ApplicationLauncher button: Object reference not set to an instance of an object

Is this anything to be concerned with, or is there something I would need to resolve? 

Edited by scottadges

Share this post


Link to post
Share on other sites

sorry if it's been asked...I didn't see it yet: does this work with 1.4.4 or 1.4.5? I tried it with 1.4.4 and the button didn't appear in the VAB. could definitely use this great mod.

Edited by Schneck

Share this post


Link to post
Share on other sites
6 hours ago, Schneck said:

sorry if it's been asked...I didn't see it yet: does this work with 1.4.4 or 1.4.5? I tried it with 1.4.4 and the button didn't appear in the VAB. could definitely use this great mod.

Working just fine here on 1.4.5, and previously worked on 1.4.4. Have you installed all the dependencies, such as Toolbar Controller?

Share this post


Link to post
Share on other sites

going to give it a shot right now. is there anything I have to do with toolbar controller to get it to work?

 

Share this post


Link to post
Share on other sites

So I'm having an issue where Janitor Closet loses the mouse-over Mod-label in the part list (in the editor). The only possible cause I can come up with is alt-tabbing.

Strange bug report I know...:/

Share this post


Link to post
Share on other sites
On 9/30/2018 at 8:54 PM, Deimos Rast said:

So I'm having an issue where Janitor Closet loses the mouse-over Mod-label in the part list (in the editor). The only possible cause I can come up with is alt-tabbing.

Strange bug report I know...:/

I need a log file, as you said, it doesnt make sense

Share this post


Link to post
Share on other sites

Hey um @linuxgurugamer is it ok if you add in a feature that will allow you to add a filter for the Making History Expansion please? 

just so if I'm making a stock craft and I know that it's stock just incase if people don't own the Making History Expansion. Thank you.

 

On 8/5/2018 at 8:18 AM, JH4C said:

Working just fine here on 1.4.5, and previously worked on 1.4.4. Have you installed all the dependencies, such as Toolbar Controller?

It's Click Through Blocker.

 

 

I hate this merge comment feature. It's stressful. 

Edited by Trekkie148

Share this post


Link to post
Share on other sites
8 hours ago, Trekkie148 said:

Hey um @linuxgurugamer is it ok if you add in a feature that will allow you to add a filter for the Making History Expansion please? 

just so if I'm making a stock craft and I know that it's stock just incase if people don't own the Making History Expansion. Thank you.

No need, use the Mod Filter. It should be treated as a mod, called SquadExpansion, so just don't show that mod

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
16 minutes ago, Demon Wolf said:

jest a let you know this mod's not coming up in CKEN even the olde one's

What version of the game are you playing?

Share this post


Link to post
Share on other sites
23 hours ago, Demon Wolf said:

v 1.4.5

Have you set your CKAN settings for your KSP install to allow mods for 1.4.3?  This has worked for me.

Share this post


Link to post
Share on other sites

@linuxgurugamerI'm trying to hide the toolbar, I especially wanted to hide it in flight. I am newer to the mod and don't know if that is a option to hide toolbar from flight or in general. I did go under Difficulty Options and click off Toolbar Enabled and restarted my game, but toolbar is still visible in all scenes. Is that a different option? So I am not to sure if its a bug or not. I did provide logs just in case.

I'm also using this mod. Don't know if there is any relations. The v6.8.2(.2-mkw) dock port icon showed up in scene at space center when it wasn't suppose to when I set JC to disable Toolbar and restarted. The logs are from when I was using v6.8.2(.3-mkw). Like I said I don't know if there is any relations to the problem, if there is one. 

https://github.com/mwerle/DockingPortAlignmentIndicator/releases

Edited by therealcrow999

Share this post


Link to post
Share on other sites
22 minutes ago, therealcrow999 said:

@linuxgurugamerI'm trying to hide the toolbar, I especially wanted to hide it in flight. I am newer to the mod and don't know if that is a option to hide toolbar from flight or in general. I did go under Difficulty Options and click off Toolbar Enabled and restarted my game, but toolbar is still visible in all scenes. Is that a different option? So I am not to sure if its a bug or not. I did provide logs just in case.

I'm also using this mod. Don't know if there is any relations. The v6.8.2(.2-mkw) dock port icon showed up in scene at space center when it wasn't suppose to when I set JC to disable Toolbar and restarted. The logs are from when I was using v6.8.2(.3-mkw). Like I said I don't know if there is any relations to the problem, if there is one. 

https://github.com/mwerle/DockingPortAlignmentIndicator/releases

That option doesnt hid the toolbar, it disables JC’s toolbar functionality.

I think the mod you want is QuickHide

Share this post


Link to post
Share on other sites

New release, 0.3.4.3

  • Added code to detect the missing kerbals:  kerbalEVAfemale, kerbalEVAVintage, kerbalEVAfemaleVintage

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.