linuxgurugamer

[1.4.5, 1.5.1, 1.6.1, 1.7.2] End your parts list nightmare - Introducing The Janitor's Closet

Recommended Posts

3 hours ago, madindehead said:

Which settings menu do you disable the tooltip in? KSP or the mod settings?

Mod settings, in the stock KSP settings page

Share this post


Link to post
Share on other sites
3 hours ago, madindehead said:

Which settings menu do you disable the tooltip in? KSP or the mod settings?

KSP settings, there will be a tab/section for Janitor's Closet

Share this post


Link to post
Share on other sites

New release, 0.3.6

  • Fixed nullref when returning to the main menu (new in 1.7.3)
  • Added InstallChecker
  • Updated AssemblyVersion.tt

Share this post


Link to post
Share on other sites

After installing, it just so happened that I decided to try out the Resource filter. It worked fine initially. Then I exited to the Space Center, went to Tracking Station, then back to SPH to work on my ship. Brought up Janitor's Closet and tried to go back to the Resource filter, and got a blank frame. After that, I can't interact with JC. Exiting back to Space Center is a partial fix. I can interact again with JC, going back to SPH or VAB, but only using the ModName and ModuleSize filters. Using the Resource and Modules filters just produces a blank frame. The issue goes away after reinstalling JC (delete then install).

Another workaround, if you have settings in the PluginData folder that you want to preserve, is to go through all the CFGs in the PluginData folder and replace all CR/LFs (carriage return/linefeed) instances with just LF (linefeed). Notepad++ made this easy. But you still have to restart KSP. A bit of a big deal if you're using 100+ mods like I do.

For me though, the issue is not a biggie because the mod works fine with 99% of what I use JC for, using the ModName and ModuleSize filters. And, there are workarounds - albeit both requiring a restart of KSP. It was only yesterday that I used JC's Resource filter and I've been using JC for months.

 

Share this post


Link to post
Share on other sites

I am aware of the issue, thanks.

You shouldn't have to exit the game, just exit to the space center and reenter the editor

Share this post


Link to post
Share on other sites

Loving this mod. Takes all the downside away from having a long list of parts mods. Just wondering, is there a way to set it so it hides unpurchased parts by default? I'm playing with KCT and right now I have to click into the UI every time I enter the VAB.

I'm also getting a NRE when I return to main menu from an existing save. KRASH also seems to be spitting out an identical error. No idea if it's mod related, I've just been ignoring it...

Here's the log if you're interested.

Share this post


Link to post
Share on other sites

Is there anyway to move the icon to the Toolbar Continued mod?  I cannot seem to find it anywhere in the settings (unless it's unselecting Toolbar Enabled in the settings menu which seems counter intuitive).

 

Share this post


Link to post
Share on other sites
10 hours ago, madindehead said:

Is there anyway to move the icon to the Toolbar Continued mod?  I cannot seem to find it anywhere in the settings (unless it's unselecting Toolbar Enabled in the settings menu which seems counter intuitive).

Unfortunately, no.

Share this post


Link to post
Share on other sites
31 minutes ago, linuxgurugamer said:

Unfortunately, no.

Ah fair enough. Thanks anyway.

Share this post


Link to post
Share on other sites

New release, 0.3.6.1

  • Fixed another nullref when returning to the main menu, was happening in 1.7.2

Share this post


Link to post
Share on other sites

Begone, parts clutter, yes!

Thanks a lot for this time and hassle saving mod, @linuxgurugamer :)

Brief question: the current view which mods are blocked is saved, but every time I reenter the VAB I have to manually select the set, the last used isn't saved as default. Would that be possible?

Share this post


Link to post
Share on other sites
On 9/25/2019 at 8:35 AM, VoidSquid said:

Begone, parts clutter, yes!

Thanks a lot for this time and hassle saving mod, @linuxgurugamer :)

Brief question: the current view which mods are blocked is saved, but every time I reenter the VAB I have to manually select the set, the last used isn't saved as default. Would that be possible?

I am aware of the issue, wasnt able ti figure it out last time I worked on this.  May get back to it in a few months

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.