Jump to content
  • 5

Fullscreen-mode at wrong display


LosWashos
 Share

Question

Hello,

since today i have a strange issue with KSP. I subscribed to the 1.2 Beta and then later switched back to the 1.1.3-Version. Now, everytime i start KSP it opens at the wrong display (i have two). When i try to unset fullscreen it doesn't react. I have to force it with alt+enter to exit fullscreen-mode. Now the fullscreen-setting reacts but also fullscreens at the wrong display, regardless of where i place the window with fullscreen switched off. I changed nothing in the system, just switched to 1.2 beta and back and now this occurs. I'm using steam and started it there and with CKAN, same Problem. Every other game starts normal. Is there any known help? Thanks.

I tried the launcher-settings, the start-settings of steam, switched which display is the main, i deleted and reinstalled the game and worked inb the config-sfc... nothing works. switching again to the beta the game opens at the right display, switching back to 1.1.3 its the same issue...

Edited by LosWashos
Link to comment
Share on other sites

Recommended Posts

  • 2

beeea97c622c5614a80371eb0aece7082a3ff1b5

Anyone who is still having issues with the game only going fullscreen on your secondary monitor, just delete "Kerbal Space Program" and "KSPLauncher" in the registry and everything should be back to normal. At least that fixed the issue for me.

If you are on Windows 10, search for "regedit" in the search thingy on the bottom of your screen. That will open the registry. Click on "SOFTWARE" in the drop-down-meny, scroll down to "Squad" and delete the  "Kerbal Space Program" and "KSPLauncher" folders.

Thank you @sal_vager, appreciate the help :)

Link to comment
Share on other sites

  • 1

Wait, this has not been fixed yet? I prefer being able to play the games I pay for. Being forced to play the game on the wrong monitor in only 1024x768 or lower without the ability to increase the resolution is not what I signed up for.

Clearly this is an issue with KSP 1.2 pre-release. Eveyone who has reported on this issue has done the same thing. They had 1.1.3 installed, they opted in for the pre-release, played the pre-release, went back to the current official released version, i.e 1.1.3 and now they can't play the game on their preferred monitor and on a resolution that belongs in the 1990s.

Assuming no one has already made a bug report on this, will this issue be taken more seriously if we do make a bug report?

Link to comment
Share on other sites

  • 0

Thank you, but both are not working. I tried the launch-options with adapter 0, 1 and 2 - no change. And unplugging the display, then starting kerbal, then replugging works as long as i dont shut ksp down and restart it, then it starts on the wrong display again and i'm playing quite a lot of ksp so unswitching every time is kind of annoying. I mean it works fine with the beta of 1.2, just since i switched back i got the problem... so when 1.2 is out the problem should be fixed... but still its a quite strange problem for now.

Edited by LosWashos
Link to comment
Share on other sites

  • 0

Yea I am having the same exact issue. I've tried everything I can think of and 1.1.3 still refuses to open in fullscreen on the primary monitor. It also refuses to let me apply any changes to the resolution. The resolution always reverts back to 1260x720 regardless of how many times I aggressively press the "Apply" button. This didn't happen last time I opted in for pre-release, and I've always had multiple versions of KSP (I save older versions).

EDIT: I don't launch the game from Steam, I launch it from the "Kerbal Space Program" directory.

Edited by heliobyte
Link to comment
Share on other sites

  • 0

Right, so I'm not the only one having this issue. I guess that is kind of reassuring(?). The symptoms are the same on my end. I opted in for 1.2, played it for a couple of hours, then went back to 1.1.3 (which is in a separate folder elsewhere on my SSD), launched 1.1.3 and the game started in fullscreen on the wrong monitor in a much lower resolution than I normally run it on. 

Now I can't change the resolution and I can not for the life of me get the game to play in fullscreen on my primary monitor. It is rather frustrating as I am addicted to playing the game with about 2.5 tonnes of mods and I kind of don't want to be forced to play an unmodded game whilst waiting for full release of 1.2 and the 1-2 weeks of waiting for all the mods I use to be updated.

Seeing as quite a few people are having this issue, it would be greatly appreciated of someone could create a sticky with the solution to this problem if there is one.

Link to comment
Share on other sites

  • 0

Are you all using Windows?

It's possible that there's a new screenmanager entry that sets the display to a specific monitor, on OSX and Linux this is in the prefs file but on Windows it's in the registry, that would explain why reinstalling has no effect.

If you're comfortable opening the registry you could take a look at HKEY_CURRENT_USER/Software/Squad/Kerbal Space Program/

You should see these:

(Default)
Screenmanager Is Fullscreen mode
Screenmanager Resolution Height
Screenmanager Resolution Width
UnityGraphicsQuality

Link to comment
Share on other sites

  • 0
7 minutes ago, sal_vager said:

Are you all using Windows?

It's possible that there's a new screenmanager entry that sets the display to a specific monitor, on OSX and Linux this is in the prefs file but on Windows it's in the registry, that would explain why reinstalling has no effect.

If you're comfortable opening the registry you could take a look at HKEY_CURRENT_USER/Software/Squad/Kerbal Space Program/

You should see these:

(Default)
Screenmanager Is Fullscreen mode
Screenmanager Resolution Height
Screenmanager Resolution Width
UnityGraphicsQuality

I happen to be using Windows. Looking at the registry I have the following:

(Standard)

Screenmanager Is Fullscreen mode_LotsOfNumbers

Screenmanager Resolution Height_LotsOfNumbers

ScreenManager Resolution Width_LotsOfNumbers

UnityGraphicsQuality_LotsOfNumbers

UnitySelectMonitor_LotsOf Number

I assume that "UnitySelectMonitor" is the one I want? In any case, its value is set to "0" by default. Which value do I need and how do I go about checking if the changes worked? I have never touched the registry before, so I don't want to mess things up.

Link to comment
Share on other sites

  • 0
Just now, liquidhype said:

I happen to be using Windows. Looking at the registry I have the following:

(snip)

UnitySelectMonitor_LotsOf Number

I assume that "UnitySelectMonitor" is the one I want? In any case, its value is set to "0" by default. Which value do I need and how do I go about checking if the changes worked? I have never touched the registry before, so I don't want to mess things up.

I don't know yet, I've never seen that line before but I assume that 0 is the first screen, just like with -adapter 0

Best thing now would be to exit without making any changes, if you do want to try another value please back up the registry first, just in case.

If -adapter doesn't work maybe try launching KSP with -show-screen-selector

Quote
-show-screen-selector  Forces the screen selector dialog to be shown.

More info here.

Link to comment
Share on other sites

  • 0

I don't suppose this works?

Quote
Farkmir iconGames.png 30 Jul @ 2:01pm 
notification_icon_flag_dark.png?v=1forum_topicicon_reply.png?v=1
I do know this post is really old but i found a solution.

If you are a windows 10 user like me just follow these steps:

1. Right click your desktop and select "monitor settings" or something alike.

2. Your monitors should be marked with numbers in the correct order, press the one you want to use as your "main screen".

3. Click make this monitor my primary monitor.

4. Press save or whatever it's called (my settings are in swedish)

5. Test by opening any game!

 

Link to comment
Share on other sites

  • 0
48 minutes ago, sal_vager said:

I don't suppose this works?

 

It did not work for me when I tried it earlier. I even set my other two monitors as primary to test, and then set the one I want to use as primary and it did not work either. The game still only opens in fullscreen on the one monitor and it drops the resolution way down and will not let me up the res at all.

I even tried uninstalling KSP, deleting all traces of the game and then re-installed only 1.1.3 and the game is still running on the wrong monitor. I even went so far as to moving all other KSP installs to a portable hard drive and left only the newly downloaded 1.1.3 on my PC. I do not understand what is causing this and it is beyond frustrating. I can deal with the game running on the wrong monitor, but I can not deal with the game running on the low resolution it is forcing me to play on.

Edited by liquidhype
Link to comment
Share on other sites

  • 0

Correct. I've tried all the usual solutions for this issue, none of them worked. If you have a spare laptop or PC with windows 10 and don't mind being subjected to this, it is rather simple to reproduce.

- Use Windoes 10 with 2 or more monitors

- Have 1.1.3 Installed

- Rename 1.1.3 folder from "Kerbal Space Program" to something else

- Opt-in for 1.2 and let it download

- Start 1.2

- Close 1.2

- Start 1.1.3

This is exactly how it happened to me. I opted in for 1.2 yesterday just to try out the new features, played for a few hours and then went back to 1.1.3. As soon as 1.1.3 was running it went into windowed mode, I went into the KSP settings and checked "Fullscreen" and then the game jumped to my secondary monitor and has resided there ever since.

Link to comment
Share on other sites

  • 0
19 minutes ago, heliobyte said:

Clearly this is an issue with KSP 1.2 pre-release. Eveyone who has reported on this issue has done the same thing. They had 1.1.3 installed, they opted in for the pre-release, played the pre-release, went back to the current official released version, i.e 1.1.3 and now they can't play the game on their preferred monitor and on a resolution that belongs in the 1990s.

KSP 1.2 most likely caused this to happen, because everyone is reporting the same series of events that happened before the issue occured. As far as  I am aware, no one has reported this issue in the past. I certainly did not have this issue in the previous opt-in pre-release.

At this point I can only assuse that 1.2 caused peoples PCs to make some sort of new persistent file somewhere on their PCs which forces 1.1.3 onto the wrong monitor and somehow locks the resolution to (in my case) 1280x768 or lower.

Surely someone on the dev team is a computer wizz and knows how to fix this.

 

Edited by liquidhype
Link to comment
Share on other sites

  • 0

Actually, as there is no code from Squad that governs which monitor KSP runs on this is quite clearly a Unity engine issue, you've run KSP 1.2 pre-release which is made in Unity 5.4.0,  and now you're running KSP 1.1.3 which was made in Unity 5.2.4, running on 5.4.0 has left a registry entry that is affecting 5.2.4

If you are using Linux or OS X you can simply delete the prefs file and Unity will start using its defaults, then it will use the values in the KSP settings.cfg

For Windows users you will need to try something different, the registry entry for Kerbal Space Program should be deleted.

@liquidhype, are you willing to try this?

Link to comment
Share on other sites

  • 0
1 minute ago, sal_vager said:

@liquidhype, are you willing to try this?

Sure, as long as it only affects KSP and doesn't give my PC a heart attack, I'm fine with deleting it.

So am I supposed to just delete the "Squad" folder in the registry then? Or just the "Kerbal Space Program" and "KSPLauncher" sub folders?

This is what I am looking at:

7vYBkhS.png

Link to comment
Share on other sites

  • 0

Back up first, but yes just the Kerbal Space Program folder as the other folder is only for the launcher though it won't hurt to delete the launcher folder as well.

Deleting that folder removes those keys, it will be as if you've never run KSP on that PC before, players have had to do this in the past when the registry got stuck on fullscreen.

Link to comment
Share on other sites

  • 0

Has anyone who fixed using the REGEDIT method able to get it to work with both a 1.2 and 1.1.3 install?

 

I have my 'career' mode in 1.1.3 using quite a few mods and this is my go to mode but i'm really loving trying out some of the 1.2 features as well. really hoping I can still run them side by side.

Link to comment
Share on other sites

  • 0
On 9/14/2016 at 4:06 AM, LosWashos said:

Hello,

since today i have a strange issue with KSP. I subscribed to the 1.2 Beta and then later switched back to the 1.1.3-Version. Now, everytime i start KSP it opens at the wrong display (i have two). When i try to unset fullscreen it doesn't react. I have to force it with alt+enter to exit fullscreen-mode. Now the fullscreen-setting reacts but also fullscreens at the wrong display, regardless of where i place the window with fullscreen switched off. I changed nothing in the system, just switched to 1.2 beta and back and now this occurs. I'm using steam and started it there and with CKAN, same Problem. Every other game starts normal. Is there any known help? Thanks.

I tried the launcher-settings, the start-settings of steam, switched which display is the main, i deleted and reinstalled the game and worked inb the config-sfc... nothing works. switching again to the beta the game opens at the right display, switching back to 1.1.3 its the same issue...

OMG I'm having the same problem! I finally just unplugged my second monitor. what is going on?

[EDIT] Deleting the Squad folder in the registry fixed it for me.

Edited by seeingeyegod
Link to comment
Share on other sites

  • 0

Seems like a alot of people are having this. I did this with the full release 1.2, changed back to 1.1.3 and its on my 1st monitor (Left). It should be on my 2nd. (middle).

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...