RealGecko

[KSP 1.3.1] Bon Voyage 0.13.2.1 - Make your wheels rolling! 2017-10-15

Recommended Posts

10 hours ago, Fr8monkey said:

Maybe hinting about it isn't the right way to do it...

What goes around:

On 08.12.2016 at 11:07 AM, Fr8monkey said:

or something like that

Comes around:

On 08.12.2016 at 11:08 AM, RealGecko said:

Sorry, my telepathic abilities are not working today

 

Share this post


Link to post
Share on other sites

I just wanted to say thank you for making this mod. I think it's exactly the timesaver I need! :)

I've just tried it on my career save using a rover with an Interstellar Extended reactor+generator for power generation. This leads me to the following feature request: Any chance the calculate other function could be expanded to support such reactors as well? Pressing the Poehali or Calculate other button produces the following in the .log:

MissingFieldException: Field '.BaseConverter.Efficiency' not found.
  at BonVoyage.BonVoyageModule.Activate () [0x00000] in <filename unknown>:0 
  at BaseEvent.Invoke () [0x00000] in <filename unknown>:0 
  at UIPartActionButton.OnClick () [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.InvokableCall.Invoke (System.Object[] args) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.InvokableCallList.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.UnityEventBase.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.UnityEvent.Invoke () [0x00000] in <filename unknown>:0 
  at UnityEngine.UI.Button.Press () [0x00000] in <filename unknown>:0 
  at UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor) [0x00000] in <filename unknown>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMousePress(MouseButtonEventData)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent(Int32)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent()
UnityEngine.EventSystems.StandaloneInputModule:Process()
UnityEngine.EventSystems.EventSystem:Update()

(Note: 1.2.2, so if that is the cause, feel free to ignore)

Share this post


Link to post
Share on other sites
1 hour ago, TeaOtter said:

Interstellar Extended reactor+generator for power generation

I'll see what can I do.

Share this post


Link to post
Share on other sites
10 hours ago, Fr8monkey said:

I have no idea about that.  Here is a new on that says 1.2.2 in it...  Sorry about all the trouble.

 

https://www.dropbox.com/home?preview=output_log.txt

That's a wrong link, to get the right link you need to push the button "Share" and in the opened dialog box click on "Create link".

Share this post


Link to post
Share on other sites
5 hours ago, The Destroyer said:

Exception: MissingFieldException Field baseconverter.effeciency not found, when I try poehail!!! 1.2.2 :(

I believe the log says more than that. The whole file would be helpful.

Share this post


Link to post
Share on other sites
12 hours ago, Enceos said:

I believe the log says more than that. The whole file would be helpful.

Okay, will do asap. That's all it said in the debug console

 

MissingFieldException: Field '.BaseConverter.Efficiency' not found.
	BonVoyage.BonVoyageModule.Activate ()
	BaseEvent.Invoke ()
	UIPartActionButton.OnClick ()
	UnityEngine.Events.InvokableCall.Invoke (System.Object[] args)
	UnityEngine.Events.InvokableCallList.Invoke (System.Object[] parameters)
	UnityEngine.Events.UnityEventBase.Invoke (System.Object[] parameters)
	UnityEngine.Events.UnityEvent.Invoke ()
	UnityEngine.UI.Button.Press ()
	UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData)
	UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData)
	UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor)
	UnityEngine.EventSystems.EventSystem:Update()

@Enceos the full message

Edited by The Destroyer

Share this post


Link to post
Share on other sites

Hi I am running KSP 1.2.2 x64 and getting two exceptions

The file is available at

https://www.dropbox.com/s/4b2s2n6uf49exsy/output_log.txt?dl=0

Input is null for field 'landedAt' in config node ''
   at System.Environment.get_StackTrace()
   at ConfigNode.AddValue(System.String name, System.String value)
   at ProtoVessel.Save(.ConfigNode node)
   at BonVoyage.BonVoyage.LoadRovers()
   at BonVoyage.BonVoyage.onLevelWasLoaded(GameScenes scene)
   at EventData`1[[GameScenes, Assembly-CSharp, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null]].Fire(GameScenes data)
   at HighLogic+<FireLoadedEvent>c__Iterator68.MoveNext()
   at UnityEngine.SetupCoroutine.InvokeMoveNext(IEnumerator enumerator, IntPtr returnValueAddress)

And

MissingFieldException: Field '.BaseConverter.Efficiency' not found.
  at BonVoyage.BonVoyageModule.Activate () [0x00000] in <filename unknown>:0 
  at BaseEvent.Invoke () [0x00000] in <filename unknown>:0 
  at RemoteTech.Modules.ModuleSPU.InvokeEvent (.BaseEvent baseEvent, Boolean ignoreDelay) [0x00000] in <filename unknown>:0 
  at RemoteTech.FlightComputer.UIPartActionMenuPatcher+EventWrapper.Invoke () [0x00000] in <filename unknown>:0 
  at BaseEvent.Invoke () [0x00000] in <filename unknown>:0 
  at UIPartActionButton.OnClick () [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.InvokableCall.Invoke (System.Object[] args) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.InvokableCallList.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.UnityEventBase.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.UnityEvent.Invoke () [0x00000] in <filename unknown>:0 
  at UnityEngine.UI.Button.Press () [0x00000] in <filename unknown>:0 
  at UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor) [0x00000] in <filename unknown>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMousePress(MouseButtonEventData)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent(Int32)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent()
UnityEngine.EventSystems.StandaloneInputModule:Process()
UnityEngine.EventSystems.EventSystem:Update()

 

Share this post


Link to post
Share on other sites
11 hours ago, Tochas said:

MissingFieldException: Field '.BaseConverter.Efficiency' not found.

Same here, rover has solar panels, fuel cells and a USI reactor (with NFE patches). Decoupling the reactor section (mining trailer) gives the same result.
 

Spoiler

MissingFieldException: Field '.BaseConverter.Efficiency' not found.
  at BonVoyage.BonVoyageModule.Activate () [0x00000] in <filename unknown>:0 
  at BaseEvent.Invoke () [0x00000] in <filename unknown>:0 
  at UIPartActionButton.OnClick () [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.InvokableCall.Invoke (System.Object[] args) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.InvokableCallList.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.UnityEventBase.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.UnityEvent.Invoke () [0x00000] in <filename unknown>:0 
  at UnityEngine.UI.Button.Press () [0x00000] in <filename unknown>:0 
  at UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor) [0x00000] in <filename unknown>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMousePress(MouseButtonEventData)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent(Int32)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent()
UnityEngine.EventSystems.StandaloneInputModule:Process()
UnityEngine.EventSystems.EventSystem:Update()

 

Maybe I'm reading it wrong, but the docs tend to indicate there's no such thing as BaseConverter.Efficiency??

Ed. Previous version works fine.

Edited by steve_v

Share this post


Link to post
Share on other sites

Version 0.11.1:

  • Fixes for KSP 1.2.2
  • Added "Close" button to main window
  • Toolbar button won't appear in editors
On 09.12.2016 at 7:57 PM, TeaOtter said:

I've just tried it on my career save using a rover with an Interstellar Extended reactor+generator for power generation.

Try latest version.

23 hours ago, Tochas said:

Input is null for field 'landedAt' in config node ''
at System.Environment.get_StackTrace()
at ConfigNode.AddValue(System.String name, System.String value)
at ProtoVessel.Save(.ConfigNode node)

When you launch your rover it's ProtoVessel field landedAt is null, and it causes error at this two methods, nothing I can do about it as it is a part of KSP core, however this error is not critical.

Share this post


Link to post
Share on other sites
1 hour ago, RealGecko said:

Try latest version.

Thanks for the new version!

Tried it with the Interstellar extended powered rover I made earlier and the buttons now all appear to work properly. However the mod does not detect the power production and refuses to engage. Calculate Other reports 0 production, so I'm thinking this might be related to how Interstellar produces power in another resource then only (?) converts portions of it to the stock electric charge if there's an actual drain or uncharged battery capacity.

Share this post


Link to post
Share on other sites
On 12/12/2016 at 8:19 AM, RealGecko said:

Version 0.11.1:

  • Fixes for KSP 1.2.2
  • Added "Close" button to main window
  • Toolbar button won't appear in editors

Try latest version.

Working nicely, thanks.

Share this post


Link to post
Share on other sites

HI Steve! the new version worked

But how do I deal with rovers stucked under a mountain?

I sent a test rover down to the nearest KSC mountains to harvest science and it appeared under the terrain (a very high slope) and the controls were disabled. sorry I forgot to take a screenshot or video

Share this post


Link to post
Share on other sites
5 hours ago, Tochas said:

I sent a test rover down to the nearest KSC mountains to harvest science and it appeared under the terrain

Wasn't rover position autofixed?

Share this post


Link to post
Share on other sites

Bon voyage keeps transporting my rovers into the monoliths when I target a waypoint, which explodes them. Is there a way to offset bon voyage, or at least just get the rover close to the target so that I can drive the last 100 meters? This might be a role play improvement, since you'd have to drive  a bit instead of teleporting around the planet.

Edited by sardia

Share this post


Link to post
Share on other sites
1 minute ago, sardia said:

Is there a way to offset bon voyage, or at least just get the rover close to the target so that I can drive the last 100 meters?

It's in ToDo list.

Share this post


Link to post
Share on other sites
On 14.12.2016 at 11:00 AM, RealGecko said:

It's in ToDo list.

@sardia 200m proximity, is a virtual boundary, if you cross it KSP starts calculating physics for that vessel. Spawning any closer is prone to explosions of either vessel. But a configurable offset for navpoints is probably needed. I use the precise position for my markers and rovers all the time, and don't need an offset myself.

@RealGecko the rover path line appears if you hover over the satellite connections button, I think it's very useful this way and wouldn't change that.

Edited by Enceos

Share this post


Link to post
Share on other sites
34 minutes ago, Enceos said:

the rover path line appears if you hover over the satellite connections button, I think it's very useful this way and wouldn't change that.

It's currently bugged, it will appear also if some ScreenMessage appear. Definitely needs to be fixed.

Share this post


Link to post
Share on other sites

Can you add a countdown timer for the pathing? It could be as simple as the distance divided by the velocity. That way it'll play much nicer with Kerbal Alarm clock, and I can just shut it down a few km or minutes early. I've noticed a couple times where the rover finished driving, but I didn't noticed til hours afterwards.

Share this post


Link to post
Share on other sites
Just now, sardia said:

Can you add a countdown timer for the pathing? It could be as simple as the distance divided by the velocity. That way it'll play much nicer with Kerbal Alarm clock, and I can just shut it down a few km or minutes early. I've noticed a couple times where the rover finished driving, but I didn't noticed til hours afterwards.

There's an option, to dewarp when rover arrived, there's a screen message noting it's arrived, there's a KSP message saying rover arrived, more than enough. Calculating arrival time is pointless cause solar powered rovers idle at night, and there're also serious speed penalties when rover moving in twighlight.

Share this post


Link to post
Share on other sites
11 hours ago, RealGecko said:

There's an option, to dewarp when rover arrived, there's a screen message noting it's arrived, there's a KSP message saying rover arrived, more than enough. Calculating arrival time is pointless cause solar powered rovers idle at night, and there're also serious speed penalties when rover moving in twighlight.

Oh, so that's what it does. There's a typo on the dewarp, it's automagic instead of automatic.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.