Jump to content

[1.4.2] Kerbal Space Transport System


Recommended Posts

Yes, Davon and Routine mission manager's real successor(or competition). The most useful thing to have if you are a long-term player is bringing things into at least LKO automatically.

Do you support mission time? As in - Will the vessel only be spawned in orbit when the recorded mission elapsed TTO expires or is it instant?

Link to post
Share on other sites
2 hours ago, smunisto said:

Do you support mission time? As in - Will the vessel only be spawned in orbit when the recorded mission elapsed TTO expires or is it instant?

Yep, missions time is supported and the eta  is displayed nicely in the interface.

 

On that note, another minor annoyance I found. The epoch and mean anomaly at epoch seem to be fixed for all deploy missions. There is a nice warning when trying to launch a deploy mission to an occupied orbit. But there is no warning launching multiple missions to the same orbit and no way to abort a mission in progress. 

Launching an unoccupied vessel, only to launch the same vessel right after with actual kerbals inside will only lead to a big explosion and dead kerbals.

Link to post
Share on other sites

I've just started a career game, as usual one of the first things I'll be doing is setting up a station in LKO and sending resources periodically (life support). 

 

Thought I'd ask here before I get to that point: does this mod allow you to use a space plane to transfer resources to a station in orbit? Does the payload have to be detached and docked? Or can the resources simply be transferred to the station when docked and the mod will remember what's been transferred once the plane returns?

 

A quick bullet point rundown of the required steps (from anyone that's tried this or similar) would be great!

 

I've always liked the idea of spaceplanes, but the grind of delivering stuff and returning the craft in one piece meant that I've always reverted to using rockets - for speed more than anything else. So I'm quite excited about this mod :)

 

Link to post
Share on other sites

I was wondering if there was any possibility this mod could be used in sandbox. Right now it seems that even in sandbox games the transfers or deployments cost funds, which of course don't exist in sandbox. This makes it impossible to use this on a few of my saves, and if there's any way to work around this limitation, I would be very grateful for any help.

Link to post
Share on other sites

Hello everyone, I've just uploaded a new version of KSTS (1.2). You can find a download-link in the first post of this thread.
I've finally added the construction-mission, which is described in the in-game help as follows:

Construction-missions allow you to build new ships directly in orbit which would otherwise be too large to be launched with a deployment-mission. To launch a construction-mission, you will need a space-station in Kerbin orbit (the vessel-type must be “station”) with at least one engineer on board as well as a transport-mission profile, which is able to reach said space station. The space station will function as your space dock and while the engineer constructs the new vessel, the selected transport-vessel will shuttle all the required parts into orbit.
Please note that the construction of a new vessel will take some time, one Kerbin-day per ton of dry mass to be exact. You can however halve this time for each additional engineer you station on your space dock

This function isn't 100% done though. At the moment the newly constructed ship will appear 100m away from your space station. It is planned to calculate this distance dynamically by looking at the size of the vessels involved as well as other vessels on the same orbit. So make sure that you only construct one ship at any given time for now.
In addition to this new feature I've fixed a couple of minor issues and added support for the sandbox-mode (funds are no longer required in sandbox).

 

On 20.10.2016 at 8:28 AM, mostlikely said:

Actually once you orbit around or land on a new celestial body (mun, minmus, ect.) the tourism contracts start requiring orbits and landings on this body too (which I don't think KSTS does yet? But it might be a great future addition!)  

However there are multiple kerbin-orbit only missions (space station, satellite, rescue, ect.) where KSTS removes the control risk and player focus investment (remember you still pay the funds and wait the time) of the launch with the exception of these tourism contracts. This just seemed odd to me when I started using KSTS so I thought I'd mention it.

 

Another issue I noticed alongside the staging is the interaction with other mods that tweak parts. For example the settings for ModularFuelTanks are lost when a craft is deployed using KSTS. 

I will see what can be done about the tourists in a future release. As for the modular fuel tanks, I was afraid this would happen. At the moment I'm loading the craft and then copy & initialize all the parts by hand in a new vessel, which is very error-prone, but thus far I haven't found any better way to create a new vessel in orbit (if anyone knows a native KSP-function, please lat me know). I will take a look at this, we probably have to copy over all the additional config-nodes from the craft-file into the new vessel...

 

On 21.10.2016 at 2:41 AM, Locob said:

I just found you, and I love you!.

What you did with your mod, is what I had in my imagination for a long time, EXACTLY how it is.

This will save me much game time. I really thank you.

I' glad you like it :)

 

On 21.10.2016 at 4:18 AM, Lord_Pall said:

Looks great. I think there might be a bug in sandbox mode. I did a deploy mission ~15t. Setup a 12t space station bit, went to the main space complex view, setup a deploy mission, but it wouldn't let me start the mission. The cost amount was flagged in red even though it was sandbox.

I'll retry in career.

It should work now in the sandbox as well (see above).

 

On 21.10.2016 at 1:22 PM, mostlikely said:

(...)

Launching an unoccupied vessel, only to launch the same vessel right after with actual kerbals inside will only lead to a big explosion and dead kerbals.

I will improve this function in a future release, vessels which are launched next to each other should get different semi-major axis.

 

On 21.10.2016 at 5:51 PM, Kielm said:

Thought I'd ask here before I get to that point: does this mod allow you to use a space plane to transfer resources to a station in orbit? Does the payload have to be detached and docked? Or can the resources simply be transferred to the station when docked and the mod will remember what's been transferred once the plane returns?

A quick bullet point rundown of the required steps (from anyone that's tried this or similar) would be great!

I've always liked the idea of spaceplanes, but the grind of delivering stuff and returning the craft in one piece meant that I've always reverted to using rockets - for speed more than anything else. So I'm quite excited about this mod :)

I am a big fan of space planes myself, which is one of the reasons I made this mod. Especially with the new construction-missions a plane which has a very favorable cost to payload ratio should be very useful. But to your question: Yes, the payload has to be detachable for deployment-missions. For transport (and construction-missions) you can simply release some fuel out of a docking port.

 

On 21.10.2016 at 8:09 PM, Locob said:

It seems Not detecting well the payload.

Here some examples.

http://imgur.com/a/LvEbn

Your screenshot seems to indicate that you have no parts attached to your decoupler. Are you sure the engine is actually attached to the small decoupler and not to the larger one underneath? Additionally you have to make sure that your payload does not include the root-part.

 

On 22.10.2016 at 4:56 PM, windpoison said:

I was wondering if there was any possibility this mod could be used in sandbox. Right now it seems that even in sandbox games the transfers or deployments cost funds, which of course don't exist in sandbox. This makes it impossible to use this on a few of my saves, and if there's any way to work around this limitation, I would be very grateful for any help.

Yes, the sandbox-mode is now supported with the new release.

Link to post
Share on other sites

@-MM-

Just stopping by to provide some feedback!

On a minor point: KSTS seems to be a little finicky about detecting new craft when recording missions. It doesn't always pick up that you've switched to a new craft on the runway to start recording, and as such the option to record does not appear. A workaround seems to be switching to the 'flights' tab before launching a new craft, then switching to 'record' once it's on the runway. Seems to crop up most when I'm still in the record tab and relaunch a vessel. 

With that out of the way - wow!

 

I got around to trying this mod out properly, and I love it. I've never done much in the way of spaceplanes purely because it was just so time consuming to get the most out of it. Between designing, launching and recovering craft I'd be looking at a good few hours to get one specific payload into orbit. Today however, after some minor teething problems (I stupidly used a fuel tank as a payload, and fuel flow rules... yep) I got a small test payload into a decent orbit. Nothing huge, just enough to launch some science satellites to Kerbin's moons. Now that the mission profile's set up, I can launch as many satellites as I want at a fraction of the cost :)

Next up, I'll be unlocking the larger spaceplane parts (something I never bother doing) so I can start sending up station modules. This has unlocked a whole side of KSP that I could only previously enjoy in creative mode - what used to take an hour or more now takes five minutes with this mod. Fantastic work :)

 

Link to post
Share on other sites

Is the mod capable of deploying vehicles to other planets and moons? If you record such a mission ofcourse. 

And if it can transfer resources to a space station in Lunar orbit. Or if i would want to transfer resources between 2 bases on Duna. Or transfer resources between a base and a station?

 

 

Edited by SebastianPahlsson
Link to post
Share on other sites

Great mod!

One small question. Maybe I am doing something wrong. I had rocket with two stages with second stage connected by decoupler into a heat shield of a ship i wanted to deploy. When second stage started to work the decoupler disappeared from the KSTS list. Is this normal? Or what I could get wrong?

Link to post
Share on other sites

@SebastianPahlsson

Just to Kerbin's SOI as far as I'm aware. To/from Kerbin so you can recover spaceplanes at the runway and so on.

@ttbs

From my experience using this, you can't use any resources from the 'payload' that you intend to deliver. So if you're delivering an entire rocket, you need to get that entire rocket into orbit with its own launch vehicle. 

Once you're in orbit, hit 'release payload' in the GUI before decoupling, then save and stop the flight. It'll decouple and record the transported mass.

FYI, if you use ANY resources in the 'payload' you're trying to deliver, you'll lose the option to release the payload. Relevant for spaceplanes that drain fuel from all stages, so set your fuel flow. I don't think electric charge counts though.

Hope that helps!

EDIT: After re-reading, I'm thinking the heat shield may have been partially worn in transit, or something from the payload must have been consumed. Try locking consumable resources on the payload, or using fairings.

Edited by Kielm
Link to post
Share on other sites
1 hour ago, ttbs said:

@Kielm

Is using electrical charge from the payload ok? And how about reaction wheels?

Haven't had any issues with EC - I believe it's just the resources that have mass. The idea seems to be that you can't alter the mass of the payload while in transit. EC has no mass, so shouldn't be a problem. 

Link to post
Share on other sites
1 hour ago, Kielm said:

Haven't had any issues with EC - I believe it's just the resources that have mass. The idea seems to be that you can't alter the mass of the payload while in transit. EC has no mass, so shouldn't be a problem. 

Yes, the idea is that you should build your rocket to deliver basically "dead weight" as payload. Otherwise you could just discard your burned out lower stages or external fuel tanks and call them your payload, which would make other deployment-missions with arbitrary payloads somewhat unrealistic. And yes, it only tracks resources which have mass in addition to engines. No reaction wheels, no lift surfaces, etc.
If you want to check if a part has been disabled, check the debug log during your flight. You will see messages like "[KSTS] marking part fuelTankSmall as used".

Link to post
Share on other sites

Thoroughly enjoying this mod @-MM-

I think I spotted another bug yesterday, concerning USI-LS. I need to do more testing to confirm, but it seems as though something's wiping out habitation times when KSTS is used to deploy manned (kerballed?) craft into orbit. So for example, I used an SSTO to lift a munar lander with 22 days of habitation time into orbit, and selected a single kerbal as the crew. It was delivered just fine, and had the kerbal on board, but the habitation time was 7 days. I went back and re-launched manually without the same problem, but I'll test a few more ways to confirm. 

Using Mk4 Spaceplane parts, I'm now lifting 36t payloads into 100km orbits above Kerbin. I can't wait to get the orbital station started! :)

Link to post
Share on other sites

How well does this work with the mun's SOI? like I launched a payload and went about 46000km from kerbin and back. How would it handle me selecting mun's orbit and it happens to be in mun's SOI

I figured out how the deploy works, so how does the transport? could I only transport the amount of resources that I send up? like if on the transport mission I only send up LFO, could I send up rocket parts? Does the transport's LFO not touch the payload's LFO?  

Link to post
Share on other sites

I have issues with deploying anything to orbit (even stock crafts). I have multiple mods installed.

When I select payload multiple NullReferenceException started to appear:

Starting the Dispatcher
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)


 
(Filename:  Line: 97)

[Part]: PartModule indexing mismatch at M3X.ShovelCockpit, index 9.
Node 'ModuleTripLogger' found in loaded data, but 'MechJebCore' is defined in prefab.
Looking for ModuleTripLogger in other indices...
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

...ModuleTripLogger module found at index 10.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[Part]: PartModule indexing mismatch at M3X.ShovelCockpit, index 10.
Node 'ModuleKISInventory' found in loaded data, but 'ModuleTripLogger' is defined in prefab.
Looking for ModuleKISInventory in other indices...
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

...ModuleKISInventory module found at index 11.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Heavy orbiter cargo loaded!
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[ModuleSrfFX]: No IThrustProvider module found at index 0!
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[ModuleSrfFX]: No IThrustProvider module found at index 0!
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Module ModuleCargoBay threw during OnStartFinished: System.NullReferenceException: Object reference not set to an instance of an object
  at ModuleCargoBay.SetupDynamicCargoOccluders (Boolean testActive) [0x00000] in <filename unknown>:0 
  at ModuleCargoBay.EnableShieldedVolume () [0x00000] in <filename unknown>:0 
  at ModuleCargoBay.OnStartFinished (StartState state) [0x00000] in <filename unknown>:0 
  at Part.ModulesOnStartFinished () [0x00000] in <filename unknown>:0 
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

InsterstellarFuelSwitch SetupTankInPart adding resources: LiquidFuel;Oxidizer;
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

InsterstellarFuelSwitch SetupTankInPart adding resources: LiquidFuel;Oxidizer;
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[ModuleSrfFX]: No IThrustProvider module found at index 0!
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

InsterstellarFuelSwitch SetupTankInPart adding resources: LiquidFuel;Oxidizer;
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Couldn't access secondaryTransform for raycasts
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Couldn't access secondaryTransform for raycasts
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

InsterstellarFuelSwitch SetupTankInPart adding resources: LiquidFuel;Oxidizer;
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[ModuleSrfFX]: No IThrustProvider module found at index 0!
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

InsterstellarFuelSwitch SetupTankInPart adding resources: LiquidFuel;Oxidizer;
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Couldn't access secondaryTransform for raycasts
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Couldn't access secondaryTransform for raycasts
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

NullReferenceException: Object reference not set to an instance of an object
  at ModuleRCS.FixedUpdate () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

NullReferenceException: Object reference not set to an instance of an object
  at ModuleRCS.FixedUpdate () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

NullReferenceException: Object reference not set to an instance of an object
  at ModuleRCS.FixedUpdate () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

When i start the mission everything is fine until clock hits 0. Then the game freezes. Last logs:

NullReferenceException: Object reference not set to an instance of an object
  at ModuleRCS.FixedUpdate () [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

Starting the Dispatcher
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)


 
(Filename:  Line: 97)

Slim Shuttle loaded!
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[KSTS] deployed new ship 'Slim Shuttle' as '867a8cec-3b03-4668-9245-0680fa2b4290'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[KSTS] added kerbonaut Valentina Kerman to vessel Slim Shuttle
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

[KSTS] added kerbonaut Bill Kerman to vessel Slim Shuttle
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

 

Link to post
Share on other sites
21 hours ago, ttbs said:

I have issues with deploying anything to orbit (even stock crafts). I have multiple mods installed.

I am having a similar, possibly exact problem as you.

My issue happens when I attempt to send *2* kerbals (or more) - but not 1.

Is this the same for you?

Link to post
Share on other sites

@Seeker89 as far as I know it's only intended for Kerbin's SOI. Try Davon supply mod for other planets.

Transport missions transport resources to a target vessel. Both need the same docking port. For a transport mission, record the ascent and reach desired orbit. You'll be able to dump a specific amount of resources with sliders, which counts as your payload. Once you've landed and saved the recording, you can transport those to a target vessel. I've tested by refuelling a vessel in orbit and works, but I haven't tried to change the resources (i.e. launch other supplies with the same transport), I'll try this later. I suspect you'd be limited to either the target vessel resources, or the transport vessel, or both.

 

@LuciferNZ, @ttbs

Curious. I'm using mk2 expansion and mk4 spaceplanes parts, as well as Mechjeb (and 40 other mods) but no problems like this. Which version of Mechjeb (hopefully the latest Dev?) are you both using, and are you using any mods that aren't listed as 1.2 compatible?

I've noticed USI-LS exhibit some odd, but not game-breaking behaviour with deployments, and nothing this serious. As usual, try verifying integrity of game cache if your game has crashed.

I have noticed there are occasional problems with unpacking vessels built with KSTS, but I haven't been able to reproduce them reliably, so if you have some steps to reliably reproduce the problem, that would help enormously.

Link to post
Share on other sites

An update to this:

I tried transporting a couple of Kerbals to an existing station in LKO, and the game hung up and crashed. No error log, nothing of use in output log either. 

After doing some testing, it seems the station I was trying to send Kerbals to had the first two available crew slots occupied, and the slot after that was an MKS Hab Ring. It's possible that KSTS is having problems transporting Kerbals into modded parts. However, as a workaround, I freed up the first two crew slots in the craft (counting from the root part outwards), and the next transport mission worked successfully. I'll raise an issue on github shortly. 

 

Are those experiencing the problem using MKS parts, or parts with non-standard crew configurations - e.g. deployable, or crew capacity that changes?

Edited by Kielm
Link to post
Share on other sites

I am having issues transporting kerbals or deploying kerbals. I can transport and deploy normally as long as I don't send kerbals anywhere. I am not using any mods that add parts and I am trying to deploy them to and transport them to a normal 3 person capsule.

 

Also after looking more into it, I can transport 1 kerbal, but when I transport a second one, it crashes.

Edited by Tibault
More Info
Link to post
Share on other sites
44 minutes ago, Tibault said:

Also after looking more into it, I can transport 1 kerbal, but when I transport a second one, it crashes.

Exactly the same as me.  Ive checked modded parts, and stock parts.

I have found, that I *CAN* deploy 2 kerbals, as long as both 'cabins' are 1 crew only.
As soon as I use a multi crew part sending multi crew, it freezes.
You can even have, say 6xMkI pods + a MkI-2(I think its called, 3 space) and deploy 7 kerbals, as long as the Mk1-2 is last on the node tree.

So, quick work-around, only use 1 kerbal crew cabins for my deployments. :wink:

What I am interested in, is if anyone has SUCCESSFULLY deployed more than 1 crew member, into a multi-crew part.

(Note: I am using deployments exclusively, but I am assuming the code is shared for transport and deployments)
 

Link to post
Share on other sites

@Tibault, @LuciferNZ

I've identified the issue and you're both correct. The problem arises when KSTS tries to put a kerbal into a multi-crew part that already has a kerbal in it. This includes situations where it tries to put 2 kerbals into a part that has capacity for 2 or more (the first one fills the first seat and the same scenario ensues).

I've raised it on github, I'm sure @-MM- will release a fix when he sees it (I believe he's in Germany and it's 3:30am there right now so...)

 

Thanks all for the information, it's made finding the problem a lot easier!

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...