Jump to content

[1.12.x] Konstruction! Weldable ports, servos, cranes, and magnets!


RoverDude
 Share

Recommended Posts

Posted (edited)
16 hours ago, RoverDude said:

Gee, thanks for your constructive feedback on something I made for free. 

 @RoverDude No sir...It was not my intent to insult you or your work. It was simply a statement of disappointment.  I use the construction ports for assembling stations in orbit and would love larger ones. Konstruction is one of my must have mods.

Please understand that I appreciate your work and that no offense was ever intended.

Edited by strider3
Link to comment
Share on other sites

1 hour ago, strider3 said:

I use the construction ports for assembling stations in orbit and would love larger ones. Konstruction is one of my must have mods.

Module Manager patch to make any non-animated (e.g. extending, shielded etc.) docking port weldable:

Spoiler
@PART[*]:HAS[@MODULE[ModuleDockingNode]:HAS[~deployAnimationController],!MODULE[ModuleWeldablePort],!MODULE[ModuleCommand]]:NEEDS[Konstruction]:FINAL
{
	MODULE 
	{
		name = ModuleWeldablePort
	}
}

 

 

Link to comment
Share on other sites

4 minutes ago, strider3 said:

Paste text exactly as you supplied, I take it?

Yes, copy text into new text file and save with a .cfg file extension to anywhere in GameData (e.g. GameData/ZZZ_Custom/WeldableDockingPorts.cfg)

Link to comment
Share on other sites

On 4/22/2022 at 5:18 PM, conao said:

Anybody has any idea what could cause the parts from this mod to disappear from the parts lists in the VAB? It worked before, the last time I checked (admitdly quite a few months ago) and I even have the Clamp-o-Tron Construction Port in one of my stations still working ok.

I have the mod installed by CKAN and I have checked that all its dependencies are also installed and updated. I also reinstalled it using the reinstall option in CKAN.

I checked that the parts have been unlocked in the Tech Tree and I even uninstalled the Janitor's Closet mod just to be sure that it's not filtering out anything. No success though. I can't find any of the PAL parts or the construction ports in the VAB.

I'm on the latest version of KSP and all mods are updated by CKAN. I'd appreciate any help and I can upload the save or a log if needed.

 

@RoverDude I can confirm that the latest version, 120.0.1 has solved the issue. The contruction ports are back in the game. Thanks a lot for your work!

 

On 6/4/2022 at 4:32 PM, Aelfhe1m said:

Module Manager patch to make any non-animated (e.g. extending, shielded etc.) docking port weldable:

  Reveal hidden contents
@PART[*]:HAS[@MODULE[ModuleDockingNode]:HAS[~deployAnimationController],!MODULE[ModuleWeldablePort],!MODULE[ModuleCommand]]:NEEDS[Konstruction]:FINAL
{
	MODULE 
	{
		name = ModuleWeldablePort
	}
}

 

 

I can confirm that this works too! Great trick! Thanks @Aelfhe1m!

Link to comment
Share on other sites

  • 1 month later...

I have a question about the Konstruction Docking Ports. 

How does the rotation feature work?

I usually can't get the angle right when docking so before I Multi-Weld, I have to correct it by rotating. How do I do that? They don't rotate like Vanilla ports.

Any help much appreciated and awesome mod, thanks for your hard work!

Link to comment
Share on other sites

  • 2 weeks later...

I also have a question... about the konfrabicator, i spent 2 hrs designing and building a station in orbit but now im stuck. 

I figured out how to use it pretty quickly, but one thing i dont understand is the resource system. like alloys, like how am i going to get alloys? i cant find a single container that can store alloys, wut :/

Link to comment
Share on other sites

30 minutes ago, Feellikeapple said:

I also have a question... about the konfrabicator, i spent 2 hrs designing and building a station in orbit but now im stuck. 

I figured out how to use it pretty quickly, but one thing i dont understand is the resource system. like alloys, like how am i going to get alloys? i cant find a single container that can store alloys, wut :/

Hmm. Am I right in assuming Konstruction is the only USI mod you have installed?

When you look at the lastest release, you'll see that it is bundled with other stuff; dependend other mods (000_USI Tools, CCK, CRP, Firespitter==> you need those)  but also other USI mods (Akita, FX, Kontainers, ReactorPack, USICore). 
I'd advise installing all of those. You can leave out Akita if you want, although it provides cool rover parts.

For the resources: I have never played Konstruction without MKS, so I'm not really sure how to go about it. You are ofcourse very welcome to join us in the wondrous world that is Modular Kolonization System:wink:
 

Edited by modus
forgot quote
Link to comment
Share on other sites

yea you caught me, im only using konstruction, i would very much like to use mks but im afraid its gonna clutter up my current mod list. cus i have all of near future and some extras like mk2 & 3 expansion, is mks too much to handle?

Link to comment
Share on other sites

3 hours ago, Feellikeapple said:

yea you caught me, im only using konstruction, i would very much like to use mks but im afraid its gonna clutter up my current mod list. cus i have all of near future and some extras like mk2 & 3 expansion, is mks too much to handle?

Don't worry about cluttering, I have all those mods you name, and many more:D

You should know that MKS is first and foremost a gameplay mod, not so much a parts mod like Near Future is. It has parts but those are to support the gameplay.

For now, I'd just install the latest release of Konstruction with everything that's bundled. That way you make sure you have the right containers for everything.
We'll also ask @RoverDudehow you handle resources in Konstruction without MKS. Do you just buy them in the VAB?

And if you want to make the big plunge into MKS, you can always ask for help in the MKS thread!

Edited by modus
typo
Link to comment
Share on other sites

wow thanks!

8 hours ago, modus said:

Don't worry about cluttering, I have all those mods you name, and many more:D

You should know that MKS is first and foremost a gameplay mod, not so much a parts mod like Near Future is. It has parts but those are to support the gameplay.

For now, I'd just install the latest release of Konstruction with everything that's bundled. That way you make sure you have the right containers for everything.
We'll also ask @RoverDudehow you handle resources in Konstruction without MKS. Do you just buy them in the VAB?

And if you want to make the big plunge into MKS, you can always ask for help in the MKS thread!

Im just worried about issues like part repeats like the artificial gravity rings and like 50 million containers and also other conflicts but ill try out mks!

1 other question, will the wear & tear system in mks conflict with dang it? cus I have that installed too

also akita is the cutest thing ever :D

Edited by Feellikeapple
Link to comment
Share on other sites

7 hours ago, Feellikeapple said:

wow thanks!

Im just worried about issues like part repeats like the artificial gravity rings and like 50 million containers and also other conflicts but ill try out mks!

1 other question, will the wear & tear system in mks conflict with dang it? cus I have that installed too

also akita is the cutest thing ever :D

I don't have dang it but I don't think it would conflict with MKS. In MKS parts don't just break or anything like that.

Link to comment
Share on other sites

  • 2 weeks later...

i always get the message "engineer not present in active ship" when i try to produce parts and when i press the button "enable construction" i get the same message.
When I switch to english it works normally. But I don't want that as a solution.

5e9832472-2022-08-07-1.png

Link to comment
Share on other sites

XzE90xG.png

 

Soimething is wrong with the Konstruction Bay. I can't transfer crew into it. If I add crew to it in the VAB, their portrait is invisible in the bottom right. The Konfabricator works okay.

Link to comment
Share on other sites

34 minutes ago, Frostiken said:

 

 

Soimething is wrong with the Konstruction Bay. I can't transfer crew into it. If I add crew to it in the VAB, their portrait is invisible in the bottom right. The Konfabricator works okay.

Would help if you provided a log file.  Just saying that something isn't working isn't helpful, it's like going to the doctor and saying that something is hurting without any other info

Link to comment
Share on other sites

12 hours ago, Frostiken said:

I can't transfer crew into it.

Currently it is only possible to transfer crew into it, after it is deployed.

So you need to deploy it (and switch to the KSC and back to the vessel) in order to be able to transfer crew into the KonStructor.

12 hours ago, Frostiken said:

If I add crew to it in the VAB, their portrait is invisible in the bottom right

This patch fixes this problem: https://github.com/UmbraSpaceIndustries/Konstruction/pull/97

Edited by mhoram
Link to comment
Share on other sites

8 hours ago, mhoram said:

Currently it is only possible to transfer crew into it, after it is deployed.

 

Hey thanks. Though... how do I deploy it? I only have a button to 'deposit resources', is that normal? What do I need to 'deposit'? Material Kits?

Did I miss the documentation on this? The original post is beyond worthless.

Edited by Frostiken
Link to comment
Share on other sites

1 hour ago, Frostiken said:

Hey thanks. Though... how do I deploy it? I only have a button to 'deposit resources', is that normal? What do I need to 'deposit'? Material Kits?

Yes, this is the right button. It is the same for me.

According to https://github.com/UmbraSpaceIndustries/Konstruction/blob/eecfe00077c8c9f643b55d821c15fcaa53ee26f9/FOR_RELEASE/GameData/UmbraSpaceIndustries/Konstruction/Parts/Konstruction_Orbital_Shipyard_250.cfg#L70-L77 you will need 4000 MaterialKits for deploying the "KS-250-O KonStructor - Orbital Shipyard".

Link to comment
Share on other sites

  • 4 weeks later...

Hi @RoverDude so it seems that KonFabricator is broken in all languages  except English.

It is caused by using hardcoded "engineer" string in if statement. Instead of this it would be much wiser to get that string from loc file 

There is a temporary solution just to switch game language but i hate it because it defeats all my hard work localising all the mods i use. So please maybe a hotfix can be quickly made.

 

Edited by ra4nd0m
Link to comment
Share on other sites

57 minutes ago, ra4nd0m said:

Hi @RoverDude so it seems that KonFabricator is broken in all launguages except English.

It is caused by using hardcoded "engineer" string in if statement. Instead of this it would be much wiser to get that string from loc file 

There is a temporary solution just to switch game language but i hate it because it defeats all my hard work localising all the mods i use. So please maybe a hotfix can be quickly made.

 

Happy to take a PR on this one.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...