RoverDude

[1.3] Konstruction! Weldable ports, servos, cranes, and magnets! [0.1.3]

Recommended Posts

57 minutes ago, Boiler1 said:

DStaal, I envisioned KIS as the Kerbal wrenching the parts apart.  Using cranes and winches to lift and support modules.  I agree with you in principal using a fork truck to lift something up into place is reasonable.  It is just not the safe thing to do in that situation.  Considering this is a video game about little green guys that make unsafe rockets that blow up all the time, I don't think not allowing the fork truck due to safety is in line with the game.  So if you want to put it in I don't have an issue with it.

Something else to consider, what about a vehicle with 2,3, or 4 of the lifting components.  It is not hard to get the KIS mass limit to 50 which would be over the capacity of the framework.  I don't see any way to limit this do you?

I'm not sure working with a 10-ton part that you’ve lifted overhead using an electromagnet running off of a battery is much safer...  :D  (My point is that I see it as 'place it with the lift, remove the lift, then fasten', I guess.  Either way, I see your point and don't really want to argue.  I agree I wouldn't want to work on it in real life.)

I don't see a way to limit spamming the parts - though as someone who's actually tried adding this to parts before I will say it's not as useful as you might think.  KIS calculates 'pickup distance' from the center of the Kerbal to the center of the part, and that distance by default is 3 meters.  (And note the distance of the Kerbal actually doing the work is relevant to what range you can actually do things at - The guy with the wrench has to be at the location you're attaching/detaching.)  So if you're lifting a Kerbodyne tank (the only stock parts larger than 20 tones, and nearly the only ones larger than 10), you need to be within 3 meters of it's center with your Kerbal.  Given that it's radius is 3.75 meters, that's a tricky task.  :wink:  (There is some play in there - I've successfully lifted 3.75 meter parts.  But you basically have to be right next to the center of the tank (not the ends) and be able to place it right next to you as well.)

Of course, some of the full Kontainers have significantly larger mass that that - the 1.25 meter container in my images above has a mass of over 19 tones - but the point about it being of less utility than you'd think still applies.

Share this post


Link to post
Share on other sites
7 hours ago, Boiler1 said:

StikkyChaos, The construction ports are rotation dependent, unlike standard docking ports.  If the rotation is off, they do not dock.  Although you can adjust torque and the craft will rotate into place if it is not too large.

......

No doubt it was mentioned somewhere but i missed it (just like StikkyChaos). Tested it and it worked. Thanks for the tip!

Share this post


Link to post
Share on other sites
10 hours ago, DStaal said:

PR submitted.

Awesome!

I agree with your point that to stack they have to place them very close together.  Should not be a problem.  I hope RD likes it!

Share this post


Link to post
Share on other sites
12 hours ago, DStaal said:

PR submitted.

This is an awesome idea.

Share this post


Link to post
Share on other sites

Yet another awesome mod from @RoverDude. I wonder what he'll come up with next.

51 minutes ago, Dres-the-space-potato said:

Is this still possible to use in 1.1?

It was never released for any version prior to 1.2 pre, so I personally wouldn't expect it to. Install it and let us know.

Share this post


Link to post
Share on other sites
22 minutes ago, tomkpunkt said:

Cant dock a Construction Port to a  Docking Port... is this intentionally or a bug?

Intentional

Share this post


Link to post
Share on other sites
1 hour ago, pheenix99 said:

Yet another awesome mod from @RoverDude. I wonder what he'll come up with next.

It was never released for any version prior to 1.2 pre, so I personally wouldn't expect it to. Install it and let us know.

Works perfectly in 1.1

Share this post


Link to post
Share on other sites
49 minutes ago, Dres-the-space-potato said:

Works perfectly in 1.1

Makes me wonder if other parts packs (even non USI) would work in the same fashion.

Share this post


Link to post
Share on other sites
Just now, Dres-the-space-potato said:

I'll check some 1.2 packs in 1.1

I'd do it as well, but I have this whole "several more hours before I can leave work" thing going on right now.

Share this post


Link to post
Share on other sites

I think I found a bug.

when compress(rotate), A space station I made doesn't weld correct angle.
It welded correct angle just 1 frame, but after first frame It rotated to previous angle.

and I tested almost 120 degree rotate, but it destroyed after 1 frame.

GIlo2NP.png

I attached save file : https://drive.google.com/open?id=0B-HJUJ6farqxSUN2dV9CWjNxalk

I used Kerbal Planetary Base Systems mod. I think you know, this. : http://forum.kerbalspaceprogram.com/index.php?/topic/133606-12-kerbal-planetary-base-systems-v132-24th-october-16/
and others are not adding parts at all.

 

My suggestion to fix this bug is this : make problem simpler and make usage simpler too.
1. remove angle snap and roll/torque param from constroport.
2. Add adjust absolute/relative angle without compress.
3. then remove compress(rotate)

If you accept my suggestion, users can dock any angle and fix angle after docking. then users will not annoy from snap rotates modules violently, and users will not have to concern angle of docking port. I hope you accept my opinion.

Share this post


Link to post
Share on other sites

so im having problems witht the mod i have tried installing three times but the only part that are coming up is the weldable parts can you give me any advice on fixing this i have no mods installed

Share this post


Link to post
Share on other sites
33 minutes ago, chandlernic1 said:

so im having problems witht the mod i have tried installing three times but the only part that are coming up is the weldable parts can you give me any advice on fixing this i have no mods installed

This mod creates a custom category and places the parts there. Have you looked in all the tabs?

Share this post


Link to post
Share on other sites

You have multiple categories so there is something wrong with your install. First guess is you have nested folders--like a GameData folder in your GameData folder. Go through the folders and make sure you don't have duplicates. Or start with a clean install and just add Konstruction with its dependencies. Once that is working you can slowly add other mods. 

Share this post


Link to post
Share on other sites

Anyone know of a guide to help explain the servos and such so I can configure the wheeled legs to stow and deploy at the desired angles?

Share this post


Link to post
Share on other sites
2 hours ago, Tarheel1999 said:

You have multiple categories so there is something wrong with your install. First guess is you have nested folders--like a GameData folder in your GameData folder. Go through the folders and make sure you don't have duplicates. Or start with a clean install and just add Konstruction with its dependencies. Once that is working you can slowly add other mods. 

dependices?

 

Share this post


Link to post
Share on other sites
9 minutes ago, chandlernic1 said:

4th try installing no luck only docking ports are showing up am i doing something wrong i have unistalled the game twice

 

picture of your gamedata folder might help

Share this post


Link to post
Share on other sites
59 minutes ago, chandlernic1 said:

4th try installing no luck only docking ports are showing up am i doing something wrong i have unistalled the game twice

 

Are you in career mode?

 

Also, you don't have to uninstall.  Just rename the current directory and reinstall.  You can have multiple copies of KSP on your computer.  It is handy to have different versions in different directories.

Edited by Boiler1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.