RoverDude

[1.3] Konstruction! Weldable ports, servos, cranes, and magnets! [0.1.3]

Recommended Posts

Where did those other structural parts in the first image come from, specifically the hub?

Share this post


Link to post
Share on other sites
2 minutes ago, RocketSquid said:

Where did those other structural parts in the first image come from, specifically the hub?

Those are parts from the next MKS version. 

Share this post


Link to post
Share on other sites

so im little confused on some of the abilites with the welding side of things. I was hoping you would be kind enough to clarify for me. Say i have two parts both with docking ports that i intend to weld together does the angle snap allow me to weld them at a different angle? for example the two docking ports are placed on the attachment points as normal, the two parts are 90 degrees to each other (lets say one horizontal one vertical). but i want the vertical part to be connected at say 75 degrees (random number, and yes i know that might leave gaps)  would this be possible with the angle snap or at all.

 

thanks

Share this post


Link to post
Share on other sites

I guess there are some weight limitations...:D I tried to grab this rather large (empty) plane with two grabbers, anything works nicely and flush but i think i need some more of them ... excellent mod, i tested the magnetic crane too, works perfect with "normal" loads :rolleyes:

uPVo2nK.png

Edited by Mikki

Share this post


Link to post
Share on other sites

@RoverDude - given the popularity of the 1.875m size in the modding community, have you considered making a construction port of that size?

Share this post


Link to post
Share on other sites

Wow. I don't suppose you're going to make a full robot arms for our Mk3 shuttles are you?

This crane is really nice.

Share this post


Link to post
Share on other sites
2 hours ago, Bombaatu said:

@RoverDude - given the popularity of the 1.875m size in the modding community, have you considered making a construction port of that size?

I'm sure if he finds he wants one he will make it.

Share this post


Link to post
Share on other sites
33 minutes ago, goldenpsp said:

I'm sure if he finds he wants one he will make it.

You may also be able to MM the necessary module into the parts you want to have this feature.

Share this post


Link to post
Share on other sites

My compliments, RoverDude! The Konstruction parts are beautiful and I look forward to playing with them.

The construction ports, OTOH, go far beyond pretty & fun. That was a brilliant innovation!

Share this post


Link to post
Share on other sites

I just wanted to give this one a go since it looks really awsome, I got the latest version from github, but it seems to logspam my KSP with the following whenever I select a part in the editor:/

JArz8wg.png

Is it "safe" to use anyways or is this something bad? It keeps spamming the log - when I type a letter and submit it to the log it is gone verry fast since those messages apear mltiple times per second.

Cheers.

 

Edit:

Of course I'm also using the latest built of KSP 1.2 pre. Only other mod would be KER.

Edited by maculator

Share this post


Link to post
Share on other sites
19 hours ago, RoverDude said:

Every single part - including that hab ring.  Just put your save in another folder, and wait to start a new save on 1.2 when you are ready.  No big deal.

Thanks for the clarfication

Just to be crystal clear, If I delete every ship containing an MKS part, will that maintain compatibility?

Is USI-LS unaffected?

Edited by Bishop149

Share this post


Link to post
Share on other sites
4 hours ago, Beowolf said:

My compliments, RoverDude! The Konstruction parts are beautiful and I look forward to playing with them.

The construction ports, OTOH, go far beyond pretty & fun. That was a brilliant innovation!

Thank you :)

2 hours ago, SpaceBadger007 said:

Wait... with this mod can we make foldable athlete rovers or do we still need IR for that?

That was the original intent - but wheels for now are either deployed or not due to the current wheel code (i.e. it is not particularly happy about moving transforms around).

1 hour ago, maculator said:

I just wanted to give this one a go since it looks really awsome, I got the latest version from github, but it seems to logspam my KSP with the following whenever I select a part in the editor:/

JArz8wg.png

Is it "safe" to use anyways or is this something bad? It keeps spamming the log - when I type a letter and submit it to the log it is gone verry fast since those messages apear mltiple times per second.

Cheers.

 

Edit:

Of course I'm also using the latest built of KSP 1.2 pre. Only other mod would be KER.

Oh, make sure you grab CRP (I forgot to bundle it).  It works on 1.2

 

 

19 minutes ago, Bishop149 said:

Thanks for the clarfication

Just to be crystal clear, If I delete every ship containing an MKS part, will that maintain compatibility?

Is USI-LS unaffected?

 

Sorry not following, can you clarify?  These threads move pretty quick

Share this post


Link to post
Share on other sites
5 minutes ago, RoverDude said:

Sorry not following, can you clarify?  These threads move pretty quick

If for sake of argument I wanted to use my current 1.1.3 save with 1.2 + MKS 0.5 would deleting all ships containing an MKS part be sufficient to maintain compatibility? This might be a feasible option for me without being too game breaking.

What I don't think I could do however is delete every ship containing a USL-LS part, seeing as thats a separate mod I'm hoping that wouldn't be necessary! 

 

Edited by Bishop149

Share this post


Link to post
Share on other sites

Yes, you would need to delete every single ship containing MKS parts.  USI-LS also changed... not sure on that one's effect.  Tanks are fine, but it's the other bits (which there are very few of) that would be a problem - i.e. the nom o matics are completely replaced.

Share this post


Link to post
Share on other sites

Forgive me if I missed this somewhere. Is the servo window supposed to be open all the time even without any servo stuff or any of the parts from this mod onboard?

Share this post


Link to post
Share on other sites

Okay I don't want to be "that guy" but it's stil spamming my log. I assumed CRP means Community Resource Pack and I got it (like everything from githup, most recent built) :/

Share this post


Link to post
Share on other sites
45 minutes ago, Kevin Kyle said:

Forgive me if I missed this somewhere. Is the servo window supposed to be open all the time even without any servo stuff or any of the parts from this mod onboard?

If you clicked the icon then yes.  Click it again to turn it off.

 

7 minutes ago, maculator said:

Okay I don't want to be "that guy" but it's stil spamming my log. I assumed CRP means Community Resource Pack and I got it (like everything from githup, most recent built) :/

huh then something really weird is going on, because that message just is not normal.  Try with no other mods on a clean save?

 

Share this post


Link to post
Share on other sites
1 hour ago, maculator said:

Okay I don't want to be "that guy" but it's stil spamming my log. I assumed CRP means Community Resource Pack and I got it (like everything from githup, most recent built) :/

I also had this problem. I took out all my mods except USI's and it didn't happened again. So after that, trying to reproduce, I got everything back, but deleted all of MM's files (configcache, configsha, physics and techtree) minus the main dll and the problem was solved, no more spam. I didn't reported to MM's topic because I already deleted that files, so I couldn't reproduce.

Edited by Crabman

Share this post


Link to post
Share on other sites

I also have this problem,

build id = 01574 2016.10.08 at 05:22:51 CEST
Branch: prerelease

Mod Konstruction / CRP / Module Manager

Share this post


Link to post
Share on other sites
46 minutes ago, Well said:

I also have this problem,

build id = 01574 2016.10.08 at 05:22:51 CEST
Branch: prerelease

Mod Konstruction / CRP / Module Manager

Same here, Konstruction + one or both CRP and MM cause a exception, Konstruktion + PreKIS + PreKAS run nicely. Build 1576

Edited by Mikki

Share this post


Link to post
Share on other sites

@RoverDude I've been waiting for something like this for ages, especially the crane. Now I can finally manually recover my capsules without needing to mess around with infernal robotics and KAS/KIS. Thanks for this. :)

Share this post


Link to post
Share on other sites

Okay so it is not just me. And I have tested it on a fresh unmodded career and got the log spam with the most recent mm (2.71 I guess is the number).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.