RoverDude

[1.8.x] Konstruction! Weldable ports, servos, cranes, and magnets! [0.1.3]

Recommended Posts

21 minutes ago, Holdground said:

actually it is now working on 1.1.3 just do the 1.1.3 fix from get hub

 

well there you go then.  I guess the no would be officially available for 1.1.3.

Share this post


Link to post
Share on other sites

I'm trying to make a circle-ish connection using the construction ports, but it doesn't seem to work. I've tried to undock and redock, make changes in the snapping options, reset acquire and so on, but the result is always the same.

What am I doing wrong? This is what multi-weld is supposed to do, yes?

Spoiler

What I'm doing:

CXmg7lG.jpg

 

Result:

W44znag.jpg

Thanks in advance.

 

Edit: I got it to work by placing the sets of ports below one lab module, and the other set above. Still would like to know what's going on, though.

Edited by Shawarmakriger

Share this post


Link to post
Share on other sites
3 hours ago, Shawarmakriger said:

I'm trying to make a circle-ish connection using the construction ports, but it doesn't seem to work. I've tried to undock and redock, make changes in the snapping options, reset acquire and so on, but the result is always the same.

What am I doing wrong? This is what multi-weld is supposed to do, yes?

  Hide contents

What I'm doing:

CXmg7lG.jpg

 

Result:

W44znag.jpg

Thanks in advance.

 

Edit: I got it to work by placing the sets of ports below one lab module, and the other set above. Still would like to know what's going on, though.

Did you try triggering the "compress parts" function via the action groups?

Share this post


Link to post
Share on other sites

Hey everyone - this is probably a really stupid question but I'm trying to get two ports to compress and all I'm getting is KABOOM! - I'm using the Compress (Rotate) Option and it triggers the animation and then Kerbal soup. Honestly not sure what I'm doing wrong - Any advice would be much appreciated so I can get on with my station :)

Share this post


Link to post
Share on other sites
8 hours ago, TheRagingIrishman said:

don't use that, it's broken atm

Ah that would make sense - Ill just try to rotate manually then :) 

I knew there would be a simple answer - Thanks 

Share this post


Link to post
Share on other sites

Hi

 

I have V1.3 KSP

I have downloaded and installed the mod and the parts appear but I don't have any control over the Crane, Arm, or Fork lift etc.  It just appears as a nice looking part stuck to my vehicle but totally unusable. 

 

Is it not 1.3 compatible ?

 

Thanks

Share this post


Link to post
Share on other sites
13 hours ago, SnoopSLR said:

Hey everyone - this is probably a really stupid question but I'm trying to get two ports to compress and all I'm getting is KABOOM! - I'm using the Compress (Rotate) Option and it triggers the animation and then Kerbal soup. Honestly not sure what I'm doing wrong - Any advice would be much appreciated so I can get on with my station :)

If you happen to use MechJeb as well, you can align the parts checking the force rotation box an set the angle you need. Combine it with the snap option of the construction ports . Without ;MechJeb it's pretty much the same, except that you'll need to eyeball the angle yourself. You might find this helpful.

3 hours ago, MattBeeching said:

Hi

 

I have V1.3 KSP

I have downloaded and installed the mod and the parts appear but I don't have any control over the Crane, Arm, or Fork lift etc.  It just appears as a nice looking part stuck to my vehicle but totally unusable. 

 

Is it not 1.3 compatible ?

 

Thanks

There is special GUI to control magnets and servos. You too might find the wiki pages on USI Konstruction helpful. =)

Share this post


Link to post
Share on other sites
3 hours ago, SchrottBot said:

If you happen to use MechJeb as well, you can align the parts checking the force rotation box an set the angle you need. Combine it with the snap option of the construction ports . Without ;MechJeb it's pretty much the same, except that you'll need to eyeball the angle yourself. You might find this helpful.

There is special GUI to control magnets and servos. You too might find the wiki pages on USI Konstruction helpful. =)

I looked for the GUI control icon but there is nothing.

When I right click on the part there are no options.

Share this post


Link to post
Share on other sites

Perhaps a dumb question, but I did download this mod after coming back from 1.2, and for some reason, I ended up downloading 1.2 Konstruction.  It was the cause of all my crashes.  I had to manually install each mod one by one until I found the culprit.  The title in this thread shows 1.3 compatible, but the SpaceDock link is hosting the 1.1.3 version.  

Can anyone confirm, or am I just going crazy and not looking hard enough?

Edit: I've since went directly to GitHub and found the sources myself.  I think OP needs to update the SpaceDock link because it's not compatible with 1.3.  

Edited by theHockey0

Share this post


Link to post
Share on other sites
12 minutes ago, theHockey0 said:

Perhaps a dumb question, but I did download this mod after coming back from 1.2, and for some reason, I ended up downloading 1.2 Konstruction.  It was the cause of all my crashes.  I had to manually install each mod one by one until I found the culprit.  The title in this thread shows 1.3 compatible, but the SpaceDock link is hosting the 1.1.3 version.  

Can anyone confirm, or am I just going crazy and not looking hard enough?

Edit: I've since went directly to GitHub and found the sources myself.  I think OP needs to update the SpaceDock link because it's not compatible with 1.3.  

Konstruction is now bundled with MKS which is why the space dock page hasn't been updated.

40 minutes ago, MattBeeching said:

I looked for the GUI control icon but there is nothing.

When I right click on the part there are no options.

Sounds like you haven't installed it properly. You should have this button available. servobutton.png

Which will open this screen

Servocontrol.png?raw=true

Share this post


Link to post
Share on other sites
2 hours ago, theHockey0 said:

Perhaps a dumb question, but I did download this mod after coming back from 1.2, and for some reason, I ended up downloading 1.2 Konstruction.  It was the cause of all my crashes.  I had to manually install each mod one by one until I found the culprit.  The title in this thread shows 1.3 compatible, but the SpaceDock link is hosting the 1.1.3 version.  

Can anyone confirm, or am I just going crazy and not looking hard enough?

Edit: I've since went directly to GitHub and found the sources myself.  I think OP needs to update the SpaceDock link because it's not compatible with 1.3.  

In one of the threads @RoverDude mentioned some issue with the spacedock update.  IIRC it was an API change with the site or something.  Either way, it's likely a low priority given you can get everything easily off of github.

Share this post


Link to post
Share on other sites
Just now, goldenpsp said:

In one of the threads @RoverDude mentioned some issue with the spacedock update.  IIRC it was an API change with the site or something.  Either way, it's likely a low priority given you can get everything easily off of github.

 

2 hours ago, dboi88 said:

Konstruction is now bundled with MKS which is why the space dock page hasn't been updated.

Sounds like you haven't installed it properly. You should have this button available. servobutton.png

Which will open this screen

Servocontrol.png?raw=true

Thanks guys.  It was driving me nuts until I went directly to the GitHub page.  I've since updated all the dependencies as well.  Cheers!

Share this post


Link to post
Share on other sites

Echoing a few other comments here, your Spacedock link is still pointing to the version for KSP 1.1.3. This caused me a loading asplosion and some confusion until I figured it out, I hadn't noticed on downloading since the thread clearly says 1.3 so I wan't looking too closely. This is one of the mods I've been waiting for my new laptop to install, so was just now trying it.

I downloaded the Github version and all is good now. Like many other people, I'm thankful for your ongoing efforts Roverdude, KSP would be much the lesser for it without them.

Share this post


Link to post
Share on other sites

Hiya! If I were making an KIS PIckup MM patch for the PAL Crane (and, now that I think about it, also for the Gripper and Forklift) using the PART-NEEDS-FOR syntax, (a) would I be right in pointing NEEDS to the PAL Crane etc. and FOR to KIS, or is it the other way around? And (b) with reference to the right folder to point to, will it be the main UmbraSpaceIndustries folder or the Konstruction subfolder? (And (c) am I actually doing this right in the first place? Still learning MM as I go...) Thanks for any answer!

Share this post


Link to post
Share on other sites
2 hours ago, B-STRK said:

Hiya! If I were making an KIS PIckup MM patch for the PAL Crane (and, now that I think about it, also for the Gripper and Forklift) using the PART-NEEDS-FOR syntax, (a) would I be right in pointing NEEDS to the PAL Crane etc. and FOR to KIS, or is it the other way around? And (b) with reference to the right folder to point to, will it be the main UmbraSpaceIndustries folder or the Konstruction subfolder? (And (c) am I actually doing this right in the first place? Still learning MM as I go...) Thanks for any answer!

And to answer your question, to help you understand MM: you would point NEEDS to KIS (this patch *needs* KIS to work) and you wouldn't use FOR (which basically means 'is a part of', and doesn't affect whether the patch with the FOR is applied at all - it only affects *other* patches: If they have a 'NEEDS' that matches, then they will be applied).

Unless you're writing a mod yourself, *never* use FOR.  (And even then, only use it to refer to yourself.)  It's misuse is probably the biggest cause of bugs in KSP.

Share this post


Link to post
Share on other sites
38 minutes ago, Aelfhe1m said:

 

1 minute ago, DStaal said:

And to answer your question, to help you understand MM: you would point NEEDS to KIS (this patch *needs* KIS to work) and you wouldn't use FOR (which basically means 'is a part of', and doesn't affect whether the patch with the FOR is applied at all - it only affects *other* patches: If they have a 'NEEDS' that matches, then they will be applied).

Unless you're writing a mod yourself, *never* use FOR.  (And even then, only use it to refer to yourself.)  It's misuse is probably the biggest cause of bugs in KSP.

Good to know guys, thanks! And gah, that means I need to go back to a couple of other custom patches and change their NEEDS tags as well. (Although weirdly enough, the MiningExpansion Size 3 ISRU they modify is more or less working as intended by the patch. I think. Gonna have to make the change though to be safe, I guess.)

Share this post


Link to post
Share on other sites
12 minutes ago, B-STRK said:

Good to know guys, thanks! And gah, that means I need to go back to a couple of other custom patches and change their NEEDS tags as well. (Although weirdly enough, the MiningExpansion Size 3 ISRU they modify is more or less working as intended by the patch. I think. Gonna have to make the change though to be safe, I guess.)

A patch with the NEEDS and FOR wrong will appear to work just fine in the situation where it's supposed to be applied.  It will cause issues (and get applied) in the situation where it's *not* supposed to be applied.

Share this post


Link to post
Share on other sites
4 hours ago, B-STRK said:

Hiya! If I were making an KIS PIckup MM patch for the PAL Crane (and, now that I think about it, also for the Gripper and Forklift) using the PART-NEEDS-FOR syntax, (a) would I be right in pointing NEEDS to the PAL Crane etc. and FOR to KIS, or is it the other way around? And (b) with reference to the right folder to point to, will it be the main UmbraSpaceIndustries folder or the Konstruction subfolder? (And (c) am I actually doing this right in the first place? Still learning MM as I go...) Thanks for any answer!

The only folder you can point to is the UmbraSpaceIndustries one, because :NEEDS looks at those but doesn't look at subfolders.  But :NEEDS[UmbraSpaceIndustries] generally isn't useful, since that just tells you that at least one USI mod installed, but not specifically which one(s).

Instead, you'll have to rely on :FOR markings that USI provides.  Various subfolders under UmbraSpaceIndustries have patches that contain things like :FOR[MKS] and :FOR[FTT].  But there's no :FOR[Konstruction], so it looks like there's no way to write a :NEEDS that checks whether Konstruction is installed.

Fortunately, in this case you don't need to.  It's not an error to have an MM patch for a part that doesn't exist.  You can just write @PART[PAL_Crane]:NEEDS[KIS], and MM will patch the crane if it exists, or ignore the patch if it doesn't.

Share this post


Link to post
Share on other sites
31 minutes ago, Wyzard said:

The only folder you can point to is the UmbraSpaceIndustries one, because :NEEDS looks at those but doesn't look at subfolders.  But :NEEDS[UmbraSpaceIndustries] generally isn't useful, since that just tells you that at least one USI mod installed, but not specifically which one(s).

Instead, you'll have to rely on :FOR markings that USI provides.  Various subfolders under UmbraSpaceIndustries have patches that contain things like :FOR[MKS] and :FOR[FTT].  But there's no :FOR[Konstruction], so it looks like there's no way to write a :NEEDS that checks whether Konstruction is installed.

Fortunately, in this case you don't need to.  It's not an error to have an MM patch for a part that doesn't exist.  You can just write @PART[PAL_Crane]:NEEDS[KIS], and MM will patch the crane if it exists, or ignore the patch if it doesn't.

Better yet, since MM can also target DLL's, a :NEEDS[Konstruction] check will work since there is a Konstruction.dll.  So there is a way to target it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.