Waz

[1.4] [1.3] [1.2.2] EnvironmentalVisualEnhancements [1.4.0-1]

Recommended Posts

@Mitchz95 that window thing is old, I don't know anything about that art of the code. But there are other mods for that now, and the built-in support that came with 1.1.

 

I've been looking into the weird cloud shadow thing that @Galileo reported and @blackrack posted a fix for - it's strongly looking like a Unity Projector bug, so I'll be looking closer at it outside KSP. I'll report it to Unity in case Squad updates to a later Unity (unlikely in the short term), but I'll also try to find a workaround. It's livable with @blackrack's patch, but Applying settings borks it back up again (even though the same code is run).

  • Like 1

Share this post


Link to post
Share on other sites
On 10/12/2016 at 5:19 PM, Waz said:

Planet textures never came from EVE AFAIK. What you want is a Kopernicus or TextureReplacer config.

Eons ago, maybe back in the EVE Overhaul days, @rbray89 was replacing terrain detail textures of the planets. Things like rocks, grass, etc textures, not the entire body. I don't remember specifically what version it was, but I always had to remove the code and recompile because my PC absolutely despised what he was trying in the beginning. They looked pretty good when they worked, and I _think_ the City Lights in the latest post-overhaul release ended up using the same code. 

Edit: At the time this was added to EVE I don't think TextureReplacer supported replacing any texture, which I'm 99% sure it now does. So that might be a better option. 

Edited by Cydonian Monk

Share this post


Link to post
Share on other sites
46 minutes ago, Waz said:

@Mitchz95@Galileo that window thing is old, I don't know anything about that art of the code. But there are other mods for that now, and the built-in support that came with 1.1.

Ok, thanks. Can you link me one of those mods? The built-in overlay is nice, but it cuts away some of the exterior and it's kind of ugly. :P

Share this post


Link to post
Share on other sites
48 minutes ago, Waz said:

EVE build 1.2-2, for KSP 1.2

See https://github.com/WazWaz/EnvironmentalVisualEnhancements/releases for latest release.

This patch fixes cloud shadow renderer order and improves performance of volumetric clouds when far away (eg. in orbit) via new config: layerVolume.visibleRange (default 10000).

HECK YES WAZ! i was uploading a new version when i saw this. the upload came to a screeching halt needless to say :)

 

@Waz So if someone is still experiencing some lag from volumetric clouds all the need to do is lower the visible range from 10,000 to say 5,000 for example?

if thats the case, you have probably done the single best thing that has happened to EVE. People will absolutely love that!

 

Just tested this out... SO DAMN GOOD. 

Edited by Galileo
  • Like 3

Share this post


Link to post
Share on other sites
17 minutes ago, Galileo said:

HECK YES WAZ! i was uploading a new version when i saw this. the upload came to a screeching halt needless to say :)

Heck yes, you - the only reason I need to improve performance is so I can use SVE :-)

17 minutes ago, Galileo said:

@Waz So if someone is still experiencing some lag from volumetric clouds all the need to do is lower the visible range from 10,000 to say 5,000 for example?

if thats the case, you have probably done the single best thing that has happened to EVE. People will absolutely love that!

Correct.

I still want to actually improve the performance of volumetric clouds when the are visible, but that's for another day.

  • Like 2

Share this post


Link to post
Share on other sites
5 minutes ago, Waz said:

Heck yes, you - the only reason I need to improve performance is so I can use SVE :-)

Correct.

I still want to actually improve the performance of volumetric clouds when the are visible, but that's for another day.

Im uploading right now. The performance is outstanding. i kept the visible range at the default and will include how to use it in my OP

i cant thank you enough man

Edited by Galileo
  • Like 4

Share this post


Link to post
Share on other sites
7 minutes ago, Waz said:

Heck yes, you - the only reason I need to improve performance is so I can use SVE :-)

Correct.

I still want to actually improve the performance of volumetric clouds when the are visible, but that's for another day.

 

3 minutes ago, Galileo said:

Im uploading right now. The performance is outstanding. i kept the visible range at the default and will include how to use it in my OP

Me thinks you are both legends - as you are channelling some kind of coding and texturing musicians riffing off the other.

Great collaborations!  Peace out.

  • Like 3

Share this post


Link to post
Share on other sites
3 minutes ago, theJesuit said:

 

Me thinks you are both legends - as you are channelling some kind of coding and texturing musicians riffing off the other.

Great collaborations!  Peace out.

I like that analogy 

Hear that @Waz? We are musicians!    Ill be Sonny and you can be Cher. :D

Edited by Galileo
  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, Galileo said:

I like that analogy 

Hear that @Waz? We are musicians!    Ill be Sonny and you can be Cher. :D

I'll be Simon, you can be Garfunkel. Paul Simon was excrements at art.

  • Like 1

Share this post


Link to post
Share on other sites
4 minutes ago, Waz said:

I'll be Simon, you can be Garfunkel. Paul Simon was excrements at art.

ok thats a deal! lol

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Waz said:

EVE build 1.2-2, for KSP 1.2

See https://github.com/WazWaz/EnvironmentalVisualEnhancements/releases for latest release.

This patch fixes cloud shadow renderer order and improves performance of volumetric clouds when far away (eg. in orbit) via new config: layerVolume.visibleRange (default 10000).

So how did you fix the shadow issue?

Share this post


Link to post
Share on other sites
7 minutes ago, blackrack said:

So how did you fix the shadow issue?

yeah he did

The only issue i have found is when you make a change in the EVE GUI, Nullrefs flood the debug tab and scatterer bugs out until you enter the tracking station and exit again. other than that everything looks good

Edited by Galileo
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, blackrack said:

So how did you fix the shadow issue?

Turns out it was a Unity bug. I eventually reproduced a workaround: disable then enable the Projector component (after setting the new Material). I've left in the 2500 renderqueue as that leaves room for scatterer atmosphere, etc. A day's bug hunting for 4 lines of code:

https://github.com/WazWaz/EnvironmentalVisualEnhancements/commit/8d5443794a14516faa7bfbed98511201a90489d2

Edited by Waz
  • Like 3

Share this post


Link to post
Share on other sites
1 hour ago, Waz said:

A day's bug hunting for 4 lines of code

I know that feeling all too well. Both in modding and in work.

Share this post


Link to post
Share on other sites
1 hour ago, blackrack said:

I know that feeling all too well. Both in modding and in work.

But you also know the buzz and massive air-punch at the end, born from the process. Real life is a roguelike.

  • Like 1

Share this post


Link to post
Share on other sites

Waz, thank you for continuing this mod.  Just out of curiosity, do you plan on following Squad's recommendation and removing LINQ and foreach at some point in the future?

Share this post


Link to post
Share on other sites
7 hours ago, Alshain said:

Waz, thank you for continuing this mod.  Just out of curiosity, do you plan on following Squad's recommendation and removing LINQ and foreach at some point in the future?

This would make about 0.01% difference at most. I've been using the Unity Profiler to examine how to best improve performance - I'll tackle those things in order, though it's currently looking like a giant leap can still be made with volume layers and a small step with 2D layers.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Waz said:

This would make about 0.01% difference at most. I've been using the Unity Profiler to examine how to best improve performance - I'll tackle those things in order, though it's currently looking like a giant leap can still be made with volume layers and a small step with 2D layers.

I see.  Well I look forward to seeing what you come up with then.

Share this post


Link to post
Share on other sites

@Waz 

as I try to install the CKAN, you are showing this error message:

2NLziYO.png

Can you tell me what can be?


If I direct download, works perfect!

Share this post


Link to post
Share on other sites

@Waz Disabling layerVolume helped - managed to consistantly pull 60fps below the cloud layer, however as i went above it GPU usage stayed under 70% (CPU and RAM both roughly 50%) and frames dropped to 40-50fps. If there's any other info/logs that you need i'd be more than happy to help, or accept that this is normal! Thanks for your work :-)

Share this post


Link to post
Share on other sites
2 hours ago, MKellerBR said:

@Waz 

as I try to install the CKAN, you are showing this error message:

2NLziYO.png

Can you tell me what can be?


If I direct download, works perfect!

Waz is not in charge of the ckan download.  You need to go ask this at the ckan thread instead

Share this post


Link to post
Share on other sites
13 hours ago, MKellerBR said:

@Waz 

as I try to install the CKAN, you are showing this error message:

2NLziYO.png

Can you tell me what can be?


If I direct download, works perfect!

SVE-LowResolution isn't even part of EVE, nor AFAIK is it distributed for KSP 1.2 via CKAN.

I've tested the CKAN install of EVE and it's base configs (the only EVE config currently available via CKAN), and it works fine.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now