Waz

[1.7] EnvironmentalVisualEnhancements [1.7.3-0]

Recommended Posts

1 minute ago, Waz said:

The basic idea was storms: instead of the whole half-sphere on this side of the planet, just an arc big enough for the storm. I haven't actually done anything with it though, so it may not be adequate.

Volumetric clouds are the expensive things and they are just around the camera.

ah, i see

would this make it possible to fake volumetric rings by having a whoooole bunch of cloud layers stacked upon each other, all only loading around a certain very thin band around the planet? or would that still be too laggy to accomplish

Share this post


Link to post
Share on other sites
4 minutes ago, The Cuttlefish Empire said:

would this make it possible to fake volumetric rings by having a whoooole bunch of cloud layers stacked upon each other, all only loading around a certain very thin band around the planet? or would that still be too laggy to accomplish

All I can say is give it a try. I maintain the mod, but I've always recommended configs besides the samples ones.

Share this post


Link to post
Share on other sites

Is version 1.4.0-1 meant to be compatible with KSP 1.3.1? CKAN thinks it is, and it installed the update into my copy of 1.3.1 today, but for some reason I don't see any clouds at all anymore...

Share this post


Link to post
Share on other sites
11 hours ago, Mihara said:

Is version 1.4.0-1 meant to be compatible with KSP 1.3.1? CKAN thinks it is, and it installed the update into my copy of 1.3.1 today, but for some reason I don't see any clouds at all anymore...

Sounds like a NetKAN/CKAN bug, because the .version file has:

    "KSP_VERSION_MIN": {
        "MAJOR": 1,
        "MINOR": 4,
        "PATCH": 0
    },

You'd have to ask the NetKAN maintainers. I'm no CKAN expert though, so I'm happy to accept a patch to the .version file.

Hmm... unless they've started scraping it from CurseForge instead - I decided to upload this release there too since many people use it for mod discovery, and they only just added 1.4.0 as a version option.

9 hours ago, viperwolf said:

@Waz Thank you for the mod and the update, its appreciated very much. Where in the world is your donate button?

Hehe... the vanished @rbray89 is the original author, I'm just maintaining it since I like playing KSP with SVE. If you want to fund my coding, buy WazHack :-)

Edited by Waz

Share this post


Link to post
Share on other sites
2 hours ago, Waz said:

Sounds like a NetKAN/CKAN bug, because the .version file has:


    "KSP_VERSION_MIN": {
        "MAJOR": 1,
        "MINOR": 4,
        "PATCH": 0
    },

You'd have to ask the NetKAN maintainers. I'm no CKAN expert though, so I'm happy to accept a patch to the .version file.

Hmm... unless they've started scraping it from CurseForge instead - I decided to upload this release there too since many people use it for mod discovery, and they only just added 1.4.0 as a version option.

Hehe... the vanished @rbray89 is the original author, I'm just maintaining it since I like playing KSP with SVE. If you want to fund my coding, buy WazHack :-)

I ran into this with someone else, they are maintaining a mod and its alot of work. I understand you did not create it, but you are working on it and releasing it so we can enjoy it. You deserve something, I try and donate to every modder I use.

Share this post


Link to post
Share on other sites
17 hours ago, Waz said:

Sounds like a NetKAN/CKAN bug, because the .version file has:


    "KSP_VERSION_MIN": {
        "MAJOR": 1,
        "MINOR": 4,
        "PATCH": 0
    },

You'd have to ask the NetKAN maintainers. I'm no CKAN expert though, so I'm happy to accept a patch to the .version file.

Hmm... unless they've started scraping it from CurseForge instead - I decided to upload this release there too since many people use it for mod discovery, and they only just added 1.4.0 as a version option.

Hey Waz,

should we reinstall the older version, if we still are on KSP 1.3.1 ?

Share this post


Link to post
Share on other sites
8 hours ago, N3N said:

Hey Waz,

should we reinstall the older version, if we still are on KSP 1.3.1 ?

I'd be surprised if the shaders from the 1.4.0 one worked with KSP 1.3.1. That's the main thing that has changed, but they *might* be backwards compatible (unlikely, the 1.3 ones were not forward compatible).

Share this post


Link to post
Share on other sites

Same issue as the others; EVE seems to have completely lost track of all of its config files after CKAN updated it to 1.4.0-1 (KSP 1.3.1). I'll see about manually reinstalling the previous version.

Update: CKAN seems to think the max version is 1.3.9. I overwrote its files with the ones from EVE 1.2.2-1.

Edited by coolguy8445

Share this post


Link to post
Share on other sites

Did you follow the instructions which say you need to install a Config as well as the 1.4 release?

Share this post


Link to post
Share on other sites

I installed the visual pack stand alone. Sadly it doesn't work. Using a fresh 1.4.

Which conifg do you mean @Waz?

Edited by PieBue

Share this post


Link to post
Share on other sites

EVE stil remains a marble, no EnvironmentalVisualEnhancements for me :(

 

Edit to wrpa things up:

KSP 1.4, latest EVE release, last stock configs, all from the link in the OP.

This is what I get everytime I use this mod:

2dNjc3u.png

Or am I absolutly stupid and this is intended?!?

Anyways: is there a way to make it less cloudy?

Edited by maculator

Share this post


Link to post
Share on other sites

It works fine for me, I am using the SVE configs, though I have now run into an issue with SVE and scatterer, so I am going to run over there

Share this post


Link to post
Share on other sites

Im using ksp 1.3.1 just for the fact that I want to wait for the mods to update. So I downloaded EVE in its latest version for 1.3.1 and I did what is usually done with most mods (Just unzip the gamedata folder to the ksp folder) however whenever i load the game up, 1. I dont see anything new and 2.even the settings are not there. 

Did I do anything wrong in the installation or is it a bug?

Share this post


Link to post
Share on other sites
1 hour ago, Arkanin5 said:

Im using ksp 1.3.1 just for the fact that I want to wait for the mods to update. So I downloaded EVE in its latest version for 1.3.1 and I did what is usually done with most mods (Just unzip the gamedata folder to the ksp folder) however whenever i load the game up, 1. I dont see anything new and 2.even the settings are not there. 

Did I do anything wrong in the installation or is it a bug?

You need the mod and a set of configs. The ones on github where you got the plugins for example. You sould end up with a folder "EnviromentalVisualEnhancements" and "BoulderCo" (<-- this might change if you use other congis from SVE, AVE etc..)

Share this post


Link to post
Share on other sites
36 minutes ago, maculator said:

You need the mod and a set of configs. The ones on github where you got the plugins for example. You sould end up with a folder "EnviromentalVisualEnhancements" and "BoulderCo" (<-- this might change if you use other congis from SVE, AVE etc..)

Thx for the help

Share this post


Link to post
Share on other sites
20 hours ago, Waz said:

Did you follow the instructions which say you need to install a Config as well as the 1.4 release?

As this is likely the billionth time you've said this to someone, I must say with shame that no I did not. I installed via CKAN which I know you have ZERO to do with, but that process doesn't suggest one has to do anything more than click the box for EVE and then select 'update.'

I'll do as you have suggested. Thank you for your endless patience.

Edited by Arcadian Del Sol

Share this post


Link to post
Share on other sites
4 hours ago, Arcadian Del Sol said:

As this is likely the billionth time you've said this to someone, I must say with shame that no I did not. I installed via CKAN which I know you have ZERO to do with, but that process doesn't suggest one has to do anything more than click the box for EVE and then select 'update.'

I'll do as you have suggested. Thank you for your endless patience.

Even through CKAN it should be insisting that you install a Config, unless the latest release has broken something they're doing, as it is the first time that I've distributed an update to the plugin without simultaneously releasing an update to the sample config (which has only changed once in the time I've been doing EVE updates, and is 10x the download size, so I felt it was time to stop making people think they need to update configs that haven't actually changed).

Share this post


Link to post
Share on other sites

@Waz, I have posted an “issue” on your github. If you would be so kind as to check it out, I would appreciate it!

Share this post


Link to post
Share on other sites
16 hours ago, Waz said:

Even through CKAN it should be insisting that you install a Config, unless the latest release has broken something they're doing, as it is the first time that I've distributed an update to the plugin without simultaneously releasing an update to the sample config (which has only changed once in the time I've been doing EVE updates, and is 10x the download size, so I felt it was time to stop making people think they need to update configs that haven't actually changed).

Well, the default planet configs are only set to being compatible with up to 1.3.9 (and no other configs are listed as compatible with 1.4), so CKAN must just skip asking you to select configs when none are available. Most separated-out configs set it to All Versions, probably for this reason.

Share this post


Link to post
Share on other sites
19 hours ago, Waz said:

Even through CKAN it should be insisting that you install a Config, unless the latest release has broken something they're doing, as it is the first time that I've distributed an update to the plugin without simultaneously releasing an update to the sample config (which has only changed once in the time I've been doing EVE updates, and is 10x the download size, so I felt it was time to stop making people think they need to update configs that haven't actually changed).

Just removed and did a fresh install, installed only this mod using CKAN. BoulderCo folder is not there, and CKAN does not alert to any need for additional downloads. I manually installed (first time! YAY!!) from your github both of the zip files and it works great.

 

Lets chalk it up to 'that period of time after new updates' where things like this are to be expected. Either way, Im just glad to have those beautiful clouds back. :)

Share this post


Link to post
Share on other sites
4 hours ago, Nebbie said:

Well, the default planet configs are only set to being compatible with up to 1.3.9 (and no other configs are listed as compatible with 1.4), so CKAN must just skip asking you to select configs when none are available. Most separated-out configs set it to All Versions, probably for this reason.

Ah, that will be it. I didn't ship a .version file with the configs, so NetKAN must have a conservative one. Definitely it should be All, I don't intend to break Configs.

Edited by Waz

Share this post


Link to post
Share on other sites

@waz so after reading the past few pages, EVE should be a ok with 1.4.1? 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.