Ser

[1.4.0 - 1.5.x] Audio Muffler Redux [v2.6.1] (2018 May, 7)

Recommended Posts

I'm getting the same serious FPS issues as other posters, which sucks because I really like this subtle sort of immersion thing.

30 FPS sitting on the runway in a 25 part plane that I get 60 fps in otherwise. 15-20 fps at a several hundred part station where I usually get 30.

I've even tried playing with the min refresh interval rate but it doesn't seem to make any difference; I've tried values between 1 and 1000. It's 300 by default.

The relevant line from the .cfg file: minCacheUpdateInterval = 300 //performance setting in ms. Too low may cause lags on active vessel crash, too high may render cache ineffective and cause fps drops in flight

Any ideas?

Share this post


Link to post
Share on other sites
13 hours ago, Rocket In My Pocket said:

I'm getting the same serious FPS issues as other posters, which sucks because I really like this subtle sort of immersion thing.

30 FPS sitting on the runway in a 25 part plane that I get 60 fps in otherwise. 15-20 fps at a several hundred part station where I usually get 30.

I've even tried playing with the min refresh interval rate but it doesn't seem to make any difference; I've tried values between 1 and 1000. It's 300 by default.

The relevant line from the .cfg file: minCacheUpdateInterval = 300 //performance setting in ms. Too low may cause lags on active vessel crash, too high may render cache ineffective and cause fps drops in flight

Any ideas?

This may be caused by some parts or mods having too much meshes or audio sources. So I need the .craft file for your 25 part plane (and list of mods used), to determine what's going on.

Share this post


Link to post
Share on other sites
1 hour ago, Ser said:

This may be caused by some parts or mods having too much meshes or audio sources. So I need the .craft file for your 25 part plane (and list of mods used), to determine what's going on.

I don't use any mods that add parts, so everything about the plane was stock.

The only "modded" part on the station was the KER computer part.

I can get you a complete list of mods that I use when I'm at my comp though and the craft file, if that'll help you.

Hmm...too many audio sources? You think maybe it's chatterer then?

Edited by Rocket In My Pocket

Share this post


Link to post
Share on other sites
59 minutes ago, Rocket In My Pocket said:

Hmm...too many audio sources? You think maybe it's chatterer then?

I don't think it's Chatterer. I've solved most of the issues with it in the first versions of the mod so it shouldn't cause any troubles. ASET cockpits are much more likely.

By the way, what CPU do you have?

Edited by Ser

Share this post


Link to post
Share on other sites
38 minutes ago, Ser said:

I don't think it's Chatterer. I've solved most of the issues with it in the first versions of the mod so it shouldn't cause any troubles. ASET cockpits are much more likely.

By the way, what CPU do you have?

I do have all the extra sound packs for Chatterer if that matters.

Comp specs are: i7-7700, gtx1070, 16GbRAM, SSD.

Plane .craft file: https://pastebin.com/mV6ahj3g

Will this screen grab of my gamedata folder do for a mod list?

Spoiler

v5WMZRF.png

 

Edited by Rocket In My Pocket

Share this post


Link to post
Share on other sites
5 hours ago, Rocket In My Pocket said:

I do have all the extra sound packs for Chatterer if that matters.

Comp specs are: i7-7700, gtx1070, 16GbRAM, SSD.

Plane .craft file: https://pastebin.com/mV6ahj3g

Will this screen grab of my gamedata folder do for a mod list?

  Reveal hidden contents

v5WMZRF.png

 

Just tried your craft file with no effect on FPS again. Tried full stock, Chatterer, Audio Muffler in all combinations with the same FPS every time. Are you sure the FPS drops are caused by Audio Muffler? I.e do your FPS restore when you remove it and get halved everytime when you add it back?

That's very strange result, because I have a weaker hardware than yours: i5 4690 (CPU has the same specs as yours besides cache and hyperthreading), GPU GTX550Ti 1Gb VRAM, 8Gb RAM, no SSD. I have some permanent FPS drops because of 80-100% GPU load but that isn't caused by Audio Muffler and I have stable 60 FPS with it when looking at clear skies or down at the runway.

Have you tried to backup all your mods and run KSP with Audio Muffler only?

EDIT: some googling made my suspicions stronger: seems like Unity had lags with hyperthreading long time ago, may be some of that still reproduces in the 5.0 version. That could explain why everyone who reports lags has i7 and I don't have them with i5 CPU. What I suggest is to try to disable hyperthreading in BIOS. Just to check.

Edited by Ser

Share this post


Link to post
Share on other sites
18 hours ago, Ser said:

Just tried your craft file with no effect on FPS again. Tried full stock, Chatterer, Audio Muffler in all combinations with the same FPS every time. Are you sure the FPS drops are caused by Audio Muffler? I.e do your FPS restore when you remove it and get halved everytime when you add it back?

That's very strange result, because I have a weaker hardware than yours: i5 4690 (CPU has the same specs as yours besides cache and hyperthreading), GPU GTX550Ti 1Gb VRAM, 8Gb RAM, no SSD. I have some permanent FPS drops because of 80-100% GPU load but that isn't caused by Audio Muffler and I have stable 60 FPS with it when looking at clear skies or down at the runway.

Have you tried to backup all your mods and run KSP with Audio Muffler only?

EDIT: some googling made my suspicions stronger: seems like Unity had lags with hyperthreading long time ago, may be some of that still reproduces in the 5.0 version. That could explain why everyone who reports lags has i7 and I don't have them with i5 CPU. What I suggest is to try to disable hyperthreading in BIOS. Just to check.

Thanks for checking it out!

Yes, the FPS is like an on/off switch; add AudioMuffler it drops, remove it and it comes back up; tried several times.

I haven't tried running it on a completely clean install yet, sounds like you might be on to something with the i7 thing though.

Share this post


Link to post
Share on other sites
1 hour ago, Rocket In My Pocket said:

I haven't tried running it on a completely clean install yet, sounds like you might be on to something with the i7 thing though.

Would be nice if someone tried turning hyperthreading off to be sure if it's the cause or not.

Share this post


Link to post
Share on other sites

tried it yesterday on my 1.3.1 install. I didn't encounter any frame drops though.

specs: Ryzen 5 1600, 8 gb ddr 4 ram, gtx 970.

Share this post


Link to post
Share on other sites
On 27.01.2018 at 3:13 PM, Benti said:

tried it yesterday on my 1.3.1 install. I didn't encounter any frame drops though.

specs: Ryzen 5 1600, 8 gb ddr 4 ram, gtx 970.

Thanks for the info. And we see it again: no hyperthreading - no lags.

I guess hyperthreading may be involved in Unity 5.0 audio group system or in audio filters used by Audio Muffler. But without them the mod would work just like the old version where everything was muffled altogether.

Share this post


Link to post
Share on other sites

I've the fps drop too. With Audio Muffler Redux, I lose about 10-15 fps.

I did the same tests as Rocket In My Pocket and so I'm sure it's this mod that's in question.

My comp specs : i5 2500k, 8Go DDR3, GTX1060, SSD (game install on it)

Like you can see I've an old i5 with no hyperthreading, so I don't think that's the problem.

I really hope you will find a solution, it's too bad, this mod looked really good.

Share this post


Link to post
Share on other sites
3 hours ago, Vandest said:

I've the fps drop too. With Audio Muffler Redux, I lose about 10-15 fps.

I did the same tests as Rocket In My Pocket and so I'm sure it's this mod that's in question.

My comp specs : i5 2500k, 8Go DDR3, GTX1060, SSD (game install on it)

Like you can see I've an old i5 with no hyperthreading, so I don't think that's the problem.

I really hope you will find a solution, it's too bad, this mod looked really good.

I'll definitely need some help in that because it's very hard to fix anything that I can't reproduce.

So, have you tried absolutely clean KSP without any other mods and still have FPS drops?

Share this post


Link to post
Share on other sites
9 hours ago, Ser said:

I'll definitely need some help in that because it's very hard to fix anything that I can't reproduce.

So, have you tried absolutely clean KSP without any other mods and still have FPS drops?

Unfortunatly yes. Without AMR (in my test) I've got 120FPS max, with AMR I've got 83FPS max.

Another thing I did not mention, I use KSP 64. I will try with 32.

Edit:

I've just tested with KSP 32 and unfortunatly it's worse, with AMR I've got 70FPS max.

Edited by Vandest

Share this post


Link to post
Share on other sites
On 30.1.2018 at 8:53 AM, Ser said:

Thanks for the info. And we see it again: no hyperthreading - no lags.

I guess hyperthreading may be involved in Unity 5.0 audio group system or in audio filters used by Audio Muffler. But without them the mod would work just like the old version where everything was muffled altogether.

This information is probably not that helpfull but:

I have a tried using AMR with stock and everything is ok. But as soon I put some  small mods in (like realplume ,  which makes it lagy with more mods),  the lags are coming.

Have a AMD Phenom II X4 965 / GTX750Ti / HDD (300GB)

So no hyperthreading ,  but lags

 

 

Share this post


Link to post
Share on other sites
21 hours ago, Nightfury said:

This information is probably not that helpfull but:

I have a tried using AMR with stock and everything is ok. But as soon I put some  small mods in (like realplume ,  which makes it lagy with more mods),  the lags are coming.

Have a AMD Phenom II X4 965 / GTX750Ti / HDD (300GB)

So no hyperthreading ,  but lags

 

 

Thanks for the hint, I'll probably look in the way of Realplume. What other mods have you lags with?

Share this post


Link to post
Share on other sites
2 hours ago, Ser said:

Thanks for the hint, I'll probably look in the way of Realplume. What other mods have you lags with?

The real lags are starting with mods that are cpu-heavy like FAR, which are ok alone, but performance stealing in bigger amounts.

I only notice the lags in my bigger mod installs, when I think of AMR as a realism-enhancement (RSS/RO/RP0...)

Share this post


Link to post
Share on other sites

Version 2.5 is out

Download here

Changes:

* KSP 1.4.1 and 1.4.2 compatible
* Reduced default wall cutoff value to make new jet sounds less ear-piercing
* Added some volume variations for better feel
* Fixed staging sound handling

Still no news for those who experience lags. Try the new version of the mod. KSP Unity version has changed and maybe something has been improved that could help your problem.

Share this post


Link to post
Share on other sites

Can't stand hearing stuff in space, lol. One of my favorite mods. Thanks for the update!

Share this post


Link to post
Share on other sites

Just want to report that with my i5 I got lower fps when using AMR.

I must admit that as I used scatterer but no AMR (last session, now no scatterer but AMR) I had more fps...

The craft got 58 parts, the fps is down to 12 and the Physics Time Ratio is ~50% with delta set to 0.04 - under these circumstances (without scatterer and without AMR) I would get 80-100% and 20-35 fps.

Edit:

Now in orbit with 20 parts left I got 17-20 fps and 65-75% Physics Time Ratio.

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
10 hours ago, Gordon Dry said:

Just want to report that with my i5 I got lower fps when using AMR.

I must admit that as I used scatterer but no AMR (last session, now no scatterer but AMR) I had more fps...

The craft got 58 parts, the fps is down to 12 and the Physics Time Ratio is ~50% with delta set to 0.04 - under these circumstances (without scatterer and without AMR) I would get 80-100% and 20-35 fps.

Edit:

Now in orbit with 20 parts left I got 17-20 fps and 65-75% Physics Time Ratio.

What hardware do you have (CPU, GPU, soundcard, OS)?     I see

Upload your craft please and list of the mods you use.

Edited by Ser

Share this post


Link to post
Share on other sites

This is a must have mod and too bad it's not stock behaviour.

 

I think it is muffling Ship Effects Continued. Is there a solution for this? Can I turn muffling off in IVA?

Edited by lajoswinkler

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.