• 0
Sign in to follow this  
Followers 0
xtoro

1.2 NavBall down every time I switch to the map.

Question

Completely stock.  Every time you switch to the map, the Navball is down.  You bring it up, go back to look at your ship, and when you go back to the map, the Navball is back down again.  Every time you switch to map view, you have bring the ball up again.  This was annoying enough to have to do the first time, but now it's every single time you switch to the map...

Share this post


Link to post
Share on other sites

9 answers to this question

  • 1

Nevermind.  In the main screen's options, there an option to enable "Auto hide navall in map view" which is enabled by default.  Rather obscure place to put it, and god knows why they enabled it by default since that's been a complaint for years...

Edited by xtoro
2 people like this

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, xtoro said:

Nevermind.  In the main screen's options, there an option to enable "Auto hide navall in map view" which is enabled by default.  Rather obscure place to put it, and god knows why they enabled it by default since that's been a complaint for years...

See my post above yours.  We posted at the same time...

Well for....

Thank you, I've been thinking it was a bug this whole time.

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, Greenfire32 said:

Well for....

Thank you, I've been thinking it was a bug this whole time.

Same here, that's why I posted it as a bug.  Never thought they would add a setting like that, or put it where it is.

Share this post


Link to post
Share on other sites
  • 0

Just wondering:
Both of you have been on the forum for a few years now. So it's safe to assume you're both playing KSP for quite some time as well. Have you seriously not noticed this navball behaviour before? It's been this way for years. It has been such a big issue for people that it was modded to make the navball visible by default. The only thing new about it is that in 1.2 for the first time you no longer need a mod to stop the navball from hiding.

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Tex_NL said:

Just wondering:
Both of you have been on the forum for a few years now. So it's safe to assume you're both playing KSP for quite some time as well. Have you seriously not noticed this navball behaviour before? It's been this way for years. It has been such a big issue for people that it was modded to make the navball visible by default. The only thing new about it is that in 1.2 for the first time you no longer need a mod to stop the navball from hiding.

For the last several releases, the first time you switched to map view, the NavBall was hidden (by default). So you hit numberpad period and it came up, and then you could switch back and forth between external view and map, and the NavBall would remain visible.

The change in 1.2 is that if that main screen default setting "hide NavBall" is checked, every time you go to map view the NavBall disappears. Which is frankly daft, compared to the previous system.

Share this post


Link to post
Share on other sites
  • 0
38 minutes ago, Plusck said:

... and then you could switch back and forth between external view and map, and the NavBall would remain visible.

And the next craft it was gone again. No. Always (in)visible by default is much better. At least now the NavBall behaves as it should.

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, Tex_NL said:

Just wondering:
Both of you have been on the forum for a few years now. So it's safe to assume you're both playing KSP for quite some time as well. Have you seriously not noticed this navball behaviour before? It's been this way for years. It has been such a big issue for people that it was modded to make the navball visible by default. The only thing new about it is that in 1.2 for the first time you no longer need a mod to stop the navball from hiding.

Like Plusck said.  It was always hidden the first time you viewed the map, and then it always stayed up unless you switched ships, and then it was up again only the first time.  It was never hidden every single time you switched to map view.  Perhaps you should save your snarky remarks for when you actually know what someone's talking about because this is a new behaviour, and hasn't "been this way for years" like you seem to think.

4 people like this

Share this post


Link to post
Share on other sites
  • 0

I never knew why the dang thing had to be hidden in map view anyway. I always found it an annoyance, and I REALLY, SUPER don't get why you would want it hidden every time. Glad there's at least an option to turn the whole hiding thing off now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0