IgorZ

[1.3.1] Kerbal Inventory System (KIS) v1.7

Recommended Posts

54 minutes ago, ManuG said:

Hello everyone :)

At first: Great Mod, i like it to give EVA some aditional purposes by things like that. I'm using KIS together with KAS and the USI colonisation system. After the last update of KSP to 1.3, i updated all mods to work with the new version - which seems to do so. But since the latest updates i have a second "disassemble" button when i'm right clicking on a structure on EVA. It's not a bad issue since both buttons seem to work, but it looks a bit confusing. Is there some sort of incompatibility with the updated mods? I read that KIS and KAS are standalone versions, could that be the issue?

"Disassembly" button doesn't belong to KIS or KAS. Try removing the both mods to figure out if they are the actual problem.

Share this post


Link to post
Share on other sites
1 hour ago, ManuG said:

Hello everyone :)

At first: Great Mod, i like it to give EVA some aditional purposes by things like that. I'm using KIS together with KAS and the USI colonisation system. After the last update of KSP to 1.3, i updated all mods to work with the new version - which seems to do so. But since the latest updates i have a second "disassemble" button when i'm right clicking on a structure on EVA. It's not a bad issue since both buttons seem to work, but it looks a bit confusing. Is there some sort of incompatibility with the updated mods? I read that KIS and KAS are standalone versions, could that be the issue?

The disassembly is something from USI. If you're getting two of them on every part, can you post a link to your log and make sure there's only 1 000_USITools folder in GameData

Share this post


Link to post
Share on other sites
Posted (edited)
24 minutes ago, TheRagingIrishman said:

The disassembly is something from USI. If you're getting two of them on every part, can you post a link to your log and make sure there's only 1 000_USITools folder in GameData

Great it seems something like that was the issue! There was only one USITools folder but i think i just have messed something up when updating USI life support, MKS and afterwards USITools to the newest version. I just moved the mods to a backup folder, reinstalled them and deleted the Tools folder before installing the newest version of USITools - solved the problem.

I can still send you a log if needed, but i think it was just silly me forgetting to delete old versions before installing the new ones :)

Thank you both for your quick answers though :)

Edited by ManuG

Share this post


Link to post
Share on other sites
2 hours ago, ManuG said:

Great it seems something like that was the issue! There was only one USITools folder but i think i just have messed something up when updating USI life support, MKS and afterwards USITools to the newest version. I just moved the mods to a backup folder, reinstalled them and deleted the Tools folder before installing the newest version of USITools - solved the problem.

I can still send you a log if needed, but i think it was just silly me forgetting to delete old versions before installing the new ones :)

Thank you both for your quick answers though :)

No if updating fixed it there's no need. Have fun and fly safe!

Share this post


Link to post
Share on other sites

Hey @IgorZ ,
thx for dedicating your time to the mod. In your OP the link in the section 'Other useful EVA mods' to KAS points to KIS1.1.3 instead of Kerbal Attachment System

Can sb tell me if  the KIS/KAS 1.3 versions are also compatible with 1.2.2 and if not where i can find them (want to continue my RSS/RO/RP-0 campaign)
THX in advance

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, KroShan said:

Hey @IgorZ ,
thx for dedicating your time to the mod. In your OP the link in the section 'Other useful EVA mods' to KAS points to KIS1.1.3 instead of Kerbal Attachment System

Thanks. I've fixed the link.

1 hour ago, KroShan said:

Can sb tell me if  the KIS/KAS 1.3 versions are also compatible with 1.2.2 and if not where i can find them (want to continue my RSS/RO/RP-0 campaign)
THX in advance

KIS 1.5 will crash the KSP 1.2+ game. KAS doesn't seem to cause obvious troubles but I cannot guarantee it's working as intended. If you need the versions for the older KSP version, go to the curse page and manually download the last compatible version of each mod.

Edited by IgorZ

Share this post


Link to post
Share on other sites

Thank you,
the files tab on Curse told me that the versions CKAN would install for me are the latest for KSP 1.2.2.

Share this post


Link to post
Share on other sites

@IgorZ

We've discussed conditional stackability for KIS before, but if it's not looking likely that it'll be implemented in the short term, then I'd like to make some progress on fixing the collapsible cardboard box part of Surface Experiment Pack with whatever means are currently available.

The intended behavior of the cardboard box is as follows:

  • It starts "deployed"/"assembled", which means that it has ModuleKISInventory (so other parts can be put into it) and ModuleKISItem (to make it carriable like the KIS SC-62). In this state, ModuleKISItem will specify that it is not stackable, and give a volumeOverride that corresponds to a solid box.
  • If the inventory is empty (and has no custom name), then it can be "flattened"/"collapsed" by a EVA kerbal. ModuleKISInventory will be disabled on the part, and ModuleKISItem will be modified to specify that the part is stackable. volumeOverride will changed to correspond to a flat piece of cardboard (to save space when stored in inventory).
  • This can be reversed, i.e. a flattened box can be "deployed"/"assembled" back into a usable container by a EVA kerbal.

Currently, the plan is to implement "flatten" and "assemble" as KSPEvent in a separate PartModule (ModuleSEPBox):

  • include some safety checks:
    • ensure KIS is installed -- SEP already has KIS as a dependency, should not be a problem
    • the part must also have ModuleKISInventory and ModuleKISItem -- already in the part config
  • enable/disable ModuleKISInventory using part.Modules.GetModule<ModuleKISInventory>().enabled
  • ModuleKISItem.stackable and ModuleKISItem.volumeOverride are public, can be accessed/modified via part.Modules.GetModule<ModuleKISItem>()

But it appears that some changes in KIS code would also be needed in order to support the desired functionality.

Presently, KIS seems to operate on the premise that ModuleKISItem fields do not change at runtime. When creating a KIS_Item (from scene, from save, or by splitting a stack) these all ultimately result in a call to KIS_Item.InitConfig(), which actually obtains the ModuleKISItem fields (e.g. stackability) from the part prefab. Likewise, part volume calculation uses the volumeOverride value from the part prefab if it is present.

Hence, the main set of changes needed is to make it such that KIS will instead uses the runtime values in ModuleKISItem:

  • when creating KIS_Item from scene, try to obtain ModuleKISItem from the part instance itself first, before fall back on the part prefab if that fails
  • when creating KIS_Item from save, either:
    • ("hard" way) check if ITEM node has a PART node with MODULE node for ModuleKISItem, try to parse that first, before fall back on the part prefab, OR
    • ("lazy" way) serialize KIS_Item.stackable, KIS_Item.volume, etc in KIS_Item.OnSave; load those instead of getting from scratch from prefab
  • when creating KIS_Item due to stack splitting, copy existing KIS_Item fields instead of building new KIS_Item from scratch from prefab

A secondary change is needed when attempting to stack, so that *both* the existing item in inventory slot and the item/part being dropped into the slot are checked to ensure that they are stackable -- this is needed to prevent a "deployed" box from being added to a stack of "flattened" boxes.

Does this plan look correct / reasonable? Let me know if I've missed something. If it all looks fine, then with your permission, I can proceed to make the changes and submit a PR for your perusal.

 

Share this post


Link to post
Share on other sites
On 6/15/2017 at 1:42 AM, cakepie said:

Hence, the main set of changes needed is to make it such that KIS will instead uses the runtime values in ModuleKISItem:

  • when creating KIS_Item from scene, try to obtain ModuleKISItem from the part instance itself first, before fall back on the part prefab if that fails
  • when creating KIS_Item from save, either:
    • ("hard" way) check if ITEM node has a PART node with MODULE node for ModuleKISItem, try to parse that first, before fall back on the part prefab, OR
    • ("lazy" way) serialize KIS_Item.stackable, KIS_Item.volume, etc in KIS_Item.OnSave; load those instead of getting from scratch from prefab
  • when creating KIS_Item due to stack splitting, copy existing KIS_Item fields instead of building new KIS_Item from scratch from prefab

Making the item persistable doesn't look as a good solution to me: you never know who will need what property, and saving all of them is an overkill. Thus, the persistence logic must be moved into the custom module which knows what it needs. And the real question is: how to improve the ModuleKISItem class to let a custom module (a descendant) to adjust the item.

The code which deals with the volume will need to be change, of course. As an acceptable solution it can be changed to accept a ModuleKISItem instead of the part prefab. When needed (e.g. in GetPartExternalScaleModifier) the prefab can be obtained from the module. What is not an acceptable solution is passing a ConfigNode around, since it's too error prone.

On 6/15/2017 at 1:42 AM, cakepie said:

A secondary change is needed when attempting to stack, so that *both* the existing item in inventory slot and the item/part being dropped into the slot are checked to ensure that they are stackable -- this is needed to prevent a "deployed" box from being added to a stack of "flattened" boxes.

It sounds right given we want the item to become a dynamic entity.

You don't need to make a "golden" PR before bothering me. Feel free to ping me in the message with a link to your branch once you have a working concept.

Share this post


Link to post
Share on other sites

Guys, a challenge announce! We all know the ironical style of the core KSP: those funny names, descriptions, missions, etc. I'd love to extend this style to the KIS part descriptions (and KAS 1.0 as well, but it's a long term goal). Alas, I'm not a native English speaker, so my sense of humor may look awkward in this language :) Any volunteers to make the descriptions "KSP-style" in English?

Even more. I'm working on refactoring KIS to start using the KSP localization system. I don't think the localizations must be the exact translations of the original language (e.g. English). As long as you can give a funny and, yet, informative description of the part in your native language, feel free to do so. I will take the Russian localization, so for the stock languages we need Spanish, Chinese, and Japan. Before end of week I'll prepare an English .cfg localization file. For now you'll have to extract the strings yourselves, sorry.

Share this post


Link to post
Share on other sites

Hi. You may remember me, you helped me with a problem a week or so ago. As a native English speaker and (I like to think) a since of humor I would be glad to come up with part discriptions for KIS

Share this post


Link to post
Share on other sites
50 minutes ago, Chesus said:

Hi. You may remember me, you helped me with a problem a week or so ago. As a native English speaker and (I like to think) a since of humor I would be glad to come up with part discriptions for KIS

Great! I'll spend some time today to prepare a basic localization file with the part strings. Will share it as soon as it's ready.

Share this post


Link to post
Share on other sites

 

KIS is not working for me...and its probably on my end. KIS is in the correct directory (ksp, gamedata, KIS-master). I think the problem is that it is likely conflicting with my other mods, but I have ALOT of mods. How would I attempt to fix it?

mods(DMagic, DockingPortAlignment, HeatControl, KAS, KerbAlarm, KerbEngineer, Interstellar extended, KWrocketry, MKS, all Nearfuture, science reley, SpaceyLift/Exp, StationPartsExpansion, StationScience,TarsierSpace,TransferWindow)...all of my mods dont conflict except for KIS

Share this post


Link to post
Share on other sites
11 minutes ago, ObjektivePanzer said:

 

KIS is not working for me...and its probably on my end. KIS is in the correct directory (ksp, gamedata, KIS-master). I think the problem is that it is likely conflicting with my other mods, but I have ALOT of mods. How would I attempt to fix it?

mods(DMagic, DockingPortAlignment, HeatControl, KAS, KerbAlarm, KerbEngineer, Interstellar extended, KWrocketry, MKS, all Nearfuture, science reley, SpaceyLift/Exp, StationPartsExpansion, StationScience,TarsierSpace,TransferWindow)...all of my mods dont conflict except for KIS

I can't say for sure, but with the download I use from curse, the name of the folder is just KIS and it works fine.  Maybe try renaming it from KIS-master to KIS and give it a try?

Share this post


Link to post
Share on other sites
12 minutes ago, ObjektivePanzer said:

KIS is not working for me...and its probably on my end. KIS is in the correct directory (ksp, gamedata, KIS-master). I think the problem is that it is likely conflicting with my other mods, but I have ALOT of mods. How would I attempt to fix it?

"KIS-master" is a wrong name for the mod's folder. The name makes me think you've downloaded a zip from Github instead of following the instructions in OP (see "How to install").

Share this post


Link to post
Share on other sites
21 minutes ago, Krakatoa said:

I can't say for sure, but with the download I use from curse, the name of the folder is just KIS and it works fine.  Maybe try renaming it from KIS-master to KIS and give it a try?

It worked...but no inventory

 

20 minutes ago, IgorZ said:

"KIS-master" is a wrong name for the mod's folder. The name makes me think you've downloaded a zip from Github instead of following the instructions in OP (see "How to install").

whoops...prob should have read it. thx

Share this post


Link to post
Share on other sites

I came from the console version (god forbid the bugs)...Im not experienced enough to do this on my own. I honestly appreciate the help

 

Share this post


Link to post
Share on other sites
2 minutes ago, ObjektivePanzer said:

I came from the console version (god forbid the bugs)...Im not experienced enough to do this on my own. I honestly appreciate the help

 

No problem.  Igor had it right, use the download from curseforge up in the OP and follow those directions and you'll be good to go. Just involves downloading the zip and copy/pasting the contents of the gamedata folder of that to the one in your game install folder. Renaming the file from the Git will not do the trick.

Share this post


Link to post
Share on other sites
Just now, Krakatoa said:

No problem.  Igor had it right, use the download from curseforge up in the OP and follow those directions and you'll be good to go. Just involves downloading the zip and copy/pasting the contents of the gamedata folder of that to the one in your game install folder. Renaming the file from the Git will not do the trick.

for some reason when i renamed the file, everything from KIS except the inventory UI was present

Share this post


Link to post
Share on other sites
52 minutes ago, ObjektivePanzer said:

 

KIS is not working for me...and its probably on my end. KIS is in the correct directory (ksp, gamedata, KIS-master). I think the problem is that it is likely conflicting with my other mods, but I have ALOT of mods. How would I attempt to fix it?

mods(DMagic, DockingPortAlignment, HeatControl, KAS, KerbAlarm, KerbEngineer, Interstellar extended, KWrocketry, MKS, all Nearfuture, science reley, SpaceyLift/Exp, StationPartsExpansion, StationScience,TarsierSpace,TransferWindow)...all of my mods dont conflict except for KIS

If you have a folder named KIS-master my first thought would be that you downloaded the source code rather than the mod.

Share this post


Link to post
Share on other sites
1 minute ago, Loren Pechtel said:

If you have a folder named KIS-master my first thought would be that you downloaded the source code rather than the mod.

Thats probably what I did, not realizing it

Share this post


Link to post
Share on other sites

Hello everyone.

I have some issues with the ground pylon. According to description this part can attached to the ground with a screwdriver or a wrench. But in fact any of my kerbals appears to have an option to do that - I hold 'H', a screwdriver symbol appears, then the buzzing sound comes through even though Jeb didn't even have any tools in his inventory. Then he can pick it up with bare hands as if nothing's been attached.Engineer or pilot, with or without a tool - the ground attachment procedure looks the same and the empty Rockomax X200-32 fuel tank attached to the pylon attached (supposedly) to the ground gets flipped over after the first collision with one little kerbal on EVA jetpack. Is it that I'm missing something or expect too much from a ground pylon or could that be a bug?

Share this post


Link to post
Share on other sites
1 hour ago, Adov said:

Hello everyone.

I have some issues with the ground pylon. According to description this part can attached to the ground with a screwdriver or a wrench. But in fact any of my kerbals appears to have an option to do that - I hold 'H', a screwdriver symbol appears, then the buzzing sound comes through even though Jeb didn't even have any tools in his inventory. Then he can pick it up with bare hands as if nothing's been attached.Engineer or pilot, with or without a tool - the ground attachment procedure looks the same and the empty Rockomax X200-32 fuel tank attached to the pylon attached (supposedly) to the ground gets flipped over after the first collision with one little kerbal on EVA jetpack. Is it that I'm missing something or expect too much from a ground pylon or could that be a bug?

Electric Screwdriver?  Not the SEP manual screwdriver. It's an actual hand-held thing that the kerbal needs to have in their inventory, then right click- equip it so you can fasten things.

Share this post


Link to post
Share on other sites
5 hours ago, Krakatoa said:

Electric Screwdriver?  Not the SEP manual screwdriver. It's an actual hand-held thing that the kerbal needs to have in their inventory, then right click- equip it so you can fasten things.

Yep. Model E-SD80 to be precise. As you can see on the screenshot Bill has it equipped and it says 'detach from the ground' when I hover the cursor over the pylon while holding 'H'. That kind of suggests that it's attached. What I was trying to say is that the same result could be achieved if Jeb or anyone else would be attaching the pylon with bare hands.

Spoiler

wnCD3ec.jpg

And here's the collision test result.

Spoiler

qZf6cxi.jpg

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now