IgorZ

[1.7.3] Kerbal Inventory System (KIS) v1.22

Recommended Posts

Could we have an inline 1.25m container? Currently if I want to have a crew craft with cargo it requires more storage than I want, and the current small container is hard to integrate into designs with it looking good. You could just scale down the larger one and change the name and stats. If it isn't that easy don't worry.

Share this post


Link to post
Share on other sites

Anyone know how to detach parts from a ship? Like, if you put a light in the wrong place in editor, and want to take it off to put somewhere else by EVA? I know this is more of a KAS question, but I asked on the thread but nobody replied.:)

Share this post


Link to post
Share on other sites

Assuming you have both of them, get a kerbal with a screw gun equipped up to the part, hold g, click it, then attach it where you need it like normal.  Just gotta keep your kerbal in range.

Share this post


Link to post
Share on other sites
14 hours ago, Krakatoa said:

Assuming you have both of them, get a kerbal with a screw gun equipped up to the part, hold g, click it, then attach it where you need it like normal.  Just gotta keep your kerbal in range.

hold H to attach I think.

Share this post


Link to post
Share on other sites

Yeah, one to detach and pick up, the other to attach, isn't it?  Point being, it's the normal KIS/KAS controls for lights as it is anything else.

Share this post


Link to post
Share on other sites
On 4/6/2017 at 8:18 AM, Skylon said:

Could we have an inline 1.25m container? Currently if I want to have a crew craft with cargo it requires more storage than I want, and the current small container is hard to integrate into designs with it looking good. You could just scale down the larger one and change the name and stats. If it isn't that easy don't worry.

If you're using MKS you'll find it has a cylindrical 1.25m KIS container bundled with it. If not, I can PM you the container and its dependencies so you don't need to download the half a gigabyte of parts it introduces to the game. (assuming @RoverDude is OK with it of course. :) )

Share this post


Link to post
Share on other sites

Hi I consulted the manual and searched a youtube tutorial, but I stil have one question:

When I park next to a ship in orbit and want to attach a dish to it I couldn't find a way to carry the dish over like puting it on my back or else. I had to attach/detach my way along my vessel then over to the other vessel and then to the point I wanted it to permanently mounted. And when I lost a dish in space there was no way for bob to carry it back to the ship.

 

So long story short: how to propper carry thing arround? Drag into kerbals menu didn't work for objects allready on the ground/space for me.

Share this post


Link to post
Share on other sites

When you grab an item you have to hold the g key then click and hold on part and then drag to inventory then release the mouse button. 

Share this post


Link to post
Share on other sites

Thank you I guess I'll just have to get use to the controls and how it works now. Haven't been using KAS/KIS for ages.

Share this post


Link to post
Share on other sites

there just one little thing that's driving me a bit crazy - the fact that the seat inventory pops up by default over the part selection menu. I have to move it out of the way to actually select a part :P@IgorZ this doesn't make your eye twitch all the time?? :wink:

Share this post


Link to post
Share on other sites
49 minutes ago, Drew Kerman said:

there just one little thing that's driving me a bit crazy - the fact that the seat inventory pops up by default over the part selection menu. I have to move it out of the way to actually select a part :P@IgorZ this doesn't make your eye twitch all the time?? :wink:

Not sure what do you mean. Have a screenshot? :) 

Share this post


Link to post
Share on other sites
6 minutes ago, IgorZ said:

Not sure what do you mean.

maybe it really is just me...

JVKi1By.png

It does it even if I move it off, close it, exit the SPH/VAB and then re-enter and open it up again. If I re-open it after closing it without exiting tho it will remain where I last closed it

I don't play with sounds, so I have them removed completely so they don't even load. I see there's supposed to be an open/close sound playing - could that not being there be causing a routine to fail out before the location is saved properly?

Share this post


Link to post
Share on other sites
1 minute ago, Drew Kerman said:

maybe it really is just me...

JVKi1By.png

It does it even if I move it off, close it, exit the SPH/VAB and then re-enter and open it up again. If I re-open it after closing it without exiting tho it will remain where I last closed it

I don't play with sounds, so I have them removed completely so they don't even load. I see there's supposed to be an open/close sound playing - could that not being there be causing a routine to fail out before the location is saved properly?

Ah! Now I get it. You don't like the default position of the window, and the position is not persistent. I've created a feature request.

Share this post


Link to post
Share on other sites
Just now, IgorZ said:

Ah! Now I get it. You don't like the default position of the window, and the position is not persistent. I've created a feature request.

Thanks, I don't really mind having to move it out of the way all the time but it does seem a bit nonsensical to have to move it out of the way all the time :P

Share this post


Link to post
Share on other sites

So how do I actually perform a refuel? I have a bunch of tanks sitting on the ground next to my lander, but when i have my pipes attached and click "pump here" nothing happens.

 

Also, how can i increase the size of my inventory? I cant carry anything with the 1L setting.

 

Thirdly, why does the mod not come with all of the sounds or textures it uses? I get a bunch of errors and the handbook reader doesn't work.

also how do i equip the wrench? This mod is broken

Edited by Yeet Yeet
More problem

Share this post


Link to post
Share on other sites

@Yeet Yeet No the mod isn't broken. You most likely installed it incorrectly. 

First, the pipes are part of KAS. They just connect the parts to your vessel. You need to use the stock resource transfer system. 

Your other two problems are due to an install issue. The mod comes with all sounds and textures but the are very sensitive to where they are placed in your GameData folder. 

If you could provide pictures of your GameData folder and the KIS folder and copies of your logs we would be able to help you more. 

Edited by ExplorerKlatt
Add user tag

Share this post


Link to post
Share on other sites

@ExplorerKlatt

A picture's going to be hard, but i can just write in the directory tree so you can see exactly where it is 

This PC > OS (C:) > Kerbal Space Program > GameData > GameData > KIS > Sounds

Yes, there are 2 gamedata folders, i just took the downloaded folder called "GameData" and dropped it into the existing GameData folder that installed with the game. As for logs, I bought this computer last week and I don't know how to find the ones you're looking for.

You mentioned a stock resource transfer system with KAS, can you explain how to do that?

 

thanks

Share this post


Link to post
Share on other sites
11 minutes ago, Yeet Yeet said:

@ExplorerKlatt

A picture's going to be hard, but i can just write in the directory tree so you can see exactly where it is 

This PC > OS (C:) > Kerbal Space Program > GameData > GameData > KIS > Sounds

Yes, there are 2 gamedata folders, i just took the downloaded folder called "GameData" and dropped it into the existing GameData folder that installed with the game. As for logs, I bought this computer last week and I don't know how to find the ones you're looking for.

You mentioned a stock resource transfer system with KAS, can you explain how to do that?

 

thanks

Hey there,

The nested GameData folders are the problem.  The stuff from in the folder needs to go in the other, not the whole thing, so it would be c>KSP>GameData>KIS>Sounds instead.  The stock resource thing is from stock KSP and it's where you right click and hit the little button in the up right of window that opens and also open the thing where you want to send the fuel, then use the in/out buttons to push the fuel where you want it.

Share this post


Link to post
Share on other sites
1 minute ago, Yeet Yeet said:

Ok so now everything works except i can't figure out how to use the left hand items.

If I understand your question, have the item in their personal inventory, right click, go to inventory (tab works too, I think), then right click the item and click equip. Then there should be instructions on the screen for what button to push for what task you're trying to accomplish.  There's also a KIS guidebook in game that you can use from the inventory that opens a PDF in game with all the details.

Share this post


Link to post
Share on other sites

1.4.4 (May 1st, 2017)

  • [Enhancement] Equip kerbal models on the start screen with sample KIS items. Can be adjusted/disabled via settings.cfg.
  • [Enhancement] Allow the Experiment Storage Unit to be carried on a kerbal's back (Wyzard256).
  • [Fix] Proper paths in the fun parts.

As usual, give it some time to appear on CKAN.

Share this post


Link to post
Share on other sites

Hi guys, tell me why some of the details of KIS are duplicated in several categories?

Спойлер

479576cdf9284e559fa5a7faff70ab0e.png  223ecce90dec49ed876d90d244939c7e.png 

How can I fix this?

Edited by Grem

Share this post


Link to post
Share on other sites

@IgorZ: Would you consider an option (in the ModuleKISItem node) to not rename single-part vessels? It was, actually, a very useful "feature" that EL made use of (survey stakes getting named to (eg) "Jebedia Kerman Base" was very convenient). I only just found out that KIS now renames the vessel to the part's name.

Of course, I could do a PR. If I do so, would you accept it?

Share this post


Link to post
Share on other sites

 

2 hours ago, Grem said:

Hi guys, tell me why some of the details of KIS are duplicated in several categories?

  Reveal hidden contents

479576cdf9284e559fa5a7faff70ab0e.png  223ecce90dec49ed876d90d244939c7e.png 

How can I fix this?

Have you installed Community Category Kit?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.