IgorZ

[1.7.3] Kerbal Inventory System (KIS) v1.22

Recommended Posts

On 8/3/2018 at 2:35 PM, se5a said:

So sometimes I've had problems where I want to detach a part, but the tool is grayed out. it's not the root part, and the only other part that is attached is the root part (though that has other things attached)

Please, attach a screenshot for this case. Even better if you could make a short video.

On 8/3/2018 at 2:35 PM, se5a said:

I've also had a few things explode when I've placed them on the ground.

It's a sad known issue which is not going to be fixed anytime soon. In short, it's because of how people design the parts. If the part has a collider defined outside of the attach node, then it under some circumstances can explode being dropped on the ground or another vessel.

On 8/3/2018 at 2:35 PM, se5a said:

and I found that attaching a wheel to a lynx rover while it's 'jacked up' using LT-1 landing struts can cause the struts to suddenly explode.

I've also had a problem where after attaching wheels to a rover, one of them refused to turn, causing the vehicle to pull to one side when trying to drive it.

Wheels are very specific parts. They have complex dynamic behavior and several moving parts. Instead of attaching the wheel from the container, try dropping it on the ground. If it didn't explode or fly in the sky, attach it on the vessel. If it still doesn't work as needed, than... bad luck. I never seen the described issue on the stock wheels and with the bare minimum of mods, but I'd assume there can be third-party parts or driving assistance mods that are not fully compatible with KIS.

21 hours ago, TeslaPenguin1 said:

How to attach the concrete ground bases from K&K from the base to the ground? I've tried asking on the K&K thread but no response :( 

Grab the base out from the container, press H and click on the ground.

Share this post


Link to post
Share on other sites
2 minutes ago, IgorZ said:

Grab the base out from the container, press H and click on the ground.

But then how do I attach that to the base?

Share this post


Link to post
Share on other sites
4 minutes ago, TeslaPenguin1 said:

But then how do I attach that to the base?

If the part is attached to the ground, you cannot attach it to the base. Instead, you should attach the base to the part. That said, you should build your new base from the ground. Alternatively, you can use KAS or Active Struts (mod) and simply connect the base and the part with a strut.

Edited by IgorZ

Share this post


Link to post
Share on other sites
1 minute ago, IgorZ said:

If the part is attached to the ground, you cannot attach it to the base. Instead, you should attach the base to the part. That said, you should build your new base from the ground. Alternatively, you can use KAS or Active Struts (mod) and simply connect the base and the part with a strut.

Ok, thx!

Share this post


Link to post
Share on other sites

The Grey Detach, this seems to happen when it's a part that's attached to the root (the radial Attachment point is the root, and I'm trying to get rid of it) :

XTxxeOG.jpg

 

I can Grab though:

v31PNxJ.jpg

 

Trying to put it on the ground, it wouldn't go the right way up without rotating it using the w key, but then it wouldn't go high enough (using b) not to clip:

9BWZBHM.jpg

While that is an ok work around in some cases, for heavy items it requires more kerbals to lift.

 

I did come across the problem with wheels not turning after being attached using stock parts, but that was some time ago. I'll have to go revisit the rover that I was having problems with recently in this game, it's at the north pole at the moment with no kerbals close by. in that case I was dropping the wheels on the ground before placing.

 

The cursor always jumps to a different location when I'm KIS'ing stuff as well, is that normal? you can see in the above pictures the grab tool cursor is nowhere near the part I'd clicked.

Edited by se5a

Share this post


Link to post
Share on other sites
2 hours ago, se5a said:

The cursor always jumps to a different location when I'm KIS'ing stuff as well, is that normal? you can see in the above pictures the grab tool cursor is nowhere near the part I'd clicked.

The cursor  jumping is not normal, but KIS cannot affect it. Everything related to keyboard keys and mouse buttons/movement is controlled by the operating system, and game's core.

As for the rest of the problem, I have an idea. It could be due to using a surface attaching part as a root . In the game it's a kind of an edge case. Normally, the surface attaching parts should not be roots, but sometimes they become roots due to the docking operations. I doubt KIS handles this case. Will check tonight.

Share this post


Link to post
Share on other sites

Yeah the radial attachment doodad was attached to a separator which would have been the root when I attached that to the main ship, I imagine the radial attachment would have become the root on separation.

Share this post


Link to post
Share on other sites

Help with a ModuleManager Patch appreciated

Am trying to create a MM patch to add items to every pod's seat - like the KIS config does. Reason for separate patch is so don't have to edit with original and to keep changes between updates of KIS.
I have tried numerous versions of the below patch (and yes, kerbal-heatshield is a real part and the correct name).
Would love to have the evapropellellant stacked, but I don't believe that to be possible.
Any suggestions? Thank you in advance! 0K
 

@KISConfig[*]//:NEEDS[KIS]:FINAL
{
    @Editor
    {
        @PodInventory
        {
        // Specifies items to add to every pod's seat. To add
        // more items add more lines.
            addToAllSeats = KIS.electricScrewdriver         // Hotkey 1
            addToAllSeats = KIS.evapropellant         // Hotkey 2
            addToAllSeats = KIS.evapropellant         // Hotkey 2
            addToAllSeats = kerbal_heatshield         // Hotkey 3
        // Specifies items to add to the first pod's seat only.
            addToTheFirstSeatOnly = KIS.evapropellant
        }
    }
}

 

Share this post


Link to post
Share on other sites

@zer0Kerbal You don't need the [*] after KISConfig

This is my patch for KISConfig 

@KISConfig:FINAL
{
    @Editor
    {
	@PodInventory // Add a screwdriver and some EVA tanks to all seats
	{
	    addToAllSeats = KIS.electricScrewdriver
	    addToAllSeats = KIS.evapropellant
	    addToAllSeats = KIS.evapropellant
	}
    }
    
    @EvaInventory // Bump up the seat inventory slots (not changing volume)
    {
	@slotsX = 4 // 2
	@slotsY = 4 // 4
    }
    
    @EvaPickup // Increase range allowed to pickup most cheaty option here
    {
	@maxDistance = 5 // 50 // 3 (default)
	// @grabMaxMass = 100000 // needed for emergencies like Construction Ports not working right
    }
    //
    // Tweakscale disables stacking, so list some overrides of common items used on EVA.
	// Manufactured "tech" pieces like solar panels and lights shouldn't be tweaked.
    //
    // Never tweakscale anything that ends up in the list below. Add stuff as needed
    @StackableItemOverride
    {
	partName = KAS_CPort1
	partName = KAS_Hook_Anchor
	partName = KAS_Hook_GrapplingHook
	partName = KAS_Hook_Harpoon
	partName = KAS_Hook_Magnet
	partName = KAS_Pylon1
	partName = KAS_Strut1
	partName = KAS.CH1
	partName = KAS.JS1
	partName = KAS.PCB1
	partName = KAS.TB60
	partName = KAS.TJ1
	partName = KAS.TJ2
	partName = KAS.W1
	partName = KAS.W2
	partName = spotLight1
	partName = spotLight2
	partName = ladderRadial
	partName = W485_SufaceLight
	partName = W485_SurfaceOmniLight
	partName = W485_Suface4WayLight
	partName = solarPanels1
	partName = solarPanels2
	partName = solarPanels3
    }
}

 

Share this post


Link to post
Share on other sites
10 hours ago, Xd the great said:

Is it possible to equip stuff with this mod while sitting on a chair?

No, the kerbal must be EVA and controllable.

Share this post


Link to post
Share on other sites

Guys, I have a question, unrelated to KIS (I'm just abusing the subscribers). How frequently have you tried to setup a perfect kerbal net satellite system around Kerbin/Mun/Sol and failed, due to the satellites started deviating from the designated positions? For once then I've tried to play a full scale career game, I've quickly realised that building a reliable satellite relay system is a big challenge. Well, I was developing for KSP long enough to have it fixed quickly by using the cheats menu ;) However, it's not exactly a KSP way to have the things done. Would you like to have a mod that does it for you? Or, do you know the name of the mod that already does it? I hate the idea that I need to re-align my satellites thru a cheat menu periodically.

Edited by IgorZ

Share this post


Link to post
Share on other sites
41 minutes ago, IgorZ said:

How frequently have you tried to setup a perfect kerbal net satellite system around Kerbin/Mun/Sol and failed, due to the satellites started deviating from the designated positions? For once then I've tried to play a full scale career game, I've quickly realised that building a reliable satellite relay system is a big challenge.

Yep, that driffting bug is quite annoying. For that reason, I never create "perfect" satelite network, rather good enough for certain period of time. At begin of new career, I try to launch around 6 satellites around equator, more/less equaly distributed around 120-140 km. Note that I play without additional ground stations. Two additional satelite in polar orbit, with difference around 90 degree between those two polar satellies. Later on, I put at least one sattelite in geostacionary orbit just above KSC. And few additonal trough contracts that are geostat/geosync orbit, where I also put some good antenna on it, so it is not only for contract, it serve purpose later on for the rest of the game.

At that middle stage game I also, put two additional satellite in polar orbit with high Ap, almost near Mun, that usualy cover all comunication needs. Also at that stage, I'm able to put some satellite around Mun and Minimus too. By that time, first 6 sattelite in orbit are driffted quite a lot, but no longer matter, com network is by then properly covered even without those.

I only babysit that one satellite abve KSC in geostacionary orbit if it drift too much. Using precise node to set desired maneuver and kOS script to execute maneuver. I plan to develop script for setting maneuver nodes too, but too lazy for that and too litle time for playing lately too. If you want to make "perfect" network, it is possible to create some kOS script that will reposition drifted satellite, but you will need to "visit" such satellite and execute such script from time to time. For example, lower Pe for some amout to get exact wanted time difference, depending how much satellite drifted, wait couple of orbits for time difference between SOI rotation and satellite orbit take effect and then raise Pe again at previous altitude.

It all depends how "perfect" it has to be for you.

Share this post


Link to post
Share on other sites
5 hours ago, IgorZ said:

How frequently have you tried to setup a perfect kerbal net satellite system around Kerbin/Mun/Sol and failed, due to the satellites started deviating from the designated positions?

5 hours ago, Supercheese said:

Although I have never attempted to precisely align a network of satellites, I do believe the Station Keeping mod can be helpful in the situation you've described:

https://forum.kerbalspaceprogram.com/index.php?/topic/173518-141-stationkeeping-restationed-precise-synchronous-orbits/

I've actually used StationKeeping (and the resonant orbit calculator) to set up satellite networks around the Mun and Minmus.  Yes, it's useful.  Use the resonant orbit calculator to get your satellites evenly-spaced with nearly-equal orbital periods, then use StationKeeping to automatically adjust their orbits so the periods match exactly.

(Despite the word "stationkeeping", it's a one-time adjustment, not an ongoing thing.  The mod isn't involved in the actual motion of the satellites; it just changes the orbital parameters, as if you'd executed a very specific maneuver node with perfect accuracy.  Since there's no orbital decay or gravitational perturbations in KSP, the satellites will stay in those exact orbits even if you  uninstall the StationKeeping mod afterward.)

Edited by Wyzard

Share this post


Link to post
Share on other sites
9 hours ago, Wyzard said:

Since there's no orbital decay or gravitational perturbations in KSP, the satellites will stay in those exact orbits even if you  uninstall the StationKeeping mod afterward

KSP has another thing that breaks "the perfect orbits": the math calculation errors. It may not be obvious in a time span of 1-3 months of game time, but in a long run they accumulate to add enough deviation. So I was thinking about a mod which constantly monitors the satellites and doesn't allow them to deviate from the designated orbit.

Share this post


Link to post
Share on other sites
1 hour ago, IgorZ said:

KSP has another thing that breaks "the perfect orbits": the math calculation errors. It may not be obvious in a time span of 1-3 months of game time, but in a long run they accumulate to add enough deviation. So I was thinking about a mod which constantly monitors the satellites and doesn't allow them to deviate from the designated orbit.

What would be really nice is a mod that monitored a ship and kept it from coming apart.

Share this post


Link to post
Share on other sites

Hi Igorz and thanks a lot to keep this mod alive. I have some trouble to put back experiments in the crate. I can grab and attach it, run it, finalize... when i grab experiment (g) and trying to put them into open inventory, my mouse cursor seem to stay "behind" inventory window and not detecting it. Am i missing something ?

I just realized that i can't put back in inventory ANY items (mods's items and stock part) Everything work fine but when i slide object in inventory the windows doesn't detect it, cursor is behind inventory window without interact with it. I'll try my luck on KIS forum

Greeting

Here a screenshot https://drive.google.com/file/d/1kM6IkjpUwDsc24GLyeLhiprKQOF0AwOe/view?usp=sharing

I just run a fresh version with only kis, kas, and NEOS installed with CKAN on latest version of ksp. Same issues  i begin to think that i missed something here....

Sorry for the poor english.

Edited by Project-2501
Problem solved Thanks !

Share this post


Link to post
Share on other sites

@Project-2501 it works fine for me,can try without neos if it still happen.then i would try install not with ckan (both kis/neos that often makes bugs ),and third can try install clicktrublocker Maybe that helps.

Share this post


Link to post
Share on other sites

I'm unable to eva attach the harpoon back onto the winch in the right direction, it always wants to attach it with the pointy end inside the winch. 

...or is this a KAS problem?

Share this post


Link to post
Share on other sites
On 8/16/2018 at 9:21 AM, IgorZ said:

How frequently have you tried to setup a perfect kerbal net satellite system around Kerbin/Mun/Sol and failed, due to the satellites started deviating from the designated positions?

Never :)

I've been warned. So even on my very first CommNet (Remotetech in RP-0, some years ago) I pulled out Hyperedit and synchronized the orbits.

Hyperedit is reasonably well suited to the task, by letting you type in a value (in seconds) for how far you want to lead or trail the vessel you want to rendezvous with. For actual RV, that's typically one second or less, but you may as well enter something that resolves to a 120° angle. The only inconvenience is that you have to look up your orbital period yourself, convert it to seconds, divide by X.

On 8/17/2018 at 12:26 AM, IgorZ said:

KSP has another thing that breaks "the perfect orbits": the math calculation errors. It may not be obvious in a time span of 1-3 months of game time, but in a long run they accumulate to add enough deviation.

There's no accumulation of errors for on-rails vessels. The stored orbital parameters remain unchanged for as long as the vessel is on rails (that is, until you visit it in the flight scene). If two vessel's SMA and ECC are identical down to the least significant digit the game even knows about (something Hyperedit takes care of, and Stationkeeping probably does the same), then there won't be any deviation, ever.

--

That said, I wanted to ask if there is a way to simply detach a part and not put it anywhere. Detach-in-place, if you will. Reason is that I have sometimes trouble putting things on the ground, so I'd rather let them fall as they may.

Edited by Laie

Share this post


Link to post
Share on other sites
19 hours ago, se5a said:

I'm unable to eva attach the harpoon back onto the winch in the right direction, it always wants to attach it with the pointy end inside the winch. 

...or is this a KAS problem?

Yes, it's KAS problem: 

This is usse should be fixed in the legacy part pack in KAS 1.0 RC1 (see the KAS Beta thread).

5 hours ago, Laie said:

That said, I wanted to ask if there is a way to simply detach a part and not put it anywhere. Detach-in-place, if you will. Reason is that I have sometimes trouble putting things on the ground, so I'd rather let them fall as they may.

Use "X". It simply detaches a child from the parent.

Edited by IgorZ

Share this post


Link to post
Share on other sites

@IgorZ Laie does remind me of an issue I've run into a couple times. It would be nice to be able to cut loose items in a Kerbal's personal inventory when there isn't anything around.  I've had a few cases where I've had a Kerbal on zero-g EVA pick up an SC-62 and during the attachment to the kerbal something collides that sends the Kerbal spinning off into space. When the container is near the 1-ton limit the weight makes it very difficult to recover and fly back to the station. It would be nice to be able shed the load.  I run about 50/50 being able to get back vs mounting a rescue to retrieve the lost Kerbal.

Edited by Tonka Crash

Share this post


Link to post
Share on other sites
On 8/28/2018 at 10:57 AM, Tonka Crash said:

@IgorZ Laie does remind me of an issue I've run into a couple times. It would be nice to be able to cut loose items in a Kerbal's personal inventory when there isn't anything around.  I've had a few cases where I've had a Kerbal on zero-g EVA pick up an SC-62 and during the attachment to the kerbal something collides that sends the Kerbal spinning off into space. When the container is near the 1-ton limit the weight makes it very difficult to recover and fly back to the station. It would be nice to be able shed the load.  I run about 50/50 being able to get back vs mounting a rescue to retrieve the lost Kerbal.

Hm. Not sure what you mean. If you need to pull something out of the inventory and leave it floating nearby, simply drop it at the kerbal - this way you'll get the velocities adjusted. Indeed, there are parts with tricky colliders that will trigger weird things (e.g. the docking ports), but in the majority of cases it works just fine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.