IgorZ

[1.7.3] Kerbal Inventory System (KIS) v1.22

Recommended Posts

21 hours ago, IgorZ said:

Vos symptômes ressemblent beaucoup à ce cas d'utilisation . Essayez de lire ce document et de vérifier si votre installation est correcte. Si vous pensez que tout va bien, mais que le problème persiste, partagez un journal .

 

thank you very much sir. it was module manager. He checked it but did not install it. thanks thanks :)

Share this post


Link to post
Share on other sites

Hi @IgorZ I noticed that I can take of kerbal helmets in space now via the button from the inventory window. I guess it isn't supposed to be like that and was locked in previous versions. It isn't a big deal of couse and I don't dislike this cool mod all of the sudden.:D

Share this post


Link to post
Share on other sites
On 11/25/2018 at 1:41 AM, Dexter_D said:

Hi @IgorZ I noticed that I can take of kerbal helmets in space now via the button from the inventory window. I guess it isn't supposed to be like that and was locked in previous versions. It isn't a big deal of couse and I don't dislike this cool mod all of the sudden.:D

Hmm. It shouldn't be allowed. I'll check. Thanks.

Edited by IgorZ

Share this post


Link to post
Share on other sites

Thank you for making and maintaining this mod, it's so far awesome.

 

Having one tangential problem with it - in the last few hours of testing the mod I've started to develop deep and abiding hatred toward the ******* tooltip used when attaching objects.

Particularly my problem is with the font spacing and the really dark background - the combination makes it nearly impossible to figure out for some parts where they will be placed, unless I spend a lot of time fiddling with the camera angle.

Both a lighter (or transparent) tooltip background, or text lines wider apart would make things easier.

 

Is there some setting somewhere where I can edit this?

Share this post


Link to post
Share on other sites

@IgorZ Small question: if I have a part from a mod in a container and I remove that mod, will the part just disappear from the container or will it delete the ship?

Share this post


Link to post
Share on other sites

@RealKerbal3xI actually ran into this yesterday. The ship loads and the part stays in the inventory. You might get error messages that KIS can't find a part in the inventory. I have error messages turned on in the debug menu, so I don't know if you would see the messages without this. When I saw the errors, I quit the game and edited my save to delete the missing parts. I did not try to access the inventory that was generating the errors.

Edited by Tonka Crash

Share this post


Link to post
Share on other sites
14 hours ago, TanoPrime said:

Is there some setting somewhere where I can edit this?

Alas, it's not adjustable.

3 hours ago, RealKerbal3x said:

Small question: if I have a part from a mod in a container and I remove that mod, will the part just disappear from the container or will it delete the ship?

The ship will load and the bad part(s) will be removed from the inventory. As @Tonka Crash mentioned, there will be an error message in the logs, but it's completely safe. On the next save, the updated state of the inventory will be stored and no errors will arise in the future.

Share this post


Link to post
Share on other sites

@IgorZ I didn't see the parts being deleted from the inventory. Like I said I didn't try to open the inventory when I saw the error messages. Or do you mean the missing part just isn't visible in the inventory?  I could believe that, but I had to edit the save to delete the parts and clear the errors.

Edited by Tonka Crash

Share this post


Link to post
Share on other sites
8 minutes ago, Tonka Crash said:

@IgorZ I didn't see the parts being deleted from the inventory. Like I said I didn't try to open the inventory when I saw the error messages. Or do you mean the missing part just isn't visible in the inventory?  I could believe that, but I had to edit the save to delete the parts and clear the errors.

No, it's not invisible. It's removed. Load the bad save file, save it immediately, and load again - there should be no errors.

Share this post


Link to post
Share on other sites
8 minutes ago, IgorZ said:

Alas, it's not adjustable.

Sad. I guess I'll have to deal with it by bringing extra light everywhere.

 

Since I have your attention - having another problem: I can't seem to find any way of attaching a heatshield to a craft, whenever I try the indicator is red (indifferent of the attach node selection).

This seems to happen with any round object (round batteries, reaction wheels), and also with probe cores.

Is attaching circular-ish objects supposed to be possible with the mod? Am I missing some tech upgrade? (I only unlocked the wrench so far)

Share this post


Link to post
Share on other sites
3 minutes ago, TanoPrime said:

Sad. I guess I'll have to deal with it by bringing extra light everywhere.

 

Since I have your attention - having another problem: I can't seem to find any way of attaching a heatshield to a craft, whenever I try the indicator is red (indifferent of the attach node selection).

This seems to happen with any round object (round batteries, reaction wheels), and also with probe cores.

Is attaching circular-ish objects supposed to be possible with the mod? Am I missing some tech upgrade? (I only unlocked the wrench so far)

The wrench can't attach parts that use node attachment, you need the electric screwdriver and that should fix your problem. 

Share this post


Link to post
Share on other sites
1 minute ago, Tonka Crash said:

The wrench can't attach parts that use node attachment, you need the electric screwdriver and that should fix your problem. 

Thank you! :)

Share this post


Link to post
Share on other sites

Hey @IgorZ, big news!

SQUAD just announced that Kerbals will be able to remove their helmets (and neck rings in fact) in update 1.6. I guess that KIS’s implementation of this will be no longer needed by January!

(I do like the helmet removal shortcut key in KIS though...I hope something like that is implemented in 1.6).

Share this post


Link to post
Share on other sites
9 hours ago, RealKerbal3x said:

Hey @IgorZ, big news!

SQUAD just announced that Kerbals will be able to remove their helmets (and neck rings in fact) in update 1.6.

Thank you for letting me know! Very appreciated :) I'm absolutely agree that removing helmets should be a stock game feature. Respect to the SQUAD team!

Share this post


Link to post
Share on other sites
20 minutes ago, IgorZ said:

Thank you for letting me know! Very appreciated :) I'm absolutely agree that removing helmets should be a stock game feature. Respect to the SQUAD team!

Yep :)

The thread, for convenience:

 

 

Edited by RealKerbal3x

Share this post


Link to post
Share on other sites

I just installed KIS and tried connecting 2 ships with fuel lines, but when I right click on a JS-1 Joint Socket I don't get menu where I can pick to Link or anything else? What am I doing wrong? Attached screen shot

Thank youcOgd32J.jpg

Share this post


Link to post
Share on other sites

@te45a The JS-1 is just the socket. You start from the RTS-1 Resource Transfer Station. You grab the connector from it and drag the hose close to the JS-1, right click on the JS-1 and you will have Attach Connector as an option.

Share this post


Link to post
Share on other sites
On 12/8/2018 at 4:09 PM, Tonka Crash said:

@te45a The JS-1 is just the socket. You start from the RTS-1 Resource Transfer Station. You grab the connector from it and drag the hose close to the JS-1, right click on the JS-1 and you will have Attach Connector as an option.

Tried that also

S7AiQdD.jpg

Share this post


Link to post
Share on other sites
On 12/8/2018 at 4:10 PM, RealKerbal3x said:

@te45a I think this is more of a KAS question, so you’d be better off asking on the KAS thread.

thank you, I'll try that too

Share this post


Link to post
Share on other sites

@te45a In your photo you just aren't close enough to grab the connector. Use your jet pack to fly up to it a little. The grab range is really pretty short. 

Share this post


Link to post
Share on other sites

updated KIS and now mechjeb is broken? my dv window is gone, and theirs no option to bring it back

Share this post


Link to post
Share on other sites
51 minutes ago, putnamto said:

updated KIS and now mechjeb is broken? my dv window is gone, and theirs no option to bring it back

KIS has no dependency on MechJeb. However, depending on how you've installed KIS, some other dependencies could get updated. Check if ModuleManager and CCK are of the right version in your system.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.