IgorZ

[1.7.3] Kerbal Inventory System (KIS) v1.22

Recommended Posts

3 hours ago, Sol Invictus said:

@IgorZ Is it still true that each time KIS is updated, all mods using it become broken until they are recompiled against new KIS?

No, it's not anymore. KSP 1.2 implements "addon binder" which resolves mods by name when resolution by version fails.

Share this post


Link to post
Share on other sites

I am new to KIS, and maybe my question has been made already, but have you ever thought about repairing breakable parts like antennas and solar panels? It does not have to be for free, another one part of the same kind should be required in the engineer inventory. It is so annoying to substitute a broken part with a new one that will never be in the same spot and overall out of action group (AGM is dead and AGX is overdone to me).

No intention to bother, this is just a thought.

Also, I'll take this occasion to say that I'm grateful you @IgorZ took on this mod, otherwise I could not play it. Really, thank you man!

I'm playing KSP since almost 5 years and it's shameful I've discovered KAS/KIS just few days ago.

 

Share this post


Link to post
Share on other sites
8 minutes ago, Metanolo said:

I am new to KIS, and maybe my question has been made already, but have you ever thought about repairing breakable parts like antennas and solar panels? It does not have to be for free, another one part of the same kind should be required in the engineer inventory. It is so annoying to substitute a broken part with a new one that will never be in the same spot and overall out of action group (AGM is dead and AGX is overdone to me).

That's actually a good idea. I've added a feature request to not forget it. Once I'm done with KAS I'll get back to KIS.

Share this post


Link to post
Share on other sites

When I'm holding on to a part, waiting to reattach it, if I hit 'escape' to cancel, the pause menu also comes up. Is there some workaround to this, such as remapping keys or something?

Edited by Samapico

Share this post


Link to post
Share on other sites
15 hours ago, Samapico said:

When I'm holding on to a part, waiting to reattach it, if I hit 'escape' to cancel, the pause menu also comes up. Is there some workaround to this, such as remapping keys or something?

This issue became common once KSP 1.2 is released. I've created a tracking bug.

Share this post


Link to post
Share on other sites
2 hours ago, AdmiralSirJohn said:

Hit Enter instead.  That cancels without bringing up the menu.

"Enter" is a keypress fraught with potential peril, as it often acknowledges doing something you may not want done.  Until this is fixed, maybe do "Escape-Escape" instead?

Share this post


Link to post
Share on other sites
55 minutes ago, Jacke said:

"Enter" is a keypress fraught with potential peril, as it often acknowledges doing something you may not want done.  Until this is fixed, maybe do "Escape-Escape" instead?

"Escape-Escape" is pretty much what I do right now, but there is an annoying ~1 second delay before the pause menu comes up for some reason. I don't know if it's physics being reloaded or something.

But I'll try Enter, thanks!

Share this post


Link to post
Share on other sites

Is there a way to use EVA or attach a part to your back to move while on EVA? I want to move a gigantor solar panel, but can't manage it without being able to use my EVA pack.

Share this post


Link to post
Share on other sites
3 hours ago, Jivaii said:

Is there a way to use EVA or attach a part to your back to move while on EVA? I want to move a gigantor solar panel, but can't manage it without being able to use my EVA pack.

You can attach a container to your back.

First place your solar panel inside a KIS container. Then grab ("G") the container and place it in your inventory, it will appear on your back.

The container has a limited volume (1000L), if the solar panel can't fit in it you can attach it as far as possible, move your kerbal, reattach the solar panle, move the kerbal, etc...

Share this post


Link to post
Share on other sites

When will you update it to 1.2.2? not trying to pressure you into doing it or anything, but i would like to  have a date or at least when you think you will update it

 

unless it's already compatible like the 1.2.1 CTT was with 1.2.2, thanks in advance :)

Share this post


Link to post
Share on other sites
4 hours ago, derpydemon said:

unless it's already compatible like the 1.2.1 CTT was with 1.2.2, thanks in advance :)

It is already compatible. 1.2.1 => 1.2.2 was a small update, very few mods get broken.

Share this post


Link to post
Share on other sites

Hi guys,

great mod I love it!!!

 I have a question though. I remember seeing somewhere on youtube a Kerbal driving a pipe between a stranded ship out of fuel and a rescue ship to refuel it. I cant remember for the love of god where I saw this. Can it be done with KIS by driving a fuel line between two spacecrafts?

 

Thanks!

 

Share this post


Link to post
Share on other sites
1 hour ago, Frag2000 said:

Can it be done with KIS by driving a fuel line between two spacecrafts?

It's done via KAS mod (see links in my signature).

Share this post


Link to post
Share on other sites

Great mod, hugely increases the usefulness of Engineers :D 

Initially, I had the problem that no parts were stackable in the inventories. In my case this was caused by kOS, which adds a module to all parts.

It can be fixed by simply adding "moduleName = KOSNameTag" to the StackableModules in the settings.cfg, just in case somebody has the same problem :) 

Edited by CrushedIce

Share this post


Link to post
Share on other sites

New version released. As usual, CKAN will update in ~24 hours.

1.4.1 (January 16th, 2017)

  • [Fix #183] Equipped parts are not restored on scene load.
  • [Fix #186] NRE when using container in the editor.
  • [Fix #187] EVA equipped parts behave bad when sitting in the command seat.
  • [Fix #189] Handle ESC key.
  • [Fix #194] Remove helmet state is not persisted.
  • [Fix #195] Equipped parts collide with kerbal model.
  • [Enhancement #184] Use KSP 1.2 feature to add inventories to kerbals.
  • [Enhancement #191] Add bottom attachment node to container mount.
  • [Enhancement #192] Disallow ILC-18k on container mount.
  • [Enhancement #193] Add quadrant attachment nodes to stock 2x2 panel.

Share this post


Link to post
Share on other sites

New to KIS. Not sure if a) I did something wrong; b) it's a known behavior; or c) it's a bug (and I can open one or you can, idc).

When I was setting up my satellite constellation, I didn't add enough batteries to make it through the night. I thought that I would do one launch to rule repair them all. Bill Kerman was loaded with 1 wrench, 1 screwdriver, and 6 Z-400 battery packs.

At the first satellite, good ol' Bill EVA'd over to it, equipped his trusty wrench and repaired the first satellite[1], placing two batteries on its hull. He returned to momma and Val ferried them over to the second satellite. Before rendezvousing, I had to call it the night and I saved and went to bed. Today, I completed the rendezvous and Bill once again EVA'd. To my dismay, he had no inventory. His capsule didn't have it. Val didn't have it. His trusty tools were not so trusty after all.

So, a) b) or c)?

[1] Ugh, it was quite the challenge getting the batteries fixed to the hull. The drill sound kept happening like it was attaching but then it would be floating a few inches above the hull. After about half-a-dozen tries I finally got it to stick. My procedure was drag from inventory, click on location, press-and-hold H, click, release H.

 

Share this post


Link to post
Share on other sites
1 hour ago, doktorstick said:

New to KIS. Not sure if a) I did something wrong; b) it's a known behavior; or c) it's a bug (and I can open one or you can, idc).

When I was setting up my satellite constellation, I didn't add enough batteries to make it through the night. I thought that I would do one launch to rule repair them all. Bill Kerman was loaded with 1 wrench, 1 screwdriver, and 6 Z-400 battery packs.

At the first satellite, good ol' Bill EVA'd over to it, equipped his trusty wrench and repaired the first satellite[1], placing two batteries on its hull. He returned to momma and Val ferried them over to the second satellite. Before rendezvousing, I had to call it the night and I saved and went to bed. Today, I completed the rendezvous and Bill once again EVA'd. To my dismay, he had no inventory. His capsule didn't have it. Val didn't have it. His trusty tools were not so trusty after all.

So, a) b) or c)?

[1] Ugh, it was quite the challenge getting the batteries fixed to the hull. The drill sound kept happening like it was attaching but then it would be floating a few inches above the hull. After about half-a-dozen tries I finally got it to stick. My procedure was drag from inventory, click on location, press-and-hold H, click, release H.

For the disappearing we need a reliable repro steps. It happen in the past due to different reasons but as for now there are no known circumstances to have this bug to show up. Best way to reproduce bugs is using clear installation of KSP since in this case I'll be able to load the your savefile for debugging.

As for the batteries hovering over the hull can you show screenshots or better make a short video?

Share this post


Link to post
Share on other sites
On 13/01/2017 at 0:06 PM, CrushedIce said:

Great mod, hugely increases the usefulness of Engineers :D 

Initially, I had the problem that no parts were stackable in the inventories. In my case this was caused by kOS, which adds a module to all parts.

It can be fixed by simply adding "moduleName = KOSNameTag" to the StackableModules in the settings.cfg, just in case somebody has the same problem :) 

And you can do that with a ModuleManager patch :cool:

An example from my mod, Crew Light.

Perhaps you could ask kOS guys to add something like that to their mod ?

Share this post


Link to post
Share on other sites
9 hours ago, IgorZ said:

For the disappearing we need a reliable repro steps. It happen in the past due to different reasons but as for now there are no known circumstances to have this bug to show up. Best way to reproduce bugs is using clear installation of KSP since in this case I'll be able to load the your savefile for debugging.

I understand you would like a modless save, but ATM I have about 30 mins a night to play. If I get more time, I'll see about spending recreating in a pristine environment. For now though, I'm reporting that it happened again. Same situation. Relaunched to do the last two satellites, repaired one, in transit to the other when I had stopped playing. Reloading and there's no tools.

What I observe is this--my ship has two inverted Command Pods MkI and an SC-62 container. Upon the reload, the Command Pods no longer have the "Valentina's Inventory" and "Bill's Inventory" buttons; the container still has its inventory button (and its items when I EVA to it). The thing that makes or breaks it is this--if the game loads the save game and starts you at the Space Center and you have to get to the ship via Tracking Station | Fly Ship, the "Bill's Inventory" button is present. If the game directly loads into space, those buttons are gone.

 

Share this post


Link to post
Share on other sites
2 hours ago, doktorstick said:

The thing that makes or breaks it is this--if the game loads the save game and starts you at the Space Center and you have to get to the ship via Tracking Station | Fly Ship, the "Bill's Inventory" button is present. If the game directly loads into space, those buttons are gone.

Wait. How you can load the game not thru the space center scene? When you choose "Resume game" and select profile you end up in space center view regardless to where you were before existing the game last time. Do you use any savegame enhancing mods? KIS requires the game to start from the space center, it's where it initializes pod inventories and other global stuff. If you somehow manage to skip this screen the problems you describe are inevitable.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.