Jump to content

[Minimum KSP version - 1.11] Kerbal Inventory System (KIS) v1.28


Recommended Posts

I am asking them, because it seems every item you tweak scale has got this volume problem...

And I have a question about heavy weight: how can you use 2 Kerbals to carry more than 1T ?

With 1 Kerbal, I can move a heat weight or volume by taking it and dropping it just a little further, then walk to it, take it and leave further and so on....

With 2 Kerbal I don't see any mean to carry something heavy without dropping it after each short walk

When volume is too big, it's impossible to carry it in its inventory

Link to post
Share on other sites
7 hours ago, gilflo said:

And I have a question about heavy weight: how can you use 2 Kerbals to carry more than 1T ?

With 1 Kerbal, I can move a heat weight or volume by taking it and dropping it just a little further, then walk to it, take it and leave further and so on....

With 2 Kerbal I don't see any mean to carry something heavy without dropping it after each short walk

When volume is too big, it's impossible to carry it in its inventory

You just need multiple Kerbals in range of the part and you can move it.  I've used that feature sometime in the last month on 1.9.1. You still have the problem you can't move it far and then you need to corral the Kerbals around the part each time you move it.

Or you can cheat the system and increase both the range and weight by changing KIS/settings.cfg either directly or through a patch.   The following post shows what I do.  Normally I leave the 1 Ton limit alone, but have my default range at 5m which is a little less tedious to deal with. But I've had stations get attacked by the Kraken and spontaneous break.  For that I make the limits ridiculous and it's like working in the VAB in free fall. (Click the date under my name to get there)

 Also, how I think of KIS has changed over time.  Instead of building craft part by part it's mostly for fixing small things.  For assembling big things I design around USI Konstruction ports.  I might need a Kerbal go out to add a port in the right place, replace broken solar panels or cut parts off (no limits for cutting), but the joining of big things is done by vessels maneuvering the pieces and Konstructions ports doing the connecting.  This respects KIS limits and lets me join big things. KIS gets used in the clean up, stripping off unneeded RCS thrusters and adding struts to reduce wobbling.  I posted a patch for longer KAS struts, too.  In the pic below you won't find docking ports between big parts, but almost all of them were flown up individually, maneuvered into place and Konstruction ports used to anchor them in place.  You can see a couple of my RCS tugs docked in the foreground. I'll use these in conjunction with KIS on Kerbals to handle big parts.

B5ebNIc.jpg

Edited by Tonka Crash
Link to post
Share on other sites
6 hours ago, Tonka Crash said:

B5ebNIc.jpg

Looks like it wobble-dance after scene-switch/closering for docking.
Thats no kraken, its imho a ingame-calculating-fail when you have other tasks running.
(For me thats only happen when i have firefox open with many tasks, download something
or convert videos in background.) 

What happen after just kick timewarp for a second or reload savegame?
(Quicksaving is essential for modded games, specially i see station-science mod.)
You also put large/heaviest parts on outside of station.
Cyclos/Spectors are biests.

Maybe you like to eva-strut it in sight.
launch ir or produce them with EPL

Link to post
Share on other sites
33 minutes ago, Jansn67 said:

Looks like it wobble-dance after scene-switch/closering for docking.
Thats no kraken, its imho a ingame-calculating-fail when you have other tasks running.
(For me thats only happen when i have firefox open with many tasks, download something
or convert videos in background.) 

What happen after just kick timewarp for a second or reload savegame?
(Quicksaving is essential for modded games, specially i see station-science mod.)
You also put large/heaviest parts on outside of station.
Cyclos/Spectors are biests.

Maybe you like to eva-strut it in sight.
launch ir or produce them with EPL

I refer the Kraken being the few times I have a ship or space station spontaneously break apart for no apparent reason. It's happened a few times to me over the years.  I save often. One time I installed a new mod and several ships that had been stable in game for months spontaneously broke up, so it was uninstall the mod and load a save. 

I like big stations, so I've learned to build around KSP limitations. One of the biggest problems I see is people having long spindly structures.  I tend to spoke arms off a core to keep the mass as close together as possible. And autostrtuting parts on the end of the arm to root tend to add stability. Most wobbles I see are due to reaction wheels far from the center of mass fighting with each other to maintain orientation. I try to keep a few near the center of mass and deactivate ones further out as the station evolves, but docked ships can still be a problem. Usually activating autostruts on their engine will lock this down (in my experience). I also have a few welded parts like 8 way hubs that form the core to improve rigidity. But adding a few KAS struts for multiple load paths do wonders for rigidity. Extraplanetary Launchpads is in use at the station and station parts for Minmus are built mostly here.

My computer itself is rarely burdened with CPU intensive tasks when running KSP.  It's a 8th gen i7 overclocked at 4.3Ghz with 32GB of RAM running on an NVME SSD.  The photo above was early in the station's history.  Below is a bit more current.   Station Science parts are not nearly the most massive I tend to deal with.  3.75m greenhouse and smelters & ISRUs dwarf them. And I have a 30m centrifuge that's soon to be added to this

0W7ipNt.jpg

Link to post
Share on other sites

@IgorZ I have the old Spacedock mod that shipped with a custom modified KIS.dll  It looks like the intent was to allow KIS actions (attach, detach, use Inventories) to happen within the vicinity of the Spacedock parts without a Kerbal on EVA.  It used ModuleKISPickup.  I'm not familiar with this module.  How is this module supposed to work?

What I can do is take things out of inventory and drop them outside the vessel, but after it's dropped I can't pick it up again and there is no option to attach it. If I send a Kerbal EVA there's no bonus distance or weight allowance that I can tell.

This is the definition in one of the Spacedocks.

   MODULE
    {
        name = ModuleKISPickup
        maxDistance = 46.275
        grabMaxMass = 66.5
        allowPartStack = true
        allowPartAttach = true
	attachPartSndPath = KIS/Sounds/attachPart
	detachPartSndPath= KIS/Sounds/detachPart
    }

 

Link to post
Share on other sites
On 4/17/2020 at 4:08 PM, Tonka Crash said:

@IgorZ I have the old Spacedock mod that shipped with a custom modified KIS.dll  It looks like the intent was to allow KIS actions (attach, detach, use Inventories) to happen within the vicinity of the Spacedock parts without a Kerbal on EVA.  It used ModuleKISPickup.  I'm not familiar with this module.  How is this module supposed to work?

What I can do is take things out of inventory and drop them outside the vessel, but after it's dropped I can't pick it up again and there is no option to attach it. If I send a Kerbal EVA there's no bonus distance or weight allowance that I can tell.

This is the definition in one of the Spacedocks.

   MODULE
    {
        name = ModuleKISPickup
        maxDistance = 46.275
        grabMaxMass = 66.5
        allowPartStack = true
        allowPartAttach = true
	attachPartSndPath = KIS/Sounds/attachPart
	detachPartSndPath= KIS/Sounds/detachPart
    }

 

Alas, this module doesn't work the way it should. It's supposed to be a pickup point, but with time too much code have accumulated that doesn't respect the concept. This will be fixed in KIS2. I've gave up trying to implement it in the old KIS. Today only a real kerbal works good as a KIS Pickup point. Non-kerbal parts may or may not work as expected (and they usually don't).

Link to post
Share on other sites
6 hours ago, IgorZ said:

Alas, this module doesn't work the way it should. It's supposed to be a pickup point, but with time too much code have accumulated that doesn't respect the concept. This will be fixed in KIS2. I've gave up trying to implement it in the old KIS. Today only a real kerbal works good as a KIS Pickup point. Non-kerbal parts may or may not work as expected (and they usually don't).

So this will remain a "virtual" lifting/moving method in KIS2, right? Something similar to the VAB?

Would it be possible to also have a way to actually grab and move parts with something like a crane or a canadarm? You know, similar to the grappling hook or the harpoon from KAS, but (optionally) working with attachment points? Since attachment points are usually placed along the symmetry axis, above the center of mass, this would come in very handy for "really" building something on site.

Link to post
Share on other sites
16 hours ago, infinite_monkey said:

So this will remain a "virtual" lifting/moving method in KIS2, right? Something similar to the VAB?

In KIS2 the whole pickup/move concept will be revised. Like, completely. I don't want to give details and set false expectations until at least Beta is released.

16 hours ago, infinite_monkey said:

Would it be possible to also have a way to actually grab and move parts with something like a crane or a canadarm?

Yes, it will be possible to construct such parts. In the old KIS it's not possible due to the module constraints.

Btw, if you need to extend the mass/distance limits in the old KIS, you can simply change the settings file. E.g. if you are not an arcade type of player, and think as an architect in the game, simply set the limits to reasonably big values and you'll be unlimited in the game. In all my latest games I played with limits 10t/30m - it covers all my needs. Be careful with the distance limit, though. It affects the performance in the carry mode, and you won't snipe the right place for part at the bigger distances anyway.

Link to post
Share on other sites

Hi Folks-

I haven't posted here much so I apologize in advance if I'm not following instructions or have missed something. I have done my own searching for an answer but can't find it and am hoping someone can point me in the right direction. 

I'm running ksp 1.9.1 with the latest version of KIS. I cannot add the break ground science parts (e.g., weather analyzer, solar array, control station, etc...) to any contained, KIS, default to KSP, or otherwise. In the VAB, if I try to use the SEQ-3/6 I can't drag the parts into the container inventory at all. With the SEQ-9, I get a message "use stock game abilities to handle this part." In trying to find a solution, I did find this string on the KIS github page, but couldn't deduce why I would get this message with non KIS parts. 

Any ideas? Again, I apologize if I'm in the wrong spot. 

Link to post
Share on other sites

@rootif The Breaking Ground science experiments cannot be stored in KIS containers. When BG came out it was found they didn't deploy correctly when pulled out of a KIS inventory, so they were banned from being stored in them.

The stock storage system also behaves differently than KIS.  You open the Breaking Ground storage container. Click on the part you want on the left and then click on the open storage slot.  You do not drag and drop the parts.

Link to post
Share on other sites
On 4/21/2020 at 5:20 AM, Tonka Crash said:

@rootif The Breaking Ground science experiments cannot be stored in KIS containers. When BG came out it was found they didn't deploy correctly when pulled out of a KIS inventory, so they were banned from being stored in them.

The stock storage system also behaves differently than KIS.  You open the Breaking Ground storage container. Click on the part you want on the left and then click on the open storage slot.  You do not drag and drop the parts.

But you can cheat: first put the devices from Breaking Ground in their container, and then put this container in the container from KIS. And voila! :)

Link to post
Share on other sites
58 minutes ago, Sokol_323 said:

But you can cheat: first put the devices from Breaking Ground in their container, and then put this container in the container from KIS. And voila! :)

Hmm. This case I didn't check. But as long as it works fine, I'm OK :) 

Edited by IgorZ
Link to post
Share on other sites
5 minutes ago, IgorZ said:

Hmm. This case I didn't check. But as long as it works fine, I'm OK :) 

I checked with small containers on 3 and 6 slots that kerbal can carry. If it is first fixed to the craft, filled with BG devices, and then unpinned and placed in a KIS container, it can be transported to any place. I was sent these devices as additional cargo on the Mun and Minmus.

Link to post
Share on other sites
On 4/17/2020 at 10:24 PM, Tonka Crash said:

My computer itself is rarely burdened with CPU intensive tasks when running KSP.  It's a 8th gen i7 overclocked at 4.3Ghz with 32GB of RAM running on an NVME SSD.  The photo above was early in the station's history.  Below is a bit more current.   Station Science parts are not nearly the most massive I tend to deal with.  3.75m greenhouse and smelters & ISRUs dwarf them. And I have a 30m centrifuge that's soon to be added to this

Awesome station. Like that.
And sorry, my fault, i missunderstood the quoted post (wobling).
Now i see you use 6/8-way-docking nodes in the middle.

Further good to see that you CPU/RAM/SSD-Rig also works hard with such stations.
I wanted to upgrade (extra for modded KSP :p) to a 2.000 euro plattform.
May i ask what GFX you use and how much FPS you have?
(When scene is at that station... or at docking process..)

You can send answer as PM to not fringe this thread OT.

Happy stationing/launchpading ;-)

Link to post
Share on other sites
3 hours ago, Shuttle Enthuasist124 said:

I am still using ksp 1.7.2 . I want to know does it work with my version

Try it. If not you remove.

I was using with 1.7.3 and worked fine. Now i'm using with 1.9.1 and it's working too.

Some mods have listed in download a version and it's respective kSP compatible, but in most cases, they keep working on other versions.

Preferably download the one for your KSP version.

Link to post
Share on other sites
4 hours ago, Shuttle Enthuasist124 said:

I am still using ksp 1.7.2 . I want to know does it work with my version

KIS version 1.22 should be the version you want.  KIS 1.23+ are for for KSP 1.8+ and are not backward compatible. 

Link to post
Share on other sites

1.25 (April 25th, 2020):

  • [Change] Stop complaining about KSP minor version change.
  • [Change] Update ES-ES localization.

Important note: Going forward the mod will not be checking KSP version unless it's proven the release was incompatible. If that's the case, then the next mod's version will have the minimum compatible version adjusted, but the maximum version will never be verified.

Edited by IgorZ
Link to post
Share on other sites

This isn't a new bug with the update, but I assembled a USI Akita rover in the field using KIS, and it doesn't drive — the wheels spin but the rover doesn't move.  Collide-O-Scope shows that something in the collider is positioned wrong:

zkvkZq5.jpg

When I build the rover in the VAB, the pink circle is centered on the red sphere and the wheel works correctly.  I attached the wheel with KIS using its attachment node, same as in the VAB, so it ought to work the same.

This has worked in the past — definitely in KSP 1.3 (I have screenshots from that save), and I'm pretty sure in 1.5 too.  Don't know about versions past that.

Is this a known bug?  It seems vaguely familiar and I think I might have noticed it before, but I haven't used these parts in more than a year so I don't really remember.  Is there maybe something I can manually edit in my .sfs file to fix the wheel collider?

Link to post
Share on other sites
2 hours ago, Wyzard said:

Is this a known bug?

Well, it's not like a real known bug, but in general it's known that KIS creates and initializes parts differently from the stock game. This was the reason why KIS was never compatible with IR. If the part doesn't have advanced dynamic behavior, it's usually OK (and it's 99% of all KSP parts). The dynamic behavior, which some advanced parts implement (like wheels or IR), in many cases doesn't work as expected. I'm pretty sure this is the case here. And ahead of your next question: no, it won't be fixed in KIS v1. However, this will likely be resolved "naturally" in KIS v2 which creates new parts in the game world in a completely different way (inspired by the stock inventory system).

2 hours ago, Wyzard said:

Is there maybe something I can manually edit in my .sfs file to fix the wheel collider?

It's really hard to say. Most of the KIS issues with the newly created parts can be resolved by simply reloading the savegame file. If it doesn't help in your case, then I have no idea. I may suggest a workaround that sometimes helps:

  1. Pull out the wheel out of inventory and drop it on the surface.
  2. Given it didn't explode or flew into the sky, try attaching it to your vessel.
Edited by IgorZ
Link to post
Share on other sites
8 hours ago, Wyzard said:

This isn't a new bug with the update, but I assembled a USI Akita rover in the field using KIS, and it doesn't drive — the wheels spin but the rover doesn't move.  Collide-O-Scope shows that something in the collider is positioned wrong:

zkvkZq5.jpg

When I build the rover in the VAB, the pink circle is centered on the red sphere and the wheel works correctly.  I attached the wheel with KIS using its attachment node, same as in the VAB, so it ought to work the same.

This has worked in the past — definitely in KSP 1.3 (I have screenshots from that save), and I'm pretty sure in 1.5 too.  Don't know about versions past that.

Is this a known bug?  It seems vaguely familiar and I think I might have noticed it before, but I haven't used these parts in more than a year so I don't really remember.  Is there maybe something I can manually edit in my .sfs file to fix the wheel collider?

@Wyzard It's easy to install Akita wheels upside down. Try rotating them before attaching to see if that fixes the problem.

Edited by notthebobo
Correct @ mention
Link to post
Share on other sites
8 hours ago, IgorZ said:

It's really hard to say. Most of the KIS issues with the newly created parts can be resolved by simply reloading the savegame file. If it doesn't help in your case, then I have no idea. I may suggest a workaround that sometimes helps:

  1. Pull out the wheel out of inventory and drop it on the surface.
  2. Given it didn't explode or flew into the sky, try attaching it to your vessel.

I built a rover in the hangar and put it on the runway, where it worked correctly and the collider looked right.  Then I took a wheel off with KIS and dropped it on the ground, and the collider broke just from that.  Anything else after that (reattaching the wheel, or putting it into a KIS container and taking it back out) makes no difference.  Reloading the save doesn't help either.

I'll look forward to KIS v2, I guess.  :wink:  In the meantime, maybe I'll install VesselMover and use that to fake driving the rover around.

2 hours ago, notthebobo said:

@Wyzard It's easy to install Akita wheels upside down. Try rotating them before attaching to see if that fixes the problem.

Good suggestion, but unfortunately not the problem in this case — I made sure the wheel is oriented correctly.  (There's a vertical shaft that's a little off-center relative to the attachment point, and the longer side goes on the bottom.)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...