Jump to content

[Minimum KSP version - 1.12] Kerbal Inventory System (KIS) v1.29


IgorZ
 Share

Recommended Posts

On 12/23/2021 at 5:47 PM, rudemario said:

I was wondering if you ever figured out what was causing this delay I mentioned back in May?

I didn't have a chance to investigate it at that time. Now, I'm focused on KISv2, which is a total code rewriting, so fixing non critical bugs in the old code is not rational.

On 12/24/2021 at 5:23 AM, darthgently said:

I know this has been addressed in the past, but things may have changed.  I have many KIS EVA propellant tanks in various inventories and am wondering if they have functionality now or should I ditch them?

They are supposed to be functional, but there is a bug https://github.com/ihsoft/KIS/issues/394. Thanks for refreshing my memory on it. I'll make a quick fix for it once I'm back from the vacation.

Link to comment
Share on other sites

1.29 (January 4th, 2022):

  • [Enhancement] Support game's UI scale in all dialogs.
  • [Enhancement] Reduce the EVA canister dry mass to 1kg.
  • [Fix] Total mass is not adjusted when fuel is expended from the EVA tank.
  • [Fix] Recalculate the resources mass on load to fix wrong state of the EVA tank.
  • [Fix #394] Refuel tank throws error on refuel action.

Fun facts:

  • Today is almost a round anniversary since the v1.28 release.
  • The mod has born 7 years ago. And it's still alive.
  • Fixing #394 was a real challenge and took 3 days to get solved. However, the time was not wasted - the experience gained will be used in KISv2.
Link to comment
Share on other sites

I don't know if it is related (but I suspect it is). I just installed the latest version of KIS, and now my module manager fails and the game won't load. That is the only mod I updated between the previous run (2 hrs ago) and now. I did a little more leg work. During startup, ModuleManger is looking for MiniAVC-V2.dll. Something is renaming that file to MiniAVC-V2.dll.pruned. I rolled back KIS, and I've got the same issue. Again, no other mods have been changed since this started.

 

 

Link to comment
Share on other sites

2 hours ago, Michel Bartolone said:

I don't know if it is related (but I suspect it is). I just installed the latest version of KIS, and now my module manager fails and the game won't load. That is the only mod I updated between the previous run (2 hrs ago) and now. I did a little more leg work. During startup, ModuleManger is looking for MiniAVC-V2.dll. Something is renaming that file to MiniAVC-V2.dll.pruned. I rolled back KIS, and I've got the same issue. Again, no other mods have been changed since this started.

 

 

I did a reinstall of module manager and it seems to come up fine now. I'm not sure why/how, the only change made is the KIS module, that causes me to need to reinstall ModuleManager. I may try pushing back to the latest version of KIS, then trying to reinstall ModuleManager before starting the game.

Link to comment
Share on other sites

1 hour ago, Michel Bartolone said:

During startup, ModuleManger is looking for MiniAVC-V2.dll. Something is renaming that file to MiniAVC-V2.dll.pruned

Afaik, ZeroMiniAVC does the renaming. However, absence of this module should not affect the main mod behavior.

How do you install KIS? If you do it via CKAN, then there can be no relation between KIS upgrade and the issue you've observed. If you install manually, ensure that ModuleManager from the KIS package matches your KSP version.

Link to comment
Share on other sites

19 hours ago, IgorZ said:

Afaik, ZeroMiniAVC does the renaming. However, absence of this module should not affect the main mod behavior.

How do you install KIS? If you do it via CKAN, then there can be no relation between KIS upgrade and the issue you've observed. If you install manually, ensure that ModuleManager from the KIS package matches your KSP version.

Yes, I used CKAN.  I still do not understand how, the only change made was to upgrade KIS (via CKAN) and then attempted to start KSP and have it fail, would not make you _think_ there may be a problem with a mod. As for your claim that if you install via CKAN there there can't be a relationship...that is a false claim. I am not saying it is the case _this time_, BUT I have seen coding flaws make it into CKAN based releases...

Link to comment
Share on other sites

1 hour ago, Michel Bartolone said:

Yes, I used CKAN.  I still do not understand how, the only change made was to upgrade KIS (via CKAN) and then attempted to start KSP and have it fail, would not make you _think_ there may be a problem with a mod. As for your claim that if you install via CKAN there there can't be a relationship...that is a false claim. I am not saying it is the case _this time_, BUT I have seen coding flaws make it into CKAN based releases...

I know I have accepted the "suggested mods" when installing a mod without thinking it through.  Is it possible you installed more than just KIS?  I can't remember what the "suggested mods" are for KIS.  You can double check by sorting the main mod list by "installed data" and seeing what was installed when

Edited by darthgently
Link to comment
Share on other sites

8 hours ago, Michel Bartolone said:

As for your claim that if you install via CKAN there there can't be a relationship...that is a false claim.

By no relation I meant KIS as a root case (e.g. if the game was broken due to incorrect manual setup). Indeed in your case upgrading KIS was a trigger of the problem. However, I tend to think it's not KIS that made the trouble, it's the upgrade itself (as an action) that caused troubles. Module manager rebuilds its database on every new mod installed, and this time something went wrong. And you mentioned that after KIS removal you still had the problem with the game. Try reinstalling MM (ensure the caches are dropped) and then add KIS again. If you get the problem again, please share the log.

Link to comment
Share on other sites

12 minutes ago, IgorZ said:

By no relation I meant KIS as a root case (e.g. if the game was broken due to incorrect manual setup). Indeed in your case upgrading KIS was a trigger of the problem. However, I tend to think it's not KIS that made the trouble, it's the upgrade itself (as an action) that caused troubles. Module manager rebuilds its database on every new mod installed, and this time something went wrong. And you mentioned that after KIS removal you still had the problem with the game. Try reinstalling MM (ensure the caches are dropped) and then add KIS again. If you get the problem again, please share the log.

Module manager does not update the database after changing version 1.28 -> 1.29 or 1.29 -> 1.28.
To successfully start the game, simply delete the cache files.

Edited by by_HOY_
Quote added
Link to comment
Share on other sites

  • 2 weeks later...

I really appreciate this mod,  thank you very much.

I am playing an ongoing career mode game that has been running for several years.  Just wondering if it is expected the existing KIS parts will transition to version 2 when it is released?

Link to comment
Share on other sites

49 minutes ago, Texxter said:

I really appreciate this mod,  thank you very much.

I am playing an ongoing career mode game that has been running for several years.  Just wondering if it is expected the existing KIS parts will transition to version 2 when it is released?

Some of them will, but some of them may not. I will do my best to keep the backwards compatibility, but it may not be feasible under some circumstances. Let's wait till at least Beta1.

Link to comment
Share on other sites

 

Hello. Please excuse me, I'm new to this forum. It took me a lot of work to deal with the problem of your mod, but I was able to understand what the error was.
Only one of your mods is installed on a fresh game 1.12.3
in the log it [ERR 03:17:36.697] ADDON BINDER: Cannot resolve assembly: KSPDev_Utils.2.6, Culture=neutral, PublicKeyToken=null
this post helped  Fix "ADDON BINDER: Cannot resolve assembly" errors in log by mwerle · Pull Request #357 · S-C-A-N/SCANsat · GitHub   

@linuxgurugamer said an alternative way to fix this issue is to ensure that the dependant mod has a higher filename (eg, rename it to "+SCANsat.Unity.dll") to ensure it gets loaded first; not sure if that might cause other issues. Seemed a bit of a hack which is why I investigated the "proper" solution.

if you change the name to +KSPDev_Utils.2.6.dll everything works fine

 

Edited by vbnz
Link to comment
Share on other sites

On 1/24/2022 at 6:35 PM, vbnz said:

Hello. Please excuse me, I'm new to this forum. It took me a lot of work to deal with the problem of your mod, but I was able to understand what the error was.
Only one of your mods is installed on a fresh game 1.12.3
in the log it [ERR 03:17:36.697] ADDON BINDER: Cannot resolve assembly: KSPDev_Utils.2.6, Culture=neutral, PublicKeyToken=null
this post helped  Fix "ADDON BINDER: Cannot resolve assembly" errors in log by mwerle · Pull Request #357 · S-C-A-N/SCANsat · GitHub   

@linuxgurugamer said an alternative way to fix this issue is to ensure that the dependant mod has a higher filename (eg, rename it to "+SCANsat.Unity.dll") to ensure it gets loaded first; not sure if that might cause other issues. Seemed a bit of a hack which is why I investigated the "proper" solution.

if you change the name to +KSPDev_Utils.2.6.dll everything works fine

 

This log record may or may NOT indicate a real problem. It sounds weird, but this is how this code works. Here you need to know  if you have a real problem in the game. If your KIS is installed properly, then you should not have any issues, even though there is the error record in the logs.

TL;DR;

This error happens due to `KSPDev_Utils` DLL is version dependent, and the addon binder expects the DLL name to match exactly to the namespace (no version suffix). There are cases when it's a problem, but with the versioned DLLs (like KSPDev_Utils), it's not.

Link to comment
Share on other sites

12 hours ago, IgorZ said:

This log record may or may NOT indicate a real problem. It sounds weird, but this is how this code works. Here you need to know  if you have a real problem in the game. If your KIS is installed properly, then you should not have any issues, even though there is the error record in the logs.

TL;DR;

This error happens due to `KSPDev_Utils` DLL is version dependent, and the addon binder expects the DLL name to match exactly to the namespace (no version suffix). There are cases when it's a problem, but with the versioned DLLs (like KSPDev_Utils), it's not.

Many thanks. Works great.

In the textbook, you need to write hold down the left mouse button.

Edited by vbnz
Link to comment
Share on other sites

12 hours ago, IgorZ said:

This log record may or may NOT indicate a real problem. It sounds weird, but this is how this code works. Here you need to know  if you have a real problem in the game. If your KIS is installed properly, then you should not have any issues, even though there is the error record in the logs.

TL;DR;

This error happens due to `KSPDev_Utils` DLL is version dependent, and the addon binder expects the DLL name to match exactly to the namespace (no version suffix). There are cases when it's a problem, but with the versioned DLLs (like KSPDev_Utils), it's not.

Thank you very much, everything works.
In the textbook, you need to write to hold down the left mouse button)))

Link to comment
Share on other sites

Does anyone know of a way to transfer certain items between the differing types of inventory? For example, I can get the electric screw driver into both types of inventory in the VAB, but if I only put it in one of the two, and put it in the wrong one, I can no longer put it in the kerbonaut's inventory in a way that allows him to equip it...

 

Link to comment
Share on other sites

5 hours ago, Michel Bartolone said:

Does anyone know of a way to transfer certain items between the differing types of inventory? For example, I can get the electric screw driver into both types of inventory in the VAB, but if I only put it in one of the two, and put it in the wrong one, I can no longer put it in the kerbonaut's inventory in a way that allows him to equip it...

 

I put KIS items (i.e screwdriver) in KIS inventory as I ran into similar issues

Link to comment
Share on other sites

13 hours ago, Michel Bartolone said:

Does anyone know of a way to transfer certain items between the differing types of inventory? For example, I can get the electric screw driver into both types of inventory in the VAB, but if I only put it in one of the two, and put it in the wrong one, I can no longer put it in the kerbonaut's inventory in a way that allows him to equip it...

 

The only working solution is drop the item from one inventory, and then pick it up from the other. E.g. if you've put the screwdriver into the stock inventory, you need to use the stock functionality to remove it from there and put on the ground. Then, you'll be able to pickup the item using native KIS functionality. However, here is  trick: only an engineer can drop items from the stock inventory. So, if you have not any in your team, then it's a dead-end.

There is another way: install KISv2 Apha3 :)  It allows dropping parts from the stock inventory to any kerbal. Alpha3 has a compatible mode for the carrier games.

Link to comment
Share on other sites

  • 4 weeks later...
On 5/4/2017 at 11:34 PM, Drew Kerman said:

Use this MM patch:

@PART[*]:HAS[~category[none],#tags[*cck*]]:FINAL
{
  @category = none
}

This will take any part that has a Community Category Kit tag and remove it from its original stock category and the second so you won't have dupes for KIS or any other mod that uses their own CCK tabs

Hello! Your patch still works, but the cardboard box is duplicated in two categories - "Eva items" and "Containers", even after applying this patch. Is there a way to remove this duplicate?

Edited by Grem
Link to comment
Share on other sites

11 hours ago, Grem said:

Hello! Your patch still works, but the cardboard box is duplicated in two categories - "Eva items" and "Containers", even after applying this patch. Is there a way to remove this duplicate?

Sounds like you need a separate patch to modify the tags for the box. Not playing right now, don't really know what box you're referring to

Link to comment
Share on other sites

On 1/6/2022 at 7:25 AM, darthgently said:

I know I have accepted the "suggested mods" when installing a mod without thinking it through.  Is it possible you installed more than just KIS?  I can't remember what the "suggested mods" are for KIS.  You can double check by sorting the main mod list by "installed data" and seeing what was installed when

By default I always uncheck all of the suggested mods...

Link to comment
Share on other sites

16 minutes ago, Michel Bartolone said:

By default I always uncheck all of the suggested mods...

Me too, but when I run into issues I double check by checking in CKAN as I described in the message you replied to.  But if you are sure, you are sure.  No point double checking

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...