Jump to content

[Minimum KSP version - 1.12] Kerbal Inventory System (KIS) v1.29


IgorZ
 Share

Recommended Posts

On 3/1/2022 at 12:57 PM, darthgently said:

Me too, but when I run into issues I double check by checking in CKAN as I described in the message you replied to.  But if you are sure, you are sure.  No point double checking

BTW, just for the record, it seems that something managed to corrupt my installed KSP base game, causing all sorts of issues, from decouplers firing when they shouldn't, to air intakes refusing to open.

I did a full reinstall, including BreakingGround, and ALL of the mods I had before, and I even copied over the saves directory, and all of my previously built ships (both SPH and VAB) and my problems all cleared up!

 

Link to comment
Share on other sites

5 hours ago, Michel Bartolone said:

BTW, just for the record, it seems that something managed to corrupt my installed KSP base game, causing all sorts of issues, from decouplers firing when they shouldn't, to air intakes refusing to open.

I did a full reinstall, including BreakingGround, and ALL of the mods I had before, and I even copied over the saves directory, and all of my previously built ships (both SPH and VAB) and my problems all cleared up!

 

It wouldn't be the first time that carpet bombing solved a problem.  Short of that, I had a good result just deleting ModuleManager cache file (can't remember the name) which forced it to regenerate. As I recall I had similar stability issues until I did that.  But it was pure blind voodoo and shotgunning in the dark.  I read that it worked for someone else for a completely different issue and so I tried it and it worked.   I would have suggested trying it if I'd remembered and knew you were going to reinstall completely.  Anyway, the point being, the corruption isn't always in the game .sfs file, nor in a particular mod, but can be in that MM cache file.  Apparently.  Again, all voodoo so far

Link to comment
Share on other sites

  • 1 month later...

I've tried installing KIS and KAS through ckan and manually, yet everytime I start up the game all the EVA items can't be placed into any inventory slot. Other things such as winches and many other items can be put into the inventory, but not the EVA items including the screwdriver and the wrench. I have other mods installed but the problem is so specific that I can't imagine it's a problem with another mod. I posted on the Kerbal forum on Steam and another person did a fresh download of KIS & KAS and ended up having the same problem.

Link to comment
Share on other sites

7 hours ago, felix MK said:

I've tried installing KIS and KAS through ckan and manually, yet everytime I start up the game all the EVA items can't be placed into any inventory slot. Other things such as winches and many other items can be put into the inventory, but not the EVA items including the screwdriver and the wrench. I have other mods installed but the problem is so specific that I can't imagine it's a problem with another mod. I posted on the Kerbal forum on Steam and another person did a fresh download of KIS & KAS and ended up having the same problem.

It sounds like you are trying to put KIS items into the new stock inventory slots.  What version of KSP?  Last I checked, just to be clear, most KIS items could only be placed in KIS inventory slots, not stock inventory slots.  KIS preceded the stock inventory system.  I know the mod dev was working on more integration between the two but as I recall, he was not able to get around some things being somewhat separate.  The two systems are quite different in how they work.   As a rule of thumb, avoid mixing stock and KIS inventory items and inventory (ok to have KIS installed, just don't put KIS items in stock inventory slots) and avoid mixing KIS construction with stock construction techniques until you get used to both separately (again, ok to have KIS installed, just don't try to grab a KIS item from KIS inventory during stock construction mode etc).  Then you can tackle the quirks of how they interact.  They can interact, but that is an ongoing project.   

Link to comment
Share on other sites

18 hours ago, darthgently said:

It sounds like you are trying to put KIS items into the new stock inventory slots.  What version of KSP?  Last I checked, just to be clear, most KIS items could only be placed in KIS inventory slots, not stock inventory slots.  KIS preceded the stock inventory system.  I know the mod dev was working on more integration between the two but as I recall, he was not able to get around some things being somewhat separate.  The two systems are quite different in how they work.   As a rule of thumb, avoid mixing stock and KIS inventory items and inventory (ok to have KIS installed, just don't put KIS items in stock inventory slots) and avoid mixing KIS construction with stock construction techniques until you get used to both separately (again, ok to have KIS installed, just don't try to grab a KIS item from KIS inventory during stock construction mode etc).  Then you can tackle the quirks of how they interact.  They can interact, but that is an ongoing project.   

my game is 1.12.   and i'm sure i just put it into KIS stock  like sc-62 .   but it still not work . :mellow:

Link to comment
Share on other sites

2 hours ago, felix MK said:

my game is 1.12.   and i'm sure i just put it into KIS stock  like sc-62 .   but it still not work . :mellow:

Could you give a screenshot, please? Or better a short video.

Link to comment
Share on other sites

6 minutes ago, felix MK said:

hi

there is another problem with eva repair,   like video, i have already put repair box into the eva backpack, but when i click the repair button ,why still remind me need 4 repair box?

http://www.fileconvoy.com/dfl.php?id=ga16f3bcc0375597e1000426876b335174c3f326975

The repair kits are part of the Stock inventory system, not KIS.  You need to have the repair kits in the kerbal's stock inventory slots (I think you can stack 4 of them in one stock slot).  If you right-click on the kerbal while in EVA you should see the kerbal's stock inventory slots in the pop-up window

Link to comment
Share on other sites

16 hours ago, darthgently said:

The repair kits are part of the Stock inventory system, not KIS.  You need to have the repair kits in the kerbal's stock inventory slots (I think you can stack 4 of them in one stock slot).  If you right-click on the kerbal while in EVA you should see the kerbal's stock inventory slots in the pop-up window

thank you i got it ,but why the repair kits can't remove into kerbal's stock from other stock such as SC-62 stock?

Link to comment
Share on other sites

4 hours ago, felix MK said:

thank you i got it ,but why the repair kits can't remove into kerbal's stock from other stock such as SC-62 stock?

I think I know what you mean, but not sure.  Because the two inventory systems were developed completely separately.  The repair functionality is tied to the stock inventory system, not KIS.  Some items can be taken out of KIS inventory using KIS "g" key and placed on ground or surface of craft, then grabbed (just click on it, no key press) using stock eva construction mode and placed into stock inventory slots.  You need to read how both KIS and Stock EVA Construction works and always keep in mind they were designed and implemented separately.   You should definitely look into how Stock Construction mode is entered/exited.  They are working together better with every KIS release

Link to comment
Share on other sites

  • 1 month later...
Posted (edited)

Is there a reason certain parts have the inventory sizes they have?

For example, both the ImC-800 and ImC-1500 have only 12 slots, but the SC-62 has 16.

I would think the ImC-1500 would more or less have double the slots of the 800, and maybe 3-4x the SC-62.

Edited by Phoenix84
Link to comment
Share on other sites

21 hours ago, Phoenix84 said:

Is there a reason certain parts have the inventory sizes they have?

For example, both the ImC-800 and ImC-1500 have only 12 slots, but the SC-62 has 16.

I would think the ImC-1500 would more or less have double the slots of the 800, and maybe 3-4x the SC-62.

Different parts were made at different time, so there may be some inconsistency. I was going to bring them in line one day... and never did it. In KISv2 it doesn't matter since the number of slots is only a GUI thing that can be changed interactively.

Link to comment
Share on other sites

51 minutes ago, IgorZ said:

Different parts were made at different time, so there may be some inconsistency. I was going to bring them in line one day... and never did it. In KISv2 it doesn't matter since the number of slots is only a GUI thing that can be changed interactively.

Thanks, now I don't feel so bad for making a MM patch to "fix" them. :cool:

I'm really looking forward to KISv2. It feels very "cheaty" right now to have two different inventories with unrelated volumes on the same part, and that's besides the lack of interaction between it and stock (which of course I don't blame you for one bit).

I noticed it's in alpha now, but I'm not feeling too confident to use it right now. I'll be keeping an eye on it though.

I recently picked up playing KSP again since before either DLC were released, but KIS and KAS were always my #1 and #2 mods.

Link to comment
Share on other sites

5 hours ago, Phoenix84 said:

I noticed it's in alpha now, but I'm not feeling too confident to use it right now. I'll be keeping an eye on it though.

I cannot recommend it for the carrier games as of now, but you can safely use it in the sandboxes.

Link to comment
Share on other sites

36 minutes ago, IgorZ said:

I cannot recommend it for the carrier games as of now, but you can safely use it in the sandboxes.

You mean career?

It's been so long since I've played anything but that mode. However if I have some time, I'll set up a sandbox instance for testing this. I'm a developer myself, so I understand the importance of testing, plus this is a very valuable mod for me. :D

Thanks for the information!

Link to comment
Share on other sites

  • 1 month later...

Hi,

I'm facing trouble trying to attach parts in EVA. I have a mission that is to attach an antenna to an old satellite. When trying to attach the antenna in space, I grab it and press 'H' on the target when having a wrench equipped, I ear the drill sound, but then nothing happens, the antenna is not attached and is back to the container inventory...
Any idea on what I'm doing wrong ?

Thanks.

Link to comment
Share on other sites

On 7/27/2022 at 7:09 AM, JM445 said:

Hi,

I'm facing trouble trying to attach parts in EVA. I have a mission that is to attach an antenna to an old satellite. When trying to attach the antenna in space, I grab it and press 'H' on the target when having a wrench equipped, I ear the drill sound, but then nothing happens, the antenna is not attached and is back to the container inventory...
Any idea on what I'm doing wrong ?

Thanks.

It's unusual behavior. Are you sure you're not mixing the stock and the KIS containers/behavior? Grabbing from KIS container is different from the stock one. If you're suer, please attach the logs so we could investigate (read here to learn how to get THE RIGHT logs).

Link to comment
Share on other sites

On 7/27/2022 at 10:09 AM, JM445 said:

Hi,

I'm facing trouble trying to attach parts in EVA. I have a mission that is to attach an antenna to an old satellite. When trying to attach the antenna in space, I grab it and press 'H' on the target when having a wrench equipped, I ear the drill sound, but then nothing happens, the antenna is not attached and is back to the container inventory...
Any idea on what I'm doing wrong ?

Thanks.

I use the "x" key to attach things, you might try that and see if it works

 

Link to comment
Share on other sites

  • 2 weeks later...

This is not a request for modder action, just documenting an odd interaction and a fix for anyone else affected. If, in KSP 1.8-1.9, you cannot store anything in a KIS container, and you have the USI Konstruction mod installed, delete GameData/UmbraSpaceIndustries/Patches/EVAConstructionTweaks.cfg

KIS used to prevent you storing any part with ModuleCargoPart in a container. This behaviour caused problems when 1.11 made a whole lot of parts have such a module. Ordinarily hence you wouldn't care in 1.9 - where the last compatible KIS version still does this - but that Konstruction patch adds a ModuleCargoPart to any part that doesn't have one, to make things work better with the stock inventory system in 1.11. Unfortunately it does it even in 1.9 and so then you can't store anything at all in a container.

Link to comment
Share on other sites

  • 2 weeks later...
On 8/9/2022 at 5:03 AM, damerell said:

This is not a request for modder action, just documenting an odd interaction and a fix for anyone else affected. If, in KSP 1.8-1.9, you cannot store anything in a KIS container, and you have the USI Konstruction mod installed, delete GameData/UmbraSpaceIndustries/Patches/EVAConstructionTweaks.cfg

KIS used to prevent you storing any part with ModuleCargoPart in a container. This behaviour caused problems when 1.11 made a whole lot of parts have such a module. Ordinarily hence you wouldn't care in 1.9 - where the last compatible KIS version still does this - but that Konstruction patch adds a ModuleCargoPart to any part that doesn't have one, to make things work better with the stock inventory system in 1.11. Unfortunately it does it even in 1.9 and so then you can't store anything at all in a container.

Hmm. I remember implementing a restriction to store ground experiments into KIS (due to they could not properly initialize when pulled out). However, I don't remember restricting any cargo part. What was your usecase? (Disclaimer: the old versions are not maintained, nor supported. But I'm curious).

Link to comment
Share on other sites

6 hours ago, IgorZ said:

Hmm. I remember implementing a restriction to store ground experiments into KIS (due to they could not properly initialize when pulled out). However, I don't remember restricting any cargo part. What was your usecase? (Disclaimer: the old versions are not maintained, nor supported. But I'm curious).

Commit def1487870e33081b4512dfac89150b259379960 does

    if (p.Modules.OfType<ModuleCargoPart>().Any()) {
      ScreenMessaging.ShowPriorityScreenMessage(CannotAddGroundSciencePartMsg);
      UISounds.PlayBipWrong();
      return null;
    }
 

My use case is being able to put anything in an inventory at all.

Link to comment
Share on other sites

17 hours ago, damerell said:

Commit def1487870e33081b4512dfac89150b259379960 does

    if (p.Modules.OfType<ModuleCargoPart>().Any()) {
      ScreenMessaging.ShowPriorityScreenMessage(CannotAddGroundSciencePartMsg);
      UISounds.PlayBipWrong();
      return null;
    }
 

My use case is being able to put anything in an inventory at all.

It's a very old version. Was fixed in scope of https://github.com/ihsoft/KIS/issues/374. Use version: "1.27 (December 23rd, 2020)"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...