Denko666

IXS Warpship Original Series

Recommended Posts

Hi there, tried this out yesterday. Looks good. One thing I noticed was that the parts are quite early in the tech tree (using CTT). IIRC they were mostly in the same tier as the Mammoth and other heavy chemical rocket engines. Might need to make sure they are unlocked very late, if not in the last node.

Otherwise, keep up the good work!

Share this post


Link to post
Share on other sites

I might contribute a part or two to this mod, I've been a fan of the concept since nasa did it. It definitely needs a centrifuge and perhaps a alternative redesign of the reactor core section. Mind if i re-use textures?

Share this post


Link to post
Share on other sites
48 minutes ago, SpaceMouse said:

I might contribute a part or two to this mod, I've been a fan of the concept since nasa did it. It definitely needs a centrifuge and perhaps a alternative redesign of the reactor core section. Mind if i re-use textures?

It's all open source so,  knock yourself out. 

I suggest you use github and issue a pull request. I can then add you as a contributor,  and we can keep everything within the same mod. 

16 hours ago, StarStreak2109 said:

Hi there, tried this out yesterday. Looks good. One thing I noticed was that the parts are quite early in the tech tree (using CTT). IIRC they were mostly in the same tier as the Mammoth and other heavy chemical rocket engines. Might need to make sure they are unlocked very late, if not in the last node.

Otherwise, keep up the good work!

To be honest i kind of forgot all about the tech trees. I'll look into making a CTT MM config by the time i'm done overhauling the resource chain consumption quircks. 

Share this post


Link to post
Share on other sites
6 hours ago, Denko666 said:

To be honest i kind of forgot all about the tech trees. I'll look into making a CTT MM config by the time i'm done overhauling the resource chain consumption quircks. 

That'd be awesome, so that this warp ship would be the ultimate goal of Kerbalkind to reach for the stars! :)

Share this post


Link to post
Share on other sites
On 17.10.2016 at 2:56 PM, pheenix99 said:

Anyone have any other recommendations for the space dock besides Keridian Dynamics? It doesn't appear that it's been updated and the thread seems dormant/dead. Now that EPL has been updated....I wanna build stuff.

 

Share this post


Link to post
Share on other sites
On 10/15/2016 at 1:43 AM, UAL002 said:

CKAN doesnt seem to force me to download roverdude's Albi drive as a dependency is that an error?

Hey UAL002,

No, it should definitively recommend both @RoverDude's Alcubierre Drive and Community Resource Pack.

I know the Community Resource Pack isn't recommended because i added it later on. And i haven't figured out how to add the dependency in CKAN

 

3 hours ago, Fendrin said:

 

Awesome Fenrir! I'll make a MM config that removes the docks in IXS Warpship OS when your mod is detected. Is that acceptable to you?

Share this post


Link to post
Share on other sites
16 hours ago, Denko666 said:

Awesome Fenrir! I'll make a MM config that removes the docks in IXS Warpship OS when your mod is detected. Is that acceptable to you?

Yes, sure. But I wonder if it won't cause problems. Vessels using the IXS version won't load anymore without them?

Share this post


Link to post
Share on other sites
1 minute ago, Fendrin said:

Yes, sure. But I wonder if it won't cause problems. Vessels using the IXS version won't load anymore without them?

Good point... 

Then, i think, we should either:

  • Merge the mods or
  • Pull in spacedocks into ixswarpshipos or
  • Remove the spacedock parts from ixswarpshipos and put spacedocks up as a suggested mod 

What's your feel on it?

Share this post


Link to post
Share on other sites

Well, regarding the IXS SpaceDocks, they are pretty not made for IXS. Most IXS WarpShips would feature the disc like command module at the front and one of the large thrusters at the rear of the ship. The docking port would most likely be in that black spot at the main hull, radial attached. A SpaceDock designed for that vessel would have at least some nodes which allow the easy attaching of a docking port fitting the main hull one. That was my initial motivation to manipulate their cfg files. The new OffworldShipYard SpaceDocks have that stack node but they still have the airlock like structure at the wrong place. Kerbals still need to EVA from a IXS to enter the SpaceDock. Maybe some more digging into ConnectedLivingSpace allows to restrict the transfer of Kerbals between certain stack nodes only, solving that problem.

Okay, my point is that those SpaceDocks are quite nice and useful for a lot of purposes and in combination with a lot of mods like Interstellar or the future series. But they are not quite IXS specific and thus I think they belong into their own mod.

A proper IXS SpaceDock might be open on both ends and have the Kerbal passable structures build into the sides.

47 minutes ago, Denko666 said:

Good point... 

Then, i think, we should either:

  • Merge the mods or
  • Pull in spacedocks into ixswarpshipos or
  • Remove the spacedock parts from ixswarpshipos and put spacedocks up as a suggested mod 

What's your feel on it?

I wouldn't make spacedock a suggested mode for ixswarphips until the ConnectedLivingSpace issue is fixed. Maybe even wait longer until there are new meshes and artwork for a more suited version around. I would remove the current ones from ixswarpships at some time in the future and mark them "deprecated" until then, like it is done in other mods I have seen.

Share this post


Link to post
Share on other sites
On ‎23‎/‎10‎/‎2016 at 9:24 AM, Fendrin said:

The docking port would most likely be in that black spot at the main hull, radial attached. A SpaceDock designed for that vessel would have at least some nodes which allow the easy attaching of a docking port fitting the main hull one. That was my initial motivation to manipulate their cfg files. The new OffworldShipYard SpaceDocks have that stack node but they still have the airlock like structure at the wrong place. Kerbals still need to EVA from a IXS to enter the SpaceDock. Maybe some more digging into ConnectedLivingSpace allows to restrict the transfer of Kerbals between certain stack nodes only, solving that problem.

A proper IXS SpaceDock might be open on both ends and have the Kerbal passable structures build into the sides.

This confirms it, there are need for more space docks! I will take action.

Also, the IXS is a very pretty mod indeed. I really appreciate the level of detail and effort that went into it's model and textures.

Share this post


Link to post
Share on other sites

Glad I didn't get too far into my 1.2 save before the spacedocks change went through, but also excited to see what the new mod adds in the future.

Share this post


Link to post
Share on other sites
11 minutes ago, kormer said:

Glad I didn't get too far into my 1.2 save before the spacedocks change went through, but also excited to see what the new mod adds in the future.

the spacedock files are not deleted, but archived in a .zip if you really need them, just unzip and you're good to go. the IDs do not clash with @FendrinSpacedocks. 

Edited by Denko666

Share this post


Link to post
Share on other sites

New version available: 0.4.0.4 (fixed) 

! New Directory Structure !

CKAN Users are advised to first remove the mod using CKAN, then go to your GameData directory in your KSP install and remove the WarpShip directory should it still be there. Then install the new version using CKAN

Users who manually update: Remove the WarpShip directory from your GameData directory in your KSP install and replace it with the IXSWarpShipOS directory that is in the .zip file

 

Direct download: https://www.dropbox.com/s/45umdx7cfn8a9me/IXSWarpShipOS-0.4.0.4-fixed.zip?dl=0

On Spacedock: 

Share this post


Link to post
Share on other sites

For some reason I am not getting any fire effects from the QV engine, there is thrust and it is working, just no visual. Did I break something or is that just not working at this time?

Share this post


Link to post
Share on other sites
3 hours ago, KCheese said:

For some reason I am not getting any fire effects from the QV engine, there is thrust and it is working, just no visual.

And it does not consume any electric charge :D

Share this post


Link to post
Share on other sites
5 hours ago, KCheese said:

For some reason I am not getting any fire effects from the QV engine, there is thrust and it is working, just no visual. Did I break something or is that just not working at this time?

My bad, seems i overlooked a couple paths when updating for the new directory.

You can find an updated version here: https://www.dropbox.com/s/44npgfbxdr7hm4m/IXSWarpShipOS-0.4.0.4-fixed.zip?dl=0

1 hour ago, RealGecko said:

And it does not consume any electric charge :D

Strange, it should be consuming 10 EC/s and 0.001 XenonGas/s (xenongas is a byproduct of the Exotic Matter generation, so you should never really run out)

Share this post


Link to post
Share on other sites

Wow quick response, you rock! Although I'm not sure if it fixed the fire issue, as it now says it consumes 127464.5 EC/Sec(Max.) and 12.746 Xenon/Sec. I'm not sure I can produce that much to check the fire, but I'll launch and see if it is really consuming that much.

Edit: Yep! The fire is there now, I saw it, for 0.000005 seconds, then my E/c was gone. Not sure if the reactor is working as intended either in the Main Hull.

Edited by KCheese
Update

Share this post


Link to post
Share on other sites
38 minutes ago, Denko666 said:

Strange, it should be consuming 10 EC/s and 0.001 XenonGas/s

Ok, looks like problem was in file downloaded from here.

On 09.11.2016 at 6:48 PM, Denko666 said:

That's not available now.

However file from new link makes everything cool: QV sucks EC like crazy :D:D:D

Edited by RealGecko

Share this post


Link to post
Share on other sites

can't make heads or tails of the ratio values. What i put in there is not what the game engine uses, there seems to be some kind of multiplier at play somewhere. 

I made a rough trial and error rebalance. It's not what i want it to be, but at least it is functional again.

Rebalanced version: https://www.dropbox.com/s/qw0dw33cy9oamto/IXSWarpShipOS-0.4.0.4-balancing.zip?dl=0

 

Share this post


Link to post
Share on other sites

Yes something weird is going on with the numbers. My TWR and SLT stats are all over the place while in VAB, even with rockets with no Warptech parts. Once I launch they seem fine. Shrug, thank you for your quick responses! Much appreciated.

Share this post


Link to post
Share on other sites

Reinstalled balancing patch, QV now showing as consuming 1274.645 EC/Sec and 127.465 Xenon/Sec. Not sure what the desired amounts are those digits are the same with a different decimal place. Desired or suspicious? I have no idea! :D

Share this post


Link to post
Share on other sites
12 hours ago, KCheese said:

Reinstalled balancing patch, QV now showing as consuming 1274.645 EC/Sec and 127.465 Xenon/Sec. Not sure what the desired amounts are those digits are the same with a different decimal place. Desired or suspicious? I have no idea! :D

That is actually as expected. Except, if you look in the QVEngine's config file, those are not the values i entered. But i'll take it for the time being. 

I'm still learning how modding works in KSP so... But i can 'disclose' ( :) ) that i'm working on a new part for the IXS and learning how to mod as i go.

 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.