linuxgurugamer

[1.5.1+] EVA Enhancements Continued

Recommended Posts

This is a revival/continuation of the old EVA Enhancements mod

The new version for KSP 1.4.1 has new dependencies

New Dependencies

CKAN has been updated to install the dependencies, if needed.

Patreon.png

https://www.patreon.com/linuxgurugamer

http://imgur.com/a/o33Xx

 

 

Current Features

  • Kerbal profession and level is now visible in the right-click action menu. No more wondering if Frolie Kerman is supposed to be an engineer or a scientist.
  • Pitch and roll can now be controlled with the keyboard. No more awkward mouse clicking and dragging... you can now do backflips and cartwheels on the Mun! By default the controls are mapped as follows:
     
  • Pitch Down - Alpha2
  • Pitch Up - X
  • Roll Left - Z
  • Roll Right - C

I have found these work well in conjunction with the standard WASDQE controls (while letting you keep your right hand on the mouse for camera control). If you wish to remap them you can use the "Settings" window, accessible from the stock application launcher or Blizzy78's toolbar.

  • the EVA "rotate on camera move" setting can now be toggled any time by hitting the SAS toggle (default T). Enabling it can make some EVA navigation a bit easier, but disabling it gives you more control.
  • jetpack power can now be modified any time through a slider in the EVA right-click action menu. Fuel usage is scaled accordingly.  Both max and fine control power can be modified.
  • the default and the fine control jetpack power level can be set via the "Settings" window.
  • precision controls can now be toggled using the same key as in normal flight mode (default is CapsLock). This automatically sets your jetpack power to 10% for finer control.
  • finally, some Nav Ball customizations for EVA mode. The throttle gauge will display your current jetpack power level between 0 and 100%. The RCS indicator will light to show your if jetpack is enabled.  (RCS indicator light is now a stock feature) The SAS indicator will light to show if "rotate on move" is enabled (only if the jetpack is on though).
  • Added setting to allow/disallow EVA kerbal from filling EVA propellent from the pod
  • Option to allow Navball follow kerbal on EVA
  • Added navball fix to settings screen
  • Added option to disable Navball markers on EVA
  • Added ability to use a modifier key with a regular key (but disables the ability to use the mod key by itself).  On Windows, the key is ALT
Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Any plans to make EVA utilize a limited amount of fuel available in the command pod, or alternatively having an option to disable the automatic EVA refuel?

Share this post


Link to post
Share on other sites
3 minutes ago, Flayer said:

Any plans to make EVA utilize a limited amount of fuel available in the command pod, or alternatively having an option to disable the automatic EVA refuel?

EvaFuel?

Share this post


Link to post
Share on other sites
1 hour ago, Flayer said:

Any plans to make EVA utilize a limited amount of fuel available in the command pod, or alternatively having an option to disable the automatic EVA refuel?

Not at this time, but go ahead and make a github issue

Since there is a mod specifically for that, I probably won't bother adding it.

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

You have the thruster power controlled by a right-click menu item; have you considered using the throttle controls instead (or in addition)?

BTW, THANK YOU for bring this back!

Share this post


Link to post
Share on other sites
2 hours ago, Ser said:

Oh thanks, I probably should have looked for myself since last time I hunted for one was over a year ago, my bad.

Share this post


Link to post
Share on other sites

Downloaded from Spacedock. The toolbar icon is a blank white square. Looking good otherwise, I've missed this mod for my EVAs :)

Share this post


Link to post
Share on other sites

Slight little goof - the link in CKAN points to the wrong location. It should be

http://forum.kerbalspaceprogram.com/index.php?/topic/149997-12-eva-enhancements-continued/

 

Share this post


Link to post
Share on other sites
10 hours ago, JeffreyCor said:

Downloaded from Spacedock. The toolbar icon is a blank white square. Looking good otherwise, I've missed this mod for my EVAs :)

Fixed

 

2 hours ago, doggonemess said:

Slight little goof - the link in CKAN points to the wrong location. It should be


http://forum.kerbalspaceprogram.com/index.php?/topic/149997-12-eva-enhancements-continued/

 

Fixed in Spacedock, CKAN will pick it up soon

Share this post


Link to post
Share on other sites

I love that this mod have been revived!!! I missed it in 1.1.3, and I even tried fixing it myself (failed that is!!!)

 

THANKS A LOT linuxgurugamer!

Share this post


Link to post
Share on other sites

I've always enjoyed this mod. Thanks for continuing. I have a possible suggestion,

After either pitching or rolling, the game automatically applies thrust to "correct/counter" the players RCS input. I should also mention that the stock game does this as well when you use the Q or E key while on EVA. This is an EXTREMELY annoying occurrence for anyone who wants full control of there kerbal on EVA. I assume some people who use this mod would agree.

If there was a way to turn this off, my immersive EVA experience would be complete... 

@linuxgurugamer I've seen you on several mod forum threads so I know your busy. I appreciate your consideration but understand you may not have time. Cheers

Share this post


Link to post
Share on other sites

The applied thrust is meant to stop your movement.  I'm not sure if that can be stopped, but I'll take a look.  it will ave to a configurable option, I don't want to change the current mode

Share this post


Link to post
Share on other sites
2 hours ago, linuxgurugamer said:

The applied thrust is meant to stop your movement.  I'm not sure if that can be stopped, but I'll take a look.  it will ave to a configurable option, I don't want to change the current mode

A configurable option would be perfect. Thanks for looking into it.

Share this post


Link to post
Share on other sites

I'd also like to mention that while using precision mode on eva, this auto applied thrust feature COMPLETELY fails after Q or E is used.

Share this post


Link to post
Share on other sites
1 hour ago, Gianni1122 said:

I'd also like to mention that while using precision mode on eva, this auto applied thrust feature COMPLETELY fails after Q or E is used.

Fails, as in it isn't applied, or it goes wonky, or what?

Share this post


Link to post
Share on other sites
17 minutes ago, linuxgurugamer said:

Fails, as in it isn't applied, or it goes wonky, or what?

Sorry. Fails as in it goes wonky. After Q or E input the kerbal endlessly tries to auto correct itself (unsuccessfully as far as I can tell)

To recreate, go eva, turn on rcs, turn on precision controls, rotate with Q/E, kerbal will-on its own-proceed to rotate left to right unable to correct/stabilize itself.

Just confirmed this occurs with EvaEnhancents added keys as well. Honestly you should just try it. Wonky is an understatement lol.

Edited by Gianni1122

Share this post


Link to post
Share on other sites

I'm at work right now, so this will help when I get home

Share this post


Link to post
Share on other sites
5 hours ago, Gianni1122 said:

I'd also like to mention that while using precision mode on eva, this auto applied thrust feature COMPLETELY fails after Q or E is used.

Ok.  What's happening is that the autocorrect code can't adjust for the low level of the thrusters.  If you simply go out of precision mode when done for a few seconds, it will work properly.

I don't think I can do anything about that, but I am going to look into seeing if I can disable that totally, especially when in precision mode.

Try increasing the Default Precision Jetpack Power to 50%, the 10% seems to be too low for the self-correcting code to deal with.  It worked for me at 50%

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Glad to have this back - It's nice to have full three-axis control of my Kerbals on EVA.

Share this post


Link to post
Share on other sites

I've found that the setting the EVA thrust level to 25% allows the auto-thrust to work properly.  That will be in the next update

Share this post


Link to post
Share on other sites
2 hours ago, linuxgurugamer said:

I don't think I can do anything about that, but I am going to look into seeing if I can disable that totally, especially when in precision mode.

Looking forward to seeing what you come up with.

 

2 hours ago, linuxgurugamer said:

I've found that the setting the EVA thrust level to 25% allows the auto-thrust to work properly.  That will be in the next update

I'll try dropping the limiter to 25. Cheers

Share this post


Link to post
Share on other sites

What I did notice is that if you spin too much while under power, then the game can get confused.  Just like a real person :-)

So what you do is to get out of Precision mode for a few seconds, then go back in

Beyond that, I spent a few hours on this last night, and unfortunately, the code is unavailable to mods, so you are going to have to live with this.

Sorry

Share this post


Link to post
Share on other sites
8 hours ago, linuxgurugamer said:

What I did notice is that if you spin too much while under power, then the game can get confused.  Just like a real person :-)

So what you do is to get out of Precision mode for a few seconds, then go back in

Beyond that, I spent a few hours on this last night, and unfortunately, the code is unavailable to mods, so you are going to have to live with this.

Sorry

Bummer :-/

I appreciate you having a look. I'm thoroughly enjoying the mods you're maintaining. 

Do you think I should I bother Squad about the game's inability to handle precision mode on eva?

Share this post


Link to post
Share on other sites

No, because that is a function of the mod, not normal EVA

Share this post


Link to post
Share on other sites

that going nuts and burning up all the mono on eva is a stock ksp thing. eva kerbals have like their own sas now so just hit the f button a time or two and it will quit doing ti. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now