linuxgurugamer

[1.6.1,.1.6.1,.1.7.2] EVA Enhancements Continued

Recommended Posts

1 hour ago, Jebs_SY said:

Yes, the log time switch can be seen here. Navball is auto-open and was switching via Haystack, if this matters.

I can observe further. Maybe is switching with haystack the / an issue.

The only thing there is the navball, I'll add a check and get out an update this evening

Share this post


Link to post
Share on other sites

New release, 0.1.6

  • Fixed nullref when switching to a scansat
     

Share this post


Link to post
Share on other sites

Is there a way to make the nav ball follow the Kerbal position, not the camera?

Share this post


Link to post
Share on other sites

Hey @linuxgurugamer, one thing that I think would make this way better is if it would be possible to enable "Locked" camera mode when running on EVA with SAS turned off (i.e. not automagically aligning the kerbal with the camera).

I have no idea if that's possible, but it occurs to me that would end up making the whole "point vessel at orbital normal to enable easy (dis)embarking" moot.

Right now when you cycle through the camera modes (with V) the closest you can get to this is "Chase" but that still has the cameral viewing normal as up all the time.

Thoughts?

Cheers!

Share this post


Link to post
Share on other sites
On 2/28/2017 at 7:51 PM, Teilnehmer said:

Is there a way to make the nav ball follow the Kerbal position, not the camera?

Are you saying it doesn't follow the kerbal now?

 

3 hours ago, stratvox said:

Hey @linuxgurugamer, one thing that I think would make this way better is if it would be possible to enable "Locked" camera mode when running on EVA with SAS turned off (i.e. not automagically aligning the kerbal with the camera).

I have no idea if that's possible, but it occurs to me that would end up making the whole "point vessel at orbital normal to enable easy (dis)embarking" moot.

Right now when you cycle through the camera modes (with V) the closest you can get to this is "Chase" but that still has the cameral viewing normal as up all the time.

This may be more of a question for some of the camera mods, not sure.  Nothing I can do about this now, anyway, busy with some other issues

Share this post


Link to post
Share on other sites
13 hours ago, linuxgurugamer said:

Are you saying it doesn't follow the kerbal now?

Exactly. I experience the same navball behavior as in stock:

  • When controlling a vessel, the navball doesn’t follow the camera. It follows the vessel.
  • But when controlling a Kerbal, the navball follows the camera, not the Kerbal.

Is it possible to make the navball follow the Kerbal?

Share this post


Link to post
Share on other sites

I see what you are talking about.  No idea, I'll look into it.

Share this post


Link to post
Share on other sites

Hi again!

I want to use LeftAlt + W/S/A/D instead of Alpha2, X, Z, C. Is it possible?

When I try to change Orbit/Surface, mouse click goes through the Navball and select other ship/Kerbal. Can it be fixed?

It seems you do not like my "Space brakes" idea. Should I count it as discarded? ;-)

Edited by Sebra

Share this post


Link to post
Share on other sites
8 hours ago, Sebra said:

Hi again!

I want to use LeftAlt + W/S/A/D instead of Alpha2, X, Z, C. Is it possible?

When I try to change Orbit/Surface, mouse click goes through the Navball and select other ship/Kerbal. Can it be fixed?

It seems you do not like my "Space brakes" idea. Should I count it as discarded? ;-)

See the OP for the key changing:

Quote

I have found these work well in conjunction with the standard WASDQE controls (while letting you keep your right hand on the mouse for camera control). If you wish to remap them you can use the "Settings" window, accessible from the stock application launcher or Blizzy78's toolbar.

The clickthrough is a KSP bug, nothing I can do about that.

Re. the space brakes, if you want to code it, I'll most likely merge it.  But nothing I'm going to do about it right now

Share this post


Link to post
Share on other sites

I cannot change controls to Alt+Key In "Settings". It's looks like it is impossible.

Share this post


Link to post
Share on other sites
On 3/6/2017 at 0:32 PM, Teilnehmer said:

Exactly. I experience the same navball behavior as in stock:

  • When controlling a vessel, the navball doesn’t follow the camera. It follows the vessel.
  • But when controlling a Kerbal, the navball follows the camera, not the Kerbal.

Is it possible to make the navball follow the Kerbal?

This is actually a KSP bug (confirmed by @sarbian), or quirk, if you like.

I have a fix for it, will get out an update with it later.

Share this post


Link to post
Share on other sites

New release, 0.1.7:

  •     Added fix to allow Navball follow kerbal on EVA
  •     Added navball fix to settings screen
  •     Updated toggle settings to be consistent with other settings

Share this post


Link to post
Share on other sites
4 hours ago, linuxgurugamer said:

This is actually a KSP bug (confirmed by @sarbian), or quirk, if you like.

I have a fix for it, will get out an update with it later.

 
 

Seems weird to call it a bug when it was a feature for the 1.0.5 update. Look under the navball header. For the record, I am glad you fixed squads "mistake" :wink:.

Edited by Svm420

Share this post


Link to post
Share on other sites
1 minute ago, Svm420 said:

Seems weird to call it a bug when it was a feature for the 1.0.5 update. Look under the navball header. For the record, I am glad you fixed squads "mistake" :wink:.

Interesting.  So now you can have it both ways :D

Share this post


Link to post
Share on other sites
Just now, linuxgurugamer said:

Interesting.  So now you can have it both ways :D

Thank you! I usually am not one for squads "improvments" :rolleyes:

Share this post


Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

Interesting.  So now you can have it both ways :D

With both settings NavBall follows camera, not Kerbal. :(

Share this post


Link to post
Share on other sites
3 minutes ago, Sebra said:

With both settings NavBall follows camera, not Kerbal. :(

Please uninstall it, delete the directory, restart CKAN and reinstall it.

Verify the correct version by looking at the .version file in the directory

I just installed it via CKAN again, had a problem so had to do what I just listed.

If it still isnt' working, log file and video, please

Share this post


Link to post
Share on other sites

Uninstalled, deleted, restarted, reinstalled. Now it works well.

But when it did not work, it still has that setting in settings. So it cannot be previous version.

Funniest part is NavBall wobbling like Kerbal head while he walks. :)

Share this post


Link to post
Share on other sites
11 minutes ago, Sebra said:

Uninstalled, deleted, restarted, reinstalled. Now it works well.

But when it did not work, it still has that setting in settings. So it cannot be previous version.

Funniest part is NavBall wobbling like Kerbal head while he walks. :)

strange, must have been something left over.  

Glad it's working, thanks

Share this post


Link to post
Share on other sites

Should NavBall show directions for Kerbals? Prograde and such...

It do not show them down on Kerbin.  But on orbit they move with camera, not with Kerbal!

Also NavBall HUD mod shows "front" direction for Kerbal, pointed down, where his feets. (just for info).

Edit:

How the EVA "rotate on camera move" should work? I turn it on (RCS on as well) and Kerbal do not rotate.

Also attempt to use SAS control by mouse give error for Engineer and Scientist, but Pilot get SAS status (shown by NavBall HUD), even if SAS control remain not lit.

Edited by Sebra

Share this post


Link to post
Share on other sites

I'll add an option to hide the markers while on EVA, but I can't totally recreate the Navball, there is too much hidden code.

 

7 hours ago, Sebra said:

Also attempt to use SAS control by mouse give error for Engineer and Scientist, but Pilot get SAS status (shown by NavBall HUD), even if SAS control remain not lit.

Please explain, i don't see any errors.

7 hours ago, Sebra said:

It do not show them down on Kerbin.  But on orbit they move with camera, not with Kerbal!

 

Actually, in orbit, they show the correct location since the kerbal is in orbit

Share this post


Link to post
Share on other sites
19 hours ago, Sebra said:

How the EVA "rotate on camera move" should work? I turn it on (RCS on as well) and Kerbal do not rotate.

Also attempt to use SAS control by mouse give error for Engineer and Scientist, but Pilot get SAS status (shown by NavBall HUD), even if SAS control remain not lit.

 

@Sebra Please explain what you are referring to, please.

What EVA "rotate on camera move"

 

I'm holding up the next release with the option to disable the NavHud markers until this evening, if you can explain the error, I'd like to fix it before releasing.

 

 

 

Share this post


Link to post
Share on other sites
On 12.3.2017 at 2:42 PM, linuxgurugamer said:

This is actually a KSP bug (confirmed by @sarbian), or quirk, if you like.

I have a fix for it, will get out an update with it later.

 

 

On 6.3.2017 at 7:32 PM, Teilnehmer said:

Exactly. I experience the same navball behavior as in stock:

  • When controlling a vessel, the navball doesn’t follow the camera. It follows the vessel.
  • But when controlling a Kerbal, the navball follows the camera, not the Kerbal.

this is not a bug but works as intended

this was mentioned in a vid of 1.0x relish promo as a new  enhancement of the kerbal UI

Edited by danielboro

Share this post


Link to post
Share on other sites
1 minute ago, danielboro said:

 

 

this is not a bug but works as intended

this was mentioned in a vid of 1.0x relish promo as an enhancement of the kerbal UI

and I mentioned this in an earlier post:  

However, the current developers seem to have a different way of looking at things.

 

Share this post


Link to post
Share on other sites
12 hours ago, linuxgurugamer said:
20 hours ago, Sebra said:

Also attempt to use SAS control by mouse give error for Engineer and Scientist, but Pilot get SAS status (shown by NavBall HUD), even if SAS control remain not lit.

Please explain, i don't see any errors.

tm1YjvS.jpg

Cannot enable SAS on non pilot Kerbal. It can be not related to your mod, just looks weird.
 

13 hours ago, linuxgurugamer said:

Actually, in orbit, they show the correct location since the kerbal is in orbit

 

They show correct locations if NavBall follows the camera. If NavBall follows Kerbal, pointers still follows the camera.

NavBall HUD is on to show real pointers.

7ICkesd.jpg

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.