linuxgurugamer

[1.6.1,.1.6.1,.1.7.2] EVA Enhancements Continued

Recommended Posts

19 hours ago, linuxgurugamer said:

@Jebs_SY

Here is a quick rebuild with the suggested change.  I haven't had time to test it out, but it should work.
Let me know how it goes

Thank you very much. Tested and works well, as it seems. :)

Share this post


Link to post
Share on other sites

KSP keeps bugging me that there is an update 1.12.1, but I don't see it on the GitHub releases.

Edited by DrPastah

Share this post


Link to post
Share on other sites
12 hours ago, DrPastah said:

KSP keeps bugging me that there is an update 1.12.1, but I don't see it on the GitHub releases.

 

Same here.  Not complaining (much), just letting you know it's not just you.

 

Share this post


Link to post
Share on other sites
14 hours ago, DrPastah said:

KSP keeps bugging me that there is an update 1.12.1, but I don't see it on the GitHub releases.

 

2 hours ago, Eric S said:

 

Same here.  Not complaining (much), just letting you know it's not just you.

 

Sorry, looks like I forgot to upload it to Github

Now uploaded

Share this post


Link to post
Share on other sites
On ‎2017‎-‎11‎-‎26 at 8:00 AM, linuxgurugamer said:

 

Sorry, looks like I forgot to upload it to Github

Now uploaded

Hi there.  I'm still getting this popup.  I run and install through CKAN.  Is this update somehow not migrating through the netkan?  Shall I bring this issue to the CKAN-thread?

Share this post


Link to post
Share on other sites
7 hours ago, MisterFister said:

Hi there.  I'm still getting this popup.  I run and install through CKAN.  Is this update somehow not migrating through the netkan?  Shall I bring this issue to the CKAN-thread?

I'll look into it, may take a day or so

8 hours ago, MisterFister said:

Hi there.  I'm still getting this popup.  I run and install through CKAN.  Is this update somehow not migrating through the netkan?  Shall I bring this issue to the CKAN-thread?

Refresh your CKAN, I just updated it to CKAN, apparently I missed that one.

 

Share this post


Link to post
Share on other sites

Hello @linuxgurugamer,
I am wondering if I should install this mod, but it seems that the functions of this mod have changed somewhat since the OP has been written. For example, there was some posts about the alt-key functionality on the page back which is not mentioned in the OP. Also, I think using caps-lock to enter precision mode and the lighting of the RCS toggle when the jet-pack is enabled are now stock features. Would you consider updating and rewriting the OP or could you point me to some more current documentation?

Share this post


Link to post
Share on other sites
4 hours ago, canisin said:

Hello @linuxgurugamer,
I am wondering if I should install this mod, but it seems that the functions of this mod have changed somewhat since the OP has been written. For example, there was some posts about the alt-key functionality on the page back which is not mentioned in the OP. Also, I think using caps-lock to enter precision mode and the lighting of the RCS toggle when the jet-pack is enabled are now stock features. Would you consider updating and rewriting the OP or could you point me to some more current documentation?

The changes were all minor, but I've updated the OP with them

Share this post


Link to post
Share on other sites
9 hours ago, linuxgurugamer said:

The changes were all minor, but I've updated the OP with them

Thanks a lot!!

Share this post


Link to post
Share on other sites

Hi, @linuxgurugamer !

1.This mod cannot remember "Use Stock Toolbar" setting. Always set it. I suppose you work on it.

2.

On 14.10.2016 at 8:25 PM, linuxgurugamer said:

Added ability to use a modifier key with a regular key (but disables the ability to use the mod key by itself).  On Windows, the key is ALT

I cannot use it. Alt key always set as control. Is it broken or I'm forgot how to?

3. How many mods still await your precious attention? I ask because 1.4.3. on the horizon. :o

Thanks for all your hard work!

Share this post


Link to post
Share on other sites
3 hours ago, Sebra said:

Hi, @linuxgurugamer !

1.This mod cannot remember "Use Stock Toolbar" setting. Always set it. I suppose you work on it.

2.

I cannot use it. Alt key always set as control. Is it broken or I'm forgot how to?

3. How many mods still await your precious attention? I ask because 1.4.3. on the horizon. :o

Thanks for all your hard work!

A log file would be helpful.

and, about 30 more mods to update

 

Share this post


Link to post
Share on other sites
23 hours ago, linuxgurugamer said:

A log file would be helpful.

https://www.dropbox.com/s/dnzubu4h7368642/output_log.txt?dl=0

Here is the log, I think. :)

In case it is important:

1.Launched simplest ship, set "Use Stock Toolbar" off, returned to KSC, back to ship, it is on.

2.Changing key show the key set. But if key is left Alt, then it show "Alt-Left Alt".

3.Username is not latin.

 

Edited by Sebra

Share this post


Link to post
Share on other sites
1 hour ago, Sebra said:

https://www.dropbox.com/s/dnzubu4h7368642/output_log.txt?dl=0

Here is the log, I think. :)

In case it is important:

1.Launched simplest ship, set "Use Stock Toolbar" off, returned to KSC, back to ship, it is on.

2.Changing key show the key set. But if key is left Alt, then it show "Alt-Left Alt".

3.Username is not latin.

 

The toolbar setting is going to be moved into the Toolbat Controller in the nbn ext update.

And I'll look into the alt  key

Share this post


Link to post
Share on other sites

New release, 0.1.13.1:

  • Updated to use the ToolbarController registration
  • Removed setting for blizzy from mod
  • Fixed ability to use the primary Modifier key in conjunction with another key

Share this post


Link to post
Share on other sites

Great mod, thank you for keeping it alive.

 

One question though, and I feel super stupid for asking this, but what or where is the stock application launcher mentioned in the OP, quoted below??

Thanks for the help

 

On 10/14/2016 at 7:25 PM, linuxgurugamer said:

 ...accessible from the stock application launcher or Blizzy78's toolbar...

 

Share this post


Link to post
Share on other sites
5 hours ago, Dafni said:

Great mod, thank you for keeping it alive.

 

One question though, and I feel super stupid for asking this, but what or where is the stock application launcher mentioned in the OP, quoted below??

Thanks for the help

 

 

That's the regular toolbar, located at either the bottom or side of the screen, depending on what scene you are in

Share this post


Link to post
Share on other sites

I'm not sure yet about what is happening (neither why), but EVAEnhancementsContinued is crashing 1.4.3 on a MacMini Mid 2011 and MacOS 10.12.6 . It's the real deal, EXC_SIGABRT inside an Unity DLL. i'm reasonably certain of the EVAEnhancementsContinued involvement on this problem because things started to work again after deleting it.

Since I managed to pinpoint the culprit (or the first victim) on this mess, instead of reporting on my full KSP install (with a lot of+ mods and the kitchen's sink installed), I will try to isolate further he issue on a specialized, dedicated installment. There's about 155 add-ons, mods or plugins on my GameData (and 33695 patches by MM), lots and lots of possible collateral effects.

If anyone else is also using MacOS, and had (or had not!) a crash using EVAEnhancementsContinued, please advise. Something is crashing Unity natively, and I think this must be sorted out somehow - at very least, I can had found a fault on Unity itself on some specific configurations (what would not be exactly a surprise, given the crappy GPUs Apple is used to use).

Share this post


Link to post
Share on other sites

If you are having problems, please try the following test:

  1. Make a new, clean install of KSP 1.4.3
  2. Using CKAN, install only EvaEnhancements and the dependencies
  3. Start the game, create a new game and get to the space center
  4. Exit the game, and check the log for errors
  5. Let me know the results
Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

If you are installing by hand, I've tested the following versions:

  • Click Through Blocker:   0.1.6.2
  • EVA Enhancements Continued:  0.1.13.1
  • Toolbar Controller: 0.1.6.5
Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Well, the good news and the terrible news.

The good news is that on a clean install the thing works, so it's unlikely that it's a bug on it.

The terrible news is that by using the same plugin versions used on the environment where the bug happens, nothing wrong happens neither.

I tested also on ToolbarControl 0.1.6.4 (ClickThroughBlocker was already updated on the faulty environment). Working as (not) expected.

God knows what exoteric and malevulous iteration from other mod would had caused the crash. =/

It was a consistent behaviour - once I manage to rebuilt the environment (I should had made a copy of that installment - lesson learnt), it happens deterministically.

Share this post


Link to post
Share on other sites

Well... On the 'bright' side, my KSP 1.4.3 installment still crashes with EVAe. =P

I'll backup the whole shebang (7.5G!) and get back to it later. I want to play now. :-)

(but definitively I want this on my day-to-day KSP - it would made my EVA considerably easier)

Edited by Lisias

Share this post


Link to post
Share on other sites
18 minutes ago, Lisias said:

Well... On the 'bright' side, my KSP 1.4.3 installment still crashes with EVAe. =P

I'll backup the whole shebang (7.5G!) and get back to it later. I want to play now. :-)

(but definitively I want this on my day-to-day KSP - it would made my EVA considerably easier)

If you used CKAN, could you get me a .ckan?  At least, a complete mod list would help in tracking this down

while not ideal, a log file will also provide me with a list.

 

I assume you have enough memory for this?

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
18 minutes ago, linuxgurugamer said:

If you used CKAN, could you get me a .ckan?  At least, a complete mod list would help in tracking this down

while not ideal, a log file will also provide me with a list.

I don't use CKAN. Got burn in the past with not so well maintained packages being automatically updated and breaking everything (not KSP itself, but the ecosystem is similar), so I prefer to manually update things - if something breaks, I know where to start the troubleshooting.

By the end of the day I post here (or to some other place you prefer) the modules and add-on list of my KSP.log.

18 minutes ago, linuxgurugamer said:

I assume you have enough memory for this?

Yes. :-)

My machine have 16G, and KSP is starting up with 6G now. Sometimes the process grows to 10 to 12G, but rarely crashes by lack of memory - I kill the process way before that, because MacOS is being developed by a bunch on monkeys that thinks that everybody uses a Tablet nowadays. and that memory compression thing makes the whole system incredibly sluggish.

I'm considering that perhaps I'm running out of VRAM - it's Unity that is issuing the exception, so it's Unity that would be receiving the Error Trap. But I installed (yet another) plugin since this, and the thing still works. This not rule out VRAM being exhausted, but this behaviour pattern suggests a bad interation between two subsystems - being triggered, only Turing knows why, by EVAe.

Edited by Lisias
lots of typos! I need more coffee!

Share this post


Link to post
Share on other sites
1 hour ago, Lisias said:

I don't use CKAN. Got burn in the past with not so well maintained packages being automatically updated and breaking everything (not KSP itself, but the ecosystem is similar), so I prefer to manually update things - if something breaks, I know where to start the troubleshooting.

By the end of the day I post here (or to some other place you prefer) the modules and add-on list of my KSP.log.

Yes. :-)

My machine have 16G, and KSP is starting up with 6G now. Sometimes the process grows to 10 to 12G, but rarely crashes by lack of memory - I kill the process way before that, because MacOS is being developed by a bunch on monkeys that thinks that everybody uses a Tablet nowadays. and that memory compression thing makes the whole system incredibly sluggish.

I'm considering that perhaps I'm running out of VRAM - it's Unity that is issuing the exception, so it's Unity that would be receiving the Error Trap. But I installed (yet another) plugin since this, and the thing still works. This not rule out VRAM being exhausted, but this behaviour pattern suggests a bad interation between two subsystems - being triggered, only Turing knows why, by EVAe.

Ok, I'll take a look, but in general, when Unity get exceptions like that, it's usually a memory issue.  Have you tried installing the Graphic Memory Monitor to see exactly what's going on?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.