allista

[1.9-1.10] Configurable Containers

Recommended Posts

For me, adding "VolumeConfigs.user" made it work, i guess in plugin code didn't account for starting from scratch. :)

I like the UI, hints explain everything and yellow highlight helps keep track of what is edited.

As for some of requests for alternate setups that match resource requirements for other mods - that may be partially solved by defining a tank setups by mod makers themselves.

If some XYZ LS mod needs food/water/oxygen, than an appropriate preset should be made either by mod author OR a player that needs this. BUT there is a difference to normal presets - these "source presets" (or "base presets" ?) should  not be deletable or editable, should be defined as MM patches that are active only if such mod is present in GameData. These presets are only used to generate initial tank setups that can be later edited and saved by player under a different name.

Share this post


Link to post
Share on other sites
4 hours ago, Michel Bartolone said:

File 'H:/KSP_1.9.1_w_BG1.4.1 W_all_mods/KSP_x64_Data/../GameData\ConfigurableContainers\VolumeConfigs.user' does not exist

This looks fishy indeed. I'll look through the full log tomorrow. But paths are created using Path.Combine, so the separator is os-specific. What is strange is that the KSPUtil.ApllicationRootPath (the part before ..) has non-native separators.

Anyways, double check that the file is named correctly and located where it is searched for.

Share this post


Link to post
Share on other sites
1 hour ago, fatcargo said:

If some XYZ LS mod needs food/water/oxygen, than an appropriate preset should be made either by mod author OR a player that needs this. BUT there is a difference to normal presets - these "source presets" (or "base presets" ?) should  not be deletable or editable, should be defined as MM patches that are active only if such mod is present in GameData. These presets are only used to generate initial tank setups that can be later edited and saved by player under a different name.

This is exactly how it works now:

https://www.github.com/allista/AT_Utils/tree/master/GameData%2F000_AT_Utils%2FTankConfigs.cfg

These are non-deletable, non-editable presets provided by users and included into distribution as MM patches.

Share this post


Link to post
Share on other sites

Adding the VolumeConfigs.user file fixed the issue on my side.

Sorry for not sharing the full logs. I'll do next time.

Thanks again for your amazing job Allista!!! And also to Linux :)

Share this post


Link to post
Share on other sites
Posted (edited)

While I've be able to edit/change tank contents with the proposed patch with an unmodded KSP (that is, except for CC and it's dependencies), as soon as I reinstalled all my other dependencies (quite a lot...) editing a tank with CC caused the whole part UI to totally disappear after the 1st tank edit... Unfortunately I've lost the Player.log by mistake. I'll try reproducing this issue this evening, checking it's still working with the previous version + the same other mods and uploading the logs.

Stay tuned ;)

Edited by Brimarx

Share this post


Link to post
Share on other sites

I just tested again and the issue did not occur this time. Maybe the 1st install had some issue, maybe it's random. Should it happen again I'll report it back and upload the logs.

Thanks again for your amazing job!

Share this post


Link to post
Share on other sites
2 hours ago, Nicky21 said:

I'm gettign an error. When i click the Edit tanks button on any of the tanks nothing happens.

This screenshot should help a bit.
https://imgur.com/a/89D3pL9

1.10, fresh install.

 

Share this post


Link to post
Share on other sites

"VolumeConfigs.user" How does one make a .user file at all? Sorry I really don't know.

Share this post


Link to post
Share on other sites
1 hour ago, Xithyl515 said:

"VolumeConfigs.user" How does one make a .user file at all? Sorry I really don't know.

It's just a name. It's a text file with the content described above. There's no extensions, not anymore. Dots are just characters of the file name.

Share this post


Link to post
Share on other sites

Allista, just commenting here to thank you, dude. Thank you for your mods and the work you do to keep it updated even after all these years

Share this post


Link to post
Share on other sites

When I compared what I got via CKAN and what I DLd via Space dock there was at least one missing config file from Configurable Containers in the AT-Utils folder.

Sorry for getting Stroppy earlier I was running short on sleep.

Share this post


Link to post
Share on other sites
On 7/24/2020 at 2:07 PM, allista said:

This looks fishy indeed. I'll look through the full log tomorrow. But paths are created using Path.Combine, so the separator is os-specific. What is strange is that the KSPUtil.ApllicationRootPath (the part before ..) has non-native separators.

Anyways, double check that the file is named correctly and located where it is searched for.

I think this looks like it should:

https://www.dropbox.com/s/twiu6117qbpfblo/fileConfirmation..JPG?dl=0

 

Share this post


Link to post
Share on other sites
3 hours ago, allista said:

Indeed. Anyways, I hope to release the fix today.

Thanks for confirming that it looks right.

 

Share this post


Link to post
Share on other sites
Posted (edited)

Bug, maybe. I'm not sure that it's related to configurable containers, but my gut sais so.
Ksp 1.10, fresh install. Lots of mods installed, but the relevant ones are CC and tweakscale.

I think configurable contaners messes with scaled up fuel tanks. For instance i took standard F-LT800 fuel tank and scaled it up from 1.25 to 1.875. Its capacity didn't change. When scaled down, however, its capacity changed.

pic:
https://imgur.com/a/mzMyqvm

edit: when checking the volume used in the tank, I found that after the first tweakscale there is a lot of empty unalocated volume. After manualy realocating it, the fuel tank now holds 1100 lfo.


-----


Second bug (this has been around for a long time)

When copying a tweakscaled fuel tank using ALT-CLICK, its voluem does not copy corectly. For instance in the pimage, teh corect volume is 8.5, but the copied version has 14.7 m3.

pic:
https://imgur.com/a/edWVpjY

 

Edited by Nicky21

Share this post


Link to post
Share on other sites

Hi, I tried to scale up an ore container to 3.75 meters for materialkits. It was empty and the ore container cost 100k funds?? But when I filled up a fuel tank of the same size with material kits, it was 75% cheaper. Also, when I try to load specialized parts into containers, it seems to break my GUI until I exit the build mode and come back into it. Does anyone recommend a container mod?

Share this post


Link to post
Share on other sites
23 hours ago, Nicky21 said:

Bug, maybe. I'm not sure that it's related to configurable containers, but my gut sais so.
Ksp 1.10, fresh install. Lots of mods installed, but the relevant ones are CC and tweakscale.

I think configurable contaners messes with scaled up fuel tanks. For instance i took standard F-LT800 fuel tank and scaled it up from 1.25 to 1.875. Its capacity didn't change. When scaled down, however, its capacity changed.

pic:
https://imgur.com/a/mzMyqvm

edit: when checking the volume used in the tank, I found that after the first tweakscale there is a lot of empty unalocated volume. After manualy realocating it, the fuel tank now holds 1100 lfo.


-----


Second bug (this has been around for a long time)

When copying a tweakscaled fuel tank using ALT-CLICK, its voluem does not copy corectly. For instance in the pimage, teh corect volume is 8.5, but the copied version has 14.7 m3.

pic:
https://imgur.com/a/edWVpjY

Found and fixed both issues.

Thanks a lot! :cool:

Share this post


Link to post
Share on other sites

Given the message above from Allista about finding and fixing both issues, perhaps I shouldn't bother, but...I found out why the VolumeConfigs.user was not working for me...there was a hidden .txt extension added to the file name by my system. That having been said, when I fixed that and tried it, I got the new GUI, but I'm having issues actually editing the tank. I get the tank editor popup, I delete the existing contents and attempt to then add a tank that is 15% Monopropellant, but it says there is no space for it. If I add 1%, it added fine. I tried several more times and got the same result. When I exited from that (since it wasn't working for me) and tried to build a new ship and edit the tanks, I was back to the 'nothing happens' when I click "Edit Tanks". I went and checked and while the file was there and still named correctly, it now had zero contents.

Hopefully I'll have the new version shortly.

Share this post


Link to post
Share on other sites

By the default topic msg, it doesnt work on Tundra addon.

Any update on it?

Thank you

Share this post


Link to post
Share on other sites

Not pushing, just setting my own expectations, when might we see the fixes released on CKAN (or on GitHub). If you say a half day, that's fine. If you say a week, that's also fine. As I said, just trying to set my own expectations.

 

Share this post


Link to post
Share on other sites
2 hours ago, Michel Bartolone said:

Not pushing, just setting my own expectations, when might we see the fixes released on CKAN (or on GitHub). If you say a half day, that's fine. If you say a week, that's also fine. As I said, just trying to set my own expectations.

Tried to release yesterday, but during final checks found a nasty issue with symmetry counterparts.

So let's say, if all goes well, then tonight. If not, tomorrow night, bugs or not; because then I'll be absent for two weeks...

Share this post


Link to post
Share on other sites
2 hours ago, allista said:

Tried to release yesterday, but during final checks found a nasty issue with symmetry counterparts.

So let's say, if all goes well, then tonight. If not, tomorrow night, bugs or not; because then I'll be absent for two weeks...

Thanks much for setting reasonable (on my part) expectations. Assuming you're going on vacation for 2 weeks, have a great time!

 

Share this post


Link to post
Share on other sites
17 hours ago, skzbr said:

By the default topic msg, it doesnt work on Tundra addon.

Any update on it?

Thank you

They're configs are a complicated webwork of MM patches that fine-tune features with numerous custom B9 tank types. Converting it to CC without upsetting the balance would be an enormous, if not impossible undertaking.

For one, I doubt tanks masses (and hence TWR) could be made the same.

@damonvv if you're interested, I'd be glad to help, or get help from someone from tundra world. If not, I really don't see the big reason for this.

Share this post


Link to post
Share on other sites
Posted (edited)
30 minutes ago, allista said:

They're configs are a complicated webwork of MM patches that fine-tune features with numerous custom B9 tank types. Converting it to CC without upsetting the balance would be an enormous, if not impossible undertaking.

For one, I doubt tanks masses (and hence TWR) could be made the same.

@damonvv if you're interested, I'd be glad to help, or get help from someone from tundra world. If not, I really don't see the big reason for this.

I think @JadeOfMaar is more home with MM and B9 tank types. He usually does that work for me (which I am grateful for :)). Maybe he can help. On the TE page I'd have a discord linked if you want more information!

Edited by damonvv

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.