allista

[1.9-1.10] Configurable Containers

Recommended Posts

18 minutes ago, damonvv said:

I think @JadeOfMaar is more home with MM and B9 tank types. He usually does that work for me (which I am grateful for :)). Maybe he can help. On the TE page I'd have a discord linked if you want more information!

Thanks!

I'll contact Jade then. He already made CC patches for OPT, so we'll probably manage to do it.

Share this post


Link to post
Share on other sites

Version 2.6.1 for Kerbal Space Program 1.10.0

Released on 2020-07-30

  • Parts
    • Hangar: allow surface attachment of all the containers
  • Fixed CC behaviour in symmetry groups
  • Fixed resource amount update when tank volume is changed (by APR or TweakScale)
  • Fixed part cloning when the part is resized by TweakScale
  • Fixed UI not showing when the VolumeConfigs.user file is absent
  • Using bundle shipped with AT_Utils

 Download (320.19 KiB) 

Share this post


Link to post
Share on other sites
19 hours ago, allista said:

Version 2.6.1 for Kerbal Space Program 1.10.0

Released on 2020-07-30

  • Parts
    • Hangar: allow surface attachment of all the containers
  • Fixed CC behaviour in symmetry groups
  • Fixed resource amount update when tank volume is changed (by APR or TweakScale)
  • Fixed part cloning when the part is resized by TweakScale
  • Fixed UI not showing when the VolumeConfigs.user file is absent
  • Using bundle shipped with AT_Utils

 Download (320.19 KiB) 

Hmm...this was released for 1.10.0, and I think it should probably work for 1.9.1, but for me, it isn't working. If anything this made things worse.

Where, on the previous version, adding the VolumeConfigs.user at least let me add a 1% of anything, after removing the existing tanks, the newest version does give me the popup, BUT, the tank is empty, and I can't add anything to it.

I've tried doing an uninstall of ConfigurableContainers (and the things CKAN said should go away with it) and then a re-install, then added the VolumeConfigs.user, with the contents described previously, and I verified the file name is correct (no phantom .txt extension) and I still can't do anything.

I click on the edit tanks button, and the gui comes up, but, as mentioned above, the existing tank shows as empty, and I can't add anything to it.

I'm attaching the various player.log files.

I know Allista is away for a couple of weeks...so I MAY go and try to build a whole new 1.9.1 installation, and try installing only ConfigurableContainers to that, to see if it works or not from fresh.

Here are the player.log files at various points in the re-install process:
https://www.dropbox.com/s/zml75tnfbq1z8r0/Player after CC Reinstall.log?dl=0
https://www.dropbox.com/s/i4ic64sq4kdzs44/Player after CC uninstall.log?dl=0

https://www.dropbox.com/s/di6ngmh4qwlpqvg/Player after reinstall and replacement of VolumeConfig.user content.log?dl=0

https://www.dropbox.com/s/33sehcjvors5k0n/Player before CC Reinstall.log?dl=0

Share this post


Link to post
Share on other sites
34 minutes ago, Michel Bartolone said:

Hmm...this was released for 1.10.0, and I think it should probably work for 1.9.1, but for me, it isn't working. If anything this made things worse.

Where, on the previous version, adding the VolumeConfigs.user at least let me add a 1% of anything, after removing the existing tanks, the newest version does give me the popup, BUT, the tank is empty, and I can't add anything to it.

I've tried doing an uninstall of ConfigurableContainers (and the things CKAN said should go away with it) and then a re-install, then added the VolumeConfigs.user, with the contents described previously, and I verified the file name is correct (no phantom .txt extension) and I still can't do anything.

I click on the edit tanks button, and the gui comes up, but, as mentioned above, the existing tank shows as empty, and I can't add anything to it.

I'm attaching the various player.log files.

I know Allista is away for a couple of weeks...so I MAY go and try to build a whole new 1.9.1 installation, and try installing only ConfigurableContainers to that, to see if it works or not from fresh.

Here are the player.log files at various points in the re-install process:
https://www.dropbox.com/s/zml75tnfbq1z8r0/Player after CC Reinstall.log?dl=0
https://www.dropbox.com/s/i4ic64sq4kdzs44/Player after CC uninstall.log?dl=0

https://www.dropbox.com/s/di6ngmh4qwlpqvg/Player after reinstall and replacement of VolumeConfig.user content.log?dl=0

https://www.dropbox.com/s/33sehcjvors5k0n/Player before CC Reinstall.log?dl=0

Unfortunately even with Dropbox app I cannot download your files. Please, zip them.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, allista said:

Unfortunately even with Dropbox app I cannot download your files. Please, zip them.

I'll do that shortly, but...I just did a clean install of KSP 1.9.1, and then installed ConfigurableContainers, its dependencies and the couple of suggested mods. Nothing else. I started a new SB game in that instance, and I get the same result...I get an edit button, I get the popup, but the tank is shown as empty, and I cannot add anything to it. That log is here: https://www.dropbox.com/s/88qw9ebvxk3movg/Player.zip?dl=0

 

The other logs are now in this zip file:
https://www.dropbox.com/s/q1ane5zanekcxwz/KSP_player_logs.zip?dl=0

 

Edited by Michel Bartolone

Share this post


Link to post
Share on other sites
Posted (edited)
17 minutes ago, Michel Bartolone said:

I'll do that shortly, but...I just did a clean install of KSP 1.9.1, and then installed ConfigurableContainers, its dependencies and the couple of suggested mods. Nothing else. I started a new SB game in that instance, and I get the same result...I get an edit button, I get the popup, but the tank is shown as empty, and I cannot add anything to it. That log is here: https://www.dropbox.com/s/88qw9ebvxk3movg/Player.zip?dl=0

 

The other logs are now in this zip file:
https://www.dropbox.com/s/q1ane5zanekcxwz/KSP_player_logs.zip?dl=0

Alas, it seems the 2.6.1 isn't compatible with KSP 1.9.1 after all due to API changes I had no idea about. :(

Spoiler

Module ModuleTankManager threw during OnStart: System.MissingFieldException: Field 'UIPartActionController.hiddenWindows' not found.

 

And KSP 1.10.1 is already released :confused:

Edited by allista

Share this post


Link to post
Share on other sites
2 hours ago, allista said:

Alas, it seems the 2.6.1 isn't compatible with KSP 1.9.1 after all due to API changes I had no idea about. :(

  Hide contents

Module ModuleTankManager threw during OnStart: System.MissingFieldException: Field 'UIPartActionController.hiddenWindows' not found.

 

Oh well...not your fault...I'll just have to stop playing for a while. A couple of other mods that are critical to the way I play are not yet available for 1.10.x (and I'm not sure when they will be).

 

Share this post


Link to post
Share on other sites
3 minutes ago, Michel Bartolone said:

Oh well...not your fault...I'll just have to stop playing for a while. A couple of other mods that are critical to the way I play are not yet available for 1.10.x (and I'm not sure when they will be).

 

The problem is with testing. KSP loads so slow that checking everything on more than one version is beyond my capacity and available time.

I really wish I could have some QA automation, some smoke tests that would at least check that everything loads without errors in the log. But not with 3D games...

Share this post


Link to post
Share on other sites
3 hours ago, allista said:

The problem is with testing. KSP loads so slow that checking everything on more than one version is beyond my capacity and available time.

I really wish I could have some QA automation, some smoke tests that would at least check that everything loads without errors in the log. But not with 3D games...

Oh I get that...I work in IT (for most of the last 40 years). Not beating up on you at all! I'll see about rolling back to the most recent version that worked for me.

Share this post


Link to post
Share on other sites
On 7/29/2020 at 5:09 AM, skzbr said:

By the default topic msg, it doesnt work on Tundra addon.

Any update on it?

Thank you

@JadeOfMaar is awesome beyond measure and has already made the patches for Tundra, which you can obtain from master branch on github:

https://github.com/damonvv/TundraExploration

They need to be tested, though, before they could be released. So we kindly ask you to try them out.

Share this post


Link to post
Share on other sites

I just wanted to post to give you a thumbs up on your changes to the interface for Configurable Containers. I never realized how annoying the previous interface was until you improved it. :D

Share this post


Link to post
Share on other sites
Posted (edited)

I have the same issues as @Michel Bartolone with the latest release and KSP 1.9.1.

@allista I guess you should mark the 2.6.x releases as compatible with KSP 1.10 only and stop bothering with KSP 1.9.x ;) 

 

Edited by Brimarx

Share this post


Link to post
Share on other sites
11 hours ago, Brimarx said:

I have the same issues as @Michel Bartolone with the latest release and KSP 1.9.1.

@allista I guess you should mark the 2.6.x releases as compatible with KSP 1.10 only and stop bothering with KSP 1.9.x ;) 

 

Unfortunately there's no way to mark it but to make another release with the next version number. SpaceDock+CKAN work that way.

1 hour ago, Tv1st said:

Hi, I have some problem with Configurable Containers,  KSP 1.9.1    mod 2.6.0

https://imgur.com/gallery/0HVNklU

if I delete the mod, then the containers become stock

Thanks, I'll check this out when I'm back.

Share this post


Link to post
Share on other sites
5 hours ago, Tv1st said:

Hi, I have some problem with Configurable Containers,  KSP 1.9.1    mod 2.6.0

https://imgur.com/gallery/0HVNklU

if I delete the mod, then the containers become stock

You have the same problem: AT_Utils-1.9.6+CC-2.6.1 doesn't work with KSP-1.9.1

The exception you show only occurs with these versions.

Share this post


Link to post
Share on other sites

Sort of bug ??? This is a weird one.
 

I try transfering fuel between 2 big tanks. Sometimes it works, sometimes it doesn't. I try tranfering fuel between other tanks; same. It sometimes works, it sometimes doesn't. This happens in the same session, seconds apart.

I try transfering monopropellant between a reserve tank to the 2 cockpits that my craft has. One cockpit accepts teh fuel, one does not !!!

I try enabling / disabling "Resource tranfer obeys crossfeed rules". No effect. F5-F9. No effect.

This is where it gets even weirder. I start a monopropelant tranfer from a reserve tank to a cockpit. Those take a while but it's slowly filling. I right click and close both windows. Normaly the transfer should be interupted at this point. I click a second later on the cockpit, it STILL slowly filling with monopropellant !!!

The debug log throws no errors. I took some pictures, but they are completely relevant. This one shows teh cockpit still filling up from a different tank than the one i have on screen (https://imgur.com/a/UKrOCOQ)

At this point i'm not exactly sure this is related to CC. I have no idea what triggers this bug.

Share this post


Link to post
Share on other sites

Things have changed a bit for me. First, I backed out CC completely from my 1.9.1 install via ckan, so it removed AT-Utils as well. Verified that tank looked normal. from the command line, I installed CC 2.5.0.1. I still can't edit the tanks...I get the new GUI?! 

Next, I noticed that the one other mod that was keeping me from moving to 1.10.1, had been updated. So I removed CC from 1.9.1, made a copy to upgrade to 1.10.1, and did that upgrade, including installing the BG DLC latest version, then went into CKAN, upgraded the mods I needed to upgrade, and installed CC. OK, it works...sort of.

I have the edit tank button, I click it and get the new gui. I delete the existing tanks, I attempt to add 20% battery and it turns the value red and greys out the (+) button.

I tried 1% and that was still valid, so I changed the value to 2%, kept that up, to 4% and it still worked, but I can't seem to get it to let me enter a value greater than 4%, _unless_ I click (MAX)...or (1/2). So I played with that a bit. I can only input values up to 4%, but if I add a 4% monoprop tank and 4% battery, and then do (max) LFO, and exit the gui, that is what I have....but if I then do edit tanks, remove the mp tank and add a liquid chem tank using (1/2), it only attempts to add a tank with 1/2 of the remaining volume. I think that is correct. Using the 1/2 button and various config changes (delete, add 1/2, add something else with max, remove the one set to 1/2, add the same using 1/2, add something else using MAX etc) I can make a tank that is close to what I want, it is just a bit clumsier than being able to set the units to % and putting in the sizes I want.

Share this post


Link to post
Share on other sites
13 hours ago, Michel Bartolone said:

Things have changed a bit for me. First, I backed out CC completely from my 1.9.1 install via ckan, so it removed AT-Utils as well. Verified that tank looked normal. from the command line, I installed CC 2.5.0.1. I still can't edit the tanks...I get the new GUI?! 

Next, I noticed that the one other mod that was keeping me from moving to 1.10.1, had been updated. So I removed CC from 1.9.1, made a copy to upgrade to 1.10.1, and did that upgrade, including installing the BG DLC latest version, then went into CKAN, upgraded the mods I needed to upgrade, and installed CC. OK, it works...sort of.

I have the edit tank button, I click it and get the new gui. I delete the existing tanks, I attempt to add 20% battery and it turns the value red and greys out the (+) button.

I tried 1% and that was still valid, so I changed the value to 2%, kept that up, to 4% and it still worked, but I can't seem to get it to let me enter a value greater than 4%, _unless_ I click (MAX)...or (1/2). So I played with that a bit. I can only input values up to 4%, but if I add a 4% monoprop tank and 4% battery, and then do (max) LFO, and exit the gui, that is what I have....but if I then do edit tanks, remove the mp tank and add a liquid chem tank using (1/2), it only attempts to add a tank with 1/2 of the remaining volume. I think that is correct. Using the 1/2 button and various config changes (delete, add 1/2, add something else with max, remove the one set to 1/2, add the same using 1/2, add something else using MAX etc) I can make a tank that is close to what I want, it is just a bit clumsier than being able to set the units to % and putting in the sizes I want.

I'm not in a place in my game where I can double check, but are you sure you're entering a percentage, and not a value in liters? I seem to recall everything working in tank volume rather than percentages...

Share this post


Link to post
Share on other sites
23 hours ago, etmoonshade said:

I'm not in a place in my game where I can double check, but are you sure you're entering a percentage, and not a value in liters? I seem to recall everything working in tank volume rather than percentages...

Yes, I am sure I'm entering percentage. I click on the m3 to switch it to % before I try entering numbers

 

Share this post


Link to post
Share on other sites
On 8/2/2020 at 5:39 PM, Michel Bartolone said:

Things have changed a bit for me. First, I backed out CC completely from my 1.9.1 install via ckan, so it removed AT-Utils as well. Verified that tank looked normal. from the command line, I installed CC 2.5.0.1. I still can't edit the tanks...I get the new GUI?! 

Next, I noticed that the one other mod that was keeping me from moving to 1.10.1, had been updated. So I removed CC from 1.9.1, made a copy to upgrade to 1.10.1, and did that upgrade, including installing the BG DLC latest version, then went into CKAN, upgraded the mods I needed to upgrade, and installed CC. OK, it works...sort of.

I have the edit tank button, I click it and get the new gui. I delete the existing tanks, I attempt to add 20% battery and it turns the value red and greys out the (+) button.

I tried 1% and that was still valid, so I changed the value to 2%, kept that up, to 4% and it still worked, but I can't seem to get it to let me enter a value greater than 4%, _unless_ I click (MAX)...or (1/2). So I played with that a bit. I can only input values up to 4%, but if I add a 4% monoprop tank and 4% battery, and then do (max) LFO, and exit the gui, that is what I have....but if I then do edit tanks, remove the mp tank and add a liquid chem tank using (1/2), it only attempts to add a tank with 1/2 of the remaining volume. I think that is correct. Using the 1/2 button and various config changes (delete, add 1/2, add something else with max, remove the one set to 1/2, add the same using 1/2, add something else using MAX etc) I can make a tank that is close to what I want, it is just a bit clumsier than being able to set the units to % and putting in the sizes I want.

 

12 hours ago, Michel Bartolone said:

Yes, I am sure I'm entering percentage. I click on the m3 to switch it to % before I try entering numbers

 

So, today I learned... :D

I've never used the percentages function before, but it looks like the error checking is bad in some way. If you enter a percentage, click the % back to m3, and remove/readd a number, the number will go white. So I guess that's a workaround at least...

 

 

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, etmoonshade said:

 

So, today I learned... :D

I've never used the percentages function before, but it looks like the error checking is bad in some way. If you enter a percentage, click the % back to m3, and remove/readd a number, the number will go white. So I guess that's a workaround at least...

Crowd QA in action :cool:

Thanks a lot folks!

Tracker issue:

https://github.com/allista/ConfigurableContainers/issues/39

Edited by allista

Share this post


Link to post
Share on other sites
8 minutes ago, allista said:

Thanks a lot!

But wait, how would it help? Doesn't CKAN use .version file from distribution archive rather than from the repo itself?

If the .version file has a "URL" property that points to an online copy of itself, that version is used instead (if the VERSION properties match), so you can make updates after release.

https://github.com/KSP-CKAN/CKAN/blob/f0f02d68f52603c3c43295f94b5d942c93cd60f4/Netkan/Transformers/AvcTransformer.cs#L72-L100

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.