linuxgurugamer

[1.5.1+] FTL Drive Continued

Recommended Posts

12 hours ago, Platonicsolid said:

Alright, created a stripped down test instance with just the Squad stock, the three mods (FTL, ClickThruBlocker, ToolbarControl) and HyperEdit.

Still getting the box when trying to list destinations. Beacon is definitely on. Appears to be a null when trying to load the BaseFieldList?

Album https://imgur.com/a/aDV3gIs will appear when post is submitted

 

And output log is here: https://www.dropbox.com/s/tx9b5488fm86li8/output_log Limited Test.txt?dl=0

 

Your imgur isn't displaying

Your problem is this:

[KSP Version]: 1.3.1.1891 (WindowsPlayer x64) (x64) en-us ==============================

The current version is for 1.4.x only, you are trying to use it in 1.3.1, it won't work

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Alright, that's what I suspected, which goes back to my prior question - it appears the latest FTL version that would support 1.3.1 is 0.2.0. Does that require ClickThruBlocker and ToolbarController, and if so, what versions?

Thanks for your help!

Share this post


Link to post
Share on other sites

No, those dependencies were added in 1.4.1

Share this post


Link to post
Share on other sites

Hi,

Just a question, please.

Can a FTL drive and beacon be placed on the same spacecraft ?

Thanks

Share this post


Link to post
Share on other sites
28 minutes ago, LopoMetello said:

Hi,

Just a question, please.

Can a FTL drive and beacon be placed on the same spacecraft ?

Thanks

Yes

Share this post


Link to post
Share on other sites
On 5/28/2018 at 2:00 PM, linuxgurugamer said:

Yes

Cool! Thanks!

Another question, please.

What can I do to improve my chances for a successful jump?

Until now, my chances are only of 46-50% which in my opinion is very risky ...

Anyway, very nice mod indeed! Thanks for all!

Share this post


Link to post
Share on other sites
58 minutes ago, LopoMetello said:

Cool! Thanks!

Another question, please.

What can I do to improve my chances for a successful jump?

Until now, my chances are only of 46-50% which in my opinion is very risky ...

Anyway, very nice mod indeed! Thanks for all!

Get further away from planetary bodies, both sides

Share this post


Link to post
Share on other sites
15 hours ago, linuxgurugamer said:

Get further away from planetary bodies, both sides

Ok, thanks.

 

Share this post


Link to post
Share on other sites

Hey Linuxgurugamer, amazing mod! Speaking theoretically, would you be able to initiate jumping in Low Kerbin Orbit with enough/larger drives?

Share this post


Link to post
Share on other sites
11 hours ago, jdalt40 said:

Hey Linuxgurugamer, amazing mod! Speaking theoretically, would you be able to initiate jumping in Low Kerbin Orbit with enough/larger drives?

Probably, but is it worth it?

Share this post


Link to post
Share on other sites

Cool! I find it nice that you didn't give it constant limits (can't initiate under X, etc.), instead making the cost incredibly large to initiate the drive in LKO. I might try to travel via very large (7.5m or so) drives to test the viability of this :p.

Share this post


Link to post
Share on other sites

Hi. Just signed up for the forums to comment on this mod. I like the idea of this mod but i keep running into issues.

My first ship with ftl drives jumped to moho did science, landed on moho and jumped back to kerbin. I docked with 2 space stations i have in LKO to dump the science in MPL/Interstellar Science Lab. After undocking from the second station i tried choosing a new target all i got was insufficient drives for all my destinations. Spinning up the drive caused the entire craft to disassemble. The drives were saying that EC=NAN  I reloaded a quick save from just before and i got the same thing. Unfortunately i destroyed this ship to keep the bug from spreading to my stations.

I don't know where to find the log file. Please tell me.

This morning i designed a new ftl ship. My second ship was an unmanned vessels with a ftl drive stage, an interplanetary stage with a ftl beacon and a lander meant to go to eves seas. I jumped to moho beacon and staged the ftl drive. When i tried to switch to it to send it back to kerbin, i ended up getting the moho beacon first and that self destructed. I switched to the ftl drive section and tried to jump back to kerbin and got EC=NAN. Then i loaded a quick save which i though was right after the successful jump and it ended up being before the launch.

Please help. Thanks.

How do i attached files? I wanted to attach the 2 craft files.

Link to craft files and a log?: https://drive.google.com/open?id=1Rn-2u8v2UCZO4YeTrWTCGlHpy1O5e4c_

The crafts will require at least Special Mission Projects mod. I use the SMP Engine Type R as my main space engine. I dont know if any other mods are needed. Might need the Mk2 Stockalike expansion (dont know which are stock and which are added) for the defiant class.

Both will also need Kerbal Dust Exeriment.

Edited by Jjbb3
Links to craft files and a log

Share this post


Link to post
Share on other sites

Put files on a file sharing site and post a link.

See the following link for info on how to get the log files.  Again, put the log files on a file sharing site and post the link


Read this BEFORE asking for supporthttp://forum.kerbalspaceprogram.com/index.php?/topic/83212-how-to-get-support-read-first/

Share this post


Link to post
Share on other sites
9 hours ago, Jjbb3 said:

Hi, Thanks for the quick reply. I edited the post before it went live. Theres a link to google drive for the 2 craft files and some log. I couldn't find an output_log.txt.

Im adding the link in this post in case the edit didnt get approved:

https://drive.google.com/open?id=1Rn-2u8v2UCZO4YeTrWTCGlHpy1O5e4c_

Read the link, you will find the output_log.txt at one of the locations it describes

Share this post


Link to post
Share on other sites

Sorry. I was looking in the KSP folder. I found it in users data. I have added it to the google drive folder.

It seems like after the first jump of the FTL Drive, it can't recalculate after a mass change from staging/docking ports.

 

Edited by Jjbb3

Share this post


Link to post
Share on other sites
On 7/6/2018 at 10:35 PM, Jjbb3 said:

This morning i designed a new ftl ship. My second ship was an unmanned vessels with a ftl drive stage, an interplanetary stage with a ftl beacon and a lander meant to go to eves seas. I jumped to moho beacon and staged the ftl drive. When i tried to switch to it to send it back to kerbin, i ended up getting the moho beacon first and that self destructed. I switched to the ftl drive section and tried to jump back to kerbin and got EC=NAN. Then i loaded a quick save which i though was right after the successful jump and it ended up being before the launch

Ok, I just want to get the steps down correctly:

  1. designed a new ftl ship with a ftl drive stage, an interplanetary stage with a ftl beacon and a lander meant to go to eves seas.
  2. jumped to moho beacon
  3. staged the ftl drive
  4. tried to switch to it to send it back to kerbin, i ended up getting the moho beacon first and that self destructed
  5. switched to the ftl drive section
  6. tried to jump back to kerbin and got EC=NAN

In #4, when you tried to switch to the ftl drive section, you got the moho beacon.  Did it spontaneously self destruct for no reason?  Were there any parts left after the self-destruct?

Share this post


Link to post
Share on other sites

@Jjbb3

There are more mods needed.  I've been able to identify them all except for one part on the Defiant:

  • FixedDish01

Can you identify what mod has this?

 

never mind, I found it

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
2 hours ago, linuxgurugamer said:

Ok, I just want to get the steps down correctly:

  1. designed a new ftl ship with a ftl drive stage, an interplanetary stage with a ftl beacon and a lander meant to go to eves seas.
  2. jumped to moho beacon
  3. staged the ftl drive
  4. tried to switch to it to send it back to kerbin, i ended up getting the moho beacon first and that self destructed
  5. switched to the ftl drive section
  6. tried to jump back to kerbin and got EC=NAN

In #4, when you tried to switch to the ftl drive section, you got the moho beacon.  Did it spontaneously self destruct for no reason?  Were there any parts left after the self-destruct?

There were about 5-10 parts left creating a nice kessler syndrome. The beacon was one of the beacons in the defiant class cargo hold. Its in an orbit of Moho (Ap: 8.99Mm/Pe: 8.99Mm). My idea was at a super high orbit i could have higher mass vehicles go to moho. Also use moho's super close orbit to avoid transfer windows. I have another beacon in roughly half that orbit for landing on moho. That was the one the defiant used to do its exploration.

And i do realize that the eve lander ftl section does not have a battery of its own (will be fixed before next launch)  but it also showed NaN with unlimited electric on in the cheats menu. And that wouldn't explain why the beacon self destructed.

I don't know if it makes a difference but the eve lander never actually reached kerbin orbit. I flew straight up till 8-10Mm when the UI said a 100% possibility and jumped. Ditched the launch stage right around 70km. Did a burn to slow it down and a burn toward the horizon to keep from a steep reentry and let stage recovery land it. I had to transfer about half of the IP stage fuel to the ftl section to reach that altitude (well had an AP over 20Mm by the time i cut the engine).

Edited by Jjbb3
Launch Flight Plan

Share this post


Link to post
Share on other sites
1 hour ago, Jjbb3 said:

There were about 5-10 parts left creating a nice kessler syndrome. The beacon was one of the beacons in the defiant class cargo hold. Its in an orbit of Moho (Ap: 8.99Mm/Pe: 8.99Mm). My idea was at a super high orbit i could have higher mass vehicles go to moho. Also use moho's super close orbit to avoid transfer windows. I have another beacon in roughly half that orbit for landing on moho. That was the one the defiant used to do its exploration.

And i do realize that the eve lander ftl section does not have a battery of its own (will be fixed before next launch)  but it also showed NaN with unlimited electric on in the cheats menu. And that wouldn't explain why the beacon self destructed.

I don't know if it makes a difference but the eve lander never actually reached kerbin orbit. I flew straight up till 8-10Mm when the UI said a 100% possibility and jumped. Ditched the launch stage right around 70km. Did a burn to slow it down and a burn toward the horizon to keep from a steep reentry and let stage recovery land it. I had to transfer about half of the IP stage fuel to the ftl section to reach that altitude (well had an AP over 20Mm by the time i cut the engine).

What about the main ship, does it get to orbit, or do you just launch it straight up?

Share this post


Link to post
Share on other sites

The eve lander just went up until it could jump. The defiant was in a stable orbit before its first jump. Although an ftl beacon disappeared from kerbin orbit (circular equatorial orbit between the mun and minmus) so the defiant's return jump was to a beacon that wasn't in a stable orbit (AP: 80Mm+, Altitude was probably half that during the return jump) was launched straight up to save fuel (circularized at ap but that was 20days after the defiant needed to return with science). 

Long before the launch of the eve lander, I circularized the beacon at the fringes of Kerbin's soi (equatorial orbit). There's very little that shouldn't be able to jump to there from what i understand of the mod. There is also a beacon in a circular polar orbit with a Ap/Pe somewhere between mun and minmus.

Edited by Jjbb3

Share this post


Link to post
Share on other sites
9 hours ago, Jjbb3 said:

The eve lander just went up until it could jump. The defiant was in a stable orbit before its first jump. Although an ftl beacon disappeared from kerbin orbit (circular equatorial orbit between the mun and minmus) so the defiant's return jump was to a beacon that wasn't in a stable orbit (AP: 80Mm+, Altitude was probably half that during the return jump) was launched straight up to save fuel (circularized at ap but that was 20days after the defiant needed to return with science). 

Long before the launch of the eve lander, I circularized the beacon at the fringes of Kerbin's soi (equatorial orbit). There's very little that shouldn't be able to jump to there from what i understand of the mod. There is also a beacon in a circular polar orbit with a Ap/Pe somewhere between mun and minmus.

I wasn't able to get it to fail.  So, can  you do it again, in a minimal a game as possible, and send me a save file

Also, I was wondering if the success chance was 100% for all the jumps.

 

Share this post


Link to post
Share on other sites

Thanks for your time. What do you mean by minimal a game? Less mods or new sandbox?

I am going to try another launch of the eve water lander when i get home from work today.

Share this post


Link to post
Share on other sites
19 hours ago, Jjbb3 said:

Thanks for your time. What do you mean by minimal a game? Less mods or new sandbox?

I am going to try another launch of the eve water lander when i get home from work today.

Both.  As few mods as possible, then create a new sandbox and do the same sequence of events.

A complete list of all the events and a full copy of the save directory would be very useful 

I was unable to replicate it, not sure if I had done it exactly the way you had done it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now