Jump to content

[1.4+] BETA: Kerbal Attachment System (KAS) v1.0 Release Candidate 1


Recommended Posts

Hey Igor,
I want to pump water from one tank into another (water in order to make supplies). I'm using Planetary Base System parts. 
Am I mistaken in thinking that I could that with KIS/KAS?

Bill linked the two tanks then I selected "Pump Here" on the receiving side. What am I doing wrong?

Link to post
Share on other sites

@MrSpeakeasy29 You might be running into an issue I saw. Start with this post on the previous page and the next couple and see if it might resemble your issue. I did find an issue transferring resources across KPBS flexible corridor connections as they use the 0.6.4 KAS library that isn't compatible with 1.0 KAS. Do you have a picture of your base showing the KAS connections?

Link to post
Share on other sites

Thanks for the reply, Tonka Crash.
I thought this might be the case. Started working on downloading the new version from Github but I'm having trouble with that too.
Something about DNS server not found.
Smells like anti-net nutrality.

Any suggestions on how to download from Github? Im signed up and all.

 

Link to post
Share on other sites
29 minutes ago, Tonka Crash said:

asy29 You might be running into an issue I saw. Start with this post on the previous page and the next couple and see if it might resemble your issue. I did find an issue transferring resources across KPBS flexible corridor connections as they use the 0.6.4 KAS library that isn't compatible with 1.0 KAS. Do you have a picture of your base showing the KAS connections?

Should I be using any other mod with KAS? Like TAC-Life Support or Interstellar Fuel Switch?
I'm currently using KAS 0.6.4. I can't find the new version 1.0.

 

 

Link to post
Share on other sites

I assumed you were using KAS v1.0 since this thread for v1.0. v0.6.4 has it's own has it's own thread. I haven't used 0.6.4 in months so no idea what could be going wrong. DNS server not found is usually an ISP issue or router problem in my experience. I use TAC Fuel Balancer frequently to transfer resources and it works with KAS 1.0 and I don't remember any problems with 0.6.4.

The KAS v1.0 is at https://github.com/ihsoft/KAS/releases I was able to google "KSP KAS github" and find the link to post here. Igor is working on a new release that should drop any day now.

 

Link to post
Share on other sites
22 minutes ago, Tonka Crash said:

I assumed you were using KAS v1.0 since this thread for v1.0. v0.6.4 has it's own has it's own thread. I haven't used 0.6.4 in months so no idea what could be going wrong. DNS server not found is usually an ISP issue or router problem in my experience. I use TAC Fuel Balancer frequently to transfer resources and it works with KAS 1.0 and I don't remember any problems with 0.6.4.

The KAS v1.0 is at https://github.com/ihsoft/KAS/releases I was able to google "KSP KAS github" and find the link to post here. Igor is working on a new release that should drop any day now.

 

Ok, fixed the DNS problem.
Downloaded KASv1.0.

Gonna download TAC Fuel Balancer as well.

I'll let ya know.
Thanks

 

Link to post
Share on other sites

The KAS v1.0 is officially released. From now on, any issues or feature request should go to the main thread.

And in case of you wonder about some stats:

  • Time spent to have v1.0 done (from the idea to the release): 1 year 8 months.
  • Source code files created during this time: 324.
  • GitHub commits: 1,417 (2.29 commits per a day in average).
  • Lines of code added: 27,206.
  • Lines of codes reused from the old KAS: 0.

This thread is now over. I will ask the moderators to close it. Thank you everyone!

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...