linuxgurugamer

[1.5.1+] VOID UnVoided - Vessel Orbital Informational Display

Recommended Posts

1 minute ago, TheScienceGuy120 said:

Hey, I need some help with this mod. i recently installed it and it doesn't work. i installed both the dependencies, i tried installing the ToadicusTools thing as well, i tried installing the version from spacedock instead, and no matter what i can't get the icon to show up. Mind helping me with this?

 

Log file, please

Share this post


Link to post
Share on other sites
5 minutes ago, linuxgurugamer said:

Log file, please

i apologize but where may i find the log file? also, thank you for replying on such short notice.

Edit: i found the log file via help from your profile, but i don't know how to upload it...

Edited by TheScienceGuy120

Share this post


Link to post
Share on other sites

I'm answering on my phone so I don't see it. But look at my signature and there's a link there

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
5 minutes ago, linuxgurugamer said:

I'm answering on my phone so I don't see it. But look at my signature and there's a link there

yeah. i checked your profile and found the log files, but i don't know how to upload them. would it be fine if i just linked you a google drive link with the file in it?

Share this post


Link to post
Share on other sites
Just now, TheScienceGuy120 said:

yeah. i checked your profile and found the log files, but i don't know how to upload them. would it be fine if i just linked you a google drive link with the file in it?

That's actually what he meant.  You can't upload the file to the forum itself, so just provide the Google Drive link.

Share this post


Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

I'm answering on my phone so I don't see it. But look at my signature and there's a link there

Alright. i apologize for taking so long but here's the output log: [Deleted due to privacy reasons and the fact that the error was fixed]

 

Edited by TheScienceGuy120

Share this post


Link to post
Share on other sites

I needs ToadicusTools, which I know you said you installed, but it doesn't appear that you installed the correct version.  Here are links to the correct versions of each:

https://github.com/linuxgurugamer/ToadicusTools/releases/download/0.22.3.2/ToadicusTools-0.22.3.2.zip

https://github.com/linuxgurugamer/VOID/releases/download/1.1.7.1/VOID-1.1.7.1.zip

Share this post


Link to post
Share on other sites
11 minutes ago, linuxgurugamer said:

I needs ToadicusTools, which I know you said you installed, but it doesn't appear that you installed the correct version.  Here are links to the correct versions of each:

https://github.com/linuxgurugamer/ToadicusTools/releases/download/0.22.3.2/ToadicusTools-0.22.3.2.zip

https://github.com/linuxgurugamer/VOID/releases/download/1.1.7.1/VOID-1.1.7.1.zip

Ah, thank you, that did it. Works just fine now! 
Also, an after thought: maybe you should list ToadicusTools as a dependency on your main page, and link it as well, just so nobody gets confused and so that you don't have to deal with this type of situation again.

Share this post


Link to post
Share on other sites
1 minute ago, TheScienceGuy120 said:

Ah, thank you, that did it. Works just fine now! 
Also, an after thought: maybe you should list ToadicusTools as a dependency on your main page, and link it as well, just so nobody gets confused and so that you don't have to deal with this type of situation again.

I thought it was, will take care of it later this evening

Share this post


Link to post
Share on other sites

And again muchas gracias for updating my favorite plugin! Your work is incredibly valuable to me (I'll PM you soon about it).

Share this post


Link to post
Share on other sites

Whats the difference (in function) between this and KER? Ive been a KER user for years, but was browsing around and saw this...

Share this post


Link to post
Share on other sites

I am having a problem getting this to work. No icon's.

Clean install of 1.6.1/DLC  with void 1.1.8.1,  ToadicusTools v0.22.3.3,  ClickThroughBlocker v0.1.6.10,  Toolbar Control v1.7.17.15.  No other mods.

Output_Log.txt = https://www.dropbox.com/s/x4q1m2ni07bffet/output_log.txt?dl=0

Thanks for all your hard work with mods.

Share this post


Link to post
Share on other sites

After Further testing I did not have the Toolbar Control 0.1.6.20 , I had Toolbar - 1.7.17.15 thinking it was the toolbar control. After adding Toolbar Control I now have all Icon's and VOID is working,

However I do not get a HUD instead i get windows/panels where HUD should be. Is this a change or am I still missing something?

Output_log.txt = https://www.dropbox.com/s/fswdp0cu49tb9fa/output_log.txt?dl=0

Again Thanks for your hard work.

Share this post


Link to post
Share on other sites
On 1/25/2019 at 10:27 AM, ScruffySailor said:

After Further testing I did not have the Toolbar Control 0.1.6.20 , I had Toolbar - 1.7.17.15 thinking it was the toolbar control. After adding Toolbar Control I now have all Icon's and VOID is working,

However I do not get a HUD instead i get windows/panels where HUD should be. Is this a change or am I still missing something?

Output_log.txt = https://www.dropbox.com/s/fswdp0cu49tb9fa/output_log.txt?dl=0

Again Thanks for your hard work.

Ill look at the log later.  Could you post an image showing the problem?

Share this post


Link to post
Share on other sites

Sure can Here is one with menu's open.  

R9lLoAq.jpg

As you can see the HUD locations are panels instead of transparent. I have been using this mod for years, this has me baffled as to why I cannot get it to work correctly.

Thanks for looking into this.

Share this post


Link to post
Share on other sites
8 hours ago, ScruffySailor said:

As you can see the HUD locations are panels instead of transparent. I have been using this mod for years, this has me baffled as to why I cannot get it to work correctly.

Thanks for looking into this.

This happened because KSP changed some skin settings which VOID was using.

I'm working on a fix right now

Share this post


Link to post
Share on other sites

Thank You,  Another mod you have to fix. I appreciate your efforts to keep all the mods you oversee working and will look forward to the fix. 

Share this post


Link to post
Share on other sites

New release, 1.1.9

  • Fixed HUD transparency.  As of 1.5, the skins weren't transparent, had to add code to make the HUD skins transparent

Share this post


Link to post
Share on other sites

I really hate to be that guy.... New Version works like a charm..... but the version file still has 1.4.5 ksp version so the usual popup get generated by avc. I fixed it for my install. just an FYI. Thanks

Share this post


Link to post
Share on other sites
8 hours ago, ScruffySailor said:

I really hate to be that guy.... New Version works like a charm..... but the version file still has 1.4.5 ksp version so the usual popup get generated by avc. I fixed it for my install. just an FYI. Thanks

Make sure you have 1.1.9 installed.  I just installed it via CKAN, and it initially installed 1.1.8, but 1.1.9 is the current one, and that was fine for me

Share this post


Link to post
Share on other sites

Yes I verified SpaceDock download of 1.1.9. Version file says version 1.1.9.0 with ksp version 1.4.5. I don't use CKAN so can't say anything about that. It's not a big deal miniAVC/ksp-AVC both just says it's for 1.4.5. Still loads and works fine.

Share this post


Link to post
Share on other sites

New release, 1.1.9.1

  • Version bump to fix bad version build

Share this post


Link to post
Share on other sites
23 hours ago, linuxgurugamer said:

New release, 1.1.9

  • Fixed HUD transparency.  As of 1.5, the skins weren't transparent, had to add code to make the HUD skins transparent

Hey man,

Thank you!   I'd been going nuts trying to figure out how to re-enable the transparency since the 1.5.x thing.  I had thought it was something I had done wrong, heh.  :)

 

Share this post


Link to post
Share on other sites

Hey LGG I have a question about the inner workings for VOID that I hope you can investigate when you have some free time. It involves this plot:

ulADuuB.png

I'm curious as to whether VOID is outputting to the CSV logger the atmospheric density value it is calculating itself, or if it is just accessing a value determined by the internal game calculations. I'm wondering where the discrepancy comes from between these three results. I've also inquired for insight from the LVD (part of KSPTOT) developer and the person behind the kOS code I'm using

Share this post


Link to post
Share on other sites

@linuxgurugamer I hate to be *that guy*, but any chance to either include your fork of ToadicusTools *in* the VOID package, or at least update the OP with a link to your repo fork of it?

only link in the OP currently, is to Toadicus' last update of the original on SpaceDock... I thought maybe you had updated it, so I googled your github and seaarched thru your repos to find it...

Others not familiar with github might not know to do that... vOv

And if I havent mentioned it before, THANX for taking over VOID... It has been my info mod of choice over KER, MJ and others, since I started playing, circa KSP 0.18 or 0.20 days :P

Edited by Stone Blue

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.