linuxgurugamer

[1.5.*, 1.6.*] SXT Continued

Recommended Posts

I was wondering why my props don't work (KSP 1.4.1, SXT 0.3.23.2) and I found in Firespitter/Plugins a Firespitter.dll.mdb instead of Firespitter.dll.

So I would conclude someone @linuxgurugamer has grabbed the wrong file out of the github repo and put it in the latest release :D

But don't worry, it happens. You're doin a great job maintaining the mod.

Edited by acc

Share this post


Link to post
Share on other sites
41 minutes ago, acc said:

I was wondering why my props don't work (KSP 1.4.1, SXT 0.3.23.2) and I found in Firespitter/Plugins a Firespitter.dll.mdb instead of Firespitter.dll.

So I would conclude someone @linuxgurugamer has grabbed the wrong file out of the github repo and put it in the latest release :D

But don't worry, it happens. You're doin a great job maintaining the mod.

it was a broken build process.  I moved SXT to a new build system, the DLLs weren't included

I've just released an updated build which includes the DLLs for Firespitter and the Retractable lifting Surface

Share this post


Link to post
Share on other sites
1 hour ago, acc said:

So I would conclude someone @linuxgurugamer has grabbed the wrong file out of the github repo and put it in the latest release :D

Your conclusion was wrong, and it would nice if you would give someone the benefit of the doubt before making a conclusion.

I don't mind mistakes being pointed out, but this was rude and uncalled for

Share this post


Link to post
Share on other sites

@linuxgurugamerSmall tweak request. This mod's version of the Apollo LM's ascent stage has the same part-name in its .cfg file as the one in the new Making History DLC. Can you please change its name (perhaps just slap the capital letters "SXT" onto the end) inside that file so that it shows up properly again for those of us with the expansion-pack?

Share this post


Link to post
Share on other sites

And what is the name?

I appreciate the bug report, but knowing the name would save me time

Share this post


Link to post
Share on other sites

GameData/SXT/Parts/Rocketry/Command/MEM/part.cfg, sorry about leaving that out.

Share this post


Link to post
Share on other sites

New release, 0.3.23.5

  • Renamed MEMLander to MEMLanderSXT to avoid conflict with stock part

Share this post


Link to post
Share on other sites
11 hours ago, theonegalen said:

This happens when you don't install the firespitter resources. Make sure they're installed. They are in the SXT download.

Nope, wasn't the issue actually, as I had done so. As I launched it up, seems a new version had just sprung up, and after closing ksp, plopping in the new version, all worked!

Share this post


Link to post
Share on other sites

@linuxgurugamer Is the latest version compatible with 1.3.1? I was trying to download it from CKAN but it can't find version 0.3.23.1 and the download fails. I don't see any signs of it being on your repo either, or is 0.3.22 the latest for 1.3.1?

I don't mind using the older version, I was just confused by what CKAN was telling me

 

Edited by Galileo

Share this post


Link to post
Share on other sites
9 minutes ago, Galileo said:

@linuxgurugamer Is the latest version compatible with 1.3.1? I was trying to download it from CKAN but it can't find version 0.3.23.1 and the download fails. I don't see any signs of it being on your repo either, or is 0.3.22 the latest for 1.3.1?

I don't mind using the older version, I was just confused by what CKAN was telling me

 

No, and i accedintly deleted that version.

ill try to get a 1.3.1 version available soon

Share this post


Link to post
Share on other sites

Ok, the last version for 1.3.1 has been restored to both spacedock and github

I have  to fix a ckan error

 

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Ok, 0.3.23.1 is now available again via CKAN

Sorry for the problem

Share this post


Link to post
Share on other sites
3 hours ago, DracoSilverpath said:

Nope, wasn't the issue actually, as I had done so. As I launched it up, seems a new version had just sprung up, and after closing ksp, plopping in the new version, all worked!

Interestingly, I was using the same version as you were but didn't have the problem. Ah well.

Share this post


Link to post
Share on other sites
7 hours ago, theonegalen said:

Interestingly, I was using the same version as you were but didn't have the problem. Ah well.

I think you may have installed via CKAN, and he may have done it manually.  Or, you had installed Firespitter to support another mod.  The DLL was definitely missing

Share this post


Link to post
Share on other sites
19 hours ago, linuxgurugamer said:

Your conclusion was wrong, and it would nice if you would give someone the benefit of the doubt before making a conclusion.

I don't mind mistakes being pointed out, but this was rude and uncalled for

It was meant to be a joke with no intention to be rude. I apologize.

Share this post


Link to post
Share on other sites
4 minutes ago, acc said:

It was meant to be a joke with no intention to be rude. I apologize.

Apology accepted.

Please understand, I'm in the middle of updating over 130 mods, and I get these types of comments and PMs a lot, so after a while it's kind of hard to tell humor from hubris

Share this post


Link to post
Share on other sites

Sorry to ask, but the Topic title say 1.4.1 , but it is only compatible up to 1.3.1?

Any clarification to clear up my confusion on this would be greatly appreciated :)

Thanks ins advance.

Share this post


Link to post
Share on other sites
3 hours ago, RB101 said:

Sorry to ask, but the Topic title say 1.4.1 , but it is only compatible up to 1.3.1?

Any clarification to clear up my confusion on this would be greatly appreciated :)

Thanks ins advance.

I dont understand.

the current version should be tagged for 1.4.1, older versions are available online

Share this post


Link to post
Share on other sites

New release, 0.3.23.6

  • Made the OX-HEX invulnerable to aero damage
  • Localization and German translation by @LeLeon
  • Updated .version file to allow all of 1.4.1+

Share this post


Link to post
Share on other sites

Been pointed towards this fine mod to scratch a few land vehicle itches, and have fallen for the massive number of parts I never knew I needed... Although a couple seem to be lesser echoes of parts I already had; I see no benefits in using the Mk1 Fuselage that SXT uses to replace the stock part, am I missing something obvious or is this a relic of a bygone era?

I'm learning (slowly) what various bits do, and what I can safely tweak and what should be left well alone, but the only way to learn is to ask... Did manage to add the "rover" wheels to WheelSounds all by myself though, which was nice.

Share this post


Link to post
Share on other sites
4 minutes ago, JH4C said:

 I see no benefits in using the Mk1 Fuselage that SXT uses to replace the stock part, am I missing something obvious or is this a relic of a bygone era?

Is that the Mk1 "warbird" cockpit? It seems kind of jokey to me, too -- I just see it as a cheaper/junkier/earlier version of that scale of pod to allow for the first of the Mk1 scale planes (instead of the tinier Bonny/Clyde cockpits).

Did you add the wheelsounds to the SXT yellow vehicles, too? I haven't unlocked those yet -- was gonna do that today. Good to know it'll be an easy patch. :)

Share this post


Link to post
Share on other sites
19 minutes ago, Beetlecat said:

Is that the Mk1 "warbird" cockpit? It seems kind of jokey to me, too -- I just see it as a cheaper/junkier/earlier version of that scale of pod to allow for the first of the Mk1 scale planes (instead of the tinier Bonny/Clyde cockpits).

Did you add the wheelsounds to the SXT yellow vehicles, too? I haven't unlocked those yet -- was gonna do that today. Good to know it'll be an easy patch. :)

No, it's just the plain fuselage item but it's using the fuel tank skin and model so it's solid rather than tubelike. I did however open my eyes a little wider, and found the original part; it hadn't been replaced, it just appears much lower down the menu than I was used to :blush: I'll just hide the other one with Janitor (the only difference aside from the model is that the part from SXT weighs 50 kilos more, which reflects its more solid structure.)

The part you need to add the sound to is TGWheel, I just copied everything else from the TR-2 and it works great. The red lights in the bumper aren't brake-activated unfortunately but I'm still happy; just be sure to change the light settings so the glow they cast matches the lens colour!

Edited by JH4C
extra thoughts

Share this post


Link to post
Share on other sites
23 hours ago, Beetlecat said:

Is that the Mk1 "warbird" cockpit? It seems kind of jokey to me, too -- I just see it as a cheaper/junkier/earlier version of that scale of pod to allow for the first of the Mk1 scale planes (instead of the tinier Bonny/Clyde cockpits).

If you're referring to the one with the ASET props IVA I made, that's not SXT. It comes from Unmanned Before Manned if you have that, but is included with Warbird Cockpits as well. The intention was indeed to give a starting cockpit for mk1 planes that wouldn't work at re-entry speeds.

Share this post


Link to post
Share on other sites
On 4/24/2018 at 3:51 PM, theonegalen said:

If you're referring to the one with the ASET props IVA I made, that's not SXT. It comes from Unmanned Before Manned if you have that, but is included with Warbird Cockpits as well. The intention was indeed to give a starting cockpit for mk1 planes that wouldn't work at re-entry speeds.

Oh! That's where I recognized that one from -- Yes -- the fact that it has internals means it must come from the warbirds cockpits!. Am I going to get into trouble if I try to fly too high with that thing (Like Better Than Starting Manned achieved with max altitude...)?

That's also why I was confused by it being a down-quality'ed version of the Mk-1. It's *meant* to be. No intent to disparage! :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.