Skalou

[1.x.x] Mk1-Cabin-Hatch [v0.2.0] ( 3 november 2016)

Recommended Posts

Error with the new Module Manager: bad syntax for the Indicator Lights patch
 

@PART[MK1CrewCabin]:NEEDS[MK1CabinHatch]:NEEDS[IndicatorLights]:BEFORE[MK1CabinHatch]:AFTER[IndicatorLights]
{
    @MODEL,1
    {
        @position = 0, -0.35, -0.625
    }
    @MODEL,2
    {
        @position = 0, -0.5375, -0.625
    }
}


You can have only 1 of the following:  FOR  BEFORE  AFTER  FIRST  LAST.

How to resolve this error?

Share this post


Link to post
Share on other sites
On 06/12/2017 at 11:35 PM, Murdabenne said:

Error with the new Module Manager: bad syntax for the Indicator Lights patch

How to resolve this error?

Oh, i didn't know of the existence of this patch! :/
it could be great to notify the concerned modders  @SchwinnTropius, @Snark

i'm not the author of it, but i can take a look.

Share this post


Link to post
Share on other sites

@Murdabenne @Skalou

It looks as though what happened here is that ModuleManager just released a major new version, which broke "backwards bug compatibility".  Specifically:  There's a particular type of syntax mistake that was never intended to be "legal" in the first place... but past versions of MM were lax about enforcement.  The new MM uses more rigorous input validation, so old code that used to squeak by is now getting caught.  The fix for it is to update that old code so it stops doing the thing it was never supposed to be doing in the first place but folks didn't realize at the time.  :wink:

The error you mention has already come up for IndicatorLights Community Extensions-- you can see the discussion here:

 

...I plan to release an update for IndicatorLights Community Extensions as soon as I can, to address the matter for that particular mod.  It should be an easy fix.

In the meantime, I wouldn't be surprised if other mod authors with MM patches in their mods could run into the same issues; if they do, the fix will be similar.

Share this post


Link to post
Share on other sites

@Snark Yep - thats why I posted.  the MM "strict" mode is breaking a ton of things. For instance, nearly 300 errors come up with Allista's ConfigurableContainer mod scripts, mainly to use of FOR and AFTER.  Seems to be a common construct, probably should drop the FOR and simply make it NEEDS.  Just thought I'd let you know here as a courtesy - as well as my posts in the other threads where the actual error mods scripts originated.

Thanks for doing what you do!

Share this post


Link to post
Share on other sites

Just an update:  I've released v1.3.1 of IndicatorLights Community Extensions, so the issues with IndicatorLights compatibility should be cleared up.  Thanks for spotting & helping with the fix, folks! :)

Share this post


Link to post
Share on other sites

would it be possible to make this hatch be more versatile by making it a surface attach part?  we could then surface attack it to any part in the editor or with KIS/KAS in flight for making a hatch into any container.

 

it would be nice if:

 

1) there were 2 versions, horizontal and vertica,l so we could mount it on top or the sides.

2) we can scale it to fit any diameter part.

3) if there is already crew space in the part just add the door and make no further modifications, however if the part has no crew space it would then add crew space of 1 kerbal. and just give it the default black IVA view so the kerbal will show up in the GUI.

 

 

4) as a side project could you update the hatches on the rest of the parts so they all match the visual styling of this hatch?  or does that require having access to the parts model in unity?  and if so, what about if you did make the surface attach part, and it was scaled slightly bigger such that it would cover the default hatches hiding them, and making the part appear to have your visual style hatch.

Share this post


Link to post
Share on other sites

This feels kinda grave dig, but is this mod not working for anyone else in 1.4?

Share this post


Link to post
Share on other sites

I can confirm the mod Mk1-Cabin-Hatch (v0.2.0) still works for KSP 1.4.x :)

@Bit Fiddler,good idea but not now for me, there is some parts like this in the history DLC too.

Share this post


Link to post
Share on other sites

It bothers me that the mk2 front cockpit has only 1 hatch..on the side but the inline mk2 has 2?...?? I keep thinking about this mod when it bothers me with hopes someone feels my pain. It kinda helps :)

Share this post


Link to post
Share on other sites
Posted (edited)

Mk1-Cabin-Hatch  v0.2.0 still works for KSP version 1.7 and should work for many  future versions ;)

Thanks for reporting here a new working (or not) ksp version.

Edited by Skalou

Share this post


Link to post
Share on other sites
Posted (edited)

I can also say that it still works fine for 1.4.5 :D (i'm still playing with this older version cause of mods). I downloaded it yesterday evening to try, and it works as it should.

I just react because I see the reply of Skalou few hours after i tried it for the first time.

I really like that it does not create a new part but just give the possibility to put or not a hatch on the existing one depending of your need vessel by vessel.

Edited by ndiver

Share this post


Link to post
Share on other sites
Posted (edited)

Just installed this via CKAN. Having the following problem. In the editor, the icon for the part clearly shows the hatch. When I try to place the part though, the texture for it is not there. The hatch is invisible, but it works if you press EVA (the kerbal seems to come out the window).

mOFMjZW.jpg

Could someone help? I'm attaching MM/KSP logs and a gamedata folder picture below.

http://www.mediafire.com/file/u1a0q74bzdulczb/logs-Dante80.zip/file

Edited by Dante80

Share this post


Link to post
Share on other sites
Posted (edited)

@Dante80,

Did you tried: the option is toggleable in the editor via the part's right-click menu "add top hatch" ?

P.S: this mod still works for the KSP version 1.7.3

Edited by Skalou

Share this post


Link to post
Share on other sites

I'm a complete idiot, you are right. :blush:

The mod works beautifully in 1.7.3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.