Jump to content
  • 0

Crash on rendez-vous in LKO


Jashin
 Share

Question

Hi everyone,

Just as I thought 1.2.1 had solved all my problems with KSP, I've encountered a bizarre crash: I'm trying to dock two vessels in orbit and as soon as one comes near the other (I suppose within the loading range), I can only catch a glimpse of the ship I'm trying to dock before the game crashes. The crash is 100% repro in my save file, there is simply no way to rendez-vous these two vessels without the game crashing on me even on a clean boot.


Here's the log: https://drive.google.com/open?id=0Bzi4vbI8ETh_V0k5WFQ4c1pYNUE

My mod folder: http://i.imgur.com/UGX9eRo.png

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 1

There is a known problem with Part Highlighter and the Aero Overlay in combination.
http://bugs.kerbalspaceprogram.com/issues/13188

The best way to avoid it is to either not use the Aero Overlay, or turn off the Part Highlighter in flight until a fix can be found.
If you are using one and not the other you should be ok.

Link to comment
Share on other sites

  • 0

I have very much the same issue, only in my case I could undock the lander from the orbiter, land, go up, rendezvous and dock, then I entered Kerbin's atmosphere and near the surface I activated parachutes and undocked the ship into two parts that descend separately, side by side. And EVERY time I would pan the camera from the craft I was piloting to view the other craft that was descending not far away, the game would instantly crash.

 

Link to comment
Share on other sites

  • 0

I'm wondering if you guys can tell us if you have Part highlighting switched on in your Settings Menu? (the "Highlight FX" radio button)
Also, before the crash occurs/occured had you been using the Aero Overlay at all? (F12)
Asking because it may be related to a known problem where these two features are a factor in the crash.
 

Link to comment
Share on other sites

  • 0
2 hours ago, JPLRepo said:

I'm wondering if you guys can tell us if you have Part highlighting switched on in your Settings Menu? (the "Highlight FX" radio button)
Also, before the crash occurs/occured had you been using the Aero Overlay at all? (F12)
Asking because it may be related to a known problem where these two features are a factor in the crash.
 

HIGHLIGHT_FX = True

pretty sure I didn't use the Aero Overlay, it's not something I use.

Is this just a 1.2.1 thing though? This is my first CTD in the 1.2 series, including pre-release

Link to comment
Share on other sites

  • 0

@JPLRepo Sorry for the late answer I hadn't seen the answers in this thread. I had been using the Part Highlighting option in the settings but the Aero Overlay was switched off: the game would just crash from a cold boot as soon as I got the two vessels close enough.

I have since trimmed down my modlist and I did a clean reinstall of my game and mods. I have been able to dock the two ships without issue but I don't understand where the crash came from: most mods I had been using are there again and now it just works whereas it didn't before...

Link to comment
Share on other sites

  • 0

Gotcha. I was using ModularFlightIntegrator at that time so that might be the reason? I don't know enough about that mod but I suspect it may have something to do with the Aero Overlay. Anyways it's working now and I have been able to dock multiple times with different ships so hopefully this crash was a one time thing. I'll be cautious with F12 though until this bug is fixed

Link to comment
Share on other sites

  • 0
7 hours ago, Jashin said:

Gotcha. I was using ModularFlightIntegrator at that time so that might be the reason? I don't know enough about that mod but I suspect it may have something to do with the Aero Overlay. Anyways it's working now and I have been able to dock multiple times with different ships so hopefully this crash was a one time thing. I'll be cautious with F12 though until this bug is fixed

I am encountering the exact same issue as you. No aero overlay, when I am trying to dock, I switch vessals and it crashes. Preparing my own post.

Edited by OddFunction
Link to comment
Share on other sites

  • 0

Using Part Highlighter alone causes the crash for me. Crash occurs when 2 vessels approach each other for a rescue or dock. Specifically it crashes when I switch camera focus to the other ship. 

 

Disabling Part Highlighter  fixed it. 

 

Aero display was never activated during any crash.

Link to comment
Share on other sites

  • 0

You guys are life and time savers. I've had the aero overlay crash for a month now but I don't really need it so no big deal. But the rendezvous crash(just learned how to rendezvous which is why I haven't had that issue) I've actually stopped playing, dreading going through each mod one by one  and spending hours looking at the log.

TLDR- thanks for this! 

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...