linuxgurugamer

[1.3] Dang It! Continued

Recommended Posts

7 hours ago, linuxgurugamer said:

Does this error happen every time?  I don't see it in the log file :-(

Yes, every time. It didn't for the first ~20 missions in a new GPP based modded save. Now it does it on every start. 

Only thing I can think of that changed related to DangIt is that I had a midair engine failure, landed, tried to repair it (not enough engineer stars) and in the process moved some SpareParts around, tried all the Repair options etc. It started after that. 

Share this post


Link to post
Share on other sites
Posted (edited)

So I'm having a problem and I'm hoping one of you guys might be able to figure out what's going wrong: DangIt is installed and has worked flawlessly for me in the past. No issues at all. And now, suddenly, I can't take Spares from any container. The button to "Take Spare Part" has completely vanished. All other aspects of DangIt continue to work just fine... but I can't fix anything at all because I can't take a Spare Part out of a pod. I've tested it with multiple types of command pods and the button to take a spare part is just... gone. Anyone know what's up?

Link to my Output_Log here: https://drive.google.com/open?id=0B49Vka7x_xExVGZ5LWxGZkVsR2s

Edited by Kardea

Share this post


Link to post
Share on other sites

I have dangit installed. I had a few batteries go out and now i havent had a failure in a few IRL days.  Is it fairly uncommon to have a failure?  All settings in dangit menu are default with exception i have all failures activated.

Share this post


Link to post
Share on other sites
Posted (edited)

I can't make the decision between this and launchfailure...

I'm really carefull with adding mods to my precious career so it would be nice if someone could help me with some answers:

- How is the performance impact?

-Is there a spreadsheet/a up to date video? Didn't find any via google. Wich level can repair what?

Yep those are the questions that bother me.

I really wish Kottabo would have a look at those mods since the available footage really isn't that advanced.

 

@HaydenTheKing I've come to this after watching a yt series and in this series failures do happen but it's not like they're verry common. He has some minor failures every now and then so I guess it's supposed to work like that.

Edited by maculator

Share this post


Link to post
Share on other sites

I just came here to post how much fun I'm having with DangIt.  I've added lots of redundancy on probes, have failures along the way (most often batteries and solar panels), have to adapt around them to complete primary and secondary mission objectives, think about how to minimize active hours, remember to set things to a fail-safe config before long timewarps, etc etc.  It's a thick layer of interesting complexity on top of standard KSP.  I love it.

I'm using both DangIt and LaunchFailure, as they're fairly distinct.  I have no idea what the performance impact is, if any.

Share this post


Link to post
Share on other sites
Posted (edited)

This really sounds like the thing I would want^^

I only play with x-science, alarm clock and mj on my "stockish" career. I limited myself to the least possible ammount of mods and thats really the bare minimum I would play with.

Now I ramped up the visuals a bit but I'm seriously looking to slowly add a handfull of gameplay mods too. So I think I'll go for dangit and KIS/KAS that should make things a bit more interresting.

 

Edit:

There is a thing I'm stil courius about: It doesn't affect unloaded vessels, does it? I mean my deep space sats are at the edge of kerbns soi having them fail every now and then would be a serious problem since theyre like 80000000m away.

Edited by maculator

Share this post


Link to post
Share on other sites

Been getting a lot of log-spam of 'Adding leak: [none]' and 'FailureModule.OnLoad". Any tips what sort of issues/conflicts I should be looking for here? Is it possible it's related either to KCT or switchable tank modules?

Share this post


Link to post
Share on other sites

Yes, try removing them and see what happens

On 5/19/2017 at 3:00 PM, maculator said:

 

There is a thing I'm stil courius about: It doesn't affect unloaded vessels, does it? I mean my deep space sats are at the edge of kerbns soi having them fail every now and then would be a serious problem since theyre like 80000000m away.

No, it doesn't affect unloaded vessels

On 5/19/2017 at 2:33 PM, fourfa said:

I just came here to post how much fun I'm having with DangIt.  I've added lots of redundancy on probes, have failures along the way (most often batteries and solar panels), have to adapt around them to complete primary and secondary mission objectives, think about how to minimize active hours, remember to set things to a fail-safe config before long timewarps, etc etc.  It's a thick layer of interesting complexity on top of standard KSP.  I love it.

I'm using both DangIt and LaunchFailure, as they're fairly distinct.  I have no idea what the performance impact is, if any.

Thanks.

Dang it can happen any time, including during launches.

Launch Failure only during launches

Share this post


Link to post
Share on other sites

I reinstalled this mod and it seemed to be working again.  All the sudden every vessel that has a 2.5 cargo bay had failures? Now I'm getting the warning sound when I click on any vessel or return to let alone space center

Share this post


Link to post
Share on other sites

New issue I try to fix a broken part and it uses the spare part but part remains broken

Share this post


Link to post
Share on other sites

Unless it is really needed, I'm delaying the 1.3 update for this mod until I can look into some of these bugs.

Depending on the final resolution, I don't know if I'll get a bug fix out for 1.2 or not.  To a certain extent, that depends on feedback here.

The delay for the 1.3 update will probably be a couple of weeks, given my time issues.  I could release it as  is, but then the bugs will still be there

Share this post


Link to post
Share on other sites
4 minutes ago, linuxgurugamer said:

Unless it is really needed, I'm delaying the 1.3 update for this mod until I can look into some of these bugs.

Depending on the final resolution, I don't know if I'll get a bug fix out for 1.2 or not.  To a certain extent, that depends on feedback here.

The delay for the 1.3 update will probably be a couple of weeks, given my time issues.  I could release it as  is, but then the bugs will still be there

I think quite a few people will probably stick to 1.2.2 for a little bit. I'd definitely like to see a bug fix release for 1.2.2

Share this post


Link to post
Share on other sites
On 5/25/2017 at 3:26 PM, HaydenTheKing said:

I reinstalled this mod and it seemed to be working again.  All the sudden every vessel that has a 2.5 cargo bay had failures? Now I'm getting the warning sound when I click on any vessel or return to let alone space center

That's a known bug

Share this post


Link to post
Share on other sites
Posted (edited)

This is a pretty minor usability note, not a bug.  I've had a few craft where I get the alert beeping in orbit, nothing listed in the F3 menu so I know it's not super critical.  I zoom in and rotate all around the craft and can't ever find anything highlighted in red, can't ever figure out what's wrong.  I usually pack things very densely in service bays etc so it's not trivial to inspect everything.  The ship keeps beeping every time I come back to the craft scene. There's no way to mute the alarm, other than just disabling all alarms (AFAICT)

Maybe at some point (not critical now, while Linux is updating all his mods) we could discuss having a bit more UI to call out failures?

edit: dang - now I re-read the previous posts more carefully, perhaps this is zero failures but just a simple beep bug

Edited by fourfa

Share this post


Link to post
Share on other sites
On 4/22/2017 at 9:23 PM, Aurelius said:

Hello, I have encountered bug when using Snacks and Dang It together. Containers from Snacks mod start to leak almost immediately. I have found that it was known issue, but supposedly resolved by MM patch. Despite having latest versions of both Dang It and Snacks I keep having this bug.

And of course thank you for your work on this mod and many others!

 

On 1/23/2017 at 5:19 PM, Moikle said:

Do the Snacks! mod's radial snack tins have a stupid high rate of failure? i just had the only 3 i have used so far fail within 5 minutes of launch... something's going wrong, or perhaps I am supposed to do something different with them? do they break under small g forces?

 I've had the same problem with the instantly leaking snacks! parts. Do you know why that happens, linuxgurugamer?

Share this post


Link to post
Share on other sites

Not yet.  I've been busy with mod updates, I'm about to start working on DangIt! 

Share this post


Link to post
Share on other sites
On 5/31/2017 at 3:52 AM, fourfa said:

edit: dang - now I re-read the previous posts more carefully, perhaps this is zero failures but just a simple beep bug

That's what it sounds like.

NOTICE:

I'm starting to work on DangI!'s bugs.  I only see the following 3 bugs on the tracker:

  1. Alarm sounds when switching vessels or switching from mapview to vessel if something is broken on another vessel
  2. Broken RCS thrusters are unrepairable after saving and loading
  3. Snacks! containers instantly leak

Please let me know ASAP if there are any other issues.  Adding them to the Github Issue list is also very useful, it's the only way I can keep track of everything

Share this post


Link to post
Share on other sites

I need some help testing.

This is a BETA release for 1.2.2:

https://www.dropbox.com/s/wti8qh75490ccci/DangIt-0.7.12.1.zip?dl=0

  •     Fixed nullref in WheelMotor on start
  •     Restricted alarm to sounding only when part is failed on active vessel
  •     Changed Update to LateUpdate in AlarmManager
  •     Restricted failures to active vessel only (in FailureModule)

Please let me know if it helps,  Specifically, this should fix the alarm sounding all the time

Share this post


Link to post
Share on other sites

If I don't get any responses about the 1.2.2 beta, I'm going to assume no one wants it and will proceed to move to 1.3.  Once I do that, I won't have time to revert changes for 1.2.2

So, it's up to you guys.  I was told that people wanted it on 1.2.2, so I'm doing this for you, not for me.

Let me know

Share this post


Link to post
Share on other sites
On 2017-06-06 at 2:05 PM, linuxgurugamer said:

I need some help testing.

This is a BETA release for 1.2.2:

https://www.dropbox.com/s/wti8qh75490ccci/DangIt-0.7.12.1.zip?dl=0

  •     Fixed nullref in WheelMotor on start
  •     Restricted alarm to sounding only when part is failed on active vessel
  •     Changed Update to LateUpdate in AlarmManager
  •     Restricted failures to active vessel only (in FailureModule)

Please let me know if it helps,  Specifically, this should fix the alarm sounding all the time

I've had the alarm sound problem with previous versions. Will give this one a try in my 1.2.2 install.

Share this post


Link to post
Share on other sites
12 hours ago, linuxgurugamer said:

If I don't get any responses about the 1.2.2 beta, I'm going to assume no one wants it and will proceed to move to 1.3.  Once I do that, I won't have time to revert changes for 1.2.2

So, it's up to you guys.  I was told that people wanted it on 1.2.2, so I'm doing this for you, not for me.

Let me know

I've moved on to 1.3. Mostly due to your work updating half my mod list.

Share this post


Link to post
Share on other sites
On 5/30/2017 at 11:54 AM, Calvin_Maclure said:

I think quite a few people will probably stick to 1.2.2 for a little bit. I'd definitely like to see a bug fix release for 1.2.2

Since you were one of the people who requested it for 1.2.2, could you do me the courtesy of testing what I released?  Otherwise I'll drop 1.2.2.

Sunday is the deadline, if I don't hear anything by Sunday, I'll move on to 1.3

Share this post


Link to post
Share on other sites
Posted (edited)

@linuxgurugamer

I'm testing the 1.2.2 now

EDIT: Is Win64 still not supported? Just saw that on the trouble shooting page on the Wiki

Edited by dlrk

Share this post


Link to post
Share on other sites
Posted (edited)
18 hours ago, dlrk said:

@linuxgurugamer

I'm testing the 1.2.2 now

EDIT: Is Win64 still not supported? Just saw that on the trouble shooting page on the Wiki

no, it is supported and I updated the Wiki

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now