linuxgurugamer

[1.4.1+] Dang It! Continued

Recommended Posts

Could you please open a girhub issue and post this in there?  I’m in the middle of heavy development on another mod which is going to take a few week to fix.

thanks

Share this post


Link to post
Share on other sites

I'm looking for a little help from the Dang It! community. First I want to say that this mod is tons of fun. I'm using it in a hard mode + kOS + RemoteTech + life support + KCT career. Losing an engine in the middle of a mission to land a probe on the Mun, tweaking the landing software to compensate, and then limping to the finish line is one of the most fun things I've done in KSP so far. Thanks LGG for maintaining this mod (along with 1/6 of the total mods I am using in my game now). 

Anyway. I'm to the point in my career where I need large liquid fuel tanks for my Nerv tugs. Usually I use some sort of modular tank/container mod for this. I tried using Configurable Containers, but then the tanks don't seem to leak/fail (the MBTF, etc. doesn't show up in the part description in the VAB). Does anyone have any advice on how to get a mod like this working with Dang It!? More generally, if there is a repository of Dang It! configs/advice for other mods to help solve problems like this, I would love to hear about it.

Sorry if this is a basic question that has been answered many times in the thread already. 

Share this post


Link to post
Share on other sites
Posted (edited)

EDIT: the take spare part button is still there, but only for the Dangit Repair Bay, and only if you're standing 6 inches in front of it. Like... literally 6 inches. Take Spare Part still isn't an option for either the truck cab or the aircraft cockpit, both of which have 10 spare parts available, no matter how close I stand. I *was* able to get the repair option for the aileron to show, but only if I'm physically standing on top of the aileron. The other issues still stand.

 

So I'm having a two-part issue that I'm hoping I can possibly get some resolution for:

1) My "take spare part" button has disappeared, so... kind of critical to the function of this mod.

2) I have an aircraft (the one pictured) that I launched using Kerbal Construction Time. It experienced an aileron failure in flight, at which point i successfully landed it. I then recovered it via KCT (with Scrapyard enabled, on the chance that matters). I then launched the aircraft again at a different runway at a later date. The aileron failure immediately shows back up (no problem there... kinda cool that it was persistant), so I dispatched a repair truck with a Dangit Repair Bay to fix it. Well, I get there and... right-clicking the part doesn't show any "drown in WD40" option like it normally does. You can see in the pic that there's no Dangit-related buttons at all... What's weird is that there aren't any Dangit buttons for *any* part... except for the airplane's cockpit, which still shows a lone "Perform Maintainance" button. All inspects, Take Parts, etc, are all gone. Any help would be greatly appreciated.

Output Log found here: https://drive.google.com/open?id=1svsgw9e8B4kv4sZKZpDVSabItfiLsqxK

Screenshot here:

7eXeNca.jpg

Edited by Kardea

Share this post


Link to post
Share on other sites

Currently using KSP 1.4.4 and i'm building a craft in the SPH. When i try to build the craft however, after it exceeds 20 parts+ my FPS drops significantly. The craft uses the mod Space Station Parts Expansion Redux.as a majority. After deleting various mods and tweaking numerous settings, i've found out that this is the mod causing the issue. 

I'm using the lastest release of this mod, but i'm not sure if their are any incompatabilites with this and SSPER (Space Station Parts Expansion Redux)?

Any help would be appreciated.

KSP Log file: https://www.dropbox.com/s/lwy4dtcrbinn1ji/KSP.log?dl=0

Share this post


Link to post
Share on other sites
10 hours ago, AncientHoplite said:

Currently using KSP 1.4.4 and i'm building a craft in the SPH. When i try to build the craft however, after it exceeds 20 parts+ my FPS drops significantly. The craft uses the mod Space Station Parts Expansion Redux.as a majority. After deleting various mods and tweaking numerous settings, i've found out that this is the mod causing the issue. 

I'm using the lastest release of this mod, but i'm not sure if their are any incompatabilites with this and SSPER (Space Station Parts Expansion Redux)?

Any help would be appreciated.

KSP Log file: https://www.dropbox.com/s/lwy4dtcrbinn1ji/KSP.log?dl=0

I prefer the output_log.txt

and this is going to have to wait a bit, busy with some other mods

 

Share this post


Link to post
Share on other sites
On 6/13/2018 at 11:05 AM, SupperRobin6394 said:

It might be nice to disable the part failure (as option) above 100x or 1000x (or anything else) warp rate?

@linuxgurugamer

Share this post


Link to post
Share on other sites
4 hours ago, SupperRobin6394 said:

Add to github issue list, pls

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now