Ger_space

[1.4.X and above] Kerbal Konstructs - 1.7.0.2 - 11.May.2019

Recommended Posts

Posted (edited)
4 hours ago, nmc said:

@Ithirahad there are many statics in "KerbinSide Core" (on CKAN) and very cool runways (with numbers that dynamically update based on heading!) in KerbinSide Remastered

Trying to get KerbinSide (via CKAN) only caused my Kerbal Konstructs to become totally nonfunctional. The menu bar tile for the aeroplane utilities still came up, but crtl-K did not bring up a menu and my existing KK-placed test items vanished. I guess I'll try a manual install.

Edited by Ithirahad

Share this post


Link to post
Share on other sites
1 hour ago, Ithirahad said:

Trying to get KerbinSide (via CKAN) only caused my Kerbal Konstructs to become totally nonfunctional. The menu bar tile for the aeroplane utilities still came up, but crtl-K did not bring up a menu and my existing KK-placed test items vanished. I guess I'll try a manual install.

I did not have that issue, sorry

I only use the basic KK function: adding statics to the game and using some of them as launchsites; I do not use the other features like "aeroplane utilities"

Share this post


Link to post
Share on other sites

I am playing on the JNSQ planet mod pack and want to use the  KSC enteded mod which needs KK.  However, KK seems to place a KSC2 site by default.  The KSC 2 site ends up being in a strange location.  Is there for me to remove the KSC 2 from spawning in the first place?

Share this post


Link to post
Share on other sites

I just tried installing KK in a JNSQ game that previously had no meaningful ksp.log errors. I don't have a KK button in the toolbar and ctrl-K does nothing when controlling a craft. I see the below in the log, it obviously says it's failed but it's not clear (to me) why. Do you have any suggestions? I'm on 1.7.1.

[ERR 12:31:51.872] ADDON BINDER: Cannot resolve assembly: KSPUtil, Culture=neutral, PublicKeyToken=null

[ERR 12:31:51.872] ADDON BINDER: Cannot resolve assembly: KSPUtil, Culture=neutral, PublicKeyToken=null

[ERR 12:31:51.873] AssemblyLoader: Exception loading 'KerbalKonstructs': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.TypeLoadException: Could not load type 'KerbalKonstructs.StaticObjects.StaticObject' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.StaticObjects.StaticGroup' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.UI.BaseBossFlight' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.UI.AirRacing' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.UI.ModelInfo' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.UI.StaticsEditorGUI' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.UI.DownlinkGUI' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.UI.TrackingStationGUI' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.UI.SharedInterfaces' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.UI.FacilityManager' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.UI.EditorGUI' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.UI.MapIconManager' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type 'KerbalKonstructs.API.PersistenceFile`1+<>c__DisplayClass6_0[T]' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<>c' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<>c__DisplayClass16_0' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<>c' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<>c' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 System.TypeLoadException: Could not load type '<>c' from assembly 'KerbalKonstructs, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

 

Share this post


Link to post
Share on other sites
Posted (edited)

Ce mod fonctionne t'il sur la version 1.7.2 de KSP?

[Translation]
Does this mod work on the 1.7.2 version of KSP?

Edited by James Kerman
Added translation

Share this post


Link to post
Share on other sites

Welcome to the forum @Maverick77.

Unfortunately the forum has an English only policy outside of the international section. We recommend you use a translation service like google translate if you wish to post in the general forum.

[Translation]

Bienvenue sur le forum @ Maverick77. Malheureusement, le forum a une politique en anglais uniquement en dehors de la section internationale. Nous vous recommandons d'utiliser un service de traduction tel que google translate si vous souhaitez publier sur le forum général.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Maverick77 said:

Hello, this mod works in 1.7.2?

 

Yes, it works fine for me.

Edited by RealKerbal3x

Share this post


Link to post
Share on other sites

I reported a problem in the GPP topic, linked below, that I think might be best asked here since it involves a KK construct in that planet pack.  I've had one person say that he just deleted KK from the game but I'm reluctant to do that if I can avoid it.  Should I be rolling the KK version back and, if so, to which version to support GPP.  My problem didn't occur under KSP 1.6.x

Am I off the mark here?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.