Ger_space

[1.7.3] Kerbal Konstructs - 1.7.3.0 - 22.Aug.2019

Recommended Posts

32 minutes ago, Ger_space said:

about group editing: Shure you aren't a second account from @Galileo??? :D

You caught me!

Share this post


Link to post
Share on other sites
58 minutes ago, million_lights said:

I could use a simple excell sheet to figure out the relative position to each other, not the biggest issue.

But right now I can't launch from my custom KSC and clipping a runway pointer below the launch positions doesnt seem to work ether.

 

I can set it as a launchsite but its not showing up in mapview or the launch site selection in the VAB/SPH. Am I doing somethign wrong?

Thank you again @Ger_space for your awesome work. I can't wait to work on my project :D

That is what a prerelease is for. I hope I can find the launch transform and set it in the models internal cfg. 

After that you should be able to make new LaunchSites.

I totally forgot about it.

Share this post


Link to post
Share on other sites
8 minutes ago, Ger_space said:

One note: new LaunchSites can't be used until you restart ksp.

was expecting that and restarted, just in case. :)

Share this post


Link to post
Share on other sites

A new prerelease is online: 

Changes:

  • Bugfix: Make Facility Editor work again 
  • New Feature: Added "KSC inter facility greens" to the list of placeable objects (crawlerway &others)
  • New Feature: You can now make the KSC Runways and Launchpads LaunchSites and launch vessels from them.

Grab it here:

https://github.com/GER-Space/Kerbal-Konstructs/releases/tag/0.9.9.4

Modders note to KSC Runways:

You can change the "LaunchPadTransform" setting in from the runway-launchsites from "End09/SpawnPoint" to "End27/SpawnPoint" and you will launch at the other side of the runway. (you need to edit the .cfg manually to do this)

 

@million_lights  and others: please give some feedback if you want to keep the triangle greeens in the KSC modlist. (these are those with a underscore in the name) If nobody uses them, I'll remove them from the final release.

Share this post


Link to post
Share on other sites
13 hours ago, Ger_space said:

Modders note to KSC Runways:

You can change the "LaunchPadTransform" setting in from the runway-launchsites from "End09/SpawnPoint" to "End27/SpawnPoint" and you will launch at the other side of the runway. (you need to edit the .cfg manually to do this)

Nice feature, which I'll find extremely useful.

 

I though I'd take this opportunity to share some modding info on the addition of flags to statics,  as already mentioned they need to be added at part creation, BUT there's no reason at all why you could not just make a set of static flags that could be placed on the static model after it's been placed

Spoiler

This is the demo sign as seen above in unity  with the flag texture assigned, I suggest you  simply apply a material and do not assign a texture, this is just an example

GquNcdO.png

This is the part hierarchy, all the extras lights etc are irrelevant , and your flag decal or whatever you call it , should be blank as below on export to ksp

h8Eemco.png

and this is what it looks like in game  without flag and with  ( ignore flipped uvs, will be sorted)

fWeysXg.png

And of course the most important bit of all without which it's all an exercise in futility

Spoiler

The static part module that is added to a statics cfg


			MODULE
	{
		name = FlagDecal
		namespace = KerbalKonstructs
		textureQuadName = FlagQuad // The flag decal transform name, doesnt matter as long as here and in unity they are the same
	}

 

 

 

Edited by SpannerMonkey(smce)
part module cfg added

Share this post


Link to post
Share on other sites

is there a way to change the folder that new instances are exported to? Given that most ppl recommend when updating mods to completely remove the mod folder it's not a great idea to store user-created content in there. If I move the created statics files out of NewInstances and into a folder of my own outside the KK folder but still within GameData will they be modified if I change something ingame or will a new file be generated in NewInstances?

Edited by Drew Kerman

Share this post


Link to post
Share on other sites

Would it be possible to make the Admiral Kerbanov again? Or is that in the original release that didn't make it over? 

Share this post


Link to post
Share on other sites
1 hour ago, Galm_1 said:

Would it be possible to make the Admiral Kerbanov again? Or is that in the original release that didn't make it over? 

Hi that was by @Eskandare iirc and he has been reworking it for some time, and indeed it would take a good deal of effort to optimise it as he intends.  So maybe one day :)

Share this post


Link to post
Share on other sites
3 hours ago, Drew Kerman said:

is there a way to change the folder that new instances are exported to? Given that most ppl recommend when updating mods to completely remove the mod folder it's not a great idea to store user-created content in there. If I move the created statics files out of NewInstances and into a folder of my own outside the KK folder but still within GameData will they be modified if I change something ingame or will a new file be generated in NewInstances?

KK first tries to modify the instances in the existing files. Only newly placed objects show up the NewInstances folder, because KK knows nothing about them. and does't want to add new instances to old files. (which would turn out ugly when you try to make a new base out of someone elses assets and want to share this as an addon to an asset pack.) 

6 hours ago, SpannerMonkey(smce) said:

 

I though I'd take this opportunity to share some modding info on the addition of flags to statics,  as already mentioned they need to be added at part creation, BUT there's no reason at all why you could not just make a set of static flags that could be placed on the static model after it's been placed

  Reveal hidden contents

This is the demo sign as seen above in unity  with the flag texture assigned, I suggest you  simply apply a material and do not assign a texture, this is just an example

GquNcdO.png

This is the part hierarchy, all the extras lights etc are irrelevant , and your flag decal or whatever you call it , should be blank as below on export to ksp

h8Eemco.png

and this is what it looks like in game  without flag and with  ( ignore flipped uvs, will be sorted)

fWeysXg.png

 

I really like this Idea. Lets see how fast I can learn (ab)using a 3d program. :D.

 

I think I found a bug you encountered when placing your buggy-TestSide. It looks like the scaled assets are also moved in scaled stepts. I'll try to fix that before I make a final release.

Share this post


Link to post
Share on other sites
Just now, Ger_space said:

I think I found a bug you encountered when placing your buggy-TestSide. It looks like the scaled assets are also moved in scaled stepts. I'll try to fix that before I make a final release.

Hey, I think it's more noticeable when the models are scaled but if you place a series of long objects the steps really show, I'd not mentioned it as I put it down to the actual surface mesh, as I've encountered similar situations in other game engines .

Share this post


Link to post
Share on other sites
7 minutes ago, SpannerMonkey(smce) said:

Hey, I think it's more noticeable when the models are scaled but if you place a series of long objects the steps really show, I'd not mentioned it as I put it down to the actual surface mesh, as I've encountered similar situations in other game engines .

The trasform is scaled, and so are the movements of the transform (which is what I never expected) Using the transform-scale as a divider should solve that problem.

Share this post


Link to post
Share on other sites

Release Time:

0.9.9.5

Changes for Players:

  • CommNet Support: All Antennas are the same strength as the KSC ones
  • RemoteTech Support: The antennas have the Ranges as displayed on the map.
    You need to enable the Support each of the setting in the KK mod settings (accessable from the spacecenter menue)
    For best gameplay experience, use the latest Kerbin-Side packages (GroundControl or complete)
  •  a new KerbalKonstruct Mission Flag by @SpannerMonkey(smce)
  • less memory garbage creation during gameplay. --> better performance.

Changes for Modders:

  • added dynamic runway markings by @whale_2. The model kourseXX will display the corresponding runway number according to its heading.
  • Added new StaticModule: "FlagDecal" This is basicly the same module as for Parts. It sets a texture of a Model to th actual flag.
  • @SpannerMonkey(smce)contributed a new BillBoard Model, which displays your current MissionFlag
  • Added the KSC facility models to the list of placeable models.
  • "isScanable" flag for instances: These objects will show up in anomaly scanners as marks. (setable in the editor)
  • hidden flag for Launchsites: Closed Launchsites are not shown in map or launchsite selector when marked "hidden". You need to go there first and open them
  • When the KK-editor is open, you can select (most) statics under the mousepointer by pressing the "left shift" key.
  • Bugfix: Scaled Models are now moved correctly

boring stuff

  • New persistence Layer for savegames
     

Special thanks to:

 @sarbian for his DebugStuff mod and @JPLRepo for ih ResearchBodies mod. without these mods I would not have succeeded in accessing the KSP models.
@whale_2 and @SpannerMonkey(smce) for providing new assets and extentions-Ideas to KerbalKonstructs.

 

You can get the Version here: https://github.com/GER-Space/Kerbal-Konstructs/releases/tag/0.9.9.5

 

Future Plans:

some more boring internal changes to KK and learn how to create 3d models :D

Edited by Ger_space

Share this post


Link to post
Share on other sites

Well old chap you certainly do get a move on when you set your mind to something.  :)  nice work, and features

Just had a thought while passing and grabbing download, would the flag module fail if there were, for example multiple flag transforms with the same name? the stock module does, each one needs unique name. Of course just a passing thought, not even tried yet :)  I fancy a big rotating sign on top the VAB :P

1 hour ago, Ger_space said:

learn how to create 3d models :D

Feel free to ask anything related to the above desire, ( there's no stupid question if you do not no the answer)always have time for new (and not so new) mod makers

Share this post


Link to post
Share on other sites
6 minutes ago, SpannerMonkey(smce) said:

Just had a thought while passing and grabbing download, would the flag module fail if there were, for example multiple flag transforms with the same name? the stock module does, each one needs unique name. Of course just a passing thought, not even tried yet :)  I fancy a big rotating sign on top the VAB :P

Feel free to ask anything related to the above desire, ( there's no stupid question if you do not no the answer)always have time for new (and not so new) mod makers

It would not fail, just only set the texture on the first transform with the right name.

On the next update I'll allow multiple transforms with the same name. (no ETA yet, but might be in 1-2 weeks)

 

Share this post


Link to post
Share on other sites

I am experiencing a truly massive performance hit with the new KK and new KerbinSide. It drops from 45fps down to 3-5 on my i7 4790K + GTX1080. If I pan the camera away from land it gets somewhat better, 10fps. This happens all the way out to Kerbin's end of SOI. If I delete these two folders everything gets back to my normal 45fps during ascent again. (60 fps in space which is my 65 inch TV's limit)

Logs:
https://www.dropbox.com/s/sefccr29w2txw02/KSP.log?dl=0
https://www.dropbox.com/s/o7k2h61uvwoyirk/output_log.txt?dl=0

Edited by SkyKaptn

Share this post


Link to post
Share on other sites

Hey @SkyKaptn

Could you try to KEEP the 2 folders and delete all the other mods you have? 

Remember to keep the dependencies for kk and kerbinside.

I suspect a logspam that slows down your game due to a conflict with other mods because your logfiles are 6 and 10MB big.

I'm not willing to open them on mobile xD

Share this post


Link to post
Share on other sites
8 minutes ago, million_lights said:

I suspect a logspam that slows down your game

I experienced this first with the -nologs parameter enabled. But yes, most certainly a conflict. I am off to work in 10 minutes so I cannot do much more in 8-9hrs time.

Share this post


Link to post
Share on other sites
1 hour ago, SkyKaptn said:

I am experiencing a truly massive performance hit with the new KK and new KerbinSide. It drops from 45fps down to 3-5 on my i7 4790K + GTX1080. If I pan the camera away from land it gets somewhat better, 10fps. This happens all the way out to Kerbin's end of SOI. If I delete these two folders everything gets back to my normal 45fps during ascent again. (60 fps in space which is my 65 inch TV's limit)

Logs:
https://www.dropbox.com/s/sefccr29w2txw02/KSP.log?dl=0
https://www.dropbox.com/s/o7k2h61uvwoyirk/output_log.txt?dl=0

this might be an issue with EVE or Scatterer. I'll look into is later, if I find a obvious problem. (45FPS is pretty bad on a 1080, as I can get 120FPS on a 1070 with KK and a lot of assets.)

The logfiles don't show any unusual activities.

Edited by Ger_space

Share this post


Link to post
Share on other sites
4 hours ago, SkyKaptn said:

I experienced this first with the -nologs parameter enabled. But yes, most certainly a conflict. I am off to work in 10 minutes so I cannot do much more in 8-9hrs time.

It looks like it is an regression I introduced somewhere between the releases. I'm still a bit clueless what the problem is, but at least I can see it.

Share this post


Link to post
Share on other sites

Same issue. 0.9.9.2 seems OK. Gonna try other pre-releases to pin it down.

Share this post


Link to post
Share on other sites

I am trying to solve the issue with assets around the KSC being separated significantly when an upscaled system is used; obviously the distance between the assets increases as the scale factor increases.

As I'm only concerned about the assets around the KSC, if I take the KSC PQSCity coordinates as the origin point I can calculate the vector between the KSC origin and any additional asset, giving me the Long/Lat components of distance. By dividing these components by the rescale factor and then adding them to the origin coordinates the result seems to be pretty accurate in giving me the Long/Lat coordinates of where the asset would be required to be placed in the rescaled system to be positioned correctly at the KSC with respect to the stock sized layout.

This can be seen here: https://docs.google.com/spreadsheets/d/1nFybNKxZD00OJJzlMiDHhYl9FbVelSSNcxW96RTiDsM/edit#gid=1324233737

I can type in the Long/Lat coordinates of "KSC Floodlight1, type in a Rescale Factor (example of 10x) and it will output the new Long/Lat coordinates. This can be verified by comparing the distances (m) in Column J, they should be approximately equal.

However, am I correct in assuming that KK positions the assets by the radialPosition values in the config over the refLongitude and redLatitude values? If so, what do the radialPosition values represent in this case and can I convert Long/Lat coordinates into values for the [0] and [1] keys for radialPosition?

Share this post


Link to post
Share on other sites
2 minutes ago, Poodmund said:

I am trying to solve the issue with assets around the KSC being separated significantly when an upscaled system is used; obviously the distance between the assets increases as the scale factor increases.

As I'm only concerned about the assets around the KSC, if I take the KSC PQSCity coordinates as the origin point I can calculate the vector between the KSC origin and any additional asset, giving me the Long/Lat components of distance. By dividing these components by the rescale factor and then adding them to the origin coordinates the result seems to be pretty accurate in giving me the Long/Lat coordinates of where the asset would be required to be placed in the rescaled system to be positioned correctly at the KSC with respect to the stock sized layout.

This can be seen here: https://docs.google.com/spreadsheets/d/1nFybNKxZD00OJJzlMiDHhYl9FbVelSSNcxW96RTiDsM/edit#gid=1324233737

I can type in the Long/Lat coordinates of "KSC Floodlight1, type in a Rescale Factor (example of 10x) and it will output the new Long/Lat coordinates. This can be verified by comparing the distances (m) in Column J, they should be approximately equal.

However, am I correct in assuming that KK positions the assets by the radialPosition values in the config over the refLongitude and redLatitude values? If so, what do the radialPosition values represent in this case and can I convert Long/Lat coordinates into values for the [0] and [1] keys for radialPosition?

you can delete the "radialPosition" config, when you have   "RefLatitude" and   "RefLongitude" in the ,cfg File. KK will recalculate the new radialPosition from that.

48 minutes ago, whale_2 said:

Same issue. 0.9.9.2 seems OK. Gonna try other pre-releases to pin it down.

It makes no sense to me, why the Framerate drops, when I cache the active Statics and don't recactivate them every second. Is is this Commit which started the trouble. 

Share this post


Link to post
Share on other sites

Just to confirm: I just did a clean install and a 100% new and untouched persistent save with only KK and KerbinSide. Same thing as last time, just marginally better with 10fps. Removed the two mods to verify the results - got maximum fps again.

Share this post


Link to post
Share on other sites

@whale_2 & @SkyKaptn

After a long night of debugging I still have no clue what the problem is. It looks like I hit some internal limitations of the mono interpreter... a simple renaming of functions to start with a capital letter will sometimes kill the framerate... :huh:

I hope I can get a somehow working release tomorrow, I need to manually code every bit again I've done in the last releases by hand, an test every change.... this takes a lot time. A simple revert of the commit which a bit bisect identified as flawed doesn't show any improvements :mad:. When I manually rebased to the last working commit and added the changes by hand (only slightly changed) the offending Change is ok, but adding the other Code from other commits makes KK broken again... So by no way this is consistent by any means. 

current progress:

  • RemoteTech & CommNet working
  • hidden LaunchSites: partial implemented
  • Anomalies: not imlemented
  • FLagDecal Module: working
  • AutoKourse: Working
  • KSC Models: not working.
  •  

Please use 0.9.8.9 or 0.9.9.1 for now.

https://github.com/GER-Space/Kerbal-Konstructs/releases

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.