Ger_space

[1.7.3] Kerbal Konstructs - 1.7.3.4 - 16.Oct.2019

Recommended Posts

6 hours ago, Tyko said:

Hi, I just added KK to GPP. Works great except when I added Rescale 2.5x. Now the launch site components are spread out and not connected. It looks like the components didn't change in size, but their relative position did. 

Is there a fix? I'd prefer to keep the components their normal size but have them moved back together.

Thanks for the help!

oYNxbhi.png

KKtoSD - it's another Sigma88 mod.

Share this post


Link to post
Share on other sites
14 hours ago, Box of Stardust said:

What's the correct specific way to export all new placed statics in the world? For easy sharing of placed KK locations and all that, and so that they'll integrate properly into other people's installs.

Still in 1.3.1 by the way.

All objects you place have thier config saved in the "GameData/KerbalKonstructs/NewInstances/" Folder. This config you can easily share. Please note, that the used models are needed to be installed at the other peoples systems and not all models are free to distribute. 

Later you can rename them and move them in any diffrent folder (under GameData). they will be loaded correctly.

It is good practice to create one base and then move all files to a seperate folder, then create the next one. 

I've killed the legacy base exporter feature at some point. Bringing it back is currently not high in my priority list.

 

 

Share this post


Link to post
Share on other sites
7 minutes ago, Ger_space said:

All objects you place have thier config saved in the "GameData/KerbalKonstructs/NewInstances/" Folder. This config you can easily share. Please note, that the used models are needed to be installed at the other peoples systems and not all models are free to distribute. 

Later you can rename them and move them in any diffrent folder (under GameData). they will be loaded correctly.

It is good practice to create one base and then move all files to a seperate folder, then create the next one. 

I've killed the legacy base exporter feature at some point. Bringing it back is currently not high in my priority list.

 

 

Ah, okay. I saw the 'ExportedInstances' folder in the KK directory and wondered if there was a feature I haven't found.

So I can just take the NewInstances directory, put it in a different, non-KK directory in GameData (i.e., GameData/OtherDirectory/NewInstances), and KK will load it, if I understand correctly.

Share this post


Link to post
Share on other sites
12 minutes ago, Box of Stardust said:

Ah, okay. I saw the 'ExportedInstances' folder in the KK directory and wondered if there was a feature I haven't found.

So I can just take the NewInstances directory, put it in a different, non-KK directory in GameData (i.e., GameData/OtherDirectory/NewInstances), and KK will load it, if I understand correctly.

You should take the cfgfiles out of the folder and not the folder. The targetfolder can have any name,  (i.e., GameData/OtherDirectory/MyStatics) 

Share this post


Link to post
Share on other sites
25 minutes ago, Ger_space said:

KK now supports stock alike smoke effects on launchpads

YEEEAAASSS

0A1eFqn.png

will start immideately )

KIDS, DONT SMOKE.-JUST A JOKE&)

peace K

Share this post


Link to post
Share on other sites

so i know this is most likely just me being dumb. but in 1.4.3, is placing new statics borked? if not. how the hiffel do i do it? i havent used KK in quite a while :D so i forget. but i know the last beta release was for 1.4.2 not .3, so figured id ask :D (yes i am indeed using the beta)

Share this post


Link to post
Share on other sites
1 hour ago, ThePhoenixSol said:

so i know this is most likely just me being dumb. but in 1.4.3, is placing new statics borked? if not. how the hiffel do i do it? i havent used KK in quite a while :D so i forget. but i know the last beta release was for 1.4.2 not .3, so figured id ask :D (yes i am indeed using the beta)

Tried to press ctrl + k, after you are traveled to the place you want to have an base 

Share this post


Link to post
Share on other sites
6 minutes ago, Ger_space said:

Tried to press ctrl + k, after you are traveled to the place you want to have an base 

lol yep. im dumb. forgot about that :P thanks

Share this post


Link to post
Share on other sites

Hi,

I finally have a working Version for KSP 1.4.3. No Expansion is required, but it is supported. 

This version does not include any old assets or example bases from AlphaAsh. The bases will go to Kerbin-Side. This is for better compatibility with Kerbin-Side remastered. I will of course continue working on Kerbin-Side and make a new release soon, but at least you have now more choises. 

 

https://github.com/GER-Space/Kerbal-Konstructs/releases/tag/1.4.3.0

Sort of changelog:

  • Added LaunchPad-Smoke support
  • Added support for the Stock-Expansion LaunchSite selector
  • Fixed a bug that prevended a crash during load, when slower computers are used and many mods are installed
  • Vessel spawned on waterlaunchsites are no longer spawned under water
  • KSC2 LaunchSite is usable without any mods (in Career games you have to find it first and open it when you are landed near to it)
  • To make KK more compatible with KSC changing mods, it will no longer ship the assets from Alpha-Ash. These will be moved into Kerbin-Side
  • Errors when saving models should no longer crash KK

 

A release for 1.3.1 will come out later. I'm now only offline for 3,5 hours.

Share this post


Link to post
Share on other sites
19 hours ago, Space Scumbag said:

I solved my Sun problems. :cool:

Here the results:

 

LOL, learn something new everyday hu. 

so...whats the point of this exactly?? in ksp i meen. besides just looking cool, what problems do you speak of?

Share this post


Link to post
Share on other sites
2 hours ago, IceTitan said:

also works on 1.4.2 ?

 

I don't know. I don't have 1.4.2 anymore. Just try it. 

Share this post


Link to post
Share on other sites

@Ger_space So, in my career i set up pads, and set them to 100k open cost.... when in the vab, i select it, purchase it, it takes the money.... and in the kk menu it says its bought, but the stock menu doesnt list it. then, when i select it as launch site and hit launch, it loads, then says launch failed. i go back into vab, and its no longer listed as purchased, but i dont have my money back.

Happened on stream, can link the VOD if you want to see for yourself per request.(i say per request as otherwise it feels like im plugging my stream, which isnt my intention.)

Share this post


Link to post
Share on other sites

This has likely nothing to do with Kerbal Konstructs or KerbinSide/Remastered, but a couple of the bases I've visited are completely shakey/shimmery textures, and has the appearance of z-fighting taken to the extreme. Just on the off-chance, do I need to double-check I'm not double-loading some assets between the KK and KSR folders?

This visual glitch also matches the shakey/shimmery edges of textures on craft in general at times, so perhaps the game is just not happy with my current setup (the visual isn't much different than the hand-sketched animation like from the "Take on me" video... ;) )

Maybe the KK-added statics are more prone to it since they're more complicated structures.

Share this post


Link to post
Share on other sites
6 minutes ago, Beetlecat said:

This has likely nothing to do with Kerbal Konstructs or KerbinSide/Remastered, but a couple of the bases I've visited are completely shakey/shimmery textures, and has the appearance of z-fighting taken to the extreme. Just on the off-chance, do I need to double-check I'm not double-loading some assets between the KK and KSR folders?

This visual glitch also matches the shakey/shimmery edges of textures on craft in general at times, so perhaps the game is just not happy with my current setup (the visual isn't much different than the hand-sketched animation like from the "Take on me" video... ;) )

Maybe the KK-added statics are more prone to it since they're more complicated structures.

Can you please send me an Screenshot When this happens and open an issue on github? I'm drunk an tomorrow I'll probably forgotten it.:D

1 hour ago, ThePhoenixSol said:

@Ger_space So, in my career i set up pads, and set them to 100k open cost.... when in the vab, i select it, purchase it, it takes the money.... and in the kk menu it says its bought, but the stock menu doesnt list it. then, when i select it as launch site and hit launch, it loads, then says launch failed. i go back into vab, and its no longer listed as purchased, but i dont have my money back.

Happened on stream, can link the VOD if you want to see for yourself per request.(i say per request as otherwise it feels like im plugging my stream, which isnt my intention.)

I guess you are using the mh expansion. The stock launcher only has the open launchsites, No cheating allowed there. 

It should update as soon as the base is purchase, but I never tested newly created bases on 1.4.3 mh. 

This release was made with hard time constraints, else it wouldn't be released yet. 

The logfile should give me more answers, but i think I can recreate the issue, because you have at least some information which steps you took.

Share this post


Link to post
Share on other sites
1 hour ago, Ger_space said:

Can you please send me an Screenshot When this happens and open an issue on github? I'm drunk an tomorrow I'll probably forgotten it.:D

For sure best not to look at it while drunk--especially not a video. I'll send you a snap later today.

Share this post


Link to post
Share on other sites
6 hours ago, Ger_space said:

I guess you are using the mh expansion. The stock launcher only has the open launchsites, No cheating allowed there. 

It should update as soon as the base is purchase, but I never tested newly created bases on 1.4.3 mh. 

This release was made with hard time constraints, else it wouldn't be released yet. 

The logfile should give me more answers, but i think I can recreate the issue, because you have at least some information which steps you took.

Ah darn, keep forgetting you havent tested with MH. yes, im using the exspansion. and yea, i figured thats how it worked, but didnt appear to be updating, plus the whole not saving it being purchased bit. And im sure this release wasnt easy per se. I appreciate all the effort ya put in :D . Anyways, here is a zip with my log file, and a link to the vod, should direct you to the correct time in the vod, just before i found the issue https://drive.google.com/file/d/148_ZgQS-wdQITVBHEA9CqAvc-Ft2BjIS/view?usp=sharing

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.