Ger_space

[1.7.3] Kerbal Konstructs - 1.7.3.4 - 16.Oct.2019

Recommended Posts

Great mod, it also seems that quite a lot of patches have been released since my post, so I’m going to soon download the latest version, hopefully the bug mentioned was fixed, (Definitely is)

Thanks for the awesome mod @Ger_space

(Also 1000th post!)

Share this post


Link to post
Share on other sites

just updated to latest KSP 1.3.1 version v1.3.9.12 and it has some odd behavior I thought was a bug in v1.3.0.0 (big skip in update revisions because I forgot there was a KSP 1.3.1 backport). If you create a new static then paste or snap it based on another object it shows up in that position fine, but when you go to adjust its position it returns to the original spawn location and offsets its position from there. Even after the game is restarted. I suppose this could be intended as if you paste/snap something then you have it where you want it and don't need to move it. But that seems a bit rigid of a design choice.

Also can the ability to shown destructed buildings be made an option? I was actually using the fact that destructed objects are not shown to replace the Tier 1 tracking dish with an animated version. Or is there now a way for me to properly remove the dish static from the KSC?

Share this post


Link to post
Share on other sites
On 5/1/2018 at 11:54 AM, Beetlecat said:

Behold -- Nye Island -- or what's left of it after the prismatic apocalypse:

9FF20E2A362595632D51E57C7E2BE8308F69227B

moving the view around in this state is entirely disorienting. It oddly only seems to affect the bottom half or so of the view -- even if the camera is spun around so that more of the base is at the top of the image.

I'm having trouble getting more shots with and without scatterer settings (in case that's contributing). The launch location selector stops "working" and I just get put on the KSC runway each time.

looks like it came out of ARMA 3

 

Share this post


Link to post
Share on other sites
3 hours ago, Galileo said:

@Ger_space I think you went the wrong direction on the "warp to next morning" settings. Now the warp to morning stops at 1h13m in GPP. That's  7 min earlier lol!  I guess kerbals need to beat that early morning traffic to get to the space center on time.

Why it wasn't an issue on my system...

I can try to check that again, because I can't reproduce that issue directly. ( On my install it looked fine) 

I'll change the calculation I. The other direction. What ksp version are you using?

Share this post


Link to post
Share on other sites
On 1/1/2017 at 3:11 PM, Ger_space said:

 

you can install kerbin-side CORE. This contains only the assets, but no prebuild bases.

i downloaded kerbinside complete, are there certain things i need to remove just to get the assets? im using a planet pack

 

Share this post


Link to post
Share on other sites
1 hour ago, MB62 said:

i downloaded kerbinside complete, are there certain things i need to remove just to get the assets? im using a planet pack

 

I think all configurations below the main bases and ground control folders 

Share this post


Link to post
Share on other sites
6 hours ago, Ger_space said:

Why it wasn't an issue on my system...

I can try to check that again, because I can't reproduce that issue directly. ( On my install it looked fine) 

I'll change the calculation I. The other direction. What ksp version are you using?

I am using 1.4.3 + MH

Edited by Galileo

Share this post


Link to post
Share on other sites
47 minutes ago, Galileo said:

I am using 1.4.3 + MH

I'll make a new build, maybe it will be then better and kerbal can sleep longer again 

Share this post


Link to post
Share on other sites

Are you using the MH launchsite selection system, or is it still the old KK one? Will it conflict if I have MH installed?

EDIT: Nevermind, I can see you do now.

Edited by m4ti140

Share this post


Link to post
Share on other sites

@Ger_space when in SPC and pressing the close / delete button of  the stock message system, I click-through and open the VAB (or whatever is behind).

The message is not deleted.

Share this post


Link to post
Share on other sites
14 hours ago, Gordon Dry said:

@Ger_space when in SPC and pressing the close / delete button of  the stock message system, I click-through and open the VAB (or whatever is behind).

The message is not deleted.

I'll try to fix this behavior somehow, I have no idea how, but I guess there is a way to do it.

Found it, and in the next release, the click-through will be gone. 

Edited by Ger_space

Share this post


Link to post
Share on other sites

how am i supposed to do for making a launchsite? the "make launchsite" button seems to be inactive when i try to put an object

Share this post


Link to post
Share on other sites
5 minutes ago, [INDO]dimas_1502 said:

how am i supposed to do for making a launchsite? the "make launchsite" button seems to be inactive when i try to put an object

´choose an other object, that can be made a launchSite. A LaunchSite needs to have a 

Quote

DefaultLaunchPadTransform = "Hierarchy/Path/To/Spawnpoint"

Parameter defined. Not all models have a spawnpoint transform. 

 

Share this post


Link to post
Share on other sites

- Bug report -

 

There is a bug with the new KK sites. It does not generate a crash but forces me to close the game. I play with the Galileo Planet Pack.

 

Sometimes ( quite often ) when i am in either the research center or the mission control and i click on something, the screen goes blank and the loading symbol appears in the bottom right. it sometimes takes me nowhere and i see the planets icon in the bottom right spinning for minutes until i decide to alt f4- it. It sometimes takes me to the vab, but while i can scroll trough the components, i cant build anythign or exit the vab.

Writing this report it strikes me that i probabily have 2 UIs open at teh same time, the mission control and the vab, but I get limited mouse control over either.

Either way, uninstalling KerbalKonstructs kills this bug.

Share this post


Link to post
Share on other sites
5 hours ago, Ger_space said:

´choose an other object, that can be made a launchSite. A LaunchSite needs to have a 

Parameter defined. Not all models have a spawnpoint transform. 

 

i used the mobilelaunchpad that used in the MH Mission Maker

Share this post


Link to post
Share on other sites
2 minutes ago, [INDO]dimas_1502 said:

i used the mobilelaunchpad that used in the MH Mission Maker

You see that within KK? Cool :-) 

the Problem is, that I don't have the new LaunchPads setup propably. I need to search for them and add the SpawnPoint config in Code. 

Share this post


Link to post
Share on other sites
On 5/7/2018 at 4:15 PM, Galileo said:

I am using 1.4.3 + MH

can you please test this build, if the kerbals can now sleep a bit longer?

https://github.com/GER-Space/Kerbal-Konstructs/releases/tag/1.4.3.4

This is what im currently working on... (from an early build) 

giphy.gif

now the water looks like this and its animated like real water.

lxuF52J.png

 

This is real KSP water, all normal water physics apply. 

Maybe someone has some use for it. 

Also the facilities in the Spacecenter view will not open when a window is open and Additional KSC Buildings now turn off thier lights during day. 

 

Share this post


Link to post
Share on other sites

@Ger_space do vessels in the water tank thingy show as “splashed down”?  If so, this could be invaluable for part testing contracts. 

Share this post


Link to post
Share on other sites

@Ger_space Its two min later. It's still 24 mins earlier than how stock does with mornings. Here is something i quickly threw together.  As you can see, the KSC is still in darkness when you warp to morning with KK.

6ZQaVpc.jpg

This is obviously with GPP, but at 1h49m, that is 0h0m in stock.

Edited by Galileo

Share this post


Link to post
Share on other sites
7 minutes ago, Galileo said:

@Ger_space Its two min later. It's still 24 mins earlier than how stock does with mornings. Here is something i quickly threw together.  As you can see, the KSC is still in darkness when you warp to morning with KK.

6ZQaVpc.jpg

This is obviously with GPP, but at 1h49m, that is 0h0m in stock.

I don't change the warp to next morning button in the tracking station. only the one in the SpaceCenter... Maybe thats why I was always seeing the sun, and thought it was ok.

26 minutes ago, MaxPeck said:

@Ger_space do vessels in the water tank thingy show as “splashed down”?  If so, this could be invaluable for part testing contracts. 

I would need to test this further, but I get some unknows science reading. (I don't think splashed down at the KSC is something that was considered possible)

Share this post


Link to post
Share on other sites
4 minutes ago, Ger_space said:

I don't change the warp to next morning button in the tracking station. only the one in the SpaceCenter... Maybe thats why I was always seeing the sun, and thought it was ok.

No, I only “warped to morning” in the SC and went to the tracking station to take the screenshots. With the current KK settings, there is barely any sun rise at all. The sun should be fairly high when you warp to the next morning.

Share this post


Link to post
Share on other sites

Hello! I was looking around for some airport terminals that I could install and use with KK. I'm a big fan of flight simulations, and love flying around Kerbin. Does anyone have an idea of where I could get some airport stuff?

Share this post


Link to post
Share on other sites
On 6/28/2017 at 5:17 PM, Ger_space said:

@SpannerMonkey(smce) 

I added now an AudioPlayer StaticModule into KK

You can get the release here: https://github.com/GER-Space/Kerbal-Konstructs/releases/tag/1.1.9.2

 


	MODULE
	{
		name = AudioPlayer				// internal identifier
		namespace = KerbalKonstructs	// internal identifier
		audioClip = KerbalKonstructs/FreeStatics/Sound/TestSample  // The sound as an .ogg or wav file
		minDistance = 1					// loudness falloff start distance
		maxDistance = 2500				// at which distance shoud the sound stopped
		loop = true						// loop the sample or play it once (currently only looping is supported)
		volume = 1 // range from 0 to 1 how load the sound should be
	}

Add this to any StaticModel definition and it will play the sound as soon you range.

I have a problem with this.  I just installed GPP for 1.4.3 with all the related mods, including this.

GPP has seagulls around the space center, and the specifics are:

	MODULE
	{
		name = AudioPlayer
		namespace = KerbalKonstructs
		audioClip = GPP/GPP_KSC++/Assets/searock1seagull/seagullloop
		minDistance = 1
		maxDistance = 300
		loop = true
		volume = 0.05
	}

 

However, when I go into space, and then enter the Map view, I hear seagulls.

Also, the sound adjustment in the settings doesn't do anything, it's either 0 or 1, and makes no difference at all

Is this a bug, or is there something I can do to fix this

Share this post


Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

I have a problem with this.  I just installed GPP for 1.4.3 with all the related mods, including this.

GPP has seagulls around the space center, and the specifics are:


	MODULE
	{
		name = AudioPlayer
		namespace = KerbalKonstructs
		audioClip = GPP/GPP_KSC++/Assets/searock1seagull/seagullloop
		minDistance = 1
		maxDistance = 300
		loop = true
		volume = 0.05
	}

 

However, when I go into space, and then enter the Map view, I hear seagulls.

Also, the sound adjustment in the settings doesn't do anything, it's either 0 or 1, and makes no difference at all

Is this a bug, or is there something I can do to fix this

You don't like the spacegulls? 

I think Galileo placed the seagulls to close to the SpaceCenter and the map view suddenly teleports the camera near to it. ( But I have no idea) ksp is sometimes wired.

I could to a workaround, so the sound is paused when the map is open. About the volume adjust. I only use unity functions, if they don't work, I'm out of ideas. I'll not start and write my own.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.