Ger_space

[1.8.1] Kerbal Konstructs - 1.8.1.15 - 15.Dec.2019

Recommended Posts

14 hours ago, Aerospacer said:

Hello, @Ger_space , can you help me with new KK tweaks?

In new version color of some Kerbin City's grass textures was changed to more dark. You wrote about the grass editor, but I could not find it and figure out how to adjust the texture colors.

 

 

the colors had to be adjusted to be consistent with the KSC. I tried my best to match the old colors, but it was not always possible. 

to edit the grass color you select the static and then press the following button:

1oDai1u.png

 

which module are you using? the legacy GrasColor or the new GrassColor2? the later one is a bit experimental, at least in the last official release. You might want to download the shader-bundles from github, to get the latest version.
 

 

 

Share this post


Link to post
Share on other sites
40 minutes ago, alberro+ said:

How do I install this? It won’t work.

Just install it. Like any other mod. You should end up with a GameData/CustomPreLaunchChecks/ and a GameData/KerbalKonstructs/ folder. But that's all you get. KerbalKonstructs alone is only the mod that makes anything else work that's related to it (like EVE is nothing without the content packs for it like SVE or Spectra). If you want to see complete bases or the statics to build your own bases you gotta download the content pack mods for those. To build or edit a base, press Ctrl+K while you're in the world with an "active vessel."

Share this post


Link to post
Share on other sites

A new release ahead of the things that might come in the future:

https://spacedock.info/mod/1052/Kerbal-Konstructs/download/1.8.1.15

 

Changes

new Hangar module

  • you can store vessels and the crew is recovered automatically
  • you can assign crew to stored vessels and launch them from the KSC menu.

Other

  • statics should be less bumpy after a scene switch
  • SpaceCenters are no longer focused when they are not on the Homeword. This feature will come back when it is properbly implemented
  • The KSC FuelTank is now visible again.
  • The LaunchSites are now sorted: 1. Group 2. Name

Changes for modders

  • support for custom launchpad smoke emitters (either Unity ParticleSystem or KSPParticleEmitter)

  • GrasColor: Normal Maps are precalculated and cached unter PluginData

  • GrassColor2: Multicolor Blendmasks allow blending of up to four textures (including alpha channel and mix) ( for example: grass + concrete + (worn) white stripes + dirt roads)
    This is like a light version of substance painter.

  • The GrassColor2 editor supports these changes

  • GrassColor2 : Normal Maps for each Texture are precalculated and cached unter PluginData. Only NearGrass receives those from the FarGrass (which looks better that way)

  • GrassEditor: You can convert any texture to grayscale, so some are more usefull now.

  • AnimateOnSunrise: Rewrote it to be less error prone.

  • AdvancedTextures: you can define the color of a mesh with the _Color parameter

  • Variant switching: allow transform names with whitespace in the middle

  • PadSmoke: allow transform names with whitespace in the middle

  • AdvancedTextures: allow transform names with whitespace in the middle

  • PadSmoke: You can select your smoke type

  • exports are now written as ,zip files and no longer as .tar

Share this post


Link to post
Share on other sites

Having a bit of trouble between launches. Generally the first time I boot up and launch, everything will be fine. 2 or 3 missions in...things will start resizing themselves. Generally they'll get bigger. (Dramatically bigger...like, dwarf the entire launch site and sticking out above the atmosphere, bigger). Also, it will often spawn me off-center of a launchpad static. Using RSS 1.7.3. Is this a known/common bug? It didn't do this on earlier versions. 

Edited by JJJacksonTyler

Share this post


Link to post
Share on other sites
3 hours ago, JJJacksonTyler said:

Having a bit of trouble between launches. Generally the first time I boot up and launch, everything will be fine. 2 or 3 missions in...things will start resizing themselves. Generally they'll get bigger. (Dramatically bigger...like, dwarf the entire launch site and sticking out above the atmosphere, bigger). Also, it will often spawn me off-center of a launchpad static. Using RSS 1.7.3. Is this a known/common bug? It didn't do this on earlier versions. 

I don't know, but the latest version released is no longer supported for KSP 1.7.X and I can't support it anytime soon again. If this problem persists when Kopernicus 1.8.X is released, then open a report on github, so it doesn't get lost. 
there have been some changes between 1.7 and 1.8, that could affect this.

Share this post


Link to post
Share on other sites

I keep getting massive performance loss with Kerbal Konstructs.

Is there a way I can determine which Kerbal Konstructs mod is causing it, and change it out for something else.  (I am suspecting KSC++, but I can't be sure.)

Share this post


Link to post
Share on other sites

Man, I hate lookin like a dummy, but here goes! I'm just now trying this mod for the first time, and have read everything Google gives me, and can't figure out something incredibly basic:

Should I be able to put down a launch pad (around KSC) and then launch from it? I've tried this twice and the little launchsite down-down menu inside the VAB never shows my launch sites (I'm in sandbox). Is that supposed to work when I do this correctly?

What I did was: put a capsule on the runway, placed LC-something (from Tundra) next to the runway, clicked Make Launchsite, filled out some stuff (I suspect this is where I am getting lost), saved everything, made sure that KSC_Builtin (which I did not create) is the "active group", have tried making the "site category" both RP and RW, tried setting Facility Type on one of them, I've tried zeros and large values for max things like parts and weight, I could go on.

Am I trying to do something that the mod doesn't do?

Share this post


Link to post
Share on other sites
On 12/17/2019 at 5:07 PM, Ruedii said:

I keep getting massive performance loss with Kerbal Konstructs.

Is there a way I can determine which Kerbal Konstructs mod is causing it, and change it out for something else.  (I am suspecting KSC++, but I can't be sure.)

Kerbal Konstructs is nothing for low-end Systems. To test, just delete the mod folders out of the GameData Folder

On 12/19/2019 at 2:22 AM, OrbitalManeuvers said:

Man, I hate lookin like a dummy, but here goes! I'm just now trying this mod for the first time, and have read everything Google gives me, and can't figure out something incredibly basic:

Should I be able to put down a launch pad (around KSC) and then launch from it? I've tried this twice and the little launchsite down-down menu inside the VAB never shows my launch sites (I'm in sandbox). Is that supposed to work when I do this correctly?

What I did was: put a capsule on the runway, placed LC-something (from Tundra) next to the runway, clicked Make Launchsite, filled out some stuff (I suspect this is where I am getting lost), saved everything, made sure that KSC_Builtin (which I did not create) is the "active group", have tried making the "site category" both RP and RW, tried setting Facility Type on one of them, I've tried zeros and large values for max things like parts and weight, I could go on.

Am I trying to do something that the mod doesn't do?

When you create a launchSite, then you have to restart KSP to use it. There is a nice KK-button in the SPH and VAB to select the site you created.

Share this post


Link to post
Share on other sites
7 hours ago, Ger_space said:

When you create a launchSite, then you have to restart KSP to use it. There is a nice KK-button in the SPH and VAB to select the site you created.

Ahh, that's what I was missing - thank you!

 

Share this post


Link to post
Share on other sites
16 hours ago, Insanity_BK said:

Hey, Im trying to put a barge in the water and idk how to make it appear in map view. How do I do it? Thanks!

you have to add a facility (type: recovery site) to it. 

 

Share this post


Link to post
Share on other sites
15 minutes ago, Insanity_BK said:

it appears I still cant get it to work, hmm. Here are my settings

 

When you go to your map view, hit the KK icon. Then a menu will show up and you have to hit the $ icon. Then it will show in the map view :)

Share this post


Link to post
Share on other sites

Hi, I'm trying to open a launchpad on Minmus, but I am not able to do so.

I sent a crewed capsule on the designed site. Opened the CTRL+K interface. Created a group. Created a launchpad instance with 0 costs for opening, activated the colliders and saved all. I then went to the VAB, but the button on the side of my launchpad name is always red, no opening option.

Could you help me, please?

Share this post


Link to post
Share on other sites
2 hours ago, damonvv said:

When you go to your map view, hit the KK icon. Then a menu will show up and you have to hit the $ icon. Then it will show in the map view :)

that worked thanks!

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, I've been getting this issue with Kerbal Konstructs on when  placing an object the game crashes to desktop, and comes up with this:
I'm using 1.3.1 w/ the most recent 1.3.1 Kerbal Konstructs, wondering if this is known and how to sort it out, still testing it with older versions to see if they work.
I'm running only Kerbal Konstructs and Squad for testing, and it still doesn't seem to work.

UPDATE: It appears to only occur when Kerbinside Remastered is installed along with it, interesting.

xON4bLe.png

Edited by Sebastiaz

Share this post


Link to post
Share on other sites

I have an intersting question.. and this involcves other structures..

How easy or hard would it be to add in say a navigational beacon like a lighthouse style building into KK? I mean if you want an example of what i am refering to, just do a look for Cape Canaveral Lighthouse..

or better yet here's a ep series of pictures of said lighthouse.

Just a thought

 

Space_Coyote

Share this post


Link to post
Share on other sites

Just including here an issue I have raised on GitHub, in case anyone has encountered and solved this issue already:

Using Kerbal Konstructs with Kerbinside and Rescale (x10.625) on KSP 1.6.1, I have everything working effectively, except that new bases don't show up in the tracking station. They do show up on x3.2, and at very close ranges, at x6.4, this leads me to believe that 'GUI.DragWindow(new Rect(0, 0, 10000, 10000));' within MapIconManager.cs is the cause of this (or if not this, then whatever manages the range at which icons are set to be displayed in the map view and/ or the tracking station). I have attempted to alter this myself but, not being a coder, have been unable to build the solution (I get errors in Visual Studio complaining about missing references and such, that should be in the .dll? Although the dll is referenced though it still doesn't reference them. I don't know, I have no experience doing this.). Could you alter the Kerbal Konstructs versions back to version 1.4.5.64 with a change to 'GUI.DragWindow(new Rect(0, 0, 25000, 25000));' or similar please so that I can use this mod alongside Rescale x10.625 and Kerbinside, or otherwise help me to make this change myself? Much obliged.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.