Ger_space

[1.8.1] Kerbal Konstructs - 1.8.1.2 - 10.Nov.2019

Recommended Posts

I've started to work on some statics but there's a few little things that I'm not sure about. Is there any tutorials on creating statics? I tried to search but couldn't find anything.

Share this post


Link to post
Share on other sites
On 9/18/2018 at 1:10 AM, Beetlecat said:

1.4.4 is very specifically broken for Kerbal Konstructs, as Squad(/devs) baked in an improper setting that disallowed it from working. 1.4.3 or 1.4.5 work(ed) fine.

lol so i was just plain unlucky then xD

welp, waiting to download 1.4.5 anyway!

Thank you very much

Edited by BlinAndVodka238

Share this post


Link to post
Share on other sites
On 9/13/2018 at 8:28 AM, Toonu said:

Hello, I am using your mod in one project in KSP with friends. I spawned my crafts normally, they are sitting on or near bases from KK/KSide, but when some other person tries to spawn his crafts (after I sent him the save) my crafts dive into the ground and explode. We are also using Physics range extender linked with BDA, so bases far away can be maybe unloaded in KK but loaded crafts via BDA?

Hello again, the problem is still unresolved though I changed range extension of BDA to 30km. It loads fine, but when I warp time forward and then stop = load physics again, things starts to jump and lag as seen in video bellow.

Crafts are still underground in most cases or jumping around - like the planes which ended like in the video.

Aaaaand, here's the log... https://www.dropbox.com/s/v9kh5v6lqsehrsk/KSP.log?dl=0

Spoiler

 

 

I would be very thankful for any help, @Ger_space

Edited by Toonu

Share this post


Link to post
Share on other sites

Hi Ger_space and others.

Im problaby just stupid, but in any way i fail to set up a recovery building on the mün.

Tried out several buildings with the Facility Type: Recovery Base, but nope.

Maybe its the Mün, the recovery crew have to much fun jumping around.

Thanks in advance.

Share this post


Link to post
Share on other sites
20 hours ago, silentbob981988 said:

Hi Ger_space and others.

Im problaby just stupid, but in any way i fail to set up a recovery building on the mün.

Tried out several buildings with the Facility Type: Recovery Base, but nope.

Maybe its the Mün, the recovery crew have to much fun jumping around.

Thanks in advance.

I don't think you can press the recovery button while bering offworld. Anf if you can, it will probably crash KK. What is excatly the Problem you see?

Share this post


Link to post
Share on other sites

I think it's not working because of being an offworld installation, tried it now on other planet and mün's

The recovery button just won't show up.

Maybe it will work in the future, until then i will use the station as refill hub for a hopper to cruise round.

Anyway it's a 10/10 mod. ^_^

Share this post


Link to post
Share on other sites
1 hour ago, silentbob981988 said:

I think it's not working because of being an offworld installation, tried it now on other planet and mün's

The recovery button just won't show up.

Maybe it will work in the future, until then i will use the station as refill hub for a hopper to cruise round.

Anyway it's a 10/10 mod. ^_^

Thats sadly a Limitation of KSP, that you can only recover a vessel on the homeworld… Maybe I can add a recover vessel function in the KK sidebotton, but I make no promises.

Share this post


Link to post
Share on other sites
1 minute ago, Ger_space said:

Thats sadly a Limitation of KSP, that you can only recover a vessel on the homeworld… Maybe I can add a recover vessel function in the KK sidebotton, but I make no promises.

Seems like an easy fix - make a button in KK and steal some code from hyperedit so that when you click the off world recovery it quietly teleports your vessel to KSC and then recovers it.

Share this post


Link to post
Share on other sites

@Toonu  Physicsrange extender seems to be the problem with that sort of jitter.  How to fix it with that mod installed I have no idea but its definitely on that side of things with or without KK.

Share this post


Link to post
Share on other sites
2 hours ago, garithmar said:

@Toonu  Physicsrange extender seems to be the problem with that sort of jitter.  How to fix it with that mod installed I have no idea but its definitely on that side of things with or without KK.

Okay, thanks for reply. Will contact BDA then.

Share this post


Link to post
Share on other sites

Hello, after contact to the BDA, I think it can be, because Physics range extender don't register KK statics as ground and thus crafts load underground in the scenario. Do you think it can be the issue or how to fix it?

Share this post


Link to post
Share on other sites

Well I'm having an issue of a differnt sort and it revolves around map icons.. 

 

First off I am not using rteally any dcompressed texturs and second I am using Kerbinside remastered.. but the interesting thing is that the Launch pad icons show up but the airport/runway markers do not..

 

I'm just wondering if this is an issue with KK or Kerbinside..

 

Any ideas?

 

Space_Coyote

Share this post


Link to post
Share on other sites
On 10/4/2018 at 8:23 AM, Toonu said:

Hello, after contact to the BDA, I think it can be, because Physics range extender don't register KK statics as ground and thus crafts load underground in the scenario. Do you think it can be the issue or how to fix it?

Not an immediate fix available. File an issue at the KK Github, so I don't forget about that when I'm reworking that part of code in the future. 

Share this post


Link to post
Share on other sites

Okay, thanks for your efforts. ;)

Share this post


Link to post
Share on other sites

What is the deal with the Hangers by the runway?   They now say that you can store aircraft in them but all attempts to do so are met with 

"There are no craft close enough to store in this facility. "    It is open so is this a function that has limits or needs something else done to

make it function?      

Share this post


Link to post
Share on other sites
5 hours ago, JustAToy said:

What is the deal with the Hangers by the runway?   They now say that you can store aircraft in them but all attempts to do so are met with 

"There are no craft close enough to store in this facility. "    It is open so is this a function that has limits or needs something else done to

make it function?      

you need to move any kerbals out of your aircraft before you can store it in the hangar.

Share this post


Link to post
Share on other sites
1 hour ago, tonimark said:

can you update this for ksp 1.5.1 ?!

It's running with ksp 1.5 but I can't publish updates in the moment. 

You can use the latest release for 1.4.x with ksp 1.5

Im in the middle of a development cycle and no releases in the next few weeks. 

My kk sources are not in a playable state, because I'm rewriting how kk internally works ( once again ) 

I hope I finish around Christmas with shiny new features (for other modders only)

Edited by Ger_space

Share this post


Link to post
Share on other sites

Is there a way to hide bases and waypoints in the map view? It seems to cause lag.

Share this post


Link to post
Share on other sites
39 minutes ago, dlrk said:

Is there a way to hide bases and waypoints in the map view? It seems to cause lag.

Press the kk button in the map view and select what you want to show.

 

Share this post


Link to post
Share on other sites

Hi there. I really like this mod and would like to applaud you on your excellent application.

I am still using ksp 1.3.1 because I'm really deeply into a career and don't see the need to upgrade.

I have a modded game with too many mods to list - all of which I have working smoothly together; including yours.

I'm using KK 1.3.9.11 so forgive me if the question has already been asked somewhere or if my version of KK is too outdated to support an answer but anyway:

When I fly somewhere, press CTRL+K and edit existing buildings or add new ones, everything I have previously bought returns to 'for sale' status when I save changes - except for the number of resident kerbals and whatever funds etc. were there, which return to their original number once I have gone back, bought the base and the associated building again.
Am I missing something here or is this a limitation I must live with? For up to half a million each, some of those bases take a lot to keep opening again, you know?

Question number two is: is there a way for me to specify a default value for the merchant buildings? Add a ratio of 3:1 buy/sell for all common resources in my game for example so I don't have to do it manually every time I build one)

Number three, an unfortunate bug in any 'science' building, which shows a grey text box with some text wedged right into the top left corner and no buttons or readable data when clicked (I cannot retrieve the science, add workers etc.) ... this is the only info/text box this happens to. Did you know about this? Is there something I can do?

Spoiler

Again, sorry for asking about an old version but this career is the best one yet and I'm sick of starting again all the time! For me, KK is not only enhancing but necessary.
Adjusting these few things would make my game save perfect.

Edited by Stephanie the Viking
Grammar

Share this post


Link to post
Share on other sites
3 hours ago, Stephanie the Viking said:

Hi there. I really like this mod and would like to applaud you on your excellent application.

I am still using ksp 1.3.1 because I'm really deeply into a career and don't see the need to upgrade.

I have a modded game with too many mods to list - all of which I have working smoothly together; including yours.

I'm using KK 1.3.9.11 so forgive me if the question has already been asked somewhere or if my version of KK is too outdated to support an answer but anyway:

When I fly somewhere, press CTRL+K and edit existing buildings or add new ones, everything I have previously bought returns to 'for sale' status when I save changes - except for the number of resident kerbals and whatever funds etc. were there, which return to their original number once I have gone back, bought the base and the associated building again.
Am I missing something here or is this a limitation I must live with? For up to half a million each, some of those bases take a lot to keep opening again, you know?

Question number two is: is there a way for me to specify a default value for the merchant buildings? Add a ratio of 3:1 buy/sell for all common resources in my game for example so I don't have to do it manually every time I build one)

Number three, an unfortunate bug in any 'science' building, which shows a grey text box with some text wedged right into the top left corner and no buttons or readable data when clicked (I cannot retrieve the science, add workers etc.) ... this is the only info/text box this happens to. Did you know about this? Is there something I can do?

  Reveal hidden contents

Again, sorry for asking about an old version but this career is the best one yet and I'm sick of starting again all the time! For me, KK is not only enhancing but necessary.
Adjusting these few things would make my game save perfect.

I'm currently developing on ksp 1.2.2, because it's still needed. ( Same code base as 1.3.1) 

The editing issue will be gone, as soon you will use the next release. The identifier in the save games week change as soon its loaded the first time. Afterwards you can edit freely without having issues.

2. I must look at the code for that... I'll answer that tomorrow 

3. Bug reports should go into the github, so I dont forget them. 

Currently too much in the mind and a few modders breaking my test releases... 

I think I fixed the same issue on 1.4.x, so it's maybe only a back port needed, or is broken there as well... 

Tomorrow I'll know more... A new release is coming this at some point this week.

Share this post


Link to post
Share on other sites

Just a small teaser of the next release:

ShrillIlliterateIbex-size_restricted.gif

this will be available for KSP 1.2.2 onwards, I'm going to make a new baseline release for everyone. I'm just finishing the Code and have some cleaning up, but later this week it will be finished. Then also a new release of Kerbin-Side will follow, because of some config-format changes. 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.